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5Introduction

1 Introduction

Ostendo allows you to manage the operational activity of your business and keep your existing
accounting software.  Business operations typically fall outside the scope of financial systems. 
Ostendo integrates these crucial activities into your business, ensuring that you have real time
information for decision-making support.  Ostendo therefore provides financial information
covering:

· Customer Deposits
· Sales and Job Invoicing
· Customer Payment receipts
· Bank Deposits
· Ongoing Work In Progress and Job Costing
· Inventory Control
· Purchase Orders raised.
· Goods Received and Invoice Matching

Information from these areas is sent to an interface program created by Development-X from
where it is posted to a 3rd Party Accounting system. 

Integration Options

Out of the box, Ostendo integrates with the following 3rd Party Accounting packages:
- MYOB
- Quickbooks
- Sage Pastel Evolution (Evolution prior to version 7)
- AccountRight Live
- MoneyWorks
- Xero
- Sage Evolution Live (Evolution version 7 onwards)

These can be divided into two groups:
- Batched Accounting Links (MYOB, Quickbooks, Sage Pastel Evolution)
- Automated Accounting Links (AccountRight Live, MoneyWorks, Xero, Sage Evolution

Live)
      
ForBatched Accounting Links, you can use one of three settings to define how you wish to run the
options

· Single-Currency Ostendo and Single-Currency 3rd Party Accounts.  This is the default
supplied with an initial Install.  

· Multi-Currency Ostendo and Multi-Currency 3rd Party Accounts.  You would define other
currencies as shown in this exercise to achieve this option. 

· Multi-Currency Ostendo and Single-Currency 3rd Party Accounts.  This is a simple setting
that allows you to have full multi-currency processing in Ostendo (Purchase receipts,
Invoices, payments, statements, etc) but output local currency Journals to the linked 3rd

-Party Accounting package

This Document

The following will be covered in this document:

· Cost Centres
· Base Mapping
· ‘T’ Charts
· Integration with the 3rd-Party Accounting system
· Sales Mapping
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2 Accounting Link Options

For Automated Accounting Links (AccountRight Live, MoneyWorks, Xero), transactions are posted
from Ostendo to the accounting package based on the frequency specified in System Settings.
Foreign currency support provided are as follows:

· AccountRight Live - None. All transactions are posted across in local currency only.
· MoneyWorks - Yes. Transactions are posted across in foreign currency

together with the exchange rate.
· Sage Evolution Live - Yes. Transactions are posted across in foreign currency

together with the exchange rate.
· Xero - Limited.Xero’s API does not allow Ostendo to pass through the

transaction exchange rate entered in Ostendo. Instead it uses the exchange rate within Xero. 

It is important to note that when the invoice (Sales or Purchase) is
passed through to Xero, that you must edit that invoice in Xero and force the exchange rate to that
of the original invoice in Ostendo. 

This is extremely important with Purchase Invoices, as not
amending the rate will result in an imbalance in the Purchase Receipts Not Invoiced account. Also
it could have an effect on FX Currency Gain / Loss on a Sales Invoice 

For Batched Accounting Links (MYOB, Quickbooks, Sage Pastel), the following options can be set
up

1. Post Foreign Currency Transactions as Local

If the linked accounting package that you are linked to only accommodates local currency or you
only use local currency Journals then ‘check’ this checkbox.  All generated Ostendo Journals will
be exported in local currency although Foreign Currency Invoices, Deposits and Payments (along
with their Exchange Rates) will still be processed in Ostendo.

2. Post Daily Summaries.

Although Ostendo creates and retains detailed Financial transactions you have the option to have
Daily (Summary) Journals sent to the Ostendo-Accounting Link routine.  The daily summaries can
be selected for the following:

· Applying Deposits
· Applying Payments
· Assembly Issues
· Assembly Receipts
· Assembly WIP Variances
· Customer Deposits
· Customer Payments
· Inventory
· Job Order Issues
· Job WIP Variances
· Purchase Receipts
· Purchase Price Variances
· Sales Invoice Costs
· Sales Invoice Revenue
· Sales Order Issues
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3 Cost Centres

Ostendo uses the concept of Cost Centres to record costs from all areas of the product.  These
Cost Centres are user-defined and are directly linked to a General Ledger Account Code in the
3rd-Party Accounting system.   

A simple Account Mapping facility is available that enables Ostendo's Cost Centres to be
referenced to GL Account Codes in the Accounting system

For the User who requires a more in-depth breakdown of Sales than an additional routine for
further mapping is also available.

Finally, for those Users who have created detailed Account Code breakdowns an Advanced
Mapping’ function is available to enable this to be carried out.

Cost Centre Groups

Cost Centres can be grouped into logical areas.  These relate to the Cost Areas such as 
· Asset
· Liability
· Income
· Expense
· Cost of Sale
· Bank
· etc

Cost Centre Groups are User-defined.

Cost Centre Maintenance

The following fields are available for creating and maintaining Cost Centres.
Cost Centre Code A meaningful code that describes which costs are contained against
this Code
Description Extended description of the Cost Centre
Group The Cost Centre Group to which this Cost Centre belongs
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4 Base Mapping

Cost Centres can be linked to areas where costs are stored.  Out-of-the-Box Ostendo contains a
list of pre-defined areas and their associated Cost Centres (as shown on the document at the end
of this paper).  The pre-defined areas are:

Stock: All Stock across all Warehouses and Locations in your Company’s Inventory is kept against
this Cost Centre.  If a Warehouse is allocated a specific Cost Centre then that will be used in
preference to this default.

Stock Adjustment Variance: Stock Adjustments are ‘received from’ or ‘issued to’ a Cost Centre.
This Cost Centre provides a global place for ‘posting’ the Costs from this function

Negative Adjustment Variance: Stock adjustment variances can occur whenever you receive
Stock but the current stock levels are negative.  In this case the Average Cost for the Item is not
amended but the difference between the Average Cost and the Cost of this receipt is ‘posted’ to
this Cost Centre

Revaluation of Stock Variance: Whenever the Stock is re-valued  (Standard Cost or Average
Cost) the difference between the old value and the new value is ‘posted’ to this Cost Centre

Stock Count Variance: Stock variances (plus or minus) as a result of a Stock Count are ‘posted’
to this Cost Centre.  

Stock In Transit: Whenever Stock is moved from one Warehouse to another via the Inventory
Transfer routine this Cost Centre will be used for that transfer.

Receipt Cost Var: Used if the Inventory Costing method is ‘Standard Costing’.  In that instance
this stores the cost difference between the Assembly Order actual Cost and the Standard Cost of
the Item.

Descriptor Expenses: This is the default Cost Centre used by Descriptors.  It can be amended at
Descriptor level to another Cost Centre and made specific to that Descriptor.   This Cost Centre is
then used as the ‘allocated’ Cost Centre during Purchase Receipts.

Catalogue Expenses: This is the default Cost Centre used by Supplier Catalogue Items.  This
Cost Centre is used as the ‘allocated’ Cost Centre during Purchase Receipts.  If a Supplier
Catalogue is allocated a specific Cost Centre then that will be used in preference to this default.

Warranty Costs: Where a Job Issue has it’s ‘Actual Issue’ allocated to a Charge Style of ‘
Warranty’ then the costs are ‘posted’ to this Cost Centre

Contract Costs: Where a Job has been created for a ‘Contract’ Type, or any Recurring Invoice
lines have a cost, where the ‘Actual Issues’ are allocated to the ‘Charge’ style of ‘Contract’, then
the costs are posted, as a Debit, to the CONTRACT COSTS Cost Centre.

Direct Labour Costs: When an Employee Timesheet Transaction is made then the costs are ‘
posted’ to this Cost Centre

Fixed Labour Overhead Costs: When an Employee Timesheet Transaction is made then the
associated FOH costs - held against the linked Labour Code - are ‘posted’ to this Cost Centre

Variable Labour Overhead Costs: When an Employee Timesheet Transaction is made then the
associated VOH costs - held against the linked Labour Code - are ‘posted’ to this Cost Centre

Purchases Received Not Invoiced: For any Purchase Orders that have been received via the ‘
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Purchase Order Receipts’ function are held in this Cost Centre until they have been ‘matched’ in
the ‘Purchase Order Invoicing’ screen 

Purchase Price Variance: Purchase Orders received via the ‘Purchase Order Receipts’ function
contain a Purchase Price and this is ‘posted’ at that time.  When it is matched against the ‘
Purchase Order Invoicing’ there may be a Price difference.  This difference is posted to this Cost
Centre.  

Creditors: Whenever a Purchase Invoice is received then the amount of that Invoice is ‘posted’ to
this Cost Centre.  

Assembly Work In Progress: For any Issues (Material, Labour, Descriptors, etc) that have been
issued to Work In Progress for an Assembly Order the cost of that issue is ‘posted’ to this Cost
Centre.  Note: The cost of the Assembly Order is taken out of this Cost Centre whenever the
Assembly Order is received into Inventory

Assembly Order Variance: If the Assembly Order has been completed and its status is ‘Closed’
then any subsequent Issues or Bookings to this Order will go direct to this Cost Centre rather than
the Assembly Work In Progress Cost Centre.

Job Work In Progress: For any Issues (Material, Labour, Descriptors, etc) that have been issued
to Work In Progress for a Job Order the cost of that issue is ‘posted’ to this Cost Centre.  Note:
The cost of the Job Order is taken out of this Cost Centre whenever the Job Order is Invoiced.

Job Cost Of Goods Sold: Any Invoice raised against the Job Order will take the cost of the
Invoice out of the ‘Job Work In Progress’ Cost Centre and add it to this Cost Centre.

Job Cost Variance: If the Job Order is ‘Closed’ then any subsequent Issues or Bookings to this
Order will go direct to this Cost Centre rather than the Job Work In Progress Cost Centre. 

Job Income: Any Income received that has been applied to a Job Invoice Line will be ‘posted’ to
this Cost Centre.  

Sales Lines Picked: Whenever a Sales Order Line is ‘Picked’ the cost of that line is moved from
the source Cost Centre (Example: ‘Stock’ Cost Centre for Inventory Items) and moved to this Cost
Centre.

Sales Cost Of Goods Sold: Whenever a Sales Order Line is ‘Invoiced’ the cost of that line is
moved from the ‘Sales Line Picked’ Cost Centre to this Cost Centre.

Sales Income: Any Income received that has been applied to a Sales Invoice Line will be ‘posted’
to this Cost Centre.  

Freight: Any Income received that covers Freight and has been applied to an Invoice will be ‘
posted’ to this Cost Centre.  

Debtors: Whenever an Invoice (or credit) is raised then the amount of that Invoice is ‘posted’ to
this Cost Centre.  Whenever a Deposit or Payments is matched to an Invoice then it is moved from
this Cost Centre to the above Sales Invoice, Sales Freight, and Sales tax Cost Centres.

Contract Income: Where an Invoice has been created from either a ‘Contract’ Job or a Recurring
Invoice, the contract Income is posted, as a Credit, to the CONTRACT INCOME Cost Centre.

Deferred Cost Of Goods: The value of any Retention amount raised against a Job Order Invoice
will take the cost of the Retention out of the ‘Job Work In Progress’ Cost Centre and add it to this
Cost Centre.
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Deferred Income: This is only used in ‘Progress Claim’ environments that have an Invoicing
Schedule where the specific scheduled Invoice has an Accounting Style of ‘Income Deferred’. This
provides facility to have this type of Income deferred for future P & L recognition.

Deferred Freight: This is only used in ‘Progress Claim’ environments that have an Invoicing
Schedule where the specific scheduled Invoice has an Accounting Style of ‘Income Deferred’. This
provides facility to have this type of Freight deferred for future P & L recognition

Deferred Tax: This is only used in ‘Progress Claim’ environments that have an Invoicing Schedule
where the specific scheduled Invoice has an Accounting Style of ‘Income Deferred’. This provides
facility to have this type of Tax deferred for future P & L recognition

Un-Applied Deposits: Deposits received from a Customer will be ‘posted’ to this Cost Centre.
When they are applied to an Invoice they will be moved to the ‘Debtors’ Cost Centre

Un-Applied Payments: Payments received from a Customer will be ‘posted’ to this Cost Centre.
When they are applied to an Invoice they will be moved to the ‘Debtors’ Cost Centre

Bank: Upon validation that the Payment was banked (Deposit Slip status updated to ‘Banked’ then
the amount is transferred from the ‘Un-deposited Funds’ Cost Centre and ‘posted’ to this Cost
Centre

Payment Rounding: If the ‘matched’ payment amount is within a ‘Rounding Tolerance’ entered in
that screen then the Payment record status is amended to ‘Fully Applied’.  The actual value of the
Rounded amount is ‘posted’ to this Cost Centre, 

Discounts Given: If a Discount Amount is entered during Payment Matching (Example: ‘Prompt
Payment’ discount) then the value of this discount is ‘posted’ to this Cost Centre.

Undeposited Funds: Whenever a Bank Deposit Slip is raised (Status is ‘Pending’) the included
payments are ‘posted’ to this Cost Centre.  

POS End of Day Variance: Whenever a 'Z' Report is printed from the End Of Day processing in
the Point of Sales function than if the Till Balance is at variance to the expected balance then the
difference is posted to this Cost Centre  

POS Shop Expenses: Whenever a Cash withdrawal or deposit is made within the POS function
then the amount Withdrawn/Deposited is held in this Cost Centre
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5 T Charts

The following T Charts are pre-defined and cover the various activities that take place in Ostendo. 
The Debit/Credit sides show the included ‘Functional Areas’ described in the previous section

5.1 Sales Issues

This covers issue of Items, Descriptors and Supplier Catalogue Items to a Sales Order

Debit Credit

SALES LINES PICKED

  
 *(For Inventory) Cost Centre

 **(For Descriptors) Cost Centre

***(For Catalogue Items) Cost Centre

* If the Warehouse from where the Item was picked does not contain a Cost Centre against
INVENTORY then the default Cost Centre matched to STOCK will be used 
** If the Descriptor does not contain a Cost Centre then the default Cost Centre matched to
DESCRIPTOR EXPENSES will be used
*** If the Supplier Catalogue from where the Item is issued does not contain a Cost Centre
then the default Cost Centre matched to CATALOGUE EXPENSES will be used

5.2 Sales Invoice

This covers the production of the Invoice. 

Debit Credit

SALES COGS

DEBTORS

SALES LINES PICKED

SALES INCOME

SALES FREIGHT

5.3 Purchase Order Receipt

This covers the production of the Invoice. 

Debit Credit
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*(For Inventory)
        If using Standard Cost) 
        Cost Centre
        RECEIPT COST VAR
                        or 
        If not using Standard Cost) 
        Cost Centre 

**(For Descriptors) Cost Centre

***(For Catalogue Items) Cost Centre

(For Direct Allocations)  JOB WORK IN
PROGRESS or ASSEMBLY WORK IN
PROGRESS

PURCHASES RECEIVED NOT INVOICED

* If the Warehouse into which the Item is received does not contain a Cost Centre then the
default Cost Centre matched to STOCK will be used 
** If the Descriptor does not contain a Cost Centre then the default Cost Centre matched to
DESCRIPTOR EXPENSES will be used
*** If the Supplier Catalogue from where the Item is issued does not contain a Cost Centre
then the default Cost Centre matched to CATALOGUE EXPENSES will be used

5.4 Purchase Price Variance

This covers situations where the Purchase Order has been received and - at some later time - the
Invoice is matched against the Receipt and where the Invoice contains a different price to the
receipt price.  This difference is posted to a Purchase Price Variance Cost centre

Debit Credit

(For Inventory)  PURCHASE PRICE VARANCE

 *(For Descriptors) Cost Centre

**(For Catalogue Items) Cost Centre

(For Direct Allocations) JOB WORK IN
PROGRESS or ASSEMBLY WORK IN
PROGRESS

PURCHASES RECEIVED NOT INVOICED

* If the Descriptor does not contain a Cost Centre then the default Cost Centre matched to
DESCRIPTOR EXPENSES will be used
** If the Supplier Catalogue from where the Item is issued does not contain a Cost Centre then
the default Cost Centre matched to CATALOGUE EXPENSES will be used

5.5 Purchase Order Invoice

The Purchase Invoice is received, matched against prior receipts, and approved.

Debit Credit

PURCHASES RECEIVED NOT INVOICED CREDITORS
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5.6 Job Issues

Issues to Jobs comes from Stock Items, Descriptors, or Labour.  These issues could be charged
to the Job or can be designated as non-chargeable (covered by Warranty, a Contract, or simply
making it non-chargeable when issuing it)

Debit Credit

JOB WORK IN PROGRESS

 (Defined ‘Non-Charge’ at time of issue) Cost
Centre

(Non-Charge Warranty) WARRANTY COSTS

(Non-Charge Contract) CONTRACT COSTS

*(For Inventory) Cost Centre

**(For Descriptors) Cost Centre

***(For Catalogue Items) Cost Centre

(Labour - broken down into)
      DIRECT LABOUR COST
      FIXED LABOUR OVERHEAD COST
      VARIABLE LABOUR OVERHEAD COST

* If the Warehouse from where the Item was picked does not contain a Cost Centre then the
default Cost Centre matched to STOCK will be used 
** If the Descriptor does not contain a Cost Centre then the Cost Centre matched to
DESCRIPTOR EXPENSES will be used
*** If the Supplier Catalogue from where the Item is issued does not contain a Cost Centre
then the Cost Centre matched to CATALOGUE EXPENSES will be used

5.7 Job Invoice

Upon creation of a Job Invoice 2 Journal transactions are created.

· Relating to the Costs of the Invoice
· Relating to the Expected Income

Debit Credit

JOB COST OF GOODS SOLD JOB WORK IN PROGRESS

Debit Credit

DEBTORS JOB INCOME  * (For Tax) 

FREIGHT

* Tax is created from the Tax Code passed through.  I.e. The Job Income amount includes
Tax
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5.8 Job WIP Variance

If a Job’s status is changed to ‘Closed’ then any residual costs for that Job remaining in Work In
Progress will be posted to a Job WIP Variance

Debit Credit

(Invoice Job Style ) JOB COST OF GOODS
SOLD

(If Job Style  is ‘No Invoice’) Cost Centre

JOB WORK IN PROGRESS

5.9 Customer Payments

Payments received from a Customer can be deposited directly into the Bank or alternatively
retained and ‘batched’ into a consolidated Bank Deposit Slip.

Debit Credit

BANK   or  UNDEPOSITED FUNDS UNAPPLIED PAYMENTS

5.10 Customer Deposits

Deposits received from a Customer can be deposited directly into the Bank or alternatively
retained and ‘batched’ into a consolidated Bank Deposit Slip.

Debit Credit

BANK   or  UNDEPOSITED FUNDS UNAPPLIED DEPOSITS

5.11 Applying Payments

Payments are matched against Invoices raised against a Customer

Debit Credit

UNAPPLIED PAYMENTS DEBTORS

DISCOUNTS GIVEN

PAYMENT ROUNDING
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5.12 Applying Deposits

Deposits are matched against Invoices raised against a Customer

Debit Credit

UNAPPLIED DEPOSITS DEBTORS

DISCOUNTS GIVEN

PAYMENT ROUNDING

5.13 Bank Deposits

Bank Deposits are applied Customer Payments and/or Customer Deposits that have been
consolidated into a single Bank Deposit Slip

Debit Credit

BANK UNDEPOSITED FUNDS

5.14 Assembly Issues

Issues to Assembly Orders comes from Stock Items, Descriptors, or Labour. 

Debit Credit

ASSEMBLY WORK IN PROGRESS *(For Inventory) Cost Centre

**(For Descriptors) Cost Centre

(Labour - broken down into)
      DIRECT LABOUR COST
      FIXED LABOUR OVERHEAD COST
      VARIABLE LABOUR OVERHEAD COST

* If the Warehouse from where the Item was picked does not contain a Cost Centre
against INVENTORY then the default Cost Centre matched to STOCK will be used 
** If the Descriptor does not contain a Cost Centre then the default Cost Centre matched
to DESCRIPTOR EXPENSES will be used

5.15 Assembly Receipts

Receipts from Assembly Orders always go into Inventory.   The Journal created depends upon
whether the Item being received uses Standard Costing or not

With Standard Costing
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Debit Credit

** (Warehouse) Cost Centre

* RECEIPT COST VAR

ASSEMBLY WORK IN PROGRESS

* If the Warehouse does not contain a Cost Centre against RECEIPT COST then the default Cost
Centre matched to RECEIPT COST VAR will be used.  The value of this variance comes from
Cost of Receipt - Standard Cost.

No Standard Costing

Debit Credit

* (Warehouse) Cost Centre ASSEMBLY WORK IN PROGRESS

** If the Warehouse does not contain a Cost Centre against INVENTORY then the default Cost
Centre matched to STOCK will be used

5.16 Assembly WIP Variance

Whenever am Assembly Order has its status changed to ‘Closed’ then any residual Costs for the
Assembly Order are posted to a WIP Variance.   Additional activity is carried out if the following
conditions apply

· If the Assembly Order was for a Custom Product and that Product is still in stock then
add the Cost to the Stock record

· If the Assembly Order was for a Custom Product and that Product has been withdrawn
from stock but has not yet been Invoiced then add the cost to the Sales Order ‘Pick but
not invoiced’ record

· If the Assembly Order was for a Custom Product and that Product has been despatched
and Invoiced then add the cost to the Sales Order’s COGS

Debit Credit

ASSEMBLY ORDER VARIANCE ASSEMBLY WORK IN PROGRESS

5.17 Inventory Adjustments

The following is used whenever a Stock Adjustment Transaction is carried out through the
Inventory Adjustment screen

Debit Credit

* (Warehouse) Cost Centre STOCK ADJUSTMENT VARIANCE

* If the Warehouse does not contain a Cost Centre against INVENTORY or ADJUSTMENTS then
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the default Cost Centre matched to STOCK or STOCK ADJUSTMENT VARIANCE respectively
will be used.

5.18 Inventory Count

The following is used whenever a Stock Count Transaction is carried out via the Stock Count
routine.

Debit Credit

* (Warehouse) Cost Centre STOCK COUNT VARIANCE

* If the Warehouse does not contain a Cost Centre against INVENTORY or STOCK COUNT then
the default Cost Centre matched to STOCK or STOCK COUNT VARIANCE respectively will be
used

5.19 Inventory Transfer

Inventory Transfer is a two-step function using an interim ‘In-Transit’ Cost Centre.  Currently this
process is carried out in a single transaction as follows

Debit Credit

*(Receiving Warehouse) STOCK

STOCK IN TRANSIT

STOCK IN TRANSIT

*(Issuing Warehouse) STOCK

* If the Warehouse does not contain a Cost Centre then the INVENTORY Cost Centre then the
default Cost Centre matched to STOCK will be used

5.20 Negative Stock

For Items that are received where the stock is currently in negative (I.e. has already been issued at
a known cost) then the cost difference of the Receipt to the previous issue will be posted to the
negative stock adjustment Cost Centre

Debit Credit

*(Warehouse) STOCK NEGATIVE ADJUSTMENT VARIANCE

* If the Warehouse does not contain a Cost Centre against INVENTORY or NEGATIVE STOCK
then the default Cost Centre matched to STOCK or NEGATIVE ADJUSTMENT VARIANCE
respectively will be used
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5.21 Inventory Revaluation

Enable any revaluation of Stock to be recorded 

Debit Credit

*(Warehouse) STOCK REVALUATION OF STOCK  VARIANCE

* If the Warehouse does not contain a Cost Centre against INVENTORY or RE-VALUATION then
the default Cost Centre matched to STOCK or REVALUATION OF STOCK VARIANCE
respectively will be used

5.22 POS Station Withdrawals/Receipts

Record the Withdrawal or Receipt of miscellaneous cash from the POS Station 

Debit Credit

 POS EXPENSES UNDEPOSITED FUNDS

5.23 POS End of Day Variations

Record variation in actual -v- calculated End of Day Cash-up

Debit Credit

 UNDEPOSITED FUNDS POS END OF DAY
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6 Base Mapping in Ostendo

Thw following mapping is used as a base within Ostendo and will be used if no Sales Mapping,
Labour Mapping, or Warehouse specific Cost Centres have been separately defined

Cost Accumulation Area Linked Cost Centre

Stock STOCK

Stock Adjustment Variance STOCK ADJUST

Negative Stock Variance NEG STOCK

Revaluation Stock Variance REVALUE STOCK

Stock Count Variance COUNT STOCK

Stock In Transit STOCK INTRANSIT

Receipt Cost Variance RECEIPT COST VAR

Descriptor Expenses DESCRIPTOR EXPENSES

Catalogue Expenses CATALOGUE EXPENSES

Warranty Costs WARRANTY COSTS

Contract Costs CONTRACT COSTS

Direct Labour Costs DIRECT LABOUR COSTS

Fixed Labour Overhead Costs FIX OH COSTS

Variable Labour Overhead Costs VAR OH COSTS

Purchases Received Not Invoiced PURCHASES RECEIPTS

Purchase Price Variance PURCHASE PRICE VAR

Creditors CREDITORS

Assembly Work In Progress ASSEMBLY WIP

Assembly Order Variance ASSEMBLY VAR

Job Work In Progress JOB WIP

Job Cost Of Goods Sold JOB COGS

Job Cost Variance JOB VAR

Job Income JOB INCOME

Sales Lines Picked SALES PICKED

Sales Cost Of Goods Sold SALES COGS
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Sales Income SALES INCOME

Sales Freight SALES FREIGHT

Debtors DEBTORS

Contract Income CONTRACT INCOME

Deferred Cost Of Goods DEFERRED COGS

Deferred Income DEFFERED INCOME

Deferred Freight DEFFERED FREIGHT

Deferred Tax DEFFERED TAX

Un-Applied Deposits UNAPPLIED DEPOSITS

Un-Applied Payments UNAPPLIED PAYMENTS

Bank BANK

Payment Rounding PAYMENT ROUNDING

Discounts Given DISCOUNTS GIVEN

Un-Deposited Funds UNDEPOSITED FUNDS

POS End of Day Variance POS EOD

POS Shop Expenses POS EXPENSES
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7 Sales Mapping

A Sales Mapping screen extends the base functionality described in the previous sections by
allowing the User to establish a more detailed structure specifically covering the Sales area.  It
consists of a hierarchical structure using

  1.- Currency
  2 - Site Name
  3 - Invoice Customer Type
  4 - Invoice Customer Region
  5 - Order Customer Type
  6 - Order Customer Region
  7 - Order Class
  8 - Order Type
  9 - Sales Order Person
10 - Category

And mapping them to 
· Income Cost Centre
· Cost of Goods Cost Centre

In the above matrix the level 8 (Category) takes the most significant whereas Level 1 (Invoice
Customer Type) takes the least significant.  For example:

If there are three mapping records containing:

· Category/Order Type/Order Class/Order Customer Type (I.e. Levels 10/8/7/5)
· Category/Sales Order Person/Order Customer Region (I.e. Levels 10/9/6)
· Sales Order Person/Order Class/Invoice Customer Region (I.e. Levels 9/7/4)

If a Sales record had matching fields defined in all three mapping records then the second
mapping record would take priority over the others.

If the Sales record had matching fields except for Category defined in all three mapping records
then the third mapping record would take priority over the others..
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8 Labour Mapping

The Labour Mapping Screen extends the basic Labour Mapping functionality and allows a User to
establish a more detailed structure covering the Labour Code area.  It consists of a hierarchical
structure using

1 - Site
2 - Category
3 - Labour Code Department
4 - Employee Department
5 - Labour Code
6 - Employee

And mapping them to 
· Direct Labour Cost Centre
· Fixed OH Cost Centre
· Variable OH Cost Centre

In the above matrix the level 5 (Employee) takes the most significant whereas Level 1 (Category)
takes the least significant.  For example:

If there are two mapping records containing:

· Employee/Employee Department/Category (I.e. Levels 6/4/2)
· Employee/Labour Code/Category (I.e. Levels 6/5/2)

The second mapping record would take priority over the first. 
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9 Integration with MYOB

9.1 Process Overview

The integration with MYOB has two elements

Within Ostendo an ‘Accounting Link’ screen is available for:
· Creating Accounting Batches
· Maintaining a list of new and amended Supplier records
· Maintaining details of new Purchase Invoices

Then posting these to the MYOB ‘Accounts Integration’ routine. 

.
The MYOB Accounting Integration routine controls the mapping of Ostendo Cost Centres to
specific MYOB Account Codes. This routine also

· Posts the Accounts transactions to MYOB
· Creates or updates MYOBs Supplier records with data from Ostendo
· Adds new Purchase Invoices received from Ostendo

9.2 MYOB Accounts Interface Routine

This section describes the fields in the Accounts Interface routine and the activities required to
facilitate posting Ostendo transactions to MYOB.

The routine has 3 display panels

· Configuration Settings
· Mapping
· Process
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Panel 3 - Configuration Settings

This screen requires you to point this Accounting Interface routine to both Ostendo and MYOB. 
The following fields are shown in this screen

Cutover Date: This is used to allow you to define the date when Ostendo Transactions will begin
posting to MYOB.  Transactions prior to this date will be received by this function but will not be
passed on to MYOB.

Ostendo Accounting File Paths

Receive Path: This defines where the Batch details received from Ostendo will be stored.  Click
on the 3 dots icon and select the location of the folder.  Note: Each Company will have a
pre-generated folder with AcctLink_COMPANY\Pending\ where ‘COMPANY’ is the name of your
Company

Send Path: This defines where the details of the Batch - after updating MYOB - will be stored.
Click on the 3 dots icon and select the location of the folder.  Note: Each Company will have a
pre-generated folder with AcctLink_COMPANY\Processed\ where ‘COMPANY’ is the name of your
Company

MYOB ODBC

Company File: This defines the location of the MYOB Company database.  Click on the 3 dots
icon and select the location of the database

MYOB Application: This defines where the MYOB application program (Example:
C:\Premier10\Myobp.exe) is located.  Click on the 3 dots icon and select the location of the
program

Username: Enter the MYOB username (Example: Administrator) required to access the Company
File

Password: Enter the password used with the above MYOB username that is required to access
the Company File

File Access

Single User Access: This must be set up to reflect the current way that MYOB is set up in your
company

Multi-User Access: This must be set up to reflect the current way that MYOB is set up in your
company

Protocol: This must be set up to reflect the current way that MYOB is set up in your company

Panel 2 - Configuration Settings

This screen requires that you map Ostendo’s Cost Centres and Tax Codes to MYOB’s Account
Codes and Tax Codes.

Step 1. In the first instance you should go into Ostendo and select File>Accounting Link.   Click on
the ‘Export Lookup Files’ button and that will download Ostendo’s Cost Centres and Tax Codes to
this function.
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Step 2. The Ostendo Cost Centres will be displayed in the left-hand column.  In the right-hand
column select the equivalent MYOB Account codes from the drop-down list.

Step 3. Click on the ‘Tax Codes’ tab down the left side of the screen to display the Tax Codes
downloaded from Ostendo.  The Ostendo Tax Codes will be displayed in the left-hand column.  In
the right-hand column select the equivalent MYOB Tax Codes from the drop-down list.

Panel 1 - Process

This screen lets you view the status of batches received from Ostendo.  

Within the Accounting Link screen in Ostendo a Batch is created when the ‘Export Batch Files for
sending’ checkbox is ‘checked’ and the ‘Process Batch Files’ button is selected.  That batch is sent
to this routine and stored in the ‘Receive Path’ location defined above.  Upon receipt the displayed
text in this screen will show the number of Batches waiting to be processed

(Button) Process:  If this button is pressed then

a) All the unprocessed batches will update the appropriate Account Codes in MYOB. 

· If all Journals in a Batch are posted without error then each Journal will be flagged as
'Transaction Valid' and the Batch Header status set to 'Batch Succeeded'

· If any Journal in a Batch is found to be in error then the affected Journal will be flagged as
'Transaction Invalid' (all valid Journals will still be flagged as ‘Transaction Valid’) and the
Batch Header status set to 'Batch Failed'

Any encountered errors will be displayed for your immediate assessment.

You should note that correction and re-sending of invalid Transactions is controlled from within
Ostendo.  Therefore the updated statuses for Batch and Transactions should be transferred back
to Ostendo.   To do this go into Ostendo and, in the ‘Accounting Link’ screen ‘check’ the ‘Import
Received Batch Files’ checkbox and then click the ‘Process Batch Files’ Button.  

b) Any new Suppliers from Ostendo will be created in MYOB and any amended Supplier details will
update the Supplier record in MYOB

c) Each new Purchase Invoice received from Ostendo will be created as an Invoice in MYOB.  You
should note that the Description against each Invoice line will be derived from the Ostendo Invoice
line’s description.

Buttons

Close: Close this MYOB Accounting interface process and exit the screen.

Process: Process all the batches in the above ‘Pending’ folder

9.3 Set Up Checklist

1.  Ostendo

Carry out the following steps in Ostendo

· Go to File>System Configuration>Systems Settings and click on the 'Accounting Link' tab. 
Ensure that the 'Accounting Link Style' is set to 'MYOB Link'

· You should have already set up Tax Codes
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· Check that the Cost Centres in General>Cost Centres cover your requirements
· Validate the Cost Centre Mapping in File>Financial Configuration>Cost Centre Mapping
· Enter Cost Centres against Warehouses if you are segregating Accounts by Warehouse
· Complete the Sales Mapping Matrix in File>Financial Configuration>Sales Mapping Matrix

if you require deeper analysis in the Sales arena
· Complete the Labour Mapping Matrix in File>Financial Configuration>Labour Mapping

Matrix if you require deeper analysis in the Labour arena
· Identify the Cost Centre against selected Descriptors (else the Default will be used)
· Export the Cost Centre and Tax Codes to the MYOB Interface function.

2.  MYOB Interface Routine

· On Panel 3 - Set Up Paths to Ostendo and MYOB
· On Panel 2 - Match Cost Centres and Tax Codes to MYOB Account Codes and Tax

Codes

9.4 Processing

1.  Ostendo Transactions

Every Ostendo operational activity described in the ‘T’ Charts section above will immediately
create an Accounting transaction that is stored within Ostendo with the appropriate Dr & Cr Cost
Centres and amounts.  These records will be given a status of ‘Ready To Send’

2.  Creating Batches

If you go into the Accounting Link screen (File>Accounting Link) and ‘check’ the ‘Export Batch for
sending’ checkbox and then click the ‘Process Batch Details’ button all the Ostendo Transactions
with a status of ‘Ready To Send’ will be assembled into a single system-generated Batch and sent
to the MYOB Accounts Integration routine.  Each Journal included in the Batch will have the Batch
Number added to each Journal record and its status updated to ‘Transaction Sent'.   The
generated Batch itself will have a status of 'Ready to Send'.  

In addition to updating the Ostendo Financial Transactions the program will also send a complete
copy of the Batch to the MYOB Accounts Integration function.  

3.  Posting to MYOB

The MYOB Accounts Integration routine converts Ostendo’s Cost Centres into MYOB Account
Codes.  If the ‘Process’ button is pressed then the Batch is sent to MYOB via the MYOB ODBC
connection.   If the connection to MYOB is not available then nothing will happen and the Batch
status will remain as 'Ready to Send'.  If a connection is established then the Batch Journals will
be posted to the relevant Accounts and:

· If all Journals in the Batch are posted without error then each Journal will be flagged as
'Transaction Valid' and the Batch Header status set to 'Batch Succeeded'

· If any Journal in the Batch is found to be in error then the affected Journal will be flagged
as 'Transaction Invalid' (all valid Journals will sill be flagged as ‘Transaction Valid’) and the
Batch Header status set to 'Batch Failed'

Any encountered errors will be displayed for your information.

The next step is to get the results back into Ostendo. 

4.  Batches with Errors

In Ostendo’s ‘Accounting Link’ screen ‘check’ the ‘Import Received Batch Files’ checkbox and then
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click the ‘Process Batch Files’ Button.  This action will get the latest status of any Batch Updates
from the ‘Accounts Interface’ routine.  If there are Batches with errors then the Accounts Link
screen will now display an extra button “Display all Batches that Failed’.  If you click on this button
then all the Batches that have errors will be displayed along with drill-down to show the specific
Transactions that contain errors.  Action should now be taken to correct the problem(s) that
caused the error

5.  Update corrected ‘Error’ Batches

Having corrected the errors, go into Ostendo’s ‘Accounting Link’ screen and click on the ‘Display
All Batches that Failed’ button.   Select the Batch Number and then click the ‘Re Post Batch’
button.  This action will reset those transactions in the Batch whose status is ‘Transaction Invalid'
to ‘Ready to Send’

These transactions will be picked up and included in a new batch when the action outlined in 2.
(above) is carried out.  

6.  Re-Process Batches

Instances may arise where - for whatever reason - the batch sent to the MYOB Accounting
Interface had not been returned with a Batch Status update.  Facility is provided where you can
resend this Batch if necessary.  If you click on the ‘Re-Process Old Batch File’ button then a panel
will be presented for you to select and re-send the previously sent Batch.  
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10 Integration with Quickbooks

10.1 Process Overview

The integration with Quickbooks has two elements

Within Ostendo an ‘Accounting Link’ screen is available for:
· Creating Accounting Batches
· Maintaining a list of new and amended Supplier records
· Maintaining details of new Purchase Invoices

Then posting these to the Quickbooks ‘Accounts Integration’ routine. 

.
The Quickbooks Accounting Integration routine controls the mapping of Ostendo Cost Centres to
specific Quickbooks Account Codes. This routine also

· Posts the Accounts transactions to Quickbooks
· Creates or updates Quickbooks Supplier records with data from Ostendo
· Adds new Purchase Invoices received from Ostendo

10.2 Quickbooks Accounts Interface Routine

This section describes the fields in the Accounts Interface routine and the activities required to
facilitate posting Ostendo transactions to Quickbooks.

The routine has 3 display panels

· Configuration Settings
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· Mapping
· Process

Panel 3 - Configuration Settings

This screen requires you to point this Accounting Interface routine to both Ostendo and
Quickbooks.  The following fields are shown in this screen

Cutover Date: This is used to allow you to define the date when Ostendo Transactions will begin
posting to Quickbooks.  Transactions prior to this date will be received by this function but will not
be passed on to Quickbooks.

Ostendo Accounting File Paths

Receive Path: This defines where the Batch details received from Ostendo will be stored.  Click
on the 3 dots icon and select the location of the folder.  Note: Each Company will have a
pre-generated folder with AcctLink_COMPANY\Pending\ where ‘COMPANY’ is the name of your
Company

Send Path: This defines where the details of the Batch - after updating Quickbooks - will be
stored.  Click on the 3 dots icon and select the location of the folder.  Note: Each Company will
have a pre-generated folder with AcctLink_COMPANY\Processed\ where ‘COMPANY’ is the name
of your Company

Quickbooks

Company File: This defines the location of the Quickbooks Company database.  Click on the 3
dots icon and select the location of the database

Company File is Remote…:  If the above Company file is on a remote machine (Client/Server or
Peer to Peer environments) then you should ‘check’ this checkbox

In this instance Quickbooks requires that a separate application called (RDS) Remote Data
Sharing also be installed.   This application has two parts 

· Server:  The ‘Server’ application is to be installed on the Server or PC that has the
company file 

· Client: The Client application is to be installed on the Client

If the checkbox is ‘checked’ then the following links will be displayed which, when selected, will
allow you to download the applications.  

http://www.development-x.com/downloads/quickbooks/RDSServer.exe
http://www.development-x.com/downloads/quickbooks/RDS30Client.exe

 
These will enable you to download these applications.  Both these installations have their own help
files explaining their use and how to configure them.

Use Quickbooks Class for General ledger Reporting:  If this is 'checked' then field 'Account
Class' will be displayed in the 'Mapping'' screen.   This enables you to link a Cost Centre to an
Account Code/Class combination

Panel 2 - Mapping

This screen requires that you map Ostendo’s Cost Centres, Tax Codes, and Credit Terms to
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Quickbooks’s Account Codes and Tax Codes.

Step 1. In the first instance you should go into Ostendo and select File>Accounting Link.   Click
on the ‘Export Lookup Files’ button and that will download Ostendo’s Cost Centres, Credit Terms
and Tax Codes to this function.

Step 2. The Ostendo Cost Centres will be displayed in the left-hand column.  In the right-hand
column select the equivalent Quickbooks Account codes from the drop-down list.

Step 3. Click on the ‘Tax Codes’ tab down the left side of the screen.  In that screen click on  the
'Add' button and select the first Tax Code.  In the right-hand column select the equivalent
Quickbooks Tax Code from the drop-down list.  Repeat for all Tax Codes in Ostendo

Step 4. Click on the ‘Terms’ tab down the left side of the screen.  In that screen click on the 'Add'
button and select the first Terms Code.  In the right-hand column select the equivalent Quickbooks
Terms Code from the drop-down list.  Repeat for all Terms Codes in Ostendo

Panel 1 - Process

This screen lets you view the status of batches received from Ostendo.  

Within the Accounting Link screen in Ostendo a Batch is created when the ‘Export Batch Files for
sending’ checkbox is ‘checked’ and the ‘Process Batch Files’ button is selected.  That batch is sent
to this routine and stored in the ‘Receive Path’ location defined above.  Upon receipt the displayed
text in this screen will show the number of Batches waiting to be processed

(Button) Process:  If this button is pressed then

a) All the unprocessed batches will update the appropriate Account Codes in Quickbooks. 

· If all Journals in a Batch are posted without error then each Journal will be flagged as
'Transaction Valid' and the Batch Header status set to 'Batch Succeeded'

· If any Journal in a Batch is found to be in error then the affected Journal will be flagged as
'Transaction Invalid' (all valid Journals will still be flagged as ‘Transaction Valid’) and the
Batch Header status set to 'Batch Failed'

Any encountered errors will be displayed for your immediate assessment.

You should note that correction and re-sending of invalid Transactions is controlled from within
Ostendo.  Therefore the updated statuses for Batch and Transactions should be transferred back
to Ostendo.   To do this go into Ostendo and, in the ‘Accounting Link’ screen ‘check’ the ‘Import
Received Batch Files’ checkbox and then click the ‘Process Batch Files’ Button.  

b) Any new Suppliers from Ostendo will be created in Quickbooks and any amended Supplier
details will update the Supplier record in Quickbooks

c) Each new Purchase Invoice received from Ostendo will be created as an Invoice in Quickbooks.
You should note that the Description against each Invoice line will be derived from the Ostendo
Invoice line’s description.

Buttons

Close: Close this Quickbooks Accounting interface process and exit the screen.

Process: Process all the batches in the above ‘Pending’ folder
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10.3 Set Up Checklist

1.  Ostendo

Carry out the following steps in Ostendo

· Go to File>System Configuration>Systems Settings and click on the 'Accounting Link' tab. 
Ensure that the 'Accounting Link Style' is set to 'Quickbooks Link'

· You should have already set up Tax Codes
· Check that the Cost Centres in General>Cost Centres cover your requirements
· Validate the Cost Centre Mapping in File>Financial Configuration>Cost Centre

Mapping
· Enter Cost Centres against Warehouses if you are segregating Accounts by Warehouse
· Complete the Sales Mapping Matrix in File>Financial Configuration>Sales Mapping

Matrix if you require deeper analysis in the Sales arena
· Complete the Labour Mapping Matrix in File>Financial Configuration>Labour Mapping

Matrix if you require deeper analysis in the Labour arena
· Identify the Cost Centre against selected Descriptors (else the Default will be used)
· Export the Cost Centres, Terms Codes and Tax Codes to the Quickbooks Interface

function.

2.  Quickbooks

Carry out the following steps in Quickbooks

· You should create a Tax Item called 'OST' with 0% Tax.  This is used by the Interface
function to accommodate minor differences in Tax calculations between Ostendo and
Quickbooks

· You should also create Customer called 'Ostendo'.  This Customer will be used against all
Sales Journals where a Customer Name is required in Quickbooks

3.  Interface Routine

· On Panel 3 - Set Up Paths to Ostendo and Quickbooks
· On Panel 2 - Match Cost Centres, Tax Codes and Terms Codes to Quickbooks Account

Codes and Tax Codes

10.4 Processing

1.  Ostendo Transactions

Every Ostendo operational activity described in the ‘T’ Charts section above will immediately
create an Accounting transaction that is stored within Ostendo with the appropriate Dr & Cr Cost
Centres and amounts.  These records will be given a status of ‘Ready To Send’

2.  Creating Batches

If you go into the Accounting Link screen (File>Accounting Link) and ‘check’ the ‘Export Batch for
sending’ checkbox and then click the ‘Process Batch Details’ button all the Ostendo Transactions
with a status of ‘Ready To Send’ will be assembled into a single system-generated Batch and sent
to the Quickbooks Accounts Integration routine.  Each Journal included in the Batch will have the
Batch Number added to each Journal record and its status updated to ‘Transaction Sent'.   The
generated Batch itself will have a status of 'Ready to Send'.  

In addition to updating the Ostendo Financial Transactions the program will also send a complete
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copy of the Batch to the Quickbooks Accounts Integration function.  

3.  Posting to Quickbooks

The Quickbooks Accounts Integration routine converts Ostendo’s Cost Centres into Quickbooks
Account Codes.  If the ‘Process’ button is pressed then the Batch is sent to Quickbooks via the
Quickbooks connection.   If the connection to Quickbooks is not available then nothing will happen
and the Batch status will remain as 'Ready to Send'.  If a connection is established then the Batch
Journals will be posted to the relevant Accounts and:

· If all Journals in the Batch are posted without error then each Journal will be flagged as
'Transaction Valid' and the Batch Header status set to 'Batch Succeeded'

· If any Journal in the Batch is found to be in error then the affected Journal will be flagged
as 'Transaction Invalid' (all valid Journals will sill be flagged as ‘Transaction Valid’) and the
Batch Header status set to 'Batch Failed'

Any encountered errors will be displayed for your information.

The next step is to get the results back into Ostendo. 

4.  Batches with Errors

In Ostendo’s ‘Accounting Link’ screen ‘check’ the ‘Import Received Batch Files’ checkbox and then
click the ‘Process Batch Files’ Button.  This action will get the latest status of any Batch Updates
from the ‘Accounts Interface’ routine.  If there are Batches with errors then the Accounts Link
screen will now display an extra button “Display all Batches that Failed’.  If you click on this button
then all the Batches that have errors will be displayed along with drill-down to show the specific
Transactions that contain errors.  Action should now be taken to correct the problem(s) that
caused the error

5.  Update corrected ‘Error’ Batches

Having corrected the errors, go into Ostendo’s ‘Accounting Link’ screen and click on the ‘Display
All Batches that Failed’ button.   Select the Batch Number and then click the ‘Re Post Batch’
button.  This action will reset those transactions in the Batch whose status is ‘Transaction Invalid'
to ‘Ready to Send’

These transactions will be picked up and included in a new batch when the action outlined in 2
above is carried out.  

6.  Re-Process Batches

Instances may arise where - for whatever reason - the batch sent to the Quickbooks Accounting
Interface had not been returned with a Batch Status update.  Facility is provided where you can
resend this Batch if necessary.  If you click on the ‘Re-Process Old Batch File’ button then a panel
will be presented for you to select and re-send the previously sent Batch.  
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11 Integration with Pastel Evolution

11.1 Process Overview

The integration with Pastel Evolution has two elements

Within Ostendo an ‘Accounting Link’ screen is available for:
· Creating Accounting Batches
· Maintaining a list of new and amended Supplier records
· Maintaining details of new Purchase Invoices

Then posting these to the Pastel Evolution ‘Accounts Integration’ routine. 

.
The Pastel Evolution Accounting Integration routine controls the mapping of Ostendo Cost Centres
to specific Pastel Evolution Account Codes. This routine also

· Posts the Accounts transactions to Pastel Evolution
· Creates or updates Pastel Evolutions Supplier records with data from Ostendo
· Adds new Purchase Invoices received from Ostendo

11.2 Pastel Evolution Accounts Interface

This section describes the fields in the Accounts Interface routine and the activities required to
facilitate posting Ostendo transactions to Pastel Evolution.

The routine has 3 display panels

· Configuration Settings
· Mapping
· Process

Panel 3 - Configuration Settings

This screen requires you to point this Accounting Interface routine to both Ostendo and Pastel
Evolution.  The following fields are shown in this screen

Cutover Date: Select a specific Cutover date or Today's date (this action  will also automatically
prefill field 'Common Database').  The Cutover Date is used to allow you to define the date when
Ostendo Transactions will begin posting to Pastel Evolution.  Transactions prior to this date will be
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received by this function but will not be passed on to Pastel Evolution.

Ostendo Accounting File Paths

Pending Path: This defines where the Batch details received from Ostendo will be stored.  Click
on the 3 dots icon and select the location of the folder.  Note: Each Company will have a
pre-generated folder with AcctLink_COMPANY\Pending\ where ‘COMPANY’ is the name of your
Company

Processed Path: This defines where the details of the Batch - after updating Pastel Evolution - will
be stored.  Click on the 3 dots icon and select the location of the folder.  Note: Each Company will
have a pre-generated folder with AcctLink_COMPANY\Processed\ where ‘COMPANY’ is the name
of your Company

Pastel 

Common Database: This is prefilled with the Common Database name when you enter a Cutover
Date in the 'Cutover Date' field.  It can be amended here if required

Company Database: Enter the Company Database name.

Panel 2 - Configuration Settings

This screen requires that you map Ostendo’s Cost Centres and Tax Codes to Pastel Evolution’s
Account Codes and Tax Codes.

Step 1. In the first instance you should go into Ostendo and select File>Accounting Link.   Click on
the ‘Export Lookup Files’ button and that will download Ostendo’s Cost Centres and Tax Codes to
this function.

Step 2. The Ostendo Cost Centres will be displayed in the left-hand column.  In the right-hand
column select the equivalent Pastel Evolution Account codes from the drop-down list.

Step 3. Click on the ‘Tax Codes’ tab down the left side of the screen to display the Tax Codes
downloaded from Ostendo.  The Ostendo Tax Codes will be displayed in the left-hand column.  In
the right-hand column select the equivalent Pastel Evolution Tax Codes from the drop-down list.

Panel 1 - Process

This screen lets you view the status of batches received from Ostendo.  

Within the Accounting Link screen in Ostendo a Batch is created when the ‘Export Batch Files for
sending’ checkbox is ‘checked’ and the ‘Process Batch Files’ button is selected.  That batch is sent
to this routine and stored in the ‘Receive Path’ location defined above.  Upon receipt the displayed
text in this screen will show the number of Batches waiting to be processed

(Button) Process:  If this button is pressed then

a) All the unprocessed batches will update the appropriate Account Codes in Pastel Evolution. 

· If all Journals in a Batch are posted without error then each Journal will be flagged as
'Transaction Valid' and the Batch Header status set to 'Batch Succeeded'

· If any Journal in a Batch is found to be in error then the affected Journal will be flagged as
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'Transaction Invalid' (all valid Journals will still be flagged as ‘Transaction Valid’) and the
Batch Header status set to 'Batch Failed'

Any encountered errors will be displayed for your immediate assessment.

You should note that correction and re-sending of invalid Transactions is controlled from within
Ostendo.  Therefore the updated statuses for Batch and Transactions should be transferred back
to Ostendo.   To do this go into Ostendo and, in the ‘Accounting Link’ screen ‘check’ the ‘Import
Received Batch Files’ checkbox and then click the ‘Process Batch Files’ Button.  

b) Any new Suppliers from Ostendo will be created in Pastel Evolution and any amended Supplier
details will update the Supplier record in Pastel Evolution

c) Each new Purchase Invoice received from Ostendo will be created as an Invoice in Pastel
Evolution.  You should note that the Description against each Invoice line will be derived from the
Ostendo Invoice line’s description.

Buttons

Close: Close this Pastel Evolution Accounting interface process and exit the screen.

Process: Process all the batches in the above ‘Pending’ folder

11.3 Set Up Checklist

1.  Ostendo

Carry out the following steps in Ostendo

· Go to File>System Configuration>Systems Settings and click on the 'Accounting Link' tab. 
Ensure that the 'Accounting Link Style' is set to 'Sage Pastel Evolution'

· You should have already set up Tax Codes
· Check that the Cost Centres in General>Cost Centres cover your requirements
· Validate the Cost Centre Mapping in File>Financial Configuration>Cost Centre Mapping
· Enter Cost Centres against Warehouses if you are segregating Accounts by Warehouse
· Complete the Sales Mapping Matrix in File>Financial Configuration>Sales Mapping Matrix

if you require deeper analysis in the Sales arena
· Complete the Labour Mapping Matrix in File>Financial Configuration>Labour Mapping

Matrix if you require deeper analysis in the Labour arena
· Identify the Cost Centre against selected Descriptors (else the Default will be used)
· Export the Cost Centre and Tax Codes to the Pastel Evolution Interface function.

2.  Pastel Evolution Interface Routine

· On Panel 3 - Set Up Paths to Ostendo and the Database Names in Pastel Evolution
· On Panel 2 - Match Cost Centres and Tax Codes to Pastel Evolution Account Codes and

Tax Codes

11.4 Processing

1.  Ostendo Transactions

Every Ostendo operational activity described in the ‘T’ Charts section above will immediately
create an Accounting transaction that is stored within Ostendo with the appropriate Dr & Cr Cost
Centres and amounts.  These records will be given a status of ‘Ready To Send’
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2.  Creating Batches

If you go into the Accounting Link screen (File>Accounting Link) and ‘check’ the ‘Export Batch for
sending’ checkbox and then click the ‘Process Batch Details’ button all the Ostendo Transactions
with a status of ‘Ready To Send’ will be assembled into a single system-generated Batch and sent
to the Pastel Evolution Accounts Integration routine.  Each Journal included in the Batch will have
the Batch Number added to each Journal record and its status updated to ‘Transaction Sent'.   The
generated Batch itself will have a status of 'Ready to Send'.  

In addition to updating the Ostendo Financial Transactions the program will also send a complete
copy of the Batch to the Pastel Evolution Accounts Integration function.  

3.  Posting to Pastel Evolution

The Pastel Evolution Accounts Integration routine converts Ostendo’s Cost Centres into Pastel
Evolution Account Codes.  If the ‘Process’ button is pressed then the Batch is sent to Pastel
Evolution via the Pastel Evolution ODBC connection.   If the connection to Pastel Evolution is not
available then nothing will happen and the Batch status will remain as 'Ready to Send'.  If a
connection is established then the Batch Journals will be posted to the relevant Accounts and:

· If all Journals in the Batch are posted without error then each Journal will be flagged as
'Transaction Valid' and the Batch Header status set to 'Batch Succeeded'

· If any Journal in the Batch is found to be in error then the affected Journal will be flagged
as 'Transaction Invalid' (all valid Journals will sill be flagged as ‘Transaction Valid’) and the
Batch Header status set to 'Batch Failed'

Any encountered errors will be displayed for your information.

The next step is to get the results back into Ostendo. 

4.  Batches with Errors

In Ostendo’s ‘Accounting Link’ screen ‘check’ the ‘Import Received Batch Files’ checkbox and then
click the ‘Process Batch Files’ Button.  This action will get the latest status of any Batch Updates
from the ‘Accounts Interface’ routine.  If there are Batches with errors then the Accounts Link
screen will now display an extra button “Display all Batches that Failed’.  If you click on this button
then all the Batches that have errors will be displayed along with drill-down to show the specific
Transactions that contain errors.  Action should now be taken to correct the problem(s) that
caused the error

5.  Update corrected ‘Error’ Batches

Having corrected the errors, go into Ostendo’s ‘Accounting Link’ screen and click on the ‘Display
All Batches that Failed’ button.   Select the Batch Number and then click the ‘Re Post Batch’
button.  This action will reset those transactions in the Batch whose status is ‘Transaction Invalid'
to ‘Ready to Send’

These transactions will be picked up and included in a new batch when the action outlined in 2.
(above) is carried out.  

6.  Re-Process Batches

Instances may arise where - for whatever reason - the batch sent to the Pastel Evolution
Accounting Interface had not been returned with a Batch Status update.  Facility is provided where
you can resend this Batch if necessary.  If you click on the ‘Re-Process Old Batch File’ button then
a panel will be presented for you to select and re-send the previously sent Batch.  
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12 Integration with AccountRight Live

Overview:

Ostendo can be integrated with the MYOB AccountRight Live Desktop or Cloud versions via the
MYOB Application Programming Interface (API).

Ostendo must be at Update 187 or later before implementing the Ostendo-AccountRight Live link.
Users are strongly encouraged to use the latest Ostendo Update together with the latest
accounting link version.

Financial transactions generated in Ostendo will automatically be posted into the AccountRight
Live system according to a pre-defined posting frequency. The batching and posting of
transactions is done by Ostendo and no user action is required.

User intervention is only required as and when there are failed batches. When batches fail to post,
a designated user needs to review the transactions, examine the reasons for the failure, rectify,
and re-post the batch.

12.1 AccountRight Live Setup

Changing from MYOB Link to MYOB AccountRight Live:

If you are changing from the batch MYOB (ODBC) Link, you should take note of the following:

a. Before upgrading the MYOB datafile, run the MYOB link and ensure there are no faulty
batches left in Ostendo.

b. Once the new AccountRight Live link is set up, you will not be using any of the old acclink
files. They can be archived. The old MYOB link application can be removed.

c. Set the Cutover Date in GENERALSETTINGS table correctly. The new cutover date should
ensure that no earlier transactions are duplicated.

d. With the ODBC link, invoices created in Ostendo were not posted across to MYOB (only
journals). So if there are unpaid /outstanding invoices in Ostendo before the cutover, these
invoices must be manually entered in AccountRight Live in order for payments to be received
for such invoices after the cutover. 

e. In the new AccountRight Live link you will see the sales in the AccountRight sales register
and receive payments through AccountRight Live which are reflected in Ostendo. (Not
applicable to classic MYOBLink style)

f. Please bear in mind that in AccountRight Live, Invoice Numbers cannot exceed 8 characters.

g. For sites that use POS, debtors can still be run in AccountRight live as all POS sales will
appear in the AccountRight Live sales register. (Not applicable to classic MYOBLink style)

h. For account sales made via POS, payments can be receipted via AccountRight Live. (Not
applicable to classic MYOBLink style)

i. Customers and Suppliers should be synchronized with the AccountRight Live file (using the
Import/Export buttons in GENERALLEDGERSETTINGS screen). (For classic MYOBLink
style, only Suppliers need to be synchronized.)

Note: If upgrading from MYOB Premier (Classic), all financial transactions must be posted into
your earlier MYOB data file before you upgrade and before completing SYSTEM SETTINGS 
setup. 
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Bring Batch Report back into Ostendo so that all transactions are marked as valid.

There must be NO failed batches outstanding. Deal with them first.

With MYOB Premier, invoices were not posted from Ostendo, only journals. With
AccountRight Live, invoices are now posted across. So any unpaid/outstanding invoices generated
in Ostendo need to be manually created in AccountRight Live in order that payments can be

received. (unless you choose AR Style: “Post Invoices and Payments as Journals”)

A. AccountRight Live Desktop

Before you proceed with the Setup process, ensure you have the following information:

a. The name of the AccountRight Live company file.

b. The AccountRight Live file should already have a username and password for
Ostendo to access it. If not, open AccountRight Live and go to Setup --> User Access. 

Ostendo user should have sufficient rights to access all the required resources
. 

c. Make sure MYOB API is already installed.

B. AccountRight Live Cloud

In addition to the above, make sure you have the credentials to log into the
my.MYOB.com account to authorize Ostendo to access the AccountRight Live file in the cloud. 

Credentials here refer to the my.MYOB Username and Password - which is different
from that created for users of the Company File.

12.2 Ostendo Setup

The following areas need to be set up in preparation for the integration with MYOB AccountRight
Live:

· Systems Settings - Accounting Link tab

· User Security and Settings - User Options tab

· General Ledger Settings

· Tax Codes 

· Cost Centre - AccountRight Live GL Codes mapping

SYSTEM SETTINGS

For integration with AccountRight Live, the following items must be specified in File --> Systems
Configuration --> Systems Settings - Accounting Link tab:

· Accounting Link Style: AccountRight Live Desktop or AccountRight Live Cloud

· Posting Frequency: Minimum 5 minutes.
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· Cutover Date: The date from which transactions will be posted to AccountRight Live. Please set
this date correctly.

· Timeout (min): This should be set to 120 minutes.

· Retry Count: Recommended 1 or 2 retries when there are connection failures.

· AR Style:  Select "Standard Invoice and Payment Posting" or "Post Invoices and Payments
as Journals". Posting invoices and payments as journals is similar to the classic MYOBLink
style.

· Invoice Number Prefix:  The default is "S". You can change it to some other alphabet if
required. This prefix helps to make invoices generated in Ostendo to be unique and avoid issues
with duplicate numbers generated by AccountRight Live.

· External Accounts Receivables: Ticked.

· No External Payments Returned:  Tick this box if you want payments to go in one direction
only - i.e. from Ostendo to AR Live.

· Prevent Manual Payments:  Tick this box if you wish to only enter payments in AccountRight
Live (not in Ostendo). POS payments captured in Ostendo will still be processed and posted to
AccountRight Live. 

USER SECURITY & SETTINGS

In File --> System Configuration --> User Security and Settings - User Options tab, there is this
option:

· No External GL Posting

At least one Ostendo user must have this option UNTICKED if you are not using Queue Services
to initiate batch posting. When there is one or more users (with this option unticked) logged in,
then the automated posting process will be active. 

If this option is TICKED for every Ostendo user, then the automated posting process will not be
active. This is one way to temporary stop posting to AccountRight Live (if required).

Alternatively, you can use Queue Services to initiate posting of batches as per your set Posting
Frequency. All you need to do is to create a user (say QS) and have this No External GL Posting
option unticked for QS (but ticked for all other users). Then when the Queue Service is started, the
financial transactions will be posted across to the Accounting system as per the Posting
Frequency.

When using Queue Services in this manner, you would need to go to File --> AccountingLink to
check if there are any failed batches .

Activate posting only when all the other integration setup tasks are completed.

GENERAL LEDGER SETTINGS

In File --> Financial Configuration, go to GeneralLedgerSettings and add a record. Follow the steps
below:
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· Accounting Link : AccountRight Live Desktop or AccountRight Live Cloud

· Update button : Click to load all the required Accounting Link scripts. You will see that the
Version field is filled in when this step is completed.

· Setup button : Click to begin the Accounting Link setup process:

1. AccountRight Live Desktop: You will first be prompted for IP address of your desktop
machine. You can use the default "localhost" if you are running a standalone system. For 
Client-Server or Peer-to-Peer networks, provide the IP address of the machine that is hosting
the AccountRight file.

AccountRight Cloud: You will be presented with an MYOB Sign-In screen. 

This is where you enter your my.MYOB credentials to authorize
Ostendo to access your company file in the Cloud. (This is the my.MYOB username and password
- not the same as the Username and Password for the Company File.  

2. Next, you will be prompted to select your company file. Keep clicking No until the correct
company file name appears - then click Yes. 

3. After selecting your company file, you will be prompted to enter the Username, followed by
Password.

4. When the message "GENERALLEDGERSETTINGS updated." is displayed, click OK to
finish setup.

Close the GeneralLedgerSettings screenandopen it again - you will see that the URL or
Path, Username, and Password fields are now filled in.

· DebugMode box: Tick it. DebugMode on will create a debuglog file in Ostendo folder each time
a batch of transactions are processed. It is advisable to set DebugMode on until the 
integration is running smoothly. 

· Connect button : Click to verify that the setup is OK. A successful connection will display the
name of the Company File being connected to.

· Import button : Click and select to import:

- Ledger Codes (This will also import Job Numbers if they are set
up in AccountRight General Ledger) 

- Customers from AccountRight Live (if required)

- Suppliers from AccountRight Live (if required)

· Export button : Click and select to export:

- Customers from Ostendo to AccountRight Live (if required)

- Suppliers from Ostendo to AccountRight Live (if required)

TAXCODES

In AccountRight Live, you can click on Lists and select TaxCodes to display all the tax codes
defined in the system. 

In Ostendo, go to File --> Financial Configuration and select Tax Codes.  Setup the required
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Ostendo Tax Codes with the Tax Rate %. For each Ostendo Tax Code, enter the appropriate
AccountRight Live taxcodes into the External  Tax Code column. 

COST CENTRES

Go to General --> Cost Centres. From the detail screen of each  Cost Centre, select the
appropriate AccountRight Live GL Account from the lookup.

Make sure all Cost Centres are mapped to the appropriate AccountRight Live Ledger Code. 

If Job Numbers are used in AccountRight, you may need to create more Cost Centres so they can
be mapped to the relevant GL codes and Job Numbers.

Job Numbers and Names (if any) are displayed in the Financial Category column in the Cost
Centre screen.

Once you have mapped all the Cost Centres, you would have completed the Accounting Link
setup.

12.3 Points of Integration

From Ostendo Update 206 onwards, you have the option of AR Style to consider:

a. Standard Invoice and Payment Posting - (Default style)
b. Post Invoices and Payments as Journals – (classic MYOB Link style)

The default style is to post sale invoices as invoices and customer payments as payments into AR
live file. This document generally assumes the default style “Standard Invoice and Payment
Posting” is used.

There are many MYOB API resources available. However not all resources are part of the
Ostendo – MYOB AccountRight Live integration. The affected resources are as follows:

1. Contact/Supplier - this is the MYOB resource which holds Supplier information. Any addition or
change in Supplier master records in Ostendo will be reflected in MYOB.

2. Contact/Customer - this is the MYOB resource which holds Customer information. Any addition
or change in Customer master records in Ostendo will be reflected in MYOB. (Not applicable to
classic MYOBLink style).

Note: Customers and Suppliers must be designated as Companies in MYOB (not as
Individuals).

Avoid using apostrophe/single quote (‘) in Customer/Supplier names. This will be
converted to a Grave accent (`) by the AccountingLink scripts. 
Avoid using backslash (\) in any names, addresses, descriptions, etc. This will be
replaced by a forward slash (/). 

3. GeneralLedger/GeneralJournal – all journals generated in Ostendo except Invoice Payment
and Invoice Deposit, are posted to this resource in MYOB. 

     From version 2.13 onwards, Journal Numbers posted to AccountRight Live will be prefixed
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with an “O” (e.g. O12345).

     (For classic MYOBLink style, Invoice Payments and Invoice Deposits are also posted as
journals.)

4. Sale/Invoice/Service – this resource caters to both Sales Invoices and CreditNotes created in
Ostendo. Sales Invoice and Credit Note transactions are posted to MYOB as “Already Printed or
Sent”. (Not applicable to classic MYOBLink style).

5. Purchase/Bill/Service – this resource caters to both Purchase(Supplier) Invoices and
CreditNotes created in Ostendo. Purchase Invoice and Credit Note transactions are posted to
MYOB as “Already Printed or Sent”.

6. Sale/CustomerPayment – Invoice Payment and Invoice Deposit journals generated in Ostendo
are posted to this resource in MYOB. Only the Debit side of the journal is posted.

Note: Payment Discounts are posted to MYOB as Credit Notes and applied to the associated
Invoices via Sale/CreditSettlement.

     (Not applicable to classic MYOBLink style).

7. Customer Payments entered directly into MYOB will be pulled back into Ostendo and
Customer Payment records will be created for the matching invoices. However no financial 
transactions will be created in Ostendo for such records – to avoid reposting back into MYOB.
Such payment records in Ostendo will be marked as “External Payments”.

    (For classic MYOBLink style, customer payments including POS payments will be posted as
journals.) 

8. On a daily basis, the AccountingLink process also checks to see if there are any Payments
deleted from MYOB over the last 45 days. Any such deletions will also trigger the deletion of the
matching Payment transaction from Ostendo’s  CustomerPaymentTrans table.

Note: When a Customer Payment header record is created in Ostendo – this generates a
Customer Payment Journal which is then posted to MYOB. 

When a payment is applied to an invoice in Ostendo – this generates an Invoice Payment journal
which will be posted to MYOB.

To ensure that Customer Payments are kept in sync between Ostendo and MYOB, Applied
payment transactions (i.e. Invoice Payment journals) can only be deleted in MYOB. 

The Accounting Link process will detect such deletions in MYOB and delete the associated Applied
Payment transaction in Ostendo.

Note: By default, the AccountingLink process will only check for deletion of Payments which are
up to 45 days old. If you need the system to check for deletion of Payments which are older than
45 days, then you need to create a USERDEFINEDCONSTANT called “MYOBDELETIONHORIZON”.
The type is “Integer” and the value is the number of days you wish to set.

To delete an Invoice payment journal in MYOB, just go to the Sales Invoice, click on history button,
select the payment and delete it.

Only un-applied Customer Payment header records can be deleted in Ostendo. When this is done,
a reversing Customer Payment journal is generated and posted to MYOB.

(Not applicable to classic MYOBLink style).

All financial transactions generated in Ostendo will be summarised into the following tables
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- JOURNALHEADER – updates GeneralJournal or CustomerPayment in MYOB

- JOURNALLINES – updates GeneralJournal or CustomerPayment in MYOB

- JOURNALINVHEADER  – updates Sale/Invoice/Service or Purchase/Bill/Service
in MYOB

- JOURNALINVLINES  – updates Sale/Invoice/Service or Purchase/Bill/Service
in MYOB

Changes to Customer Master and Supplier Master record will create transactions in 
FINANCIALCUSTOMERS and FINANCIALSUPPLIERS tables respectively. These transactions
will then be used to update MYOB Contact/Customer and Contact/Supplier resources.

(For classic MYOBLink style, only SupplierMaster records are synchronozed between ARLive and
Ostendo.)

12.4 The Automated Process

As transaction records are being added to the tables listed above, Ostendo will flag them as
“Ready to Send”.  

Ostendo will post transactions to MYOB AccountRight Live based on the frequency set in System
Settings. The frequency of posting can be set to in terms of minutes or hours. Frequency of once
every hour or two hours should be sufficient. 

All transactions which are “Ready to Send” will be assigned a batch number and posted as one
batch in the following order:

- FINANCIALSUPPLIERS transactions to MYOB Contact/Supplier,

- FINANCIALCUSTOMERS transactions to MYOB Contact/Customer,

- JOURNALHEADER and LINES transactions (except Invoice Payments and
Invoice Deposits) to MYOB GeneralLedger/GeneralJournal

- JOURNALINVHEADER and LINES transactions to MYOB Sale/Invoice/Service or
Purchase/Bill/Service 

- JOURNALHEADER and LINES for Invoice Payments and Invoice Deposits to
MYOB Sale/CustomerPayment.

This process runs automatically in the background  when there is at least one user logged in. 

This process can be stopped if the “No External GL Posting” flag is ticked for ALL users of the
system. This flag is found in SYSTEM CONFIGURATION à User Security & Options à User
Options tab.

User intervention is only required if there are failed batches occurring – which is indicated in the
top status bar of the Ostendo main screen:
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If you click on the failed batches in the status bar, you will get the following:

Click on “Display All batches that Failed” button and you will see a list of failed batches.

Click on the Detail tab, and you will see the invalid transactions:

Reviewing and correcting Failed Batches:

The following GENERAL Inquiries are available to review the batches and transactions:

- Inquiry – Ledger Journals

- Inquiry – Ledger Sales Invoices

- Inquiry – Ledger Purchase Invoices

Example of Ledger Sales Invoices inquiry – detail screen:
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You could also create your own inquiries/database queries to review the transactions in these
tables.

Common causes of failed batches include:

- Incorrect tax codes used (Tax code mapping not done correctly).

- Missing Account Codes (Cost Centre – Ledger Codes mapping incorrect or
incomplete).

Once the errors are fixed, the batches can be re-posted by clicking on the Repost Batch and
Process Batches buttons.
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13 Integration with MoneyWorks

Overview:

Ostendo can be integrated with the MoneyWorks DataCentre Accounting system via the
MoneyWorks Application Programming Interface (API).

Ostendo must be at Update 187 or later before implementing the Ostendo-MoneyWorks link.
Users are strongly encouraged to use the latest Ostendo Update together with the latest
accounting link version.

Financial transactions generated in Ostendo will automatically be posted into the MoneyWorks
system according to a pre-defined posting frequency. The batching and posting of transactions is
done by Ostendo and no user action is required.

User intervention is only required as and when there are failed batches. When batches fail to post,
a designated user needs to review the transactions, examine the reasons for the failure, rectify,
and re-post the batch.

Existing Invoices

If there are any outstanding invoices in Ostendo which are not fully paid before the planned cutover
date, these must be manually created in MoneyWorks with the exact same invoice numbers
otherwise subsequent payments (entered after cutover) will not be posted. 

13.1 MoneyWorks Setup

To integrate Ostendo with MoneyWorks DataCentre, you need to do the following:

1. Start up MoneyWorks DataCentre and go to Services tab. Accept the default port numbers
and tick the "Enable REST service on port: 6710" box.

2. Start up MoneyWorks Gold and go to File --> Sharing and Users.

Create a username and password with the appropriate privileges in the MoneyWorks
document. This will be the username used by Ostendo to access the MoneyWorks document 
(company file).

Existing Invoices

If there are any outstanding invoices in Ostendo which are not fully paid before the planned cutover
date, these must be manually created in MoneyWorks with the exact same invoice numbers
otherwise subsequent payments (entered after cutover) will not be posted. 
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13.2 Ostendo Setup

The following areas need to be set up in preparation for the integration with MoneyWorks
DataCentre:

· Systems Settings - Accounting Link tab

· User Security and Settings - User Options tab

· General Ledger Settings

· Tax Codes 

· Cost Centre - MoneyWorks GL Codes mapping

SYSTEM SETTINGS

For integration with MoneyWorks, the following items must be specified in File --> Systems
Configuration --> Systems Settings - Accounting Link tab:

· Accounting Link Style: MoneyWorks

· Posting Frequency: Minimum 5 minutes.

· Cutover Date: The date from which transactions will be posted to MoneyWorks. Please set this
date correctly.

· Timeout (min): This should be set to 120 minutes.

· Retry Count: Recommended 1 or 2 retries when there are connection failures.

· External Accounts Receivables: Ticked.

· No External Payments Returned:  Tick this box if you want payments to go in one direction
only - i.e. from Ostendo to MoneyWorks. 

USER SECURITY & SETTINGS

In File --> System Configuration --> User Security and Settings - User Options tab, there is this
option:

· No External GL Posting

At least one Ostendo user must have this option UNTICKED if you are not usng Queue Services
to initiate posting. When there is one or more users (with this option unticked) logged in, then the
automated posting process will be active. 

If this option is TICKED for every Ostendo user, then the automated posting process will not be
active. This is one way to temporary stop posting to MoneyWorks (if required).

Alternatively, you can use Queue Services to initiate posting of batches as per your set Posting
Frequency. All you need to do is to create a user (say QS) and have this No External GL Posting
option unticked for QS (but ticked for all other users). Then when the Queue Service is started, the
financial transactions will be posted across to the Accounting system as per the Posting
Frequency.
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When using Queue Services in this manner, you would need to go to File --> AccountingLink to
check if there are any failed batches .

Activate posting only when all the other integration setup tasks are completed.

GENERAL LEDGER SETTINGS

In File --> Financial Configuration, go to GeneralLedgerSettings and add a record. Fill in the
following:

· Accounting Link : MoneyWorks

· URL or Path : Enter the MoneyWorks API Endpoint URL. This is normally in the following
format:

http://ipaddress:6710/REST/username:password@moneyworksdocumentname/

Please note that the MoneyWorks Document name is case-sensitive and must
be url-encoded. 

For example:
http://10.1.0.198:6710/REST/ostendo:ostendo@Acme%20Widgets%20Gold.mwd7/

or        
http://localhost:6710/REST/ostendo:ostendo@Acme%20Widgets%20Gold.mwd7/

If your MoneyWorks DataCentre folder is password protected, then the URL
Path will be as follows:

http://foldername:folderpassword@ipaddress:6710/REST/username:password@foldername/mone
yworksdocumentname/

Please note that the FolderName and MoneyWorks Document name are
case-sensitive and must be url-encoded. 

Example:
http://CompanyFiles:pass@localhost:6710/REST/ostendo:ostendo@CompanyFiles%2FAcme%20
Widgets%20Gold.mwd7/

· Username : Username specified in MoneyWorks Document.

· Password : Password for the Username above.

· API Token : Not used.

· Private Key : Not used.

· Version : This is a display only field to show what version of the posting script you are currently
using.

· DebugMode : Ticking this will produce a debuglog file in Ostendo folder each time a batch of
transactions is posted. This is useful during initial stages of integration to resolve any teething
problems. Can be turned off after the integration is running smoothly.

· Database path : This is a display only field to show which database you are actually connected

http://ipaddress:6710/REST/username:password@moneyworksdocumentname/
http://10.1.0.198:6710/REST/ostendo:ostendo@Acme%20Widgets%20Gold.mwd7/
http://localhost:6710/REST/ostendo:ostendo@Acme%20Widgets%20Gold.mwd7/
http://foldername:folderpassword@ipaddress:6710/REST/username:password@foldername/moneyworksdocumentname/
http://foldername:folderpassword@ipaddress:6710/REST/username:password@foldername/moneyworksdocumentname/
http://CompanyFiles:pass@localhost:6710/REST/ostendo:ostendo@CompanyFiles%2FAcme%20Widgets%20Gold.mwd7/
http://CompanyFiles:pass@localhost:6710/REST/ostendo:ostendo@CompanyFiles%2FAcme%20Widgets%20Gold.mwd7/
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to.

After filling in the required fields, click on the Update button. This will download the required
integration scripts from Development-X Limited. You will see that the version field will be updated
when this completes.

Next, click on Connect button to test that you can actually connect to your MoneyWorks
Document.

Next, click on the Import button, and select GL Codes. This will import the General Ledger
Accounts Codes from MoneyWorks. These codes will be used to map to the Ostendo Cost
Centres later.

Make sure the MoneyWorks Ledger Codes have the correct Tax code assigned.

If there is a requirement to export Customers and/or Suppliers from Ostendo to MoneyWorks, then
click Export button.

The same set of Customers and Suppliers must be set up on both sides.

TAXCODES

Refer to the MoneyWorks User Guide for the relevant MoneyWorks tax codes:. 
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Go to File --> Financial Configuration and select Tax Codes.  Setup the required Ostendo Tax
Codes with the Tax Rate %. For each Ostendo Tax Code, enter the appropriate MoneyWorks
taxcodes into the External  Tax Code column. 

COST CENTRES - MoneyWorks GL CODES MAPPING

Go to General --> Cost Centres. From the detail screen of each  Cost Centre, select the
appropriate MoneyWorks GL Account from the lookup.

Please note that the MoneyWorks System Accounts are not imported into Ostendo’s
GENERALLEDGERCODES table as you should not post any transactions directly to these
accounts. 

Make sure all Cost Centres are mapped to the appropriate MoneyWorks Ledger Code. 

Once you have mapped all the Ostendo Cost Centres to the appropriate MoneyWorks GL
Accounts, you would have completed the setup.

At  this point you may want to import Customers and Suppliers from MoneyWorks into Ostendo (or
export them from Ostendo to MoneyWorks). You can do so by going to File --> Financial
Configuration and selecting General Ledger Settings. Click on the Import button to import or the
Export button to export.

13.3 Points of Integration

There are many MoneyWorks API resources available. However not all resources are part of the
Ostendo – MoneyWorks integration. The affected resources are as follows:

1. Name  table - this is the MoneyWorks resource which holds Supplier and Customer
information. Any addition or change in Supplier/Customer master records in Ostendo will be
reflected in MoneyWorks.

Supplier records require the Accounts Payable ledger code to be included in the
transaction.

Customer records require the Accounts Receivable ledger code to be included.

Please note the following differences between Ostendo and MoneyWorks:

a. In Ostendo, Supplier names and Customer names are unique, but not in
MoneyWorks. Therefore you should remove duplicate names in MoneyWorks before
integrating with Ostendo.

b. In Ostendo CustomerMaster records, we have a BillingCustomer field.  There is
no equivalent field in MoneyWorks Name table. In MoneyWorks, a BillingCustomer is
indicated by a period (“.”) at the end of the NameCode (see example below). A customer
which has a billingcustomer will have a namecode which starts with the
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BillingCustomer namecode first. 

This Namecode has no relevance to Ostendo. It is noted here just for your
information.

   c. If you are using multi-currency, make sure all required currencies are set up in
MoneyWorks before you export customers or suppliers over to MoneyWorks. In Ostendo, all
customers and suppliers transacting in foreign currencies must have the Foreign Currency 

box ticked and the Currency code specified. All other customers or suppliers transacting
in the base currency must have the Foreign Currency box unticked.

 2. Transaction table – all journals except Invoice Payment and Invoice Deposit,
invoices/creditnotes  are posted to this resource in MoneyWorks.

 3. Payments table - Invoice Payments and Invoice Deposits

 4. Transaction Types

a. CR - Customer payment, Customer Deposit, Invoice payment, Invoice Deposit

b. JN - Journals

c. CI - Purchase Invoice

d. DI - Sales Invoice

  

All financial transactions generated in Ostendo will be summarised into the following tables and
posted to Transaction/Payment tables in MoneyWorks:

a. JOURNALHEADER 

b. JOURNALLINES 

c. JOURNALINVHEADER 

d. JOURNALINVLINES 

Changes to Customer Master and Supplier Master record will create transactions in
FINANCIALCUSTOMERS and FINANCIALSUPPLIERS tables respectively and posted to Name

table in MoneyWorks. 

13.4 The Automated Process

As transaction records are being added to the Financial Transactions tables, Ostendo will flag
them as “Ready to Send”.  

Ostendo will post transactions to MoneyWorks based on the frequency set in System Settings. The
frequency of posting can be set to in terms of minutes or hours. Frequency of once every 30
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minutes or an hour should be sufficient. 

All transactions which are “Ready to Send” will be assigned a batch number and posted as one
batch in the following order:

- FINANCIALSUPPLIERS transactions to MoneyWorks Name table,

- FINANCIALCUSTOMERS transactions to MoneyWorks Name table,

- JOURNALHEADER and LINES transactions (except Invoice Payments and
Invoice Deposits) to MoneyWorks Transaction table

- JOURNALINVHEADER and LINES transactions to MoneyWorks Transaction
table

- JOURNALHEADER and LINES for Invoice Payments and Invoice Deposits to
MoneyWorks Payments table.

This process runs automatically in the background , when there is at least one user logged in. 

This process can be stopped if the “No External GL Posting” flag is ticked for ALL users of the
system. This flag is found in SYSTEM CONFIGURATION à User Security & Options à User
Options tab.

User intervention is only required if there are failed batches occurring – which is indicated in the
top status bar of the Ostendo main screen:

If you click on the failed batches in the status bar, you will get the following:

Click on “Display All batches that Failed” button and you will see a list of failed batches.

Click on the Detail tab, and you will see the invalid transactions:
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Reviewing and correcting Failed Batches:

The following GENERAL Inquiries are available to review the batches and transactions:

- Inquiry – Ledger Journals

- Inquiry – Ledger Sales Invoices

- Inquiry – Ledger Purchase Invoices

Example of Ledger Purchase Invoices inquiry – detail screen:

You could also create your own inquiries/database queries to review the transactions in these
tables.



54 Ostendo Accounting Link

Common causes of failed batches include:

- Incorrect tax codes used (Tax code mapping not done correctly).

- Currency Code not set up in MoneyWorks

- Missing Account Codes (Cost Centre – Ledger Codes mapping incorrect or
incomplete).

Once the errors are fixed, the batches can be re-posted by clicking on the Repost Batch, followed
by the  Process Batches buttons.
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14 Integration with Xero

Overview: 

Ostendo integration to Xero offers an automated approach to the posting process of financial
entries. This means that depending upon your posting frequency setting, the financial transactions
created in Ostendo will automatically be passed through to Xero.

Ostendo must be at Update 187 or later before implementing the Ostendo-Xero link. Users are
strongly encouraged to use the latest Ostendo Update together with the latest accounting link
version.

There are two ways you can set up your Ostendo-Xero integration. 

The method you choose depends upon the areas of Ostendo you wish to use. It’s all about
whether you wish to manage your debtors in Ostendo or within Xero. Whatever method you
choose, the debtors invoice created in Ostendo will be passed through to the debtors ledger in
Xero, unlike the integration with other older products eg: MYOB where Ostendo only passes GL
journals across and the debtors ledger is maintained entirely within Ostendo.) 

Method 1: (preferred method) 

This method will allow you to manage debtors from within Xero. This means the invoice will be
raised in Ostendo, then passed through to Xero where you would record the customer payment
through the Bank Rec screen or via the Customer Payment option in Xero. Ostendo then reads
back the customer payment and updates the invoice in Ostendo and creates a ‘posted’ customer
payment (no financial posting is generated in Ostendo with this type of payment) 

This means that Ostendo debtors ledger is up to date when transactions are viewed through the
Operations Centre. It also allows Ostendo to determine available credit on customers when Jobs
or Sales Orders are created. 

Customer Statements could be run from either Xero or Ostendo. 

Method 2: 

This method MUST be used if ‘ANY’ of the following areas of Ostendo are in use 

Point Of Sale 

Customer Payments 

Customer Deposits 

Because Xero does not allow us to post directly to a Bank account, we must post the above GL
entries created to a Bank Clearing account in Xero. (This is an account type in Xero of ‘Current
Asset’, rather than that of a Bank Account.). Then bank rules must be setup in Xero in order to
automatically create a transfer between this account and the actual bank account to enable the
bank reconciliation in Xero to be completed. 

It is important to note that a good knowledge of Xero is required for this. 

This method adopts the approach that the debtors ledger is maintained within Ostendo. 

Customer Statements could be run from either Xero or Ostendo 
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Existing Invoices

If there are any outstanding invoices in Ostendo which are not fully paid before the planned cutover
date, these must be manually created in Xero with the exact same invoice numbers otherwise
subsequent payments (entered after cutover) will not be posted. 

Known Limitations with Xero Integration:

· Cannot Use Ostendo Rounding Of Invoice Header Tax Rules
· Xero API does not allow the application of AR Credits to Invoices to be read back as

payments into Ostendo
· Unable to summarise daily financial transaction posting to accounting software
· Must use a Bank Clearing Account and Rules in Xero if Ostendo Customer Payments or

Deposits are used as Xero does not allow direct journal posting to Bank Accounts
· There are transactional volume limitations within Xero that should be considered. Xero is

promoted as a ‘Small Business Accounting Package’, therefore not suitable for high
volume transactions.

· Credits Applied in Xero cannot be read back by Ostendo, therefore a Match Credit To
Invoice Payment needs to be processed in Ostendo to remain in sync.

14.1 Xero API Setup

Ostendo is integrating with Xero as a Private Application. Please refer to the following
links to learn how to set up the Xero API:

http://developer.xero.com/documentation/getting-started/private-applications/

This link explains the following:

· How to generate a pair of files called the public/private key-pair

· How to apply the public key certificate to your Xero organisation and generate the
Consumer Key. You will also be provided the Xero API Endpoint URL.

The Private Key file together with the Consumer Key and Xero API Endpoint URL will be
used by Ostendo to access your Xero Organisation.

Existing Invoices

If there are any outstanding invoices in Ostendo which are not fully paid before the planned cutover
date, these must be manually created in Xero with the exact same invoice numbers otherwise
subsequent payments (entered after cutover) will not be posted. 

http://developer.xero.com/documentation/getting-started/private-applications/
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14.2 Ostendo Setup

The following areas need to be set up in preparation for the integration with Xero:

· Systems Settings - Accounting Link tab

· User Security and Settings - User Options tab

· General Ledger Settings

· Tax Codes / Groups

· Cost Centre - Xero GL Codes mapping

SYSTEM SETTINGS

For integration with Xero, the following items must be specified in File --> Systems Configuration --
> Systems Settings - Accounting Link tab:

· Accounting Link Style: Xero

· Posting Frequency: Minimum 5 minutes.

· Cutover Date: The date from which transactions will be posted to Xero. Please set this date
correctly.

· Timeout (min): This should be set to 120 minutes.

· Retry Count: Recommended 1 or 2 retries when there are connection failures.

· External Accounts Receivables: Ticked.

· No External Payments Returned:  Tick this box if you want payments to go in one direction
only - i.e. from Ostendo to Xero.

USER SECURITY & SETTINGS

In File --> System Configuration --> User Security and Settings - User Options tab, there is this
option:

· No External GL Posting

At least one Ostendo user must have this option UNTICKED (if you are not using Queue Services
to initiate posting). When there is one or more users (with this option unticked) logged in, then the
automated posting process will be active. 

If this option is TICKED for every Ostendo user, then the automated posting process will not be
active. This is one way to temporary stop posting to Xero (if required).

Alternatively, you can use Queue Services to initiate posting of batches as per your set Posting
Frequency. All you need to do is to create a user (say QS) and have this No External GL Posting
option unticked for QS (but ticked for all other users). Then when the Queue Service is started, the
financial transactions will be posted across to the Accounting system as per the Posting
Frequency.

When using Queue Services in this manner, you would need to go to File --> AccountingLink to
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check if there are any failed batches .

Activate posting only when all the other integration setup tasks are completed.

GENERAL LEDGER SETTINGS

In File --> Financial Configuration, go to GeneralLedgerSettings and add a record. Fill in the
following:

· Accounting Link : Xero

· URL or Path : From Xero API setup. (Should be something like  https://api.xero.com/api.xro/2.0/
)

· Username : Not used.

· Password : Not used.

· API Token : This is the Consumer Key string generated during Xero API setup.

· Private Key : This is the full path to where you placed the Private Key File generated during
Xero API setup. (It is recommended you place this file in the Ostendo folder).

· Version : This is a display only field to show what version of the posting script you are currently
using.

· DebugMode : Ticking this will produce a debuglog file in Ostendo folder each time a batch of
transactions is posted. This is useful during initial stages of integration to resolve any teething
problems. Can be turned off after the integration is running smoothly.

· Database path : This is a display only field to show which database you are actually connected
to.

After filling in the required fields, click on the Update button. This will download the required
integration scripts from Development-X Limited. You will see that the version field will be updated
when this completes.

Next, click on Connect button to test that you can actually connect to your Xero organisation.

Next, click on the Import button, and select GL Codes. This will import the General Ledger
Accounts Codes, Tracking Categories and Options (if any) from Xero. These will be used to map
to the Ostendo Cost Centres later.

TAXCODES / GROUPS

Xero relies on specific Tax Codes in order to determine Input and Output Tax. You must specify
these from the base country of your Xero database. 

For example:

New Zealand: INPUT2 (15% GST on Exps) 

https://api.xero.com/api.xro/2.0/
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OUTPUT2 (15% GST on Income) 

Australia OUTPUT (10% GST on Exps) 

INPUT (10% GST on Income) 

You will find all relevant Xero Tax Codes from: 

http://developer.xero.com/documentation/api/types/#TaxTypes

 

Go to File --> Financial Configuration and select Tax Codes.  Setup the appropriate Ostendo Tax
Codes with the Tax Rate %. Enter the appropriate Xero External Tax Code (Income) along with the
External Purchase Tax Code (NB: These are case sensitive) 

This means that one Tax Code in Ostendo can be set for Sales and Purchases, and Ostendo will
post it to the Xero External Tax Codes specified here. 

Now setup up Ostendo Tax Groups and Matrix. 

COST CENTRES - XERO GL CODES MAPPING

Go to General --> Cost Centres. From the detail screen of each  Cost Centre, select the
appropriate Xero GL Account from the lookup. If Tracking Categories and Options were imported
from Xero, they can be mapped in the Financial Category column.

Do not attempt to map to any Xero Bank Accounts, but map to Bank Clearing Accounts instead.

Once you have mapped all the Ostendo Cost Centres to the appropriate Xero GL Accounts, you
would have completed the setup.

At  this point you may want to import Customers and Suppliers from Xero into Ostendo (or export
them from Ostendo to Xero). You can do so by going to File --> Financial Configuration and
selecting General Ledger Settings. Click on the Import button to import or the Export button to
export.

14.3 Points of Integration

There are many Xero API resources available. However not all resources are part of the Ostendo
– Xero integration. The affected resources are as follows:

1. Contacts - this is the Xero resource which holds Supplier and Customer information. Any
addition or change in Supplier/Customer master records in Ostendo will be reflected in

http://developer.xero.com/documentation/api/types/#TaxTypes
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Xero except ‘InActive’ records.

Xero API does not allow for posting of ContactStatus = DELETED. This means
that InActive Suppliers or Customers in Ostendo need to be manually set as DELETED in Xero.

The IsSupplier Boolean value cannot be set via Xero API – it is automatically set
when an accounts payable invoice is generated against the contact. This means Suppliers
exported from Ostendo into Xero will initially have the IsSupplier set to “false”.

The IsCustomer Boolean value cannot be set via Xero API – it is automatically set
when an accounts receivable invoice is generated against the contact. This means Customers
exported from Ostendo into Xero will initially have the IsCustomer set to “false”.

2. Manual Journals – all journals except Invoice Payment and Invoice Deposit, are posted to
this resource in Xero.

There are a few accounts that you can’t use when entering manual journals in
Xero. These include system accounts (accounts receivable, accounts payable & retained earnings)
and bank accounts. You will receive a 400 validation error if you try and use these 
reserved accounts. Consider setting up one or more clearing accounts if you need to journal to a
bank account.

3. Invoices – this resource caters to both Sales Invoices (Type= ACCREC) and Purchase
Invoices (Type= ACCPAY). Sales Invoice transactions and Purchase Invoice transactions are
posted to Xero as AUTHORISED invoice transactions.

4. CreditNotes - this resource caters to both Sales CreditNotes (Type= ACCRECCREDIT) and
Purchase CreditNotes (Type= ACCPAYCREDIT). CreditNotes are posted to Xero as
AUTHORISED creditnote transactions.

5. Payments – Invoice Payment and Invoice Deposit journals are posted to Payments resource in
Xero. Only the Debit side of the journal is posted.

Note: Payment Discounts are posted to Xero as Credit Notes and applied to the
associated Invoices.

6. Customer Payments entered directly into Xero (if “No External Payments Returned” is
not ticked in System Settings) will be pulled back into Ostendo and Customer Payment
records will be created for the matching invoices. However no financial transactions will be created
in Ostendo for such records – to avoid reposting back into Xero again. Such payment records in
Ostendo will be marked as “External Payments”.

Any such Payments entered in Xero which are subsequently deleted in Xero will also trigger the
deletion of the matching “External Payment” from Ostendo’s CustomerPayments table.

7. OverPayments – When OverPayments created in Xero are applied to sales invoices, these
applied payments will be brought into Ostendo and applied to the corresponding invoices as
External Payments.

All financial transactions generated in Ostendo will be summarised into the following tables: 

JOURNALHEADER – updates ManualJournals or Payments in xero 

JOURNALLINES – updates ManualJournals or Payments in Xero 

JOURNALINVHEADER – updates Invoices or CreditNotes in Xero 

JOURNALINVLINES – updates Invoices or CreditNotes in Xero 

Changes to Customer Master and Supplier Master record will create transactions in
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FINANCIALCUSTOMERS and FINANCIALSUPPLIERS tables respectively. 

Note: If you select “No External Payments Returned” in System Settings – Accounting Link,
then payments (and deleted payments) entered in Xero will not be brought back into Ostendo.

Since you cannot delete applied payments in Ostendo, the proper way to delete a
payment is to do a payment reversal (negative payment) in Ostendo. The AccountingLink will then
post this payment reversal into Xero to offset the original payment.

Xero Limits

Please note that Xero has certain transaction limits. This link explains the Xero Limits quite clearly:

http://developer.xero.com/documentation/getting-started/xero-api-limits/

We have done the following to minimize the chances of exceeding these limits:

1. To reduce the number of calls we make to Xero when exporting customer and supplier
records, we bundle 100 records at a time. However each request cannot exceed 3.5MB (size 
limit per call).

2. The 1000 API calls limit is a “rolling 24 hour period”. So if API calls are spread out evenly
then it would be less of an issue. We have provided in Systems Settings the function to set 
the frequency of posting. If you have fairly high transaction volumes, you may need to set a more
regular posting frequency (perhaps hourly or every 30 mins).

You should also be familiar with Xero’s SYSTEM LIMITS as described in the link above:

a. Xero can only handle up to 1000 invoices per month

b. Xero can handle up to 1000 bank transactions per month

c. Using Xero to handle Inventory of more than 1000 items may cause performance issues.
(Having Ostendo handle inventory should help).

d. Storing more than 5000 Contacts (suppliers + customers + employees) in Xero could also
cause performance issues.

Also there is the Pricing Plan limits – which determines the number of Invoices that can be
processed by Xero in a month.

14.4 The Automated Process

As transaction records are being added to the tables, Ostendo will flag them as “Ready to Send”.
Ostendo will post transactions to Xero based on the frequency set in System Settings. The
frequency of posting can be set to in terms of minutes or hours. For most customers, once every
hour or two hours should be frequent enough.

All transactions which are “Ready to Send” will be assigned a batch number and posted as one

http://developer.xero.com/documentation/getting-started/xero-api-limits/
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batch in the following order:

FINANCIALSUPPLIERS transactions to Xero Contacts,

FINANCIALCUSTOMERS transactions to Xero Contacts,

JOURNALHEADER and LINES transactions (except Invoice Payments and Invoice
Deposits) to Xero Manual journals

JOURNALINVHEADER and LINES transactions to Xero Invoices and CreditNotes

JOURNALHEADER and LINES for Invoice Payments and Invoice Deposits to Xero
Payments.

This process runs automatically in the background when there is at least one user logged in.

This process can be stopped if the “No External GL Posting” flag is ticked for ALL users of the
system. This flag is found in File->System Configuration->User Security & Options->User Options
tab.

User intervention is only required if there are failed batches occurring – which is indicated in the
top status bar of the Ostendo main screen: 

If you click on the failed batches in the status bar, you will get the following: 

Click on “Display All batches that Failed” button and you will see a list of failed batches. Click on
the Detail tab, and you will see the invalid transactions: 
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Reviewing and correcting Failed Batches: 

The following GENERAL Inquiries are available to review the batches and transactions: 

- Inquiry – Ledger Journals 

- Inquiry – Ledger Sales Invoices 

- Inquiry – Ledger Purchase Invoices 

Example of Ledger Journal inquiry – detail screen: 

You could also create your own inquiries/database queries to review the transactions in these
tables. Common causes of failed batches include: 

- Incorrect tax codes used (Tax code mapping not done correctly). 

- Ledger Account in Xero was not set to accept payments. 
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- Missing Account Codes (Cost Centre – Ledger Codes mapping incorrect or incomplete). 

Once the errors are fixed, the batches can be re-posted by clicking on the Repost Batch and
Process Batches buttons. 
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15 Integration with Sage Evolution Live

Overview: 

Ostendo integration to Sage Evolution Live (Evolution version 7 and above) offers an automated
approach to the posting process of financial entries. This means that depending upon your posting
frequency setting, the financial transactions created in Ostendo will automatically be passed
through to Evolution.

The Sage Evolution Link requires the following:

1. Ostendo Update 206 or later
2. Ostendoevo.dll build 83 or later
3. Sage Evolution version 7
4. Pastel.Evolution.dll version 7.0.0.72 

Ostendo can be integrated with the SAGE Evolution General Ledger Accounting system via the
Sage Evolution SDK.

Financial transactions generated in Ostendo will automatically be posted into the Sage Evolution
system according to a pre-defined posting frequency. The batching and posting of transactions is
done by Ostendo and no user action is required.

User intervention is only required as and when there are failed batches. When batches fail to post,
a designated user needs to review the transactions, examine the reasons for the failure, rectify,
and re-post the batch.

15.1 Sage Evolution Live API Setup

To integrate Ostendo with Sage Evolution, you need to do the following:

A. Activate the Sage Evolution SDK Connector 

B. Complete the Accounting Link setup in Ostendo

Existing Invoices

If there are any outstanding invoices in Ostendo which are not fully paid before the planned cutover
date, these must be manually created in Sage Evolution with the exact same invoice numbers
otherwise subsequent payments (entered after cutover) will not be posted.

The following information is required to establish the connection with the Sage Evolution database:

- The password for Username “sa”.
- The Common Connection Server name
- The Common Database name
- The Company File (SQL) Server name
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- The Company file (database) name

Also required is an SQL Provider to make SQL calls to the Sage Evolution database.
Go to Control Panel à  Administrative Tools à  Data Sources (ODBC).

      Go to the Drivers tab and you should see something like this:

- The SQL Provider in this example would be SQL Server Native Client 10.0.

Evolution Inventory Defaults

Go to Inventory Maintenance – Inventory Defaults and click on Goods Received
Vouchers tab. 
- Untick “Separate GRV from Supplier Invoice”
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-Select “Post Supplier Invoice Number” for Transaction Reference

-Then click YES for Purchase orders too.

If you are using Project Codes, go to the Entry Options tab and turn on “Post Project per
Line”.
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-Decimal Positions: Under the General tab, set the Decimal Places as shown. This is to
avoid any rounding differences between Ostendo and Evolution. 

Transaction Types

Please make sure the appropriate posting accounts are specified in all Transaction
Types in Inventory, Accounts Receivable, and Accounts Payable. 
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For example: Inventory | Maintenance | Transactions Types. 

INV – this transaction type is used for Sales Invoice posting. Set the Debit account to
Trade Debtors, Credit account to Sales, and the Tax account to the GST account
for Sales. Tick the option for Tax. See below:

SINV – This transaction type is used for Purchase invoice posting. Set the Credit account
as Trade Creditors, the Debit account as the Purchase Accrual / Purchase Receipt not Invoiced,
and specify the Tax account. Tick the Tax option. See below:

Revenue Accounts

Make sure your revenue accounts are set up to allow sales and purchase transactions.
For example:



70 Ostendo Accounting Link

Accounts Receivable Groups and Accounts Payable Groups

– make sure the Descriptions matches CustomerTypes and SupplierTypes in Ostendo
respectively.
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Accounts Receivable and Accounts Payable Areas

– make sure the Descriptions matches the RegionCodes used for Ostendo Customers
and Suppliers.
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Accounts Receivable and Accounts Payable Ageing Periods

The ExternalCreditTerm in CreditTerms table in Ostendo must match the Code in the AR
or AP Ageing Periods in Evolution. If no match is found, default terms will be used.

Please note that Ageing Periods in Evolution are set in both Accounts Receivable
and Accounts Payable whereas there is only one Credit Terms table in Ostendo for both
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Customers and Suppliers.

15.2 Ostendo Setup

The following areas need to be set up in preparation for the integration with Sage Evolution Live:

· Systems Settings - Accounting Link tab

· User Security and Settings - User Options tab

· General Ledger Settings

· Tax Codes 

· Cost Centre - Xero GL Codes mapping

· ExternalLedgerTypes table

SYSTEM SETTINGS

For integration with Sage Evolution Live, the following items must be specified in File --> Systems
Configuration --> Systems Settings - Accounting Link tab:

· Accounting Link Style: Sage Evolution Live

· Posting Frequency: Minimum 5 minutes.

· Cutover Date: The date from which transactions will be posted to Evolution. Please set this date
correctly.

· Timeout (min): This should be set to 120 minutes.

· Retry Count: Recommended 1 or 2 retries when there are connection failures.

· External Accounts Receivables: Ticked.

· No External Payments Returned:  Tick this box if you want payments to go in one direction
only - i.e. from Ostendo to Evolution.

USER SECURITY & SETTINGS

In File --> System Configuration --> User Security and Settings - User Options tab, there is this
option:

· No External GL Posting

At least one Ostendo user must have this option UNTICKED (if you are not using Queue Services
to initiate posting). When there is one or more users (with this option unticked) logged in, then the



74 Ostendo Accounting Link

automated posting process will be active. 

If this option is TICKED for every Ostendo user, then the automated posting process will not be
active. This is one way to temporary stop posting to Evolution (if required).

Alternatively, you can use Queue Services to initiate posting of batches as per your set Posting
Frequency. All you need to do is to create a user (say QS) and have this No External GL Posting
option unticked for QS (but ticked for all other users). Then when the Queue Service is started, the
financial transactions will be posted across to the Accounting system as per the Posting
Frequency.

When using Queue Services in this manner, you would need to go to File --> AccountingLink to
check if there are any failed batches .

Activate posting only when all the other integration setup tasks are completed.

GENERAL LEDGER SETTINGS

In File --> Financial Configuration, go to GeneralLedgerSettings and add a record. Fill in the
following:

· Accounting Link : Sage Evolution Live

· Common Connection : This should be in the following format:  

DBCommonConnection=server=servername\SQLname;initial catalog=
EvolutionCommon;integrated security=false;MultipleActiveResultSets=True;User id=sa
;Password=your_sa_password;

· Username : Not used.

· Password : Not used.

· API Token : Not used.

· Database Connection : This should be in the following format:  

DBConnection=server=servername\SQLname;initial catalog=databasefilename
;integrated security=false;MultipleActiveResultSets=True;User id=sa;Password=
your_sa_password; Provider=ODBCdrivername;
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· Version : This is a display only field to show what version of the posting script you are currently
using.

· DebugMode : Ticking this will produce a debuglog file in Ostendo folder each time a batch of
transactions is posted. This is useful during initial stages of integration to resolve any teething
problems. Can be turned off after the integration is running smoothly.

· Database path : This is a display only field to show which database you are actually connected
to.

After filling in the required fields, click on the Update button. This will download the required
integration scripts from Development-X Limited. You will see that the version field will be updated
when this completes.

Next, click on Connect button to test that you can actually connect to your Evolution file.

Next, click on the Import button, and select GL Codes. This will import the General Ledger
Accounts Codes from Evolution. These will be used to map to the Ostendo Cost Centres later.

TAXCODES

Go to File --> Financial Configuration and select Tax Codes.  Setup the appropriate Ostendo Tax
Codes with the Tax Rate %. Enter the appropriate Xero External Tax Code (Income) along with the
External Purchase Tax Code (NB: These are case sensitive) 

This means that one Tax Code in Ostendo can be set for Sales and Purchases, and Ostendo will
post it to the Xero External Tax Codes specified here. 

Now setup up Ostendo Tax Groups and Matrix. 

Ensure Ostendo Tax Codes are defined in Evolution.

COST CENTRES

Go to General --> Cost Centres. From the detail screen of each  Cost Centre, select the
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appropriate Evolution GL Account from the lookup

If you are using Project Codes in Evolution, you can also map the default Project Codes (Financial
Category) to the corresponding Ostendo Cost Centre codes.

EXTERNALLEDGERTYPES table

This Ostendo table is required to be populated with all Payment Types defined in Evolution’s
Accounts Receivable module. This includes payments and refunds.

The AccountingLink will only process payment/refund types defined in this table.

Relationship between JournalType “Invoice Payment” in Ostendo and Evolution’s AR Transaction
Types: 

Each Transaction Type in Evolution AR has a Credit Ledger Account and Debit Ledger
Account. 

 

The Payment Type is then defined in the EXTERNALLEDGERTYPES table like this:

For this example, when an Invoice Payment journal is created in Ostendo, it will debit
UNAPPLIED PAYMENTS and credit DEBTORS. The UNAPPLIED PAYMENTS cost centre should
be mapped to UnApplied Payments and the DEBTORS should be mapped to 613 (Debtors)
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Ostendo setup is now complete.

At  this point you may want to import Customers and Suppliers from Evolution into Ostendo (or
export them from Ostendo to Evolution). 

You can do so by going to File --> Financial Configuration and selecting General Ledger Settings.
Click on the Import button to import or the Export button to export.

15.3 Points of Integration

There are many Sage Evolution resources available. However not all resources are part of the
Ostendo – Sage Evolution integration. The affected resources are as follows:

1. Vendor & Client tables - these hold Supplier and Customer information. Any addition or
change in Supplier/Customer master records in Ostendo will be reflected in Sage
Evolution.

Evolution’s CLIENT table has a mandatory ACCOUNT field of 20 characters and a NAME
field of 50 characters. If you are exporting new Ostendo Customers to Evolution, then the
ACCOUNT value for Customers with name less than or equal to 20 characters will be the
same as the customer name.
For names greater than 20 characters, we will use the first 17 characters concatenated
with a 3 digit number to create a unique ACCOUNT value. 

Evolution has 5 address lines while Ostendo has 3 address lines plus City, State, and
Country. For this integration, we will adopt the following convention:
Ostendo address line 1 goes to Evolution address line 1
Ostendo address lines 2 & 3 goes to Evolution address line 2
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Ostendo City goes to Evolution address line 3
Ostendo State goes to Evolution address line 4
Ostendo Country goes to Evolution address line 5

CustomerType/SupplierType in Ostendo must match the Group Description in Evolution
Accounts Receivables and Accounts Payables. If no match is found during importing or
exporting, the default value will be used.

RegionCodes in Ostendo must match the Areas Description in Evolution. If no match is
found during importing or exporting, the Region code will be blank.
The ExternalCreditTerm in CreditTerms table in Ostendo must match the Code in the AR
or AP Ageing Periods in Evolution. If no match is found, default terms will be used.  

Please note that Ageing Periods in Evolution are set in both Accounts Receivable and
Accounts Payable whereas there is only one Credit Terms table in Ostendo for both
Customers and Suppliers.

2. PostAR table - all sales invoices/creditnotes, payments are posted to this resource in
Evolution

3. PostAP table - all purchase invoices/creditnotes are posted to this resource in Evolution. 

4. PostGL table - all journals are posted to this resource in Evolution

Journal Types

The following Journal transaction types need to be set up in Sage Evolution:

a. INVCOSTS - Invoice Costs
b. JOBISSUES - Job Issues
c. ASSYISSUES - Assembly Issues
d. PORECEIPT - Purchase Receipt
e. JNL - Other Journals (Customer Payment,

Customer Deposit, Apply Payment, Payment Charge) 
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All financial transactions generated in Ostendo will be summarised into the following tables and
posted to Transaction/Payment tables in Evolution:

a. JOURNALHEADER 
b. JOURNALLINES 
c. JOURNALINVHEADER 
d. JOURNALINVLINES 

Changes to Customer Master and Supplier Master record will create transactions in
FINANCIALCUSTOMERS and FINANCIALSUPPLIERS tables respectively and posted to
Evolution. 

Payment Types – EXTERNALLEDGERTYPES table

This Ostendo table is required to be populated with Payment Types defined in Evolution’s
Accounts Receivable module. This includes payments and refunds that are to be processed in
Ostendo. 

15.4 The Automated Process

As transaction records are being added to the Financial Transactions tables, Ostendo will flag
them as “Ready to Send”.  

Ostendo will post transactions to Sage Evolution based on the frequency set in System Settings.
The frequency of posting can be set to in terms of minutes or hours. For most customers, once
every 30 minutes or an hour should be frequent enough. 

All transactions which are “Ready to Send” will be assigned a batch number and posted as one
batch in the following order:

- FINANCIALSUPPLIERS transactions to Sage Evolution Vendor table,
- FINANCIALCUSTOMERS transactions to Sage Evolution Client table,
- JOURNALHEADER and LINES transactions (except Invoice Payments and Invoice

Deposits) to Sage Evolution POSTGL table
- JOURNALINVHEADER and LINES transactions to Sage Evolution POSTAR and POSTAP

tables
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- JOURNALHEADER and LINES for Invoice Payments and Invoice Deposits to Sage
Evolution POSTGL table

This process runs automatically in the background, when there is at least one user logged in. 

This process can be stopped if the “No External GL Posting” flag is ticked for ALL users of the
system. This flag is found in SYSTEM CONFIGURATION à  User Security & Options à  User
Options tab.

User intervention is only required if there are failed batches occurring – which is indicated in the
top status bar of the Ostendo main screen:

If you click on the failed batches in the status bar, you will get the following:

Click on “Display All batches that Failed” button and you will see a list of failed batches.
Click on the Detail tab, and you will see the invalid transactions:

Reviewing and correcting Failed Batches:

The following GENERAL Inquiries are available to review the batches and transactions:

- Inquiry – Ledger Journals
- Inquiry – Ledger Sales Invoices
- Inquiry – Ledger Purchase Invoices

Example of Ledger Purchase Invoices inquiry – detail screen:
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You could also create your own inquiries/database queries to review the transactions in these
tables.

Common causes of failed batches include:

- Incorrect tax codes used (Tax code mapping not done correctly).
- Currency Code not set up in Sage Evolution.
- Missing Account Codes (Cost Centre – Ledger Codes mapping incorrect or incomplete).

Once the errors are fixed, the batches can be re-posted by clicking on the Repost Batch, followed
by the  Process Batches buttons.
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16 Creating Initial Balances

1.  Introduction

There are differing ways in which you can commence integration of Ostendo with
your Accounting system.  This can include:

· New orders entered into Ostendo in conjunction with phasing out current
Sales and Purchase Orders in the Accounting System

· Create ‘Opening Balances’ and immediately have ongoing activity
generated from Ostendo.

These activities can be:
· Scheduled to introduce Sales, Purchase, and Inventory integration at

different times
· Introduce all activities at the same time.

It is not the intention here to dictate how you should phase in the integration but
to suggest the actions required to commence integration of the two systems

2.  Test Databases

Firstly, it is strongly advised that you ‘Bench Test’ the integration from a ‘Test’
Company within Ostendo to a ‘Test’ database in the Accounting system.  Only
when this has been fully proved should you apply this to the ‘Live’ databases.

You should also note that Ostendo must already be populated with all Items,
Descriptors, Customers and Suppliers and the Accounting Link fully set up with
Cost Centred cross-referenced to GL Account Codes, etc.

3.  Creating Opening Balances

3.1. Inventory

Within Ostendo the current stock level is held against the Item Master BUT this is
maintained from Stock Movement records.  Therefore Opening Balances should
be created by carrying a Stock Adjustment as follows:

Step 1.  In Ostendo go into Inventory>Inventory Adjustments and create an
Adjustment Batch header and ‘Save’ the record.  Take note of the generated
Batch Number    

Step 2.  In Ostendo go into Inventory>Settings>Adjustment Types and create
an Adjustment Type to cover the Opening Balance Transaction (Example:
Opening)

Step 3.  Create a Spreadsheet containing the following fields (These are fields in
Ostendo’s INVENTORYADJUSTLINES table)
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AdjustmentNo
WarehouseCode
Location
ItemCode
ItemDescription
Unit
AdjustmentType
AdjustmentQty
AdjustmentCost
SerialNo
ExpiryDate
BatchNo
RevisionNo
ItemGrade
ItemColour
ItemSize

You should now populate these fields with the Items from your ‘old’ system.  You
may wish to consider exporting the Item Codes from Ostendo’s ITEMMASTER
Table by going into File>Data Exporting.  

Step 3.  You should now ensure that there is an entry in the following fields:

AdjustmentNo: The Number you noted above
WarehouseCode: This must exist in Ostendo
Location: This must exist in Ostendo for the Warehouse
ItemCode: The Item being update
Unit: The Item Unit must exist against the Item Code
AdjustmentType: Use the Adjustment Type you created above
AdjustmentQty: Enter the current Stock Quantity at this Location
AdjustmentCost: Enter the current Average Cost of the Item

If the Item has ‘Sub-Level Variants’ such as SerialNo, ExpiryDate, BatchNo,
RevisionNo, ItemGrade, ItemColour, or ItemSize then a separate line must be
created for each variant.  You should also note that a Serial Numbered Item can
only have a quantity of 1

Step 4.  The next step is to import the data from the spreadsheet by going into
File>Data Importing and going through the import routine.

Step 5.  The final step is to go back to Inventory>Inventory Adjustments and
create select the ‘Lines’ tab against the Adjustment Batch.  Check that the
imported lines are correct then go back to the ‘Detail’ tab.  In that screen click on
the ‘Post all Adjustments’ button

3.2. Sales Invoices
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If you are entering open Invoices into Ostendo then you can carry out the
following steps.

Step 1.  You will - most probably - wish to keep the same Invoice Numbers that
were originally used in your Accounting System.  Therefore go into 
Sales>Settings>Sales Rules and select ‘Manual’ against rule ‘Direct Invoice
Numbering’

Step 2.  Go into Inventory>Descriptors and create a Descriptor called (say) ‘
Invoice Balance’.

Step 3.  Go into Sales>Direct Invoicing and create a Direct Invoice for each of
the outstanding Invoices using the above Descriptor in the Invoice Line where
the ‘Order Price’ is amended to conform to the Invoice Amount.

Step 4.  Having created all the Invoices go into Sales>Batch Invoice Printing
and ‘Print’ the Invoices.

Step 5.  Having printed the Invoices you may wish to go back to
Sales>Settings>Sales Rules and select ‘Automatic’ against rule ‘Direct
Invoice Numbering’

3.3. Outstanding Orders

Although the following have no immediate financial impact you may wish to
consider creating them for ongoing:

· Issue/receipts of Inventory
· Receipts of Goods and Invoices in Purchasing
· Issue of Goods and Services in Sales and Jobs
· Issue and Receipt of Inventory in Assembly Orders

3.3.1. Sales Orders

If you are entering open Sales Orders into Ostendo then you should go to 
Sales>Sales Orders and create a Sales Order for each outstanding Order.  In
the Order ‘Lines’ screen enter the lines showing the outstanding delivery quantity
only

3.3.2. Job Orders

If you are entering open Job Orders into Ostendo then you should go to 
Jobs>Job Orders and create a Job Order for each outstanding Order.  In the
Order ‘Lines’ screen enter the lines showing the outstanding completed
quantities only
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3.3.3. Purchase Orders

If you are entering open Purchase Orders into Ostendo then you should go to 
Purchasing>Purchase Orders and create a Purchase Order for each
outstanding Order.  In the Order ‘Lines’ screen enter the lines showing the
outstanding quantity only

3.3.4. Assembly Orders

If you are entering open Assembly Orders into Ostendo then you should go to 
Assembly>Assembly Orders and create an Assembly Order for each
outstanding Order for the current Outstanding Receipt quantity.  If necessary go
into the Order ‘Lines’ screen and adjust the components and component
quantities as required

4.  Posting the Journals

The transaction generated under 3.1 and 3.2. (above) will have created Journals
that are posted to the ‘Ostendo to Accounts Link’ program.  You should set the
Cut-Off date in that routine to exclude these transactions from being posted to
the integrated Accounting system.
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