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1 Introduction

The objective of these short Tutorials is to focus on a particular aspect within Ostendo.   Where
possible the tutorials use the information currently defined in the 'DEMO' Company
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2 Additional Fields

The following screens in Ostendo have spare fields available in their record layout.  These are
present to allow Ostendo customers to define and use data fields that are specific to their business

The following  have 8 fields containing Date Formats, plus 8 fields containing a mixture of all
Formats

· Assembly Order Header
· Customer Asset
· Customers
· Descriptors
· Items
· Job Order Header
· Labour Codes
· Purchase Order Header
· Sales Order Header
· Suppliers
· Job Tasks
· Assembly Steps
· Sales Invoice Header
· Purchase Receipts
· Purchase Invoices

The following have 2 fields containing Date Formats, plus 4 fields containing a mixture of all
Formats

· Job Lines
· Sales Lines
· Purchase Lines
· Assembly Lines
· Purchase Receipt Lines
· Purchase Invoice Lines
· Sales Invoice Lines
· POS Lines

1.  Creating the first Text field

We will add a field that allows open-format entry of a Drawing Number

Go into File>Customisation Configuration>Additional Fields and click the ‘Add’ button.   Enter
the following data:

Module: Select ‘Items’ from the drop-down
Caption: Enter (say) ‘Drawing Number’
Field Type: Select ‘Text’ from the drop-down list
Value List; Leave blank

‘Save’ the record.   Now go into Inventory>Items and click on the ‘Additional Fields’ tab in the ‘
Detail’ view against any Item and enter a Drawing Number. Click on the ‘List’ tab to go to the Item
‘List’ view.   

2.  Including the field in the Item’s List panel

You may wish to see this ‘Additional Field’ in this View, therefore - in the centre of the screen -
right mouse and select ‘Customize List Fields’.  (If you cannot see this then you should go into
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File>Customisation Configuration>User Security and Options and ‘check’ the ‘List
Customizing’ checkbox on the ‘User Options’ view)

In the presented panel scroll down until you come to ‘ADDITIONALFIELD_1’.  In the adjacent ‘
Display Label’ field enter ‘Drawing Number’ and - finally - ‘check’ the ‘Show Field’ checkbox.  ‘
Save’ the entry.  You will see that your additional field is now visible in the ‘List’ View.

3.  Creating a Text field with ‘Look-Up’ options

We will now add a field that allows you to select (say) the Draughtsman who created the Drawing

Go back to File>Customisation Configuration>Additional Fields and click the ‘Add’ button. 
Enter the following data:

Module: Select ‘Items’ from the drop-down
Caption: Enter (say) ‘Draughtsman’
Field Type: Select ‘Text’ from the drop-down list
Value List; Enter the names of a couple of Draughtsmen, each

entered on a new line (I.e. Hit the ‘Enter’ key after each
name)

‘Save’ the record.   Now go into Inventory>Items and click on the ‘Additional Fields’ tab in the ‘
Detail’ view against any Item and you will see that this field has a drop-down in which you will see
the above-entered Draughtsmen.  Select one of them.   Click on the ‘List’ tab and repeat the
actions outlined in 2 (above) but refer to ‘ADDITIONALFIELD_2’.  

4.  Creating a Date field

We will now add a field that allows you to nominate the Date when the Drawing was last amended

Go back to File>Customisation Configuration>Additional Fields and click the ‘Add’ button. 
Enter the following data:

Module: Select ‘Items’ from the drop-down
Caption: Enter (say) ‘Date Amended’
Field Type: Select ‘Date’ from the drop-down list
Value List; Leave Blank

‘Save’ the record.   Now go into Inventory>Items and click on the ‘Additional Fields’ tab in the ‘
Detail’ view against any Item and you will see that this field is available for entry of a Date from the
drop-down calendar.  Select one of them.   Click on the ‘List’ tab and repeat the actions outlined in
2 (above) but refer to ‘ADDITIONALDATEFIELD_1’.  
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3 Backflushing

Backflushing is used during Assembly Order receipts to automatically issue components required
to make the Assembled Item at the time the Item is received into stock.

1. Preparation

You can define if you want all Assembly receipts to automatically backflush or only have this
feature against selected Items.  

To set the Backflush to be all receipts go to Inventory>Settings>Item Rules and select ‘All Items
’ under drop-down against field ‘Assembly Backflush Policy’.

In this training session we will backflush against a specific Item.  Therefore:
§ Go into Inventory>Settings>Item Rules and select ‘Item Specific’ under drop-down

against field ‘Assembly Backflush Policy’.  
§ To identify the specific Item go into Inventory>Items and select Item 1105-2184 (Handle

Assembly).  In the ‘Detail’ screen click on the ‘Additional Inventory Settings’ button.  In
that panel ‘check’ the ‘Backflush Issues on Assembly Receipts’ checkbox

2. Backflushing in action

2.1.  Order Creation

Go into Assembly>Assembly Orders and create an Assembly Order for 40 off 1105-2184

If you click on the ‘Lines’ tab within the Order you will see that the BOM was copied with the
following amounts

Item Code 760-2176 (Tube-Stainless Steel-25mm1200mm) 40 off
Labour Code LAB-ASSEMBLY (Assembly Labour) 40 hours
Item Code 900-2182 (Handle Grip-Rubber-25mm) 80 off

Add the following line to the Order Line
Descriptor Code GENERALTIME (Time - Non Employee Related) 10 hrs

Note the Order Number then close out of the Assembly Order screen

2.2.  Receive and Backflush

Go to Assembly>Assembly Receipts and create a Receipt batch.  Click on the ‘Lines’ tab and -
in that screen - click on the ‘Select Assembly for prefilling receipts’ button.  On the displayed
panel select the above Assembly Order.  This should create a single line displaying Item 
1105-2184.  Scroll to the ‘Qty’ field and change the prefilled quantity to 10.  Save the record then
click on the ‘Detail’ tab.   On the Detail screen click on the ‘Post all Receipt Entries’ button. Then
close out of the Assembly receipts screen.

Go back to Assembly>Assembly Orders and select the above Order and click on the ‘Lines’ tab.
You will see that it has backflushed the Item Codes and the Descriptor but NOT the Labour Code. 
The reason for this is that Employee Times booked through the Timesheet (Labour>Timesheets)
will be used to update Labour Activities.  Having said this you may not wish to use the Timesheet
function but simply get Ostendo to ‘Backflush’ Labour Code activities.  We will do this in the next
step.
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2.3.  Backflush Labour Codes

Go into Assembly>Settings>Assembly Rules and ‘check’ the checkbox ‘Include Labour When
Backflushing’.  Once ‘checked’ you should also nominate a default Employee (say Bob Drum)
from the drop-down against ‘Default Employee for Backflushing’.

Now go to Assembly>Assembly Receipts and create a Receipt batch.  Click on the ‘Lines’ tab
and - in that screen - click on the ‘Select Assembly for prefilling receipts’ button.  On the
displayed panel select the above Assembly Order.   As before scroll to the ‘Qty’ field and change
the prefilled quantity to 10.  Save the record then click on the ‘Detail’ tab.   On the Detail screen
click on the ‘Post all Receipt Entries’ button. Then close out of the Assembly receipts screen.

Go back to Assembly>Assembly Orders and select the above Order and click on the ‘Lines’ tab.
You will see that it has backflushed the Labour Code in addition to the Item and Descriptor Codes. 
You may wish to click on the ‘Actual Issues’ tab in the lower part of this screen to look at the Issue
History for the selected line.

2.4.  Items with variants

If the Item has sub-level variants (such as Colour, Serial Number, Batch, etc) then the backflush
cannot automatically take place.  In this instance an ‘Issue Batch’ is generated against which you
should manually state which variant has been issued.  Let’s see how this works:

Go back to Assembly>Assembly Orders and select the above Order and click on the ‘Lines’ tab.
Add a new line containing the following Item that has 3 variations of Colour

Item Code OC-7451 (Office Chair - Fabric Executive) 40 off

Go back into Assembly>Assembly Receipts and create another Receipt batch.  Click on the ‘
Lines’ tab and - in that screen - click on the ‘Select Assembly for prefilling receipts’ button.  On
the displayed panel select the above Assembly Order.   As before scroll to the ‘Qty’ field and
change the prefilled quantity to 10.  Save the record then click on the ‘Detail’ tab.   On the Detail
screen click on the ‘Post all Receipt Entries’ button. Then close out of the Assembly receipts
screen.

If you go back to Assembly>Assembly Orders and select the above Order and click on the ‘
Lines’ tab.  You will see that Backflushing has not been carried out against OC-7451.  However, if
you go to Assembly>Assembly Issues you will see that an Issue Batch has been created to
cover this.  That Issue Batch will require the specific variant to be selected before it is issued

2.5.  Source On Demand

If the Assembly Order Component Line is an Item Code with ‘Supply Method’ of ‘Source on
Demand’ then the Item will not be backflushed because a supply Order is scheduled to be
generated to satisfy this demand

Similarly, if the Assembly Order Component Line is a Descriptor with ‘Source By’ of ‘Purchasing’
then the same condition will apply 
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4 Creating and applying Credits

1.  Introduction

This tutorial describes the various options available in Ostendo for crediting Sales Invoices.  There
are two types of Credit:

· Including return of supplied Goods
· Financial Credit only

You can create Credits in the following ways:
· Credit a Sales Order Invoice (from Counter Style Sales Order) with Item return
· Credit a Sales Order Invoice (from Delivery Style Sales Order) with Item return
· Credit a Job Order Invoice (Scheduled Invoice Style Job Order) with Item return
· Credit a Job Order Invoice (Actual Qty Style Job Order) with Item return
· Credit a Direct Invoice including Item return
· Create a full or partial 'Financial Credit'

2.  Credits

2.1. Credit with Product Returns

2.1.1. Credit a Sales Order Invoice (Counter Style) with Item/Descriptor Return

To partially or fully Credit an Invoice generated from a ‘Counter Style’ Sales Order with a product
return go into Sales>Sales Order and select the Order.  You may have to click on the ‘Include
Closed Status’ checkbox at the bottom of the ‘List’ view.   If the Order status is ‘Closed’ then
amend the status to ‘Finished’.  Now go into the ‘Lines’ tab and:

· Select the Item (or Descriptor) being credited.  
· In the lower part of the screen click on the ‘Picked Lines’ tab and add a new line where

the returned quantity is entered as a negative.
· Click on the ‘Sales Lines’ tab and amend the ‘Order Qty’ such that it now reflects the

quantity after the return
·  ‘Save’ the entry then click on the ‘Invoices’ Button to generate the Credit Note.
· Go back into the Order Header and change the status as required 

This action will create the Credit Note in addition to returning Inventory into stock

The next step is to apply this Credit to the original Invoice.  Therefore go to Sales>Customer
Payments and create a new payment record.  Select the Customer to which the Credit applies and
then click on the drop-down against field ‘Payment Style’ and select ‘Apply Credits to Invoices’.
In the adjacent field (‘Credit No’) select the above Credit.  Click on the ‘Apply to Invoices’ tab and
apply the Credit to the selected Invoice(s) and then click on the ‘Update Selected Invoices’
button.

2.1.2. Credit a Sales Order Invoice (Delivery Style) with Item/Descriptor Return

There are two ways to Credit a Delivery Style Sales Order:

· Credit a specific Delivery - Full Credit only
· Credit a Sales Order - Partial or Full Credit

2.1.2.1.  Credit a Specific Delivery
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To fully Credit a Delivery from a Delivery Style Sales Order that includes a product return you
should go into Sales>Batch Invoicing and highlight the Invoice and then click on the ‘Credit’
button. .  If you now go into Sales>Sales Deliveries you will see that the Credit action has
changed the status of the linked Sales Delivery from ‘Invoiced’ to ‘Shipped’.    

· Go into the ‘Detail’ tab and change the status to ‘In Picking’.  Now go into the ‘Lines’ tab
· Add a new Picked line and enter the previously issued quantity as a negative
· ‘Save’ the entry to place the Inventory back into stock
· Go back to the Delivery ‘List’ tab and delete the Delivery

If you go to Sales>Sales Orders you can amend the Order as required.

The next step is to apply this Credit to the original Invoice.  Therefore go to Sales>Customer
Payments and create a new payment record.  Select the Customer to which the Credit applies and
then click on the drop-down against field ‘Payment Style’ and select ‘Apply Credits to Invoices’.
In the adjacent field (‘Credit No’) select the above Credit.  Click on the ‘Apply to Invoices’ tab and
apply the Credit to the selected Invoice(s) and then click on the ‘Update Selected Invoices’
button.

2.1.2.2.  Credit a Sales Order

To partially or fully Credit a Delivery Style Sales Order as a result of a product return you should
first go into Sales>Sales Order and select the Order.  You may have to click on the ‘Include
Closed Status’ checkbox at the bottom of the ‘List’ view.   If the Order status is ‘Closed’ then
amend the status to (say) ‘Finished’ and ‘Save’ the entry.  Now go into the ‘Lines’ tab and:

· Add a new Line for the Item and quantity being returned (Note that the quantity is negative)
and ‘Save’ the entry

· Click on the ‘Deliveries’ button and generate a new Delivery record.  You can enter a
(negative) Pick quantity to return the Item into stock.

· Go back to the Delivery ‘Detail’ tab and change the status to Shipped.  Click on the ‘Sales
Invoices’ button to generate and print the Credit Note

The next step is to apply this Credit to the original Invoice.  Therefore go to Sales>Customer
Payments and create a new payment record.  Select the Customer to which the Credit applies and
then click on the drop-down against field ‘Payment Style’ and select ‘Apply Credits to Invoices’.
In the adjacent field (‘Credit No’) select the above Credit.  Click on the ‘Apply to Invoices’ tab and
apply the Credit to the selected Invoice(s) and then click on the ‘Update Selected Invoices’
button.

2.1.3. Credit a Job Order (Schedule Invoice Style) with Item/Descriptor return

To partially or fully Credit a Job Order (Invoice Schedule Style) as a result of a product return you
should first go into Jobs>Job Orders and select the Order.  You may have to click on the ‘Include
Closed Status’ checkbox at the bottom of the ‘List’ view.   If the Order status is ‘Closed’ then
amend the status to ‘Finished’.  Now go into the ‘Lines’ tab and select the Item (or Descriptor)
being credited.  In the lower part of the screen click ‘Actual Issue’ tab and add a new Line with a
quantity equal to the quantity being returned (as a negative).  ‘Save’ the entry.  This will return the
Item into Stock  

As this is a ‘Scheduled Invoice’ Style Job based on a pre-determined amount the Item/Descriptor
returns do not affect the original Invoicing Schedule.  Therefore any Credits are ‘Financial’ Credits
and should be carried out in one of two ways.

· Credit a Scheduled Invoice in full.   Click on the ‘Invoices’ button down the right of the
screen and bring up the Invoicing Schedule for this Job.  Highlight the Invoice to be
credited and click on the ‘Generate a Credit for the Selected Invoice’ button and print
the Credit.
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· Partial Credit an Invoice.  You should create a Credit as defined in 2.4.

In both the above instances the Credit should be applied to the original Invoice. Therefore go to 
Sales>Customer Payments and create a new payment record.  Select the Customer to which the
Credit applies and then click on the drop-down against field ‘Payment Style’ and select ‘Apply
Credits to Invoices’.  In the adjacent field (‘Credit No’) select the above Credit.  Click on the ‘
Apply to Invoices’ tab and apply the Credit to the selected Invoice(s) and then click on the ‘
Update Selected Invoices’ button.

2.1.4. Credit a Job Order (Actual Qty Style) with Item/Descriptor return

To partially or fully Credit a Job Order (Actual Quantity Style) as a result of a product return you
should first go into Jobs>Job Orders and select the Order.  You may have to click on the ‘Include
Closed Status’ checkbox at the bottom of the ‘List’ view.   If the Order status is ‘Closed’ then
amend the status to ‘Finished’.  Now go into the ‘Lines’ tab and select the Item (or Descriptor)
being credited.  In the lower part of the screen click ‘Actual Issue’ tab and add a new Line with a
quantity equal to the quantity being returned (as a negative).  ‘Save’ the entry.  This will create a
reversed transaction.  

As this is an ‘Actual Quantity’ Style Job you should now create the Credit by clicking on the ‘
Invoices’ button down the right of the screen to bring up the Invoicing screen for this Job.  The
reversed value should appear in the ‘To Be Invoiced’ field.  Click on the ‘Create Pending Invoice
 ’button to generate the Credit; then the ‘Print Selected Invoice’ to print it.

The next step is to apply this Credit to the original Invoice.  Therefore go to Sales>Customer
Payments and create a new payment record.  Select the Customer to which the Credit applies and
then click on the drop-down against field ‘Payment Style’ and select ‘Apply Credits to Invoices’.
In the adjacent field (‘Credit No’) select the above Credit.  Click on the ‘Apply to Invoices’ tab and
apply the Credit to the selected Invoice(s) and then click on the ‘Update Selected Invoices’
button.

2.2. Credit a Direct Invoice including Item return

To Credit a Direct Invoice (created via Sales>Direct Invoicing) you should go into Sales>Batch
Invoicing and highlight the Invoice (It will have an Invoice Type of ‘Direct Invoicing’ and status ‘
Printed’) then click on the ‘Credit’ button down the right of the screen.  This will immediately
create the Credit in addition to reversing the issues made by the originating Invoice.  NOTE: If the
selected Invoice is not a ‘Direct Invoice’ (but a ‘Generated Invoice’) then the issue reversals will
NOT take place

The next step is to apply this Credit to the original Invoice.  Therefore go to Sales>Customer
Payments and create a new payment record.  Select the Customer to which the Credit applies and
then click on the drop-down against field ‘Payment Style’ and select ‘Apply Credits to Invoices’.
In the adjacent field (‘Credit No’) select the above Credit.  Click on the ‘Apply to Invoices’ tab and
apply the Credit to the selected Invoice(s) and then click on the ‘Update Selected Invoices’
button.

2.3. Create a Full or Partial Financial Credit

You can raise a Credit and subsequently apply to any Invoice by going into Sales>Direct
Invoicing and clicking on the ‘Add’ button.  On the displayed panel ‘check’ the ‘Create an Invoice
or Credit without an Order’ radio button and select a Customer from the drop-down against field ‘
Billing Customer’ then click the ‘Create’ button.  Enter the Header information then click on the ‘
Lines’ tab to enter a Descriptor line with a negative quantity.  Finally, click the print ‘Print’ button to
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print the Credit.  

The next step is to apply this Credit to the original Invoice.  Therefore go to Sales>Customer
Payments and create a new payment record.  Select the Customer to which the Credit applies and
then click on the drop-down against field ‘Payment Style’ and select ‘Apply Credits to Invoices’.
In the adjacent field (‘Credit No’) select the above Credit.  Click on the ‘Apply to Invoices’ tab and
apply the Credit to the selected Invoice(s) and then click on the ‘Update Selected Invoices’
button.
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5 Creating and printing Specific Report Layouts

This short tutorial shows you how to copy an existing Form (Example: Invoice, Delivery docket,
etc), amend it, and then save it as a different layout.  The amended Form is then used under
user-defined criteria.  In this example we will amend the Sales Invoice and use the amended
Invoice for a specific Type of Customer.

Go into File>Reporting Configuration>Report and View Developer and click the 'Add' button.  
In the presented panel 'check' the 'Copy from Another' radio button and select 'Invoice' from the
drop-down list in the next field.  Finally 'check' the 'Copy to Company' radio button and click the '
create' button.    The Data extract parameters and the Report itself will be copied to your signed-on
Company folder.    In Master Settings tab click on the 'Edit' button to the right of the screen and go
to the Report Layout.  At the top of the screen you will see that you are looking at the Report
Layout for Form SalesInvoiceSheet.fr3.    At this point you can make any changes you wish to the
Form Layout.  At the end click on File>Save As and save the report as (say) SpecialInvoice.fr3. 
You now have two Report Layouts that use the same data extraction criteria.  Exit the Report and
View Developer.

The form can now be used by a Customer Type by completing the following steps:

Step 1:  Go into Sales>Settings>Customer Types and set up a Customer Type of (say) ‘
Wholesale’ 

Step 2:  Go into File>Reporting Configuration>Specific Forms Layout and set up a record with
the following:

         Print Form Name: Invoice
         Condition: Customer Type
         Value: Wholesale
         File Name: C:\Program Files\Ostendo\Reports\DEMO\ SpecialInvoice.fr3

Where the Filename is the full path where you stored the alternate Invoice Layout

Having set up the above you now need to go into Sales>Customers and add Customer Type '
Wholesale' to a Customer record.

Finally create a Sales Order using the above Customer, add and pick lines.  If you now print the
Invoice you will find that the alternate Invoice will be used
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6 CRM Service Levels

1.  Introduction

CRM Service Levels allow you to establish Service Agreements that comprise of a time target for a
Call response with option to have these targets against Steps within the Call; and subsequently
monitor actual response times for analysis purposes.

A Service Agreement comprises of:
Steps that are carried out in response to the Call
Severity (or Urgency) Levels that can apply to the Service Agreement
Response time required for the combination of Step/Severity

Urgent Priority Normal

Respond 1 minute 30 mins 1 hour

On Site 1 hour 2 hours 3 hours

Completed 2 hours 4 hours 6 hours

Each Customer is then allocated a Service Agreement and a Severity Level.

For monitoring your performance you can identify a target achievement rate expected from each 
Step/Severity

Urgent Priority Normal

Respond 100% 90% 90%

On Site 100% 90% 85%

Completed 100% 80% 70%

Let us create a Service Agreement

2.  Setting up Service Agreements

2.1.  Service Agreements

The first action is to define a Service Agreement Code to cover (say) the type of Customer. 
Therefore, go into CRM>Settings>Service Agreements and click the ‘Add’ button.  Create a new
Agreement record called ‘Retail’

2.2.  Agreement Steps

The next activity is to define the Steps (or Milestones) against which the Call can be progressed
and monitored.  Therefore, go into CRM>Settings>Service Agreement Steps and add (say)
three steps called Respond, On Site, and Completed.

2.3.  Agreement Levels

The next setup function is to define different Service (or Priority) Levels within the Service
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Agreement.  Therefore, go into CRM>Settings>Service Agreement Levels.  Add (say) three
Levels called Urgent, Priority, and Normal.

2.4.  Agreement Measures

Pulling all the above together go into CRM>Settings>Service Agreement Measures.   Against
each combination of Agreement Step and Agreement Level within the Service Agreement you can
identify

· The expected Response Time from the time the Call was first received
· The expected level of achievement between the Expected Response Time and the Actual

Response time

Urgent Priority Normal

Respond 1 minute 100% 30 mins 90% 1 hour 90%

On Site 1 hour 100% 2 hours 90% 3 hours 85%

Completed 2 hours 100% 4 hours 80% 6 hours 70%

3.  Service Agreement Activation

Having defined the Service Level Agreement lets now ‘activate’ it.  Go into CRM>Settings>CRM
Rules and enter the following:

Service Level Tracking Activated: ‘Check’ the checkbox.
Default Service Agreement: From the drop-down list select the Default Service
Agreement that will be used when generating a Call.  As you have only created one
Service level Agreement you should (of course) select that one
Default Severity Level: From the drop-down list select the Service Level within the above
Agreement that will be used as the default when generating a Call.   You should note that
if a Customer has a Service Support Agreement/Service Level identified against the
Customer record then that Service Agreement Level will be used in preference to this
default.  For now select Agreement Level ‘Normal’

4.  Adding a Service Agreement to a Customer record

4.1.  Adding the Service Agreement

Go into Sales>Customers and select a Customer (say) ‘Jim Gold & Co Ltd’ then go to the ‘
Detail’ tab.   Click on the ‘Pricing and Invoicing’ tab and enter the following:

Service Agreement: Select Service Agreement ‘Retail’ from the drop-down list.  
Service Agreement Level: Select ‘Normal’ from the drop-down list. 

4.2.  Adding a Customer Contact

Whilst still in the Customer screen click on the ‘Related’ button and select ‘Contacts’ from the
displayed list.   (You can also go to this screen via CRM>Contacts).  Add you own contact and link
that to Customer ‘Jim Gold & Co Ltd’.  You should also note that if the Contact has an email
address then you can ‘double click’ on the address and it will bring up your PCs email facility
prefilled with this email address.
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5.  Using Service Level Agreements,

Let us create a Service Call received from the above Customer.  Go to CRM>Call Centre and
click on the ‘Add’ button to register a new call.  Select the Contact that you created above.  

You will see two tabs that are visible when you enabled Service Level Tracking in the CRM Rules.

5.1. Service Level - Sub Tab

This shows the Service Agreement and Service Level held against the Customer record.  If the
Customer does not have a definitive Service Agreement or the source of this call is from other than
a Customer then the default that you identified in CRM Rules will be used.  Within this tab you can
amend the following:

Severity Level: This is prefilled with the Default Service Agreement Level as entered into
the CRM Rules screen or the Service Agreement Level as held against a Customer
Record.  It can be amended here to another Severity Level if required
Notes: You can enter unlimited amount of Notes that are related to this Service Level. If
you click in the Notes area you will see two Icons appearing in the top-right of the field.  If
you click on the first Icon then the Notes field will occupy a much larger area so that you
can see the full content of your notes.
Before we go to the second Icon go to General>Frequently Used Text and create a
common Text Message such as ‘This Severity covers Normal Service Agreements’.
Having done that go back to the Service Level - Sub Tab and click on the second Icon.  A
separate screen will appear showing the Frequently Used Text message that you have just
created.  If you ‘double click’ on the selected text, to highlight it and click the OK button
then the text will be copied to these Notes.

5.2. Service Response - Sub Tab

This shows all the Steps contained within the Service Level Agreement for the chosen Service
Level.  This screen shows the Planned Response Date/Time based on the Call’s Date and Time
and scheduled against each Step base on the Work Times set up in General>Settings>Work
Times.  In this screen you can record the actual time spent on each Step thereby enabling you to
analyse the actual response times relative to the agreed Service Agreement response times.

Go into field ‘Actual Response Time‘ and enter the actual Date/Time when the Step was
completed.  You can click on the drop-down Calendar and

· Select the Date by clicking on the Day
· Select the Time by clicking on the time element (HH, MM, or SS) and using the up/down

arrows
· Selecting the a.m./p.m. field and alternating using the up/down arrows
· Click on the ‘Now’ button to select the current Date/Time
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7 Customer / Supplier Item Code X-Ref

This Tutorial describes how you can link Customer and/or Supplier Item Codes to your own
internal code and have them both available when selecting the Item during Order entry.

1.  Internal Item Code

Let us first set up your own Item Code by going into Inventory>Items and creating (say) 

Item: B1234
Unit: Each
Description: Tutorial Item
Sell Price: 25
Buy Price: 15

2.  Customer Item Codes

While you are still in the Item screen click on the ‘Related’ button down the right-hand side of the
screen and select ‘Item Customers’.  On the presented screen click the ‘Add’ button.  Create a
line with (say) the following:

Customer: Jim Gold & Co Ltd
Customer Code: BF-1221
Unit: Carton
Conversion: 10
Customer Description:Blue Fan

‘Save’ the record then exit the Item Customers screen.

Whenever you are searching the Item List you can type in either your own number or the Customer
’s number.  Let’s see this in action.  

Go to Sales>Sales Orders and create a Sales Order for Jim Gold & Co Ltd.  Select the ‘Lines’
tab and then click on the ‘Add’ Button.  Make sure that the ‘Line Type’ is ‘Item Code’.  Enter BF-
in the ‘Code’ field and then click on the ‘spyglass’ icon in the ‘Code’ field.  The displayed panel will
show both your Item Code and the Customer’s Item Code.  Selecting the Item will add the Item to
the Sales Order.  Enter quantity 20 and then ‘Save’ the line.
Click on the ‘Print’ Button to the right of the screen to print the Order Acknowledgement.  You
will see both your, and the Customer’s, reference numbers will be printed.

3.  Supplier Item Codes

Go back to Inventory>Items and select the Item Code you created above then click on the ‘
Pricing’ button.  (Alternatively you can go to Pricing>Item Pricing and select the Item Code).
Within the Detail view click on the ‘Buy Prices’ tab and add (say) the following Buy Price Line:

Supplier: Hardware Company
Unit: Box
Conversion: 20
Supplier Item Code: HC/0034
Supplier Description: Fan - boxed
Unit Price: 320

‘Save’ the record then exit the Item Prices screen.
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Whenever you are searching the Item List you can type in either your own number or the Supplier’
s number.  Let’s see this in action.  

Go to Purchasing>Purchase Orders and create a Sales Order for Hardware Company.  Select
the ‘Lines’ tab and then click on the ‘Add’ Button.  Make sure that the ‘Line Type’ is ‘Item Code’.
Click on the ‘spyglass’ icon in the ‘Code’ field.  In the displayed panel enter (say) HC and click the
search Icon.  The resultant display will show both your Item Code and the Supplier’s Item Code.
Selecting the Item will add the Item to the Purchase Order.  Enter quantity 10 and then ‘Save’ the
line.
Click on the ‘Print’ Button to the right of the screen to print the Purchase Order.  You will see both
your, and the Supplier’s, reference numbers will be printed.
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8 Data Restriction by User

In Ostendo you have the option to define - by User - restrictions regarding which records can be
accessed.  When the User goes into the relevant screen(s) only those records defined here are
available.

In this tutorial we will restrict a User to only looking at Jobs which have a Job Type of ‘Standard’.  

1.  Creating a User

Go into File>System Configuration>User Security and Options and click the ‘Add’ button.
Create a new User and check the ‘Normal User’ Radio Button.  Click on the ‘User Access’ tab
and ensure that access has been granted to all the Jobs screens and Reports.  Save the settings
and exit the screen.

2.  Setting up the Restriction Parameters

Go into File>System Configuration>System Screen Conditions and click the ‘Add’ button.  

Enter the following information:

User Name:  Select the User you created above
Screen:  Select ‘Job Orders’ from the drop-down list
Filter Condition:  Enter JOBTYPE = 'Standard' 

Save the settings and exit the screen.

3.  Viewing the results

Go into File>Switch User and sign on as the User you created above.  If you go into Job>Job
Orders you will see that the display is restricted to Job Type ‘Standard’

Go back to File>Switch User and sign on as ‘Admin’

4.  Extending the Selection

We will extend the above to allow access to both Standard and Service Type Jobs.

Go back to File>System Configuration>System Screen Conditions and open up the Filter
Condition field.

Change the filter criteria to:  (JOBTYPE = 'Standard' or JOBTYPE = 'Service’)

If you now switch User you will see that the display will show both Standard and Service Job Types
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9 Database Inquiries

Within Ostendo you can (a) create your own spreadsheet from data held within Ostendo and (b)
display existing .xls files.   Upon first entering this screen it will show a standard Spreadsheet
layout.  This short tutorial will take you through the process of accessing your Ostendo Database
and extracting information for viewing in the spreadsheet.

Creating a Query

To extract information you first need to create a Query.  A Query is a sequence of instructions that
tells the computer what to extract from the database.   To begin go to General>Data Spreadsheet
.  In the displayed panel select Data>Query Builder.   On the displayed screen there are four
panels

Tables - The names of all the Tables (database files) that are used by Ostendo
Fields - Having selected a specific Table this will show each field in that Table
Query - This is where you create and maintain the query as described below
Selection Criteria - Enables you to define parameters when running this query

Let us construct a ‘Query’ that extracts data from the Inventory Master table.  (A separate Tutorial
covering Queries is available)

The first command is ‘select’.  With this command you are telling the computer which fields to
select.  However the computer doesn’t know from which table you are selecting therefore the
command should be extended to tell it from which table to extract the field.  In this example we will
extract all fields from the Inventory Master (Inventory) table.  The instruction would be 

Select * from Inventory

If you type this in the right hand panel and hit ‘Run’ button the full data from the Inventory table will
be output to a spreadsheet.  (Hint – when you get to the ‘Inventory’ table in the left-hand panel
you can double click on it and it will automatically copy to the right without the *)

You may wish to only extract selected fields from the Inventory table.  This is simply done by
specifying the required field(s) in the ‘select’ statement.  For example:

Select ItemCode, WarehouseCode, LocationCode from Inventory

Note:  Each selected field is separated by a comma.

(Hint – Once again you can double click on the field on the left side of the screen and it will
automatically copy to the right).

Selection Parameters

The Query defined above extracts data from every record in the Item Master table.  You may wish
to limit the extracted records to a range of Items.  Ostendo therefore allows you to enter selection
parameters.  Using the above example let us allow a range of Item Codes to be selected.

To create a parameter you should 
· Highlight the Table in the ‘Table’ panel (This would be ItemMaster in our exercise)
· Click the ‘Add’ button at the bottom of the screen.  This will add a new line in the ‘Selection

Criteria’ Panel.  Enter the following information
Display Name: Enter (say) ‘Item Code From’
Field Name: From the drop-down list select the field against which the parameter
entry will be made. In our example it will be ItemCode
Operator: From the drop-down list select the operand that will apply to the
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parameter.  The available operands are:
= (Equal To)
> (Greater Than)
< (Less Than)
>= (Greater than or equal)
<= (Less than or equal)
<> (Not equal to)

In our instance it would be >=
Look Up Table: From the drop-down list select the LookUp table from which the
selection will be make. In our example it would be 1004

· Click the ‘Add’ button again and add another line with the following 
Display Name: Enter (say) ‘Item Code To’
Field Name: ItemCode
Operator: <=
Look Up Table: 1004

Save the parameter settings by clicking on the ‘Save’ button at the bottom of the screen.

Now Save the whole query by clicking on the Save button down the right of the screen

If you now ‘Run’ the Query the selection parameters will be presented for the Range to be entered.

As you have ‘Saved’ the query it can be recalled at any time by clicking on the ‘Query List’ button
and selecting the query

The extracted data can be printed or saved as a .xls Spreadsheet
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10 Descriptors and Their Use

1.  What is a Descriptor?

A Descriptor can represent anything that you wish to Invoice that is not an Inventoried Item. 
Examples of Descriptors are:

· Non-Stock Items 
· Travel 
· Accommodation 
· One-off charges 
· Etc

A Descriptor can also be used as a descriptive line against an Invoice.  In this instance it also
serves to determine a Tax Code (I.e. The Descriptor’s Tax Group is matched to the Customer’s
Tax group to provide a Tax Code).

2.  Standard Descriptor

This is the ‘standard’ style of general usage Descriptor.  We will create a Descriptor to cover
mileage charges.  To begin you should go into General>Settings>Standard Units and create a
Unit of Km with description ‘Kilometres’.  Now go into Inventory>Descriptors and create a
Descriptor of (say) ‘Travel’.  Select ‘Km’ as the Unit.   Add a description and a Sell Price of (say) $
1.50 per Km.   You may also wish to add some Sales Notes at the bottom of the screen; these will
be copied to the Sales order Line.

To use the Descriptor go into Sales>Sales Orders and create a new Sales Order by clicking on
the ‘Add’ button.  On the presented panel select Customer ‘Jim Gold & Co Ltd’ and then click on
the ‘Create Order’ button.    In the generated order click on the ‘Lines’ tab and then the ‘Add’
button.  In the lower part of the screen change the ‘Line Type’ to ‘Descriptor’ and select ‘Travel’
from the drop-down in field ‘Code’.  Finally enter a quantity of (say) 20 Kilometres and then ‘Save’
the record.

If you now click on the ‘Print’ button down the right of the screen you can print the Order
Acknowledgement.

3.  Time Unit Descriptor

This type of Descriptor is based on time units and, when used in Job Orders, is included in a Order
’s planned and projected hours statistics.

To begin you should go into General>Settings>Standard Units and create a Unit of Hrs with
description ‘Hours’.    You should also ‘check’ the ‘Is Time Unit’ checkbox and enter a value of 1
in ‘Time per Hour’.  Next, go into Inventory>Descriptors and create a Descriptor of (say) ‘
Subcontract’.  Select ‘Hours’ as the Unit.   Add a description, default Supplier and Sell Price.

To use the Descriptor go into Jobs>Job Orders and create a new Job Order by clicking on the ‘
Add’ button.  On the presented panel select Customer ‘Jim Gold & Co Ltd’ and then click on the ‘
Create Order’ button.    In the generated order click on the ‘Lines’ tab and then the ‘Add’ button.
In the lower part of the screen change the ‘Line Type’ to ‘Descriptor’ and select ‘Subcontract’
from the drop-down in field ‘Code’.  Finally enter a quantity of (say) 10 hours and then ‘Save’ the
record.
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If you now click on the ‘Related’ button and select ‘Job Values’ the panel that appears will show
the 10 hours as the ‘Planned’ hours.  This will be used against Actual Values to evaluate the
progress of the Job

4.  Kit Set Code

A Kitset is used in Sales and Job Orders where you sell a ‘Kit’ of parts at a defined price
irrespective of the cost of the Items within the Kit.  In our example we will make a ‘Pizza’ and sell it
for $9.95.  The contents of the pizza will be the pizza ‘Base’ and the ‘Cheese’.   First go into
Inventory>Items and create the following Items

Code Unit Description Sell Price Cost**
Base Each Pizza Base $6 $4
Cheese Kg Mozzarella Cheese $12 $8

** Note: To enter the Cost click on the ‘Costing’ button in the Item’s ‘Detail’ screen and enter the
above costs in both the Average Cost and Standard Cost fields then ‘Save’ the entries

The next step is to create the Kit Set Descriptor.  Therefore go into Inventory>Descriptor and
create the Kitset with the following information

Code Pizza
Unit Each
Description Plain Pizza
Sell Price $9.95
Classification ‘check’ the ‘Descriptor is used as a Kitset Code’ Radio button

The final step is to create the Kitset.  Therefore go into Sales>Kitsets and click the ‘Add’ button.
Select ‘Pizza’ from the drop-down list.  You will note that the standard Sell Price of $9.95 is
displayed on this screen.  Click on the ‘Lines’ tab and enter the following:

Code Qty
Base 1
Cheese .2

You are now ready to create a Sales Order using this Kitset.  Go to Sales>Sales Orders and
create a new Sales Order.  Click on the ‘Lines’ tab and then the ‘Add’ button.  In the lower part of
the screen select ‘Kitset Code’ from the drop-down under field ‘Line Type’ then select ‘Pizza’
from the drop-down under ‘Code’.  Enter a quantity of 1 then ‘Save’ the entry.

You can issue the Kit by one of two methods:
· Using the ‘Picking’ button on the batch entry bar, or
· Using the ‘Picked Lines’ tab at the bottom of the screen

If you issue the Kitset then the Kitset Components are ‘backflushed’ (I.e. Issued) from stock.

4.1.  In the above example you manually entered a Sell Price against the Kitset Descriptor.  You
may prefer to get Ostendo to evaluate the Sell Price and two methods are available:

(a) Go into Sales>Kitsets and recall the ‘Pizza’.  On the ‘Detail’ screen click on the ‘
Rolled Up Prices from Kitset Lines’ and ‘Save’ the changes.  You will see that the Sell
Price has changed to reflect the sum of the Sell Prices of the Kitset Components.
(b) Now click on the ‘Rolled Up Costs from Kitset Lines’ and enter (say) 80 in field ‘
Markup%’ then ‘Save’ the changes.  You will see that the Sell Price has changed to reflect
the cost of the Kitset Components and applying the Markup%.  

Both these options will update the ‘Sell Price’ field in the ‘Pizza’ Descriptor record.
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5. Task Bill Code

A Task Bill is used in Job Orders where you carry out a Task at a defined price irrespective of the
cost of carrying out the Task.  In our example we will ‘Fit out’ a bathroom for a standard price of
$2000.  The contents of the Task will be a Bath, Washbasin and Labour of 5 hours.  First go into 
Inventory>Items and create the following Items

Code Unit Description Sell Price Cost**
Bath Each Standard Bath $900 $450
WashBasin Each Standard WashBasin $400 $200

** Note: To enter the Cost click on the ‘Costing’ button in the Item’s ‘Detail’ screen and enter the
above costs in both the Average Cost and Standard Cost fields then ‘Save’ the entries

The next step is to create the Task Bill Descriptor.  Therefore go into Inventory>Descriptor and
create the Task Bill with the following information

Code Bathroom
Unit Each
Description Fit Out Bathroom
Sell Price $2000
Classification ‘check’ the ‘Descriptor is used as a Task Bill Code’ Radio button

The final step is to create the Task Bill.  Therefore go into Jobs>Task Bills and click the ‘Add’
button.  Select ‘Bathroom’ from the drop-down list.  You will note that the standard Sell Price of
$2000 is displayed on this screen.  Click on the ‘Lines’ tab and enter the following:

Component Type Code Qty
Item Code Bath 1
Item Code WashBasin 1
Descriptor Code General Time 5

You are now ready to create a Job Order using this Task Bill.  Go to Jobs>Job Orders and click
the ‘Add’ button.   Select a Customer then click on the ‘Task Information’ tab.  In that panel go to
field ‘How Job Lines are related to this Task’ and amend this to ‘A single Task Bill is linked to
this Task’ from the drop-down list.  In field ‘Task Bill Code’ select ‘Bathroom’ then click the ‘
Create Order’ button

Click on the ‘Lines’ tab in the generated order where you will see a single Task.  This Task now
has two elements.

· Entering the ‘actual’ usage of the Task Bill content to arrive at the cost of carrying out this
Task

· Entering a Task Completion so that the activity can be billed to the Customer.

5.1.  Entering actual usage.  In the ‘Lines’ tab of the Job Order click on the ‘Task Completions’
tab and then click the ‘Add’ button.  Enter a quantity of 1 and ‘Save’ the entry. on the ‘Batch Entry’
bar.  If you ‘Prefill Issues’ then you will see that the Bath, WashBasin and General Time will be
presented for entering the Actual Usage.

5.2.  Entering Task Completion.  In the ‘Lines’ tab of the Job Order click on the ‘Task
Completions’ tab and then click the ‘Add’ button.  Enter a quantity of 1 and ‘Save’ the entry. If you
click on the ‘Invoices’ button then you can print the Invoice relating to the completion of this Task.
Note: If you have ‘Invoice Approvals’ flag set in Jobs>Settings>Job Rules then you should first ‘
Approve’ the Invoice via Jobs>Job Pending Invoices
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6.  Recurring Invoice

A Recurring Invoice is simply a schedule of planned Invoices as agreed with your Customer.  A
Descriptor is used as the basis for providing a description of the Invoice Line in addition to
determining the Tax Rate to apply to the Invoice (via the Tax Group combination associated to the
Customer and Descriptor records).

During this exercise we will create a recurring Invoice covering 6 monthly amounts of $550.  Go
into Sales>Recurring Invoices and click on the ‘Add’ button.  On the presented screen you can
create a schedule of planned Invoices as follows:

· Select a Customer from the drop-down list against field ‘Customer’ then
· Select ‘Contract Style’ of ‘Fixed Term’
· In the ‘Invoice Line Details’ section down the left of this screen define:

- Frequency Every ‘1’  ‘Month’
- Start Date = Today
- Number of Times = 6
- Per Invoice Value = $500

· In the ‘Invoice Line Details’ section down the right of this screen select Descriptor Code
‘Monthly Charge’

· Click the ‘Create’ Button to generate the Invoice Schedule
· Note the Contract Number generated by Ostendo.  This will be used in the next step.  

You can view the generated Invoice by going to the ‘Scheduled Invoices’ tab.  

To generate an Invoice from this schedule go into Sales>Batch Invoicing and select the ‘Add’
button.  A screen is presented in which you should ‘check’ the Include Recurring (Contract)
Invoicing checkbox

· Select the above contract in the drop-down in fields ‘From Contract No’ and ‘To Contract
No’ fields

· Click the ‘Create’ button.  
As the first scheduled Invoice was planned for today this routine will create an Invoice for this
scheduled line.  Print the Invoice back to the screen.

Go back to Sales>Recurring Invoices and click on the ‘Scheduled Invoices’ tab.  You will see
that the first scheduled Invoice now has the Invoice Number held against it.  Note: Any Scheduled
Invoice that has not been converted can have the Date and amount altered.   You may also add or
delete entries.

7. Job Retentions

A Descriptor is used within a Retention Invoice to provide a description of the Invoice Line in
addition to determining the Tax Rate to apply to the Invoice (via the Tax Group combination
associated to the Customer and Descriptor records).

To use the Descriptor go into Jobs>Job Orders and create a new Job Order by clicking on the ‘
Add’ button.  On the presented panel select Job Style ‘Progress’ and Customer ‘Jim Gold & Co
Ltd’ and then click on the ‘Create Order’ button.    In the generated order ‘check’ the checkbox ‘
This is a Fixed Price Job’ and enter a value of (say) 1000 in the adjacent ‘Nett Value’ field.  
Click on the ‘Invoices’ button down the right of the screen and an Invoice panel will appear.   Click
on the ‘Detail’ tab, then ‘check’ the ‘A Planned Retention applies to this Job’ checkbox and
enter the Retention information such as:

Retention%: 10%
Planned Retention Date: (say) the end of the following month
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Code: RETENTIONCLAIM

‘Save’ the record and close out of the screen.

If you go to Jobs>Reports>Jobs Retentions Listing you will see the list of Retentions, each
having a Retention Due Date and current value.

8. Job Scheduled Invoice

A Scheduled Invoice is used against a Job that has an Invoice Style of ‘From Schedule’.  The
Schedule itself is user-defined where a series of Invoices are raised and each Invoice represents a
proportion of the total Job Value.  Each Invoice can be represented by a single Descriptor or a
further breakdown using additional Descriptors as follows

8.1.  Single Descriptor

Go to Jobs>Job Invoices and select the Invoicing schedule that you created in the previous
section and click on the ‘Invoices’ tab.    Click the ‘Add’ button to generate a scheduled Invoice
Line.  Under field ‘Code’ select Descriptor ‘PROGRESSCLAIM’ from the drop-down list.  If you
click on the ‘Invoice Line’ tab you will see that the Radio Button ‘Use the Line Below for printing
on the Invoice’ is already ‘checked’.   This option will print Descriptor ‘PROGRESSCLAIM’ along
with its Description and Line Comments.  (Note: In this panel you can amend the description and
add note that are specific to this Invoice).  Go back to the ‘Schedule’ tab and click on the ‘Create
Pending Invoice’ button.  Finally click on the ‘Print Selected Invoice’ button and - In PREVIEW
Mode - look at the Invoice.

8.2.  Additional descriptive lines

While still in the above Invoice click on the ‘Invoice Line’ tab and select the second Radio Button ‘
Use the line below as the priced Invoice line….etc’.   Now click on the ‘Lines for printing only’
tab.  Click the ‘Add’ button and add two lines with (say)

Code Qty
GENERALTIME 5
MATERIALS 250

Go back to the ‘Schedule’ tab and click the‘Print Selected Invoice’ button and - In PREVIEW
Mode - look at the Invoice.

8.3.  Priced descriptive lines

Go back to the ‘Invoice Line’ tab and select the third Radio Button ‘Enter multiple Priced
Lines….etc’.   Now click on the ‘Lines for printing only’ tab.  Add additional Information to the
Lines that are currently there.  For example

Code Unit Price Qty
GENERALTIME 75 10
MATERIALS 1 250

Go back to the ‘Schedule’ tab and click the‘Print Selected Invoice’ button and - In PREVIEW
Mode - look at the Invoice.
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11 Emailing From Job Calendar

Emailing from Job Calendar

This Tutorial will take you through the process of emailing instructions to an
Employee from the Job Calendar and directly updating the recipient's 'Outlook'
Calendar

1.  The first step is to create the script.  Therefore go into File>Scripting
Configuration>Script Editor and create a new script called (say) 'Job
Notification'.  Select 'Order' from the 'Style' drop-down.  Click on the 'Script' tab
and add the following script.  

Const
  OrganizerEmail = 'demo@development-x.com';
  SMTPHost = 'mail.development-x.com';
  POP3Host = 'mail.development-x.com';
  POP3Pass = 'demo';

function GetEmployeeFromEmail(EmailAddress: String): String;
var
  ResQuery: TpFIBQuery;
begin
  ResQuery := TpFIBQuery.Create(nil);
  try
    ResQuery.Database := OstendoDB;
    ResQuery.Options := qoStartTransaction;
    ResQuery.SQL.Clear;
    ResQuery.SQL.ADD('Select RESOURCENAME from
RESOURCEMASTER where EMPLOYEEEMAIL=:EMPLOYEEEMAIL');
    ResQuery.SQL.ADD('and RESOURCETYPE=:RESOURCETYPE');
    ResQuery.PN('EMPLOYEEEMAIL').AsString := EmailAddress;
    ResQuery.PN('RESOURCETYPE').AsString := 'Employee';
    ResQuery.ExecQuery;
    Result := ResQuery.FN('RESOURCENAME').AsString;
  finally
    ResQuery.Close;
    ResQuery.Free;
  end;
end;

procedure GetReplies;
var
  MsgCount, AttachCount: Integer;
  x, i: Integer;
  EmailAddress, EmailSubject, EmailBody, EmailAttachment: String;
  OrderNumber, TaskName, EmployeeName: String;
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  SubjectParts: TStringList;
begin
  {receive email using settings specified at top of script in "const" section}
  MsgCount := ReceiveEmail(POP3Host,OrganizerEmail,POP3Pass,True);
  SubjectParts := TStringList.Create;
  try
    for x := 1 to MsgCount do
    begin
      EmailSubject :=GetEmailMessage('Subject',x);
      EmailBody := GetEmailMessage('Body',x);
      EmailAddress := GetEmailMessage('FromAddress',x);
      EmployeeName := GetEmployeeFromEmail(EmailAddress);
      {Accept / Tentative / decline in email subject}
      SubjectParts.Text := ReplaceText(EmailSubject, ':', #13);
      if SubjectParts.count < 3 then exit;
      {0 = Status 1 = OrderNumber 2 = Taskname}
      OrderNumber := trim(SubjectParts[1]);
      TaskName := trim(SubjectParts[2]);
      if trim(SubjectParts[0]) = 'Accepted' then
        ExecuteSQL('Update JOBTASKRESOURCES set
RESOURCESTATUS=''Accepted'''
         + ' where ORDERNUMBER=' + '''' + OrderNumber + ''''
         + ' and TASKNAME=' + '''' + TaskName + ''''
         + ' and RESOURCETYPE=''Employee'''
         + ' and RESOURCENAME=' + '''' + EmployeeName + ''''
         )
      else if trim(SubjectParts[0]) = 'Declined' then
        ExecuteSQL('Update JOBTASKRESOURCES set
RESOURCESTATUS=''Declined'''
         + ' where ORDERNUMBER=' + '''' + OrderNumber + ''''
         + ' and TASKNAME=' + '''' + TaskName + ''''
         + ' and RESOURCETYPE=''Employee'''
         + ' and RESOURCENAME=' + '''' + EmployeeName + ''''
         );
    end;
    if MsgCount = 1 then
      MessageDlg('[' + inttostr(MsgCount) + '] Reply was Processed'
,mtinformation,mbok,0)
    else
      MessageDlg('[' + inttostr(MsgCount) + '] Replies were Processed'
,mtinformation,mbok,0);
  finally
    SubjectParts.Free;
  end;
end;

function GetEmployeeEmail(EmployeeName: String): String;
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var
  ResQuery: TpFIBQuery;
begin
  ResQuery := TpFIBQuery.Create(nil);
  try
    ResQuery.Database := OstendoDB;
    ResQuery.Options := qoStartTransaction;
    ResQuery.SQL.Clear;
    ResQuery.SQL.ADD('Select EMPLOYEEEMAIL from
RESOURCEMASTER where RESOURCENAME=:RESOURCENAME');
    ResQuery.SQL.ADD('and RESOURCETYPE=:RESOURCETYPE');
    ResQuery.PN('RESOURCENAME').AsString := EmployeeName;
    ResQuery.PN('RESOURCETYPE').AsString := 'Employee';
    ResQuery.ExecQuery;
    Result := ResQuery.FN('EMPLOYEEEMAIL').AsString;
  finally
    ResQuery.Close;
    ResQuery.Free;
  end;
end;

function DateTimeToOutlookString(ADateTime: TDateTime): String;
begin
  ADateTime := ConvertToUniversalTime(ADateTime);
  Result := FormatDateTime('YYYYMMDD"T"HHMMSS"Z"',ADateTime);
end;

function CreateInvite(Attendees: String; StartDateTime: TDateTime;
EndDateTime: TDateTime; Location: String;
  OrderNumber: String; Subject: String; Description: String): String;
var
  TempList,AttendeeList: TStringList;
  ICSFile: String;
  x: Integer;
begin
  TempList := TStringList.Create;
  AttendeeList := TStringList.Create;
  try
    TempList.Add('BEGIN:VCALENDAR');
    TempList.Add('PRODID:-//Development-X//Ostendo//EN');
    TempList.Add('VERSION:2.0');
    TempList.Add('METHOD:REQUEST');
    TempList.Add('BEGIN:VEVENT');
    {Loop and add multiple attendees CRLF delimited}
    AttendeeList.Text := Attendees;
    for x := 0 to AttendeeList.Count -1 do
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TempList.Add('ATTENDEE;ROLE=REQ-PARTICIPANT;RSVP=TRUE:MAI
LTO:' + AttendeeList.Strings[x]);
    TempList.Add('ORGANIZER:MAILTO:' + OrganizerEmail);
    TempList.Add('DTSTART:' +
DateTimeToOutlookString(StartDateTime));
    TempList.Add('DTEND:' + DateTimeToOutlookString(EndDateTime));
    TempList.Add('LOCATION:' + Location);
    TempList.Add('SEQUENCE:0');
    TempList.Add('UID:' + OrderNumber);
    TempList.Add('DTSTAMP:' + DateTimeToOutlookString(Now));
    TempList.Add('DESCRIPTION:' + Description);
    TempList.Add('SUMMARY:' + Subject);
    TempList.Add('CLASS:PUBLIC');
    TempList.Add('END:VEVENT');
    TempList.Add('END:VCALENDAR');
    ICSFile := OSTENDOPATH + 'Invite' + Ordernumber + '.ics';
    TempList.SaveToFile(ICSFile);
    Result := ICSFile;
  finally
    TempList.Free;
    AttendeeList.Free;
  end;
end;

var
  ICSFile, OrderNumber, TaskName, TaskDesc, Location: String;
  AttendeeList: TStringList;
  ResQuery: TpFIBQuery;
  EmailString: String;
  TaskStart, TaskFinish: TDateTime;
begin
  if MessageDlg('Do you wish to get replies (yes) or send invites
(no)',mtinformation,mbyes+mbno,0) = mrYes then
  begin
    GetReplies;
    exit;
  end;
  OrderNumber := GetSourceFieldValue('ORDERNUMBER', 'LINE');
  TaskName := GetSourceFieldValue('TASKNAME', 'LINE');
  TaskDesc := GetSourceFieldValue('TASKDESCRIPTION', 'LINE');
  Location := 'On Site';
  TaskStart := strtodatetime(GetSourceFieldValue('TASKSTART', 'LINE'));
  TaskFinish := strtodatetime(GetSourceFieldValue('TASKFINISH', 'LINE'));

  {Get Resources for job/task with Assigned status}

  AttendeeList := TStringList.Create;
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  ResQuery := TpFIBQuery.Create(nil);
  try
    ResQuery.Database := OstendoDB;
    ResQuery.Options := qoStartTransaction;
    ResQuery.SQL.Clear;
    ResQuery.SQL.ADD('Select RESOURCENAME,SYSUNIQUEID from
JOBTASKRESOURCES where
RESOURCESTATUS=:RESOURCESTATUS');
    ResQuery.SQL.ADD('and RESOURCETYPE=:RESOURCETYPE');
    ResQuery.SQL.ADD('and ORDERNUMBER=:ORDERNUMBER');
    ResQuery.SQL.ADD('and TASKNAME=:TASKNAME');
    ResQuery.PN('RESOURCESTATUS').AsString := 'Assigned';
    ResQuery.PN('RESOURCETYPE').AsString := 'Employee';
    ResQuery.PN('ORDERNUMBER').AsString := OrderNumber;
    ResQuery.PN('TASKNAME').AsString := TaskName;
    ResQuery.ExecQuery;
    while not ResQuery.eof do
    begin
      EmailString :=
GetEmployeeEmail(ResQuery.FN('RESOURCENAME').AsString);
      if trim(EmailString) <> '' then
      if pos('@',EmailString) > 0 then
        AttendeeList.Add(EmailString);
      ResQuery.Next;
    end;
    if trim(AttendeeList.text) = '' then
    begin
      MessageDlg('There is nothing to send, employees for this task have
been notified',mtinformation,mbok,0);
      exit;
    end;
    ICSFile :=
CreateInvite(AttendeeList.text,TaskStart,TaskFinish,Location,OrderNumbe
r,{Subject}OrderNumber + ':' + TaskName,TaskDesc);
    if trim(ICSFile) <> '' then
      SendEmailMessage(SMTPHost,OrganizerEmail,
AttendeeList.CommaText, 'subject','body',ICSFile);
    {Update JOBTASKRESOURCES RESOURCESTATUS to Notified}
    ResQuery.Close;
    ResQuery.ExecQuery;
    while not ResQuery.eof do
    begin
      ExecuteSQL('Update JOBTASKRESOURCES set
RESOURCESTATUS=''Notified'' where SYSUNIQUEID=' +
ResQuery.FN('SYSUNIQUEID').AsString);
      ResQuery.Next;
    end;
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    MessageDlg('Invites were sent to employees',mtinformation,mbok,0)
  finally
    ResQuery.Close;
    ResQuery.Free;
    AttendeeList.Free
  end;
end.

You should now amend the Constants in the script to that used by your
organisation.

2.  The next step is to link the script to the Job Activity in the Job Calendar. 
Therefore, go into File>Scripting Configuration>Order Scripts and add a new
record containing Screen:Job Calendar and ScriptName: as created above.

3.  To ensure that the email is sent to the correct address you should now go into 
Labour>Employees and validate the email addresses against each Employee.

4.  We will now see how this all pulls together.

4.1. Go into Jobs>Job Calendar and create a new Job.  If you 'right mouse' on
the generated rectangle you will see the above script name.  Click on this and it
will run the script.

A panel will appear from which you can 'send' the email to the Employee(s).  

If you click the 'No' button then the email will be sent and the following
confirmation panel will appear

4.2. The Employee will then receive the email with an attached appointment
message.  The email will display as follows

Upon opening the attachment the following will be displayed
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You can see that there are options to Accept, Decline, Tentative, or propose a
new time.

4.3.  Upon completing the option the response is returned to the Sender and a
reservation placed in Outlooks Calendar.
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12 Features and Options

Features and Options allow you to configure a Customer-Specific Product during Order Entry.

A 'Feature' is an aspect of a product showing the variables being offered (for example: What Type
of Birthday Cake do you want?).  Within each Feature are the defined Options (Example: Plain
Sponge, Chocolate Sponge, Battenberg, etc).  Features and Options are used during Order Entry
where each Feature is shown from which you select an Option.  This will generate a
Customer-Specific Bill of Material which, in turn, provides a quoted price for the configuration.

In this Tutorial you will use the DEMO Database to:
· Create a 'base' Bill of Material for a Birthday Cake
· Add Features and Options to the Bill of Material
· Configure a customised Birthday Cake via a Sales Order.  This will include exercises to

show how to:
o Add a new Line to the configured BOM
o Increase Quantity in the configured BOM
o Decrease Quantity in the configured BOM
o Remove a line in the configured BOM
o Replace a line the configured BOM

Create Items

Go into Inventory>Items and create the following

Item Code: CAKE
Unit: Each
Description: Cake
Default Supply Method: Source On Demand
Sourced By: Custom
Configured By: Features
Sell Price: $10.00 (This is the 'Base' price with no added Features/Options)
Batch No: 'Check' this checkbox

Item Code: PLAIN
Unit: Each
Description: Plain Sponge Base

Item Code: CHOCOLATE
Unit: Each
Description: Chocolate Sponge Base

Item Code: BATTENBERG
Unit: Each
Description: Battenberg Base

We will also use the existing GENERALTIME Descriptor Code to record times

2.  Base Bill of Material

A base Bill of Material should be defined for the Custom Configured Item.  At the very least this
should contain the Steps necessary to make the parent Item.  You may also include basic Items,
Descriptors and Labour Codes that are not affected by the Features and Options process.    In this
example we will have a BOM with 2 Steps.  The first step contains no Items (as this will be added
during the configuration process) and a Labour Code.  The second step will contain the Labour
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Code only and covers the time required to finish the configured Cake.     Therefore go into 
Assembly>Bills Of Material and create a BOM for CAKE.   In the 'Detail' tab click on the 'Routing
Steps' tab and add step 'Finishing' to the existing default 'Assembly' step.   Click on the BOM '
Lines' tab and add 0.25 hour of Descriptor GENERALTIME to Step ‘Assembly’.  Add the same
Descriptor Code and time to the second ‘Finishing’ step.   You should now have two lines in the
BOM each with 0.25 hour of Descriptor GENERALTIME but different Steps.  The Cake Style will
be added as part of the Configuration process during Order Entry.

3.  Creating Features and Options

Whilst you are in the Bill of Material screen you will see that there is a tab called 'Features'.   This
is only active if the parent Item is Sourced By 'Custom' and Configured By 'Features'. This screen
enables you to define the Features and Options to be used.  Click on this tab.   The upper portion
of the screen shows all the Features that are currently held against this BOM. The lower part of the
screen enables you to create and maintain Features along with all Options used within each
Feature.

Using the above we will carry out various scenarios that can be used within the Features and
Options process

Example 1.  Adding Components 

This is the simplest form of Features and Options where the selected Options are added to the
base BOM.    In this exercise we will create a Feature that provides the option to select the Cake
Type.

Ensure that you are in the 'Features' tab of the Bill of Material for Item CAKE.  Click the 'Add'
button to create a new Feature and - in the lower part of the screen - add the following

Seq No: 10
Feature: What Cake Type do you want?
Step: Assembly

Click on the 'Options' tab and add the following three Options to this Feature:

Option Name: Plain Sponge
Code Type: Item Code
Option Code: PLAIN
Qty Per Feature: 1
Option Price: $9.00
**Description Segment: /Plain Base

** Note that the Description of the end product when Configured Product will be a
combination of the Parent Item's description plus the Option's Description Segment. I.e. 
Cake/Plain Base

Option Name: Chocolate Sponge
Code Type: Item Code
Option Code: CHOCOLATE
Qty Per Feature: 1
Option Price: $10.00
Description Segment: /Chocolate Base

Option Name: Battenberg Base
Code Type: Item Code
Option Code: BATTENBERG
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Qty Per Feature: 1
Option Price: $14.00
Description Segment: /Battenberg Base

Now let's raise a Sales Order.   Therefore go to Sales>Sales Orders and raise a Sales Order.  Go
to the 'Lines' tab and select CAKE from the drop-down list under field 'Code'.  Having selected the
Cake you will see four icons in the Code field; select the third Icon to configure the Cake.   A
separate panel will appear showing the above Feature.  Click on the drop-down in field 'Option' and
select the required Option.  Finally click the 'Accept Options Selected' button at the bottom-right of
the panel.

You will be taken back to the Order Line screen where the 'CAKE' Price and selected option Price
has been added together to become the Quoted Price for the Order Line.  You will also note that
the Description of the Order Line comprises of the Description of the Cake with addition of the
descriptions of the selected Options.

Example 2: Increase quantity of an existing Item

In this example we will demonstrate how the Features and Options process can increase the
quantity of an existing entry in the base BOM.   The BOM you created above has 0.25 hours of
Descriptor GENERALTIME in the ‘Finishing’ step.   This relates to using 'Plain' Icing on the Cake.
If we had 'Decorative' Icing then this would take longer to finish this Assembly Step.  In this
instance we would need to increase the basic 0.25 hours of Descriptor GENERALTIME by a
further 0.3 hours to make a combined 0.55 hours 

We need to tell Ostendo the SPECIFIC Component that you are increasing.  To do this you not
only provide the Line Code and Assembly Step but also the Line Number within the Step. 
Therefore go into the BOM and take note of the Line Number against Descriptor GENERALTIME
in the ‘Finishing’ step

The next step is to create a 'Phantom' BOM that will be added to the Option.  Therefore create a
new Item Code called (say) 'Phantom M'.     Go into Assembly>Bills of Material and define it as
being a Phantom Assembly.  Go into the 'Routing Steps' screen and add Step 'Assembly'

Go into the Lines tab of the Bill of Material and add the following:

Descriptor Code: GENERALTIME
Step: Finishing              
Line#: The Line Number that you noted above
Quantity: 1              

This defines what is required when using the phantom.  The actual quantity to be added to the
configuration will be defined in the 'Options' tab of the 'CAKE' Assembly as follows

Go into the 'CAKE' Bill of Material and select the 'Features' tab.  Click the 'Add' button to create a
new Feature and - in the lower part of the screen - add the following

Seq No: 20
Feature: What Type of Icing do you want?
Step: Finishing

Click on the 'Options' tab and add the following two Options to this Feature:

Option Name: Fancy Icing
Code Type: Item Code
Option Code: Phantom M
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Qty Per Feature: 0.3
**Option Price: $5.00
Description Segment: /Fancy Icing

** This is the Sell Price of this Option and will be added to the base price if this option is
selected

Option Name: Plain Icing
Code Type: Item Code
Option Code: Phantom M
Qty Per Feature: 0.0
Option Price: $0.00
Description Segment: /Plain Icing

If you now raise a Sales Order for CAKE and - in the Item Code field – click on the third Icon to
configure the Product.   You will find that the Sell Price and Description of the line reflects the
Options that have been selected.  
 
Click on the 'Related' button and select 'Create Required Assembly Order' and convert the
Configured Product into an Assembly Order. You will see that because the Item Code Phantom M
is a phantom the Assembly Order generation process will 'Blow Through' the Phantom and match
up the Item Code/Step Name/Line Number of the selected Option.  As it currently exists Ostendo
will combine the base and Option quantities together in the final Assembly Order.

Example 3: Decrease quantity of an existing Item

This is similar to Example 2 except that the quantity entered against the option is negative. 

Example 4: Remove an Item

Once again, this is similar to Example 2 except that the quantity entered in the option is a negative
quantity that equals the quantity in the Main BOM. As the sum of the two quantities is now zero
Ostendo will ignore the line when creating the Assembly Order. 

Example 5: Replace an Item

This is a combination of Example 4 where the Item being replaced has a negative quantity equal to
the positive quantity in the Main BOM and Example 1 which adds the replacing Item in the same
Phantom BOM.  
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13 Foreign Currency Processing

Introduction

Within Ostendo you have the following options
· Single-Currency Ostendo and Single-Currency 3rd Party Accounts.  This is the default

supplied with an initial Install.  
· Multi-Currency Ostendo and Multi-Currency 3rd Party Accounts.  You would define other

currencies as shown in this exercise to achieve this option. 
· Multi-Currency Ostendo and Single-Currency 3rd Party Accounts.  This is a simple setting

that allows you to have full multi-currency processing in Ostendo (Purchase receipts,
Invoices, payments, statements, etc) but output local currency Journals to the linked 3rd

-Party Accounting package

These exercises will take you through Ostendo and describe the actions required to set up and
process a Foreign Currency covering the following

· Accounting Link setup
· Setting Up Currency Code along with their related Cost centres
· Multi-Currency Purchasing
· Multi-Currency Sales
· Multi-Currency Job Orders

1.  Accounting Link Setup

Go into File>System Configuration>System Settings and click on the ‘Accounting Link’ tab.
You will see three main areas that should be addressed.

1.1. Accounting Link Style

From the drop-down list under ‘Accounting Link Style’ select the Accounting software that you
linking to.  If you select ‘Other Accounting Solution’ then you are required to point to Ostendo
Scripts that process and Reprocess the Financial Batch Files

1.2. Post Foreign Currency Transactions as Local

If the linked accounting package that you are linked to only accommodates local currency or you
only use local currency Journals then ‘check’ this checkbox.  All generated Ostendo Journals will
be exported in local currency although Foreign Currency Invoices, Deposits and Payments (along
with their Exchange Rates) will still be processed in Ostendo.

1.3. Post Daily Summaries.

Although Ostendo creates and retains detailed Financial transactions you have the option to have
Daily (Summary) Journals sent to the Ostendo-Accounting Link routine.  The daily summaries can
be selected for the following:

· Applying Deposits
· Applying Payments
· Assembly Issues
· Assembly Receipts
· Assembly WIP Variances
· Customer Deposits
· Customer Payments
· Inventory
· Job Order Issues
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· Job WIP Variances
· Purchase Receipts
· Purchase Price Variances
· Sales Invoice Costs
· Sales Invoice Revenue
· Sales Order Issues

2.  Setting Up Currency Codes

Go into File>Financial Configuration>Currency Codes and create the foreign currencies.  Note:
It is not necessary to create one for your home currency.

For each Currency click on the ‘Detail’ tab and identify the Cost Centres to be used to cover:
· Foreign Purchase Receipts
· Foreign Debtors Control
· Foreign Debtors Exchange
· Foreign Unapplied Payments
· Foreign Unapplied Deposits
· Foreign Discounts Given
· Foreign Payment Rounding
· Exchange Gain or Loss 

If you need to create or maintain Cost Centres then go into General>Cost Centres

Exchange Rates: The final setup step is to identify the Exchange Rate.  In the Currency Codes
screen you will see a tab called ‘Rates’.  In that screen you can identify the Fixed Term or Floating
Exchange Rate.  This Rate will be used to prefill exchange Rate fields where used.  Of course you
will be able to adjust it in the specific transaction if required.

3. Multi-Currency Purchasing

Define Foreign Currency Suppliers:  Go into Purchasing>Suppliers and Create a Supplier
record.   In the ‘Detail’ screen you will see (at the bottom of the right-hand column) a ‘Foreign
Currency’ checkbox.  ‘Check’ this and in the adjacent ‘Currency Code’ field select the Currency.
That’s all that is required.!!

Supplier Pricing:  Go into Pricing>Item Pricing and select (say) Item FC-7621 (Filing Cabinet –
6 Drawer).  Click on the ‘Buy Prices’ tab (half way down the screen) and enter details about the
purchase price from the above Supplier.  Enter the Unit Price (This will be in the Supplier’s
currency) and any quantity break pricing.

Create a Purchase Order:  Go into Purchasing>Purchase Orders and create a Purchase Order
against the Supplier you created above.  Initially the monetary amounts will display in local
currency until the Order is saved.  It is at this stage that Ostendo can determine the Supplier’s
currency and will populate the ‘Detail’ screen with the Currency and the current Exchange Rate.
You can amend the Exchange Rate if required.

Click on the ‘Lines’ tab and add (a) Item FC-7621.  You will see that it will pull through the above
Supplier Pricing price and currency.  Now add (b) an Item that does not have a Supplier Price. 
You will see that Ostendo derives the Local Currency Price and applies the Purchase Order
header Exchange Rate to arrive at a Buy Price in the Suppliers Currency

Purchase Receipts:  Go into Purchasing>Purchase Receipts  and create a Purchase Receipt
linked to the above Purchase order.  You will see that the receipt Lines are populated with the
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Purchase order Line prices in the Supplier’s currency.  You should enter the received quantity and
then return to the ‘Detail’ view.  Before updating the receipts check that the Exchange Rate in this
screen is correct and then click the ‘Post All Purchase receipt Entries’ button.

At this point you may wish to go to General>Reports>Financial Batch Report and select the
Journals posted ‘today’.  In that report you will see the journals generated for the Purchase receipt

Purchase Invoices:  Go into Purchasing>Purchase Invoices  and create a Purchase Invoice
and – in the ‘Lines’ tab – select the above Receipt.   You should enter the Invoiced quantities and
then return to the ‘Detail’ view.  Once again, before updating the receipts, check that the
Exchange Rate in this screen is correct and then click the ‘Post Purchase Invoice’ button.

As before go to General>Reports>Financial Batch Report and select the Journals posted ‘today’
.  In that report you will see the journals generated for the Purchase Invoice

Purchase Shipments:  Create another Purchase Order similar to the one you created above then
go into Purchasing>Purchase Shipments and create a Purchase Shipment linked to the
Supplier.   While still in the ‘Detail’ view click on the ‘Purchase Orders’ tab and select the PO that
you have just created.  At this point you can amend the Exchange Rate, if required.  The next step
is to record any additional Shipment Charges.  Therefore click on the ‘Shipment Charges’ tab and
select a Charge Code of (say) ‘Carriage’.  You should note that not only can you select the
Currency of the Shipment Charge but you can also amend the exchange Rate relating to that
currency.

If you now click on the ‘Lines’ tab at the top of the screen you will see that the Shipment Charges
are displayed in Local Currency using the entered Exchange Rate and the Purchase Order Lines
of the Shipment show both the Supplier Price and the local currency equivalent.  As this is,
effectively, a Receipt then you have the option to amend the Receipt Price.

Finally go back to the ‘Detail’ view and click the ‘Receive Purchases and Close Purchase
Shipment’ button

As before go to General>Reports>Financial Batch Report and select the Journals posted ‘today’
.  In that report you will see the journals generated for the Purchase Shipment.

4. Multi-Currency Sales

Payment Accounts: As you are going to receive payments in Ostendo you should first establish
the Payment Accounts.  Therefore go into File>Financial Configuration>Payment Accounts
and create Payment Accounts linked to their respective Currency Codes

Sell Prices by Currency: There are two steps required:

1. Go into Pricing>Settings>Price Levels and define a Price Level along with the currency that it
applies to.

2. Go into Pricing>Item Pricing and locate Item FC-7621.  If you click the ‘Add’ button a new line
will appear.   From the drop-down under field ‘Price Level’ select the Price Level that you have just
created.  In field ‘Price Calculation Method’ select ‘Fixed Price’ then enter the Sell Price in field ‘
Unit Price’.  You also have the option to specify up to 5 Quantity Break Prices in this currency.

Define Foreign Currency Customers:  Go into Sales>Customers and Create a Customer
record.   In the ‘Detail’ screen you will see (at the bottom of the right-hand column) a ‘Foreign
Currency’ checkbox.  ‘Check’ this and in the adjacent ‘Currency Code’ field select the Currency. 
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While you are still in the ‘Detail’ view click on the ‘Pricing and Invoicing’ tab.  From the
drop-down under ‘Price Level’ select the Price level you created above

Process a Sales Order:  Go into Sales>Sales Orders and create a Sales ‘Quote’ (Sales Style =
Counter) against the Customer you created above.  Ostendo will determine the Customer’s
currency and populate the ‘Detail’ screen with the Currency and the current Exchange Rate.  You
can amend the Exchange Rate if required.

Click on the ‘Lines’ tab and add (a) Item FC-7621.  You will see that it will pull through the above
Sell Price for the Price Level.  Now add (b) an Item that does not have a Sell Price within the above
Price level.  You will see that Ostendo derives the Local Currency Price and applies the Sales
Order header Exchange Rate to arrive at a Sell Price in the Customers Currency.

If you now print the Quote then it will print in the Customer’s currency.  Note: For users who are
using earlier versions of Ostendo (Prior to Update 63) you should replace your existing Quote
layout (SalesQuoteSheet.fr3) with the system-level report supplied with the Upgrade.

You should now convert the Quote into an Order and click on the ‘Print’ button to print the Order
acknowledgement.

The next step is to issue the Lines then click on the ‘Invoice’ button to generate the Invoice.
Within the generated Invoice you can amend the Exchange Rate if required before you ‘Print’ the
Invoice.  Once again you should replace the .fr3 report if you have upgraded from an earlier
version of Ostendo.

Receive a Deposit: Go into Sales>Customer Deposit and click the ‘Add’ button.  The first action
is to define the Payment Account into which the Deposit will be paid.  This will bring back the
Currency related to the Account and the current Exchange Rate (which can be amended as
required).  Select the Customer you created above and complete the rest of the Deposit screen. 
When using this screen there are two points to note:

1. You should always select the Payment Account first so that Ostendo knows the currency
being deposited. 
2. If the Payment Account is for a Foreign Currency then the Banking Method must be ‘
Directly to Account’

You will notice that you are not restricted to the Customer’s Currency but can receive a Deposit in
any other Currency in which case Currency Triangulation will be carried out

Receive and apply a Payment: Go into Sales>Customer Payments and click the ‘Add’ button.
As with Deposits, the first action is to define the Payment Account into which the Customer
Payment will be paid.  Select the Customer you created above and complete the rest of the
Payment screen.  Again, as with Deposits::

1. You should always select the Payment Account first so that Ostendo knows the currency
being deposited. 
2. If the Payment Account is for a Foreign Currency then the Banking Method must be ‘
Directly to Account’
3. You will notice that you are not restricted to the Customer’s Currency but can receive a
Deposit in any other Currency in which case Currency Triangulation will be carried out

If you now ‘Save’ the Payment and click on the ‘Apply to Invoices’ tab you will see that the
Invoices are displayed in the currency of the Payment using the exchange rate from that entered
in ‘Detail’ screen.  Apply the payment to Invoices as required.

5.  Multi-Currency Job Orders

All planned and actual activities in Job Orders are carried out in local currency.  You can however
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define the Invoicing Currency and exchange rate when you progress the Job Order.  This enables
you to generate an Invoice in the Customer’s Currency from actual values carried out in local
currency
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14 Importing Data into Ostendo

This describes how you can import data into Ostendo 

1.  Data Dictionary

Before you import data into Ostendo you need to first establish:
· What Table you are Importing into
· What fields are mandatory
· What are optional
· What data must be preset in Ostendo
· Etc

You can get this information by going into Ostendo and selecting General>Reports>Full Listing
of Tables.    Select and print out the Table(s) that you are importing.

2.  Spreadsheet

The data to be imported should be in a spreadsheet in either .csv or .xls format

You should note that not all fields in the Table extracted in 1 (above) are required in the
spreadsheet.  However you should note the following:

2.1. Mandatory fields

There are two types of Mandatory fields that must be in the spreadsheet and contain a value. 
These are: 

· The logical Primary Key of the table being imported (For example: The Item Code is the
Primary Key when Importing into the Item Master Table)

· Those fields in the Table Listing identified as ‘SYSTEM’ required

2.2. Predefined Values

If, in the Table Listing, a field has pre-set values in Ostendo (An Order Status for example) then, 
· If the field is selected for Import, it must have an entry whose value is one of those

displayed in Blue in the Table Listing.  
· If the field is not selected for import then Ostendo will give the field the DEFAULT value

shown in the Table Listing.  

2.3. Linked Table

If, in the Table Listing, a field is referenced to a ‘Linked’ Table then, if the field is selected for
Import, it must have an entry whose value already exists in the Linked Table.  For example, if you
are importing Customers and you include Price Level in the import then you should first establish
the Price Levels by going into Pricing>Settings>Price Levels and adding the required Price
Levels.  See 3.1. (Getting Distinct Values for ‘Linked Tables) below for help in determining these
entries

2.4. Boolean Fields

If the field is defined as ‘SMALLINT’ in the Table Listing and is included in the Spreadsheet then it
must be given a value of either ‘True’ or ‘False’

2.5. Double

If the field is defined as ‘DOUBLE’ in the Table Listing and is included in the Spreadsheet then it
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must be given a numeric value that can contain decimals.  This cannot be blank and you should
enter 0 if it does not have a value.  If this field is not included in the spreadsheet the import
process will assume zero

2.6. Integer

If the field is defined as ‘INTEGER’ in the Table Listing and is included in the Spreadsheet then it
must be given a numeric value that is a whole number only (I.e. No decimals).  This cannot be
blank and you should enter 0 if it does not have a value.  If this field is not included in the
spreadsheet the import process will assume zero

2.7. Date

If the field is defined as ‘DATE’ in the Table Listing and is included in the Spreadsheet then it can
be left blank or given a date that is in the same format as the Regional Settings on your PC.  If it is
left blank then it is treated as a ‘null’ field which is displayed as 31st December 1899

2.8. Blob

If the field is defined as ‘BLOB’ in the Table Listing it means that any number of alphanumeric
characters can be entered.  If this field is included in the Spreadsheet then no checks are made
and it may be left blank

2.9. VarChar

If the field is defined as ‘VARCHAR’ in the Table Listing it means that any alphanumeric character
can be entered.  If this field is included in the Spreadsheet then no checks are made and it may be
left blank

2.10. Timestamp

Treat this field the same as a DATE field

2.11. Time

If the field is defined as ‘TIME’ in the Table Listing and is included in the Spreadsheet then it can
be left blank or given a time to the format HH:MM:SS

3.  Importing

To prepare for importing you should first create and save a spreadsheet with the Mandatory and
Optional fields populated as described above.  

The major files (Customers, Suppliers, Items, etc) can contain many thousands of records.  It can
be a huge task to find unique values against ‘Linked Table’ fields.  As these must already exist in
Ostendo before importing the Main data we have provided a process that uses a Script to get this
information.  This is described in the next paragraph

3.1. Getting Distinct Values for ‘Linked Tables

Step 1. Loading the Script

Go into File>Custom Scripts and load the script shown at the end of this section

Step 2. Running the Script
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When you run the script you should point the script to the .xls or .csv file being imported then click
the ‘Open’ button.  You should then enter the Column Number (assuming the first column in the
spreadsheet is 1) of the column containing the ‘Table’ Value and then click the ‘Answer’ Button.  A
file DistinctValues.txt will be generated and the Script will place this directly under your ‘C’ drive
(C:\DistinctValues.txt).   It will also be displayed back to your screen where you can print out the
document, if required.

Please Note that if the import spreadsheet contained Column Headings then the Column Heading
itself will be a Distinct Value and should either be deleted or be ignored.

Step 3. Importing the Distinct Values

You can either key the values directly into Ostendo or Import them using the Import routine
described in 3.2.  If you are taking this latter option you need to re-configure the DistinctValues.txt
as follows:

Go into Microsoft Excel and open the DistinctValues.txt file (you may have to view ‘All File Types’
to see this file).  Upon selecting the file, Excel will automatically bring forward a ‘Text Import
Wizard’ and allows you to populate the spreadsheet with the Text File data.

Within Ostendo ‘Table Lookup’ entries have - as a minimum - a Key Field and a Description and
both are mandatory.  Therefore - in the generated Excel file - you should either enter a meaningful
description in the column adjacent to the DistinctValue or copy the whole column and paste into a
new column thus making the Description the same as the Key Value.

‘Save’ the spreadsheet as either a .csv or .xls file

You can then import from this file as described in the next section

Having repeated this for all ‘Table Lookup’ fields you can Import the main file using the process
described in 3.2.

3.2.  Importing into Ostendo

Go to File>Data Importing and go through the following steps

Step 1: Click on the Radio Button to select the format of your spreadsheet then click the ‘Next’
button.   You can also click on the ‘Load Specification’ button to reload a previously saved
specification (saved in Step 7)

Step 2: Select the Table into which the data is being imported and click the ‘Next’ button

Step 3: Point to the location of the spreadsheet and then amend the following if your spreadsheet
contains column headings.  You should set the following field values to exclude this row from the
import:

Start at Row - Enter 2 because row 1 contains the column headings
This Row contains Field Names - Enter 1
Click the ‘Next’ button.  

Step 4: You should now match the fields in your .xls or .csv file with the equivalent fields required
in Ostendo.  (Note: You do not need to match the SysUniqueID because Ostendo will allocate this
when the record is created).  Once each field has been mapped click the ‘Next’ button.  

Step 5: If the Spreadsheet being imported used Regional Settings that are not the same as your
PC’s Regional Settings then this panel allows you to redefine the format of the fields being
imported.  Click the ‘Next’ button when done.  
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Step 6: You can now tell the Import routine what you want it to do with the data relative to existing
information in Ostendo.  I.e.:

· Append - Add all records even if they currently exist in Ostendo
· Update - Update existing Ostendo records where there is a matching key.  You will be

required to identify the unique key field identity from the drop-down list
· Append/Update - Add the record if it doesn’t exist and update the record where there is

a matching key.  You will be required to identify the unique key field identity from the
drop-down list.

· Delete - Delete existing records where there is a matching key.  You will be required to
identify the unique key field identity from the drop-down list

· Copy - Delete all existing records in Ostendo and recreate from the import file.
· Append New - Add a new record where the record in the Import file does not currently

exist in Ostendo.  You will be required to identify the unique key field identity from the
drop-down list

It is strongly recommended that you use the Append/Update option

Click the ‘Next’ button.  

Step 7: This screen confirms your settings.  You can at this point click the ‘Save Specification’
button to save the mappings, etc should you wish to re-import at a later time.

Ensure that all the settings are correct and then click on the ‘Execute’ button to import the records.

4.  Points to Note

You should note the following points that could affect the Import

4.1. Duplicate Records

Ostendo is case ‘insensitive’.  This means that (for example) Customer Name ‘Meat Co Ltd’ and ‘
MEAT Co Ltd’ are - according to Ostendo - the same.  If you get a ‘Duplicate’ error then the
problem is most likely to be that both versions of the Customer Name are in the Spreadsheet.

4.2. Special Characters

Ostendo makes extensive use of SQL and SQL uses special characters to denote End of Field,
End of record, etc.  This means that ‘key’ fields in the file being imported must NOT contain these
special characters.  

, - Comma
; - Semi Colon
‘ - Apostrophe
“ - Quotation marks

You should review the key fields in your spreadsheet and remove these characters

++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

// Table Distinct Value Script
var
  OpenDlg: TOpenDialog;
  x,ColumnNumber: Integer;
  ImportFile: String;
  OutputList: TStringlist;
  TempList: TStringList;

function GetImportFile: string;
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var
  OpenDlg: TOpenDialog;
begin
  OpenDlg := TOpenDialog.Create(Nil);
  try
    OpenDlg.InitialDir := 'C:\';
    OpenDlg.Filter := 'Excel Files (*.csv)|*.csv|All Files (*.*)|*.*';
    if OpenDlg.Execute then
      Result := OpenDlg.filename
    else
      Result := '';
  finally
   OpenDlg.Free;
  end;
end;

{Main Code Section}
begin
  OutputList := TStringList.Create;
  TempList := TStringList.create;
  ImportFile := GetImportFile;
  if trim(ImportFile) = '' then exit;
  try
    ColumnNumber := AskQuestion('Column Number','INTEGER','Please enter the Column
Number','');
    TempList.LoadFromFile(ImportFile);
    for x := 0 to TempList.Count - 1 do
     begin
      if OutputList.IndexOf(trim(ParseString(TempList.Strings[x],',',(ColumnNumber - 1)))) < 0 then
       begin
        OutputList.Add(trim(ParseString(TempList.Strings[x],',',(ColumnNumber - 1))));
       end;
     end;
    OutputList.SaveToFile('c:\DistinctValues.txt');
    run('c:\DistinctValues.txt');
  finally
    TempList.free;
    OutputList.free;
  end;
end.
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15 Inquiry Views and Drill-Downs

Within Ostendo not only can you create your own Inquiry screens but you can also create Go-To
links from the current Inquiry screen to related Ostendo Screens and/or other Inquiry Views.  Each
Inquiry View can also display multiple 'tabs' for drill-downs.  This whole scenario allows for the
following options

· Single Level Inquiry
· Single Level Inquiry with Go-To options
· Parent/Child Inquiry
· Parent/Child Inquiry with Go-To options
· One-to-Many Inquiry
· One-to-Many Inquiry with Go-To options

We will use the Demo Database to see how each of these scenarios work

Single Level Inquiry

Let us create an Inquiry that looks at all Sales Orders.

Go into File>Reporting Configuration>Report and View Developer and click the 'Add' button to
take you to the 'New Data Output' panel.  In that screen enter the following

Select the 'Inquiry' Radio Button
Name: Inquiry - All Sales Orders
Click the 'Create' button

In the presented 'Master Settings' screen enter the following

Include in Main Menu: 'Checked'
Name: Inquiry - All Sales Orders
Menu Order: Leave Blank
Category: Select 'Sales' from the drop-down
Title: Sales Order Inquiry

In the Master Query #0 area copy and paste the following

select ORDERNUMBER as "Order_Number", ORDERSTATUS as "Status", ORDERDATE
as "Order_Date",
REQUIREDDATE as "Req_Date", ORDERTYPE as "Order_Type", CUSTOMER as
"Customer",  BILLINGCUSTOMER as "Billing_Customer", WORKFLOWSTATUS as
"Tracking_Code",
SALESPERSON as "Salesperson", PURCHASEREFERENCE as "Purchase_Order",
ORIGINALORDERAMOUNT as "Order_Value",
INVOICEDNETTAMOUNT as "Invoiced_Value",  ORDERNOTES as "Notes",
sysuniqueid
from SALESHEADER
where orderstatus <> 'Lost' and orderstatus <> 'Quote'
order by 3,1

'Save' the entry.

To see the result you can either click on the 'Preview' button or go to Sales>Inquiries where you
will see Inquiry - All Sales Orders.   If you select a line in the 'List' tab and go to the 'Detail' tab
you will see the data in 'Card' format
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Single Level Inquiry with Go-To options

You can extend the above Inquiry screen to have a 'Go To' option to link to Ostendo's main
Customer screen.

Go into File>Reporting Configuration>Inquiry Drill-Down and ensure that you are on the '
Screens' tab.  Add the following record.

Inquiry: Inquiry - All Sales Orders.   This refers to the screen that has the Go-To
Module: Sales.  This refers to Ostendo's Main menu where the screen can be found
Screen: Customers.   This refers to the actual 'Go-To' screen name
Linked To: Header.   Links to the Sales Order Header
Screen Field: Customer.   The Name of the 'linked' field in the SO Header
Tab Index: 1.   Open up on the Customer's 'Detail' tab
Inquiry Field: Customer.   The Name of the 'linked' field in the Master Query #0

'Save' the record

If you now go to Sales>Inquiries>Inquiry - All Sales Orders and 'Right Mouse' anywhere in the
middle of the display you will see an option called 'Go To'.   Select that and you will see that
'Customers' now appears in the list.  If you select this you will be taken to the Customer Master
screen

Let us now create Inquiry View and add this as a 'Go-To' to the Inquiry - All Sales Orders view.
This exercise will inquire on all the Contacts linked to the Customer.  Therefore create another
Inquiry as described above with the following info

Go into File>Reporting Configuration>Report and View Developer and click the 'Add' button to
take you to the 'New Data Output' panel.  In that screen enter the following

Select the 'Inquiry' Radio Button
Name: Inquiry - Customer Contacts
Click the 'Create' button

In the presented 'Master Settings' screen enter the following

Include in Main Menu: 'Checked'
Name: Inquiry - Customer Contacts
Menu Order: Leave Blank
Category: Select 'Sales' from the drop-down
Title: Customer Contacts

In the Master Query #0 area copy and paste the following

select CompanyLinkedTo as "Company",
ContactName as "Contact",
ContactPhone as "Phone_Number",
sysuniqueid
from Contactmaster where ContactType = 'Customer'
order by 1

Go into File>Reporting Configuration>Inquiry Drill-Down and add ensure that you are on the
To Inquiry tab.  Add the following record.

Inquiry From: Inquiry - All Sales Orders.   Refers to the screen that has the Go-To
From Field: Customer.   The Name of the 'linked' field in Inquiry - All Sales Orders
Linked To: Header.   This is 'linked to' the Sales Order Header
Inquiry To: Inquiry - Customer Contacts.   The Go-To Inquiry



51Inquiry Views and Drill-Downs

To Field: COMPANYLINKEDTO.   The 'linked' field in the Go-To Inquiry

'Save' the record

If you now go to Sales>Inquiries>Inquiry - All Sales Orders and 'Right Mouse' anywhere in the
middle of the display you will see an option called 'Go To'.   Select this and you will see the new
'Inquiry - Customer Contacts' .  If you select this you will be taken to the Inquiry screen where it
will show all contacts for the specific Order Customer.

Parent/Child Inquiry

The previous Inquiry Screen shows All Sales Orders.  What we are going to do here is add Sales
Order Lines to that Inquiry.

Recall Inquiry - All Sales Orders in Report and View Developer and click on the 'Detail Queries'
tab.    Under 'Query #1' copy and Paste the following:

select LINENUMBER as "LineNo", CODETYPE as "Line_Type", LINECODE as "Code",
LINEDESCRIPTION as "Description", 
LINEUNIT as "Unit", ORDERQTY as "Order_Qty", REMAININGQTY as "Remaing_Qty",
ORDERUNITPRICE as "Unit_Price", 
REQUIREDDATE as "Required_Date", LINESTATUS as "Line_Status", 
sysuniqueid
from SALESLINES
where ORDERNUMBER = :Order_Number
order by 1,2,3

'Save' the record

If you now go to Sales>Inquiries>Inquiry - All Sales Orders you will see an additional 'Lines' tab.
If you click on this it shows the selected header record and details of all included Order Lines

Parent/Child Inquiry with Go-To options

Using the 'Drill-Down' function we can now relate 'Go-To' options to Order Lines in the Inquiry.  In
this exercise we will drill down to show the Order Line's Properties.

Firstly, create the Inquiry View called (say) Inquiry - Order Line Properties.  In the Master Query
#0 area copy and paste the following

select propertyname as "Property_Name", propertyvalue as "Property_Value" ,
sysuniqueid from SALESLINEPROPERTIES

 
The next step is to go into File>Reporting Configuration>Inquiry Drill-Down and create the link.
Ensure that you are on the 'To Inquiry' tab and add the following record.

Inquiry From: Inquiry - All Sales Orders.   Refers to the screen that has the Go-To
From Field: SysuniqueID.   The Name of the 'linked' field in the Sales Order Line
Linked To: Lines 1.   The 'linked' to in the 'parent' Inquiry Line
Inquiry To: Inquiry - Order Line Properties.   The Go-To Inquiry
To Field: HeaderSysUniqueID.   The 'linked' field in the Order Lines Property record

'Save' the entry.

To see the result go to Sales>Inquiries where you will see Inquiry - All Sales Orders.   If you
select a line in the 'List' tab and go to the 'Lines' tab you can 'Right Mouse' anywhere in the middle
of the display to display the 'Go To'.   If you select this you will see the new 'Inquiry - Order Line
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Properties' .  If you select this you will be taken to the Inquiry screen where it will show all
Properties for the specific Order Line.

One-to-Many Inquiry

The above Parent/Child Inquiry shows All Sales Orders and their Sales Lines.  What we are going
to do here is include additional related and non-related 'tabs' to the main Inquiry.
Tab 1.  

The 'Lines' tab which, in the previous examples, appears at the top of the screen will now be
presented as Tab 1 in the One-to-Many view.  You will see this once we have added a second tab.

Tab 2.  

In this example we will link the History applicable to this Sales Order.  You should note that this
query uses 'select * from SalesHistory'.   Although you can use this type of query it is
recommended that you specify the individual fields that you wish to output (plus SysUniqueID) as
this allows you to personalise the Column Heading in addition to not pulling in the
system-information fields

Recall Inquiry - All Sales Orders in Report and View Developer and click on the 'Detail Queries'
tab.    Under 'Query #2' copy and Paste the following:

select * from SalesHistory where BillCustomer = :Customer

At the bottom of the 'Detail Queries' screen you will see two areas in which you should add the tab
names.  In our exercise they will be 'Lines' and 'History'

'Save' the record

If you now go to Sales>Inquiries>Inquiry - All Sales Orders you will see that the lower part of the
screen contains the tabs.   If you click on these you can drill down to view the information.

While you are in this view try the following

Click on the 'Band' across the centre of the screen and drag it up and down.   You will see that the
'Parent' record details will wrap around

Tab 3

In the next example we will create a tab that is independent of the parent - Sales Order - record. 
This will show the Analysis Groups table.   Therefore recall Inquiry - All Sales Orders in Report
and View Developer and click on the 'Detail Queries' tab.    Under 'Query #3' copy and Paste the
following:

select * from AnalysisGroups

At the bottom of the 'Detail Queries' screen add 'Analysis Groups' to the third tab area.  You
should now have tabs 'Lines', 'History'  and 'Analysis Groups'

'Save' the record

If you now go to Sales>Inquiries>Inquiry - All Sales Orders you will see that the lower part of the
screen contains the tabs.   If you click on these you can drill down to view the information.

One-To-Many Inquiry with Go-To options
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Using the 'Drill-Down' screen we can now relate 'Go-To' options to tabs.

In this exercise we will drill-down on the 'History' tab to select a specific Invoice.

Go into File>Reporting Configuration>Inquiry Drill-Down and ensure that you are on the '
Screens' tab.  Add the following record.

Inquiry: Inquiry - All Sales Orders.   This refers to the screen that has the Go-To
Module: Sales.  This refers to Ostendo's Main menu where the screen can be found
Screen: Batch Invoicing.   This refers to the actual 'Go-To' screen name
Linked To: Lines 2.  The link is to the 2nd Query 'Query #2'
Screen Field: InvoiceNumber.   Name of the 'linked' field in the Invoice
Tab Index: 1.   Open up on the linked Invoice 'Detail' tab
Inquiry Field: InvoiceNumber.   The Name of the 'linked' field in the Inquiry

'Save' the record

If you now go to Sales>Inquiries>Inquiry - All Sales Orders and click on the 'History' tab.  In this
tab 'Right Mouse' anywhere in the middle of the display you will see an option called 'Go To' which
has the 'Invoices' in the list.  If you select this you will be taken to the Invoice 'Detail' screen for the
Invoice related to this History record.
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16 Invoices in Ostendo

1.  Introduction

This tutorial describes the various options available in Ostendo for Invoices 

· Invoice Formats
· Standard Invoice Format
· Jobs ‘Scheduled’ Invoice Format

· Invoices
· Job Orders
· Sales Orders
· POS
· Contract (Recurring)
· Direct
· Consolidated - Jobs, Sales and Contract (Recurring)

· Job Order - Invoice Approvals

2.  Invoice Formats

There are two formats for Invoices.

2.1.  Standard Invoice Format.

The ‘Standard’ format applies to Invoices generated from Sales Orders, Job Orders (‘Actual
Quantity’ Style), Direct Invoices, and Recurring Invoices.  It prints details of all Lines.   To view this
format go into Sales>Direct Invoicing, click the ‘Add’ button and select Customer ‘Jim Gold &
Co Ltd’.  Click on the ‘Lines’ tab and add (say) 2 Item Code Lines, and 2 Descriptor Code Lines.
Now click the ‘Print’ button and print the Invoice back to your screen in ‘Preview’ Mode.

Within the Standard Invoice Format there are 3 ways in which the Lines can be presented.
· Print each Line within a Group
· Print a Group Header and Footer in addition to lines within the Group
· Print a Group Footer summary record with no Line Details

The first option you have already done above.  To see the other two in action you should first go to 
General>Settings>Analysis Groups and create (say) the following Groups with the associated
settings in the ‘Invoice Form Grouping’ field.

Material Header and Footer
Descriptors Group Totals Only

Going back to the Direct Invoice you created above you will see, in the Lines screen, a field called ‘
Analysis Group’.  For each of the records link them to the appropriate Analysis Group Code

If you now re-print the Invoice you can see the effect created by each option.

Note: The main Item and Descriptor records contain field ‘Analysis Group’.  This allows you to
pre-allocate the Analysis Group, which is automatically copied to the Invoice..

2.2.  Jobs ‘Scheduled’ Invoice Format

Because a ‘From Schedule’ style Job Order uses an agreed Invoicing schedule the Invoice print
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will contain details as defined against each Planned Invoice.  Let us first create a Job by going into 
Jobs>Job Orders and creating a Job using a Job Type of ‘Progress’

On the ‘Detail’ screen of the created Job click on the ‘This is a fixed Price Job’ checkbox and
enter (say) 1000 in the adjacent field ‘Nett Value’.   The next step is to create the Invoicing
Schedule, so click on the ‘Invoices’ button to the right of the screen (or go to Jobs>Job Invoices
).  In that screen you can generate planned Invoices up to the amount of the total Job Value. 
Therefore click the ‘Add’ button to create a Planned Invoice.  In the generated record amend the ‘
Plan%’ to (say) 10 and under ‘Code’ select ‘Progress Claim’.  ‘Save’ the record.  Create a
second ‘Planned’ Invoice for a further 40% with the same ‘Code’.  Finally create a third Planned
Invoice for the balance.  Each Planned Invoice can be configured to show one of the following
options

· Print the linked Descriptor and notes only
· Print the Linked Descriptor and notes with additional descriptive lines 
· Don’t print the Linked Descriptor but print additional priced descriptive line

We will go through each of these to show how they work.

Option 1.  Highlight the first (10%) scheduled Invoice then click on the ‘Invoice Line’ tab in the
centre of the screen.  You will see that the first Radio Button is ‘checked’ (this is the default).   You
can add extra info that is applicable to this Planned Invoice if required.  Now click on the ‘
Schedule’ tab and click the ‘Create Pending Invoice’ button to generate an Invoice Number…this
will populate the ‘Invoice No’ field.  Finally click on the ‘Print Selected Invoice’ button to see what
it looks like.

Option 2.  Highlight the second (40%) scheduled Invoice then click on the ‘Invoice Line’ tab.  ‘
Check’ the second Radio Button.  With this option you can print the Descriptor along with any
additional Information Lines you may wish to add.   Click on the ‘Lines for printing Only’ tab and
add the following information

Line   Code        Description Unit Qty
10 General Time General Chargeable Time Hours 6
20 Freight Delivery of Goods $ 25.00

Add any notes against each line as required.

Now click on the ‘Schedule’ tab and click the ‘Create Pending Invoice’ button to generate an
Invoice Number…this will populate the ‘Invoice No’ field.  Finally click on the ‘Print Selected
Invoice’ button to see what it looks like.

Option 3.  Highlight the third (50%) scheduled Invoice then click on the ‘Invoice Line’ tab.  ‘Check
’ the third Radio Button.  With this option you don’t print the Descriptor but you do print lines with
user-defined Line Values.  Click on the ‘Lines for printing Only’ tab and add the following
information

Line   Code     Description Unit Unit Price Qty
10      Labour Hours claimed Hours     25.008
20      Material Materials Used $   250.00 1
30      Miscellaneous Other Charges $     50.001

You will notice that an ongoing check is made against the total Planned Invoice value

Now click on the ‘Schedule’ tab and click the ‘Create Pending Invoice’ button to generate an
Invoice Number…this will populate the ‘Invoice No’ field.  Finally click on the ‘Print Selected
Invoice’ button to see what it looks like.
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3.  Invoices

3.1.  Job Invoices

To create an Invoice then the Job must have either
(a) A Invoicing Schedule if it is a ‘Scheduled’ style Job, or
(b) An issue made against it if it is an ‘Actual Issues’ style Job

Invoices can either be produced from within the Job Order itself, via the Job Invoicing screen, or
via a Batch Invoicing routine

3.1.1.  From within the Job Order

Go into Jobs>Job Orders and highlight the Job to be invoiced (or go into the ‘Detail’ view of the
Job) then click on the ‘Invoices’ button down the right of the screen.  The Job Invoices panel will
appear:

· If it is a ‘Scheduled’ style Job then select the specific scheduled Invoice and click the ‘
Create Pending Invoice’ button.

· If it is an ‘Actual Issues’ style Job then simply click the ‘Create Pending Invoice’ button.  If
this is ‘greyed out’ then there is nothing to Invoice

You can then print the Invoice by clicking on the ‘Print Selected Invoice’ button.  

3.1.2.  Using the Job Invoices screen

Go into Jobs>Job Invoices and highlight the Job to be invoiced then click on the ‘Detail’ tab.  The
screen that you used in 3.1.1. (above) will appear and you can process the Invoice in the same
manner
 
3.1.3.  Using Batch Invoicing

Go into Sales>Batch Invoicing and click the ‘Add’ button to create a new batch.    ‘Check’ the ‘
Include Job Orders’ checkbox and select the Job Order Number in both the ‘From Order No’
and ‘To Order No’ fields.  Click the ‘Create’ button to generate the Invoice.
Note: For Scheduled Invoice Style Jobs this routine will pick up the schedule(s) that are due within
the dates entered at the top of the Batch Creation screen

3.2.  Sales Orders

The Sales Order Invoicing process will only Invoice those Lines and quantities that have been ‘
Picked’.  The Picking is done in either the Sales Order itself (for Counter Sale Style Orders) or in
the Delivery process (for Delivery Style orders).

To demonstrate the Invoicing process you should first create a Sales Order by going into 
Sales>Sales Orders and creating a ‘Counter Sale’ order.  Go to the ‘Lines’ tab and add a couple
of Items to the Order.   Now click on the ‘Picking’ button on the Batch Entry bar and issue the
lines.  You are now ready to create the Invoice.

Invoices can either be produced from within the Sales Order itself or via a Batch Invoicing routine

3.2.1.  From within the Sales Order

If you are not already in the Sales Order screen then go to Sales>Sales Orders and highlight the
Sales Order to be invoiced (or go into the ‘Detail’ view of the Sales Order) then click on the ‘
Invoices’ button down the right of the screen.  The Job Invoices panel will appear:

· If it is a ‘Scheduled’ style Job then select the specific scheduled Invoice and click the ‘
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Create Pending Invoice’ button.
· If it is an ‘Actual Issues’ style Job then simply click the ‘Create Pending Invoice’ button.  If

this is ‘greyed out’ then there is nothing to Invoice

You can then print the Invoice by clicking on the ‘Print Selected Invoice’ button. 

3.2.2.  Using Batch Invoicing

Go into Sales>Batch Invoicing and click the ‘Add’ button to create a new batch.    ‘Check’ the ‘
Include Sales Deliveries’ and/or ‘Include Sales Order (Counter Style)‘ checkbox(s) and select
the specific Delivery or Sales Order Number.  Click the ‘Create’ button to generate the Invoice.

3.3.  POS

The Point Of Sale function has its own specific Invoice Layout.  In the base Ostendo this layout is
called ‘POS Invoice’ and is selected against the POS Workstation record (POS>Settings>POS
Stations).  The format can be amended using the Report and View Developer.  Refer to the
detailed tutorials on POS regarding how to set up POS and how to create a POS Order.   Having
created the Order and issued the goods you can click on the 
‘Pay’ button (or F12 key) to bring up a payment entry panel.

A ‘Payment Receipt’ is printed if the Payment Style was ‘Cash Sale’
An Invoice is printed if the if the Payment Style was ‘On Account’

3.4.  Contract (or Recurring) Invoice

A Recurring Invoice defines an agreed schedule of Invoices for activities being carried out.  This
simply creates the Invoice without the need to book time or materials against the activity.

To create a Recurring Invoice schedule go into Sales>Recurring Invoices and click on the ‘Add’
button.  On the presented screen you can create a schedule of planned Invoices as follows:

· Select a Customer from the drop-down list against field ‘Customer’ then
· Select ‘Contract Style’ of ‘Fixed Term’
· In the ‘Invoice Line Details’ section down the left of this screen define:

- Frequency of the Recurring Invoicing - Enter Every 1 Frequency Month
- Number of Time - Enter (say) 6
- The Start Date - Leave as system date
- The nominal amount per Invoice - Enter (say) $100

· In the ‘Invoice Line Details’ section down the right of this screen select ‘
MONTHLYCHARGE’ from the drop-down under ‘Code’

· Click the ‘Create’ Button to generate the Planned Invoice schedule.  

You can view the generated Invoice by going to the ‘Scheduled Invoices’ tab

If you go to the ‘Detail’ tab you can enter additional information that will appear on each generated
Invoice.  Having created the schedule we will now create an Invoice from this schedule.

Go into Sales>Batch Invoicing and click the ‘Add’ button to create a new batch.    ‘Check’ the ‘
Include Recurring Invoices‘ checkbox(s) and select the Contract that you have just created.
Click the ‘Create’ button to generate the Invoice.

3.5.  Direct Invoicing
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There are instances where you may wish to create an Invoice with no prior Sales Order.  To do
this, go into Sales>Direct Invoicing and click on the ‘Add’ button.  On the displayed panel ‘check’
the ‘Create an Invoice or Credit without an Order’ radio button and select a Customer from the
drop-down against field ‘Billing Customer’ then click the ‘Create’ button.  Enter the Invoice
Header and Line details as required and then click the print ‘Print’ button to print the Invoice.   

You should note that this process also gives you the option - in the ‘Detail’ tab - to receive
payments and match to this Invoice

3.6.  Consolidated Invoices

Up to now you have created a single Invoice in response to Issuing Goods or carrying out activities
to a Job or Sales order.  A Consolidated Invoice, on the other hand, creates a single Invoice
covering issues and activities over a period of time.

There are two levels of Invoice Consolidation:
Consolidate by Order - During Invoice generation all lines due to be Invoiced from a
single Order will be included in the Consolidated Invoice.
Consolidate by Customer - During Invoice generation all lines across all Orders due to
be Invoiced for a Customer will be included in a single consolidated Invoice.

To set the option - by Customer - go into Sales>Customers and, in the ‘Detail’ screen click on
the ‘Pricing and Invoicing’ tab and select which option you are going to try from the drop-down
under ‘Invoice Consolidation’

The next step is to create the Invoiceable entries.  Using the methods described in:

3.1. Create a Job Order (Schedule style) and create a Planned Invoicing schedule.
3.2. Create a Job Order (Actual Issues Style) and issue materials and descriptors
3.3. Create a Sales Order (Counter Sale Style) and issue materials and descriptors
3.4. Create a Sales Order (Delivery Style) and issue materials and descriptors
3.5. Create a Contract with an Invoicing schedule.

In all the above cases do NOT generate the Invoice. 

Now go into Sales>Batch Invoicing and click the ‘Add’ button to create a new batch.    ‘Check’
the ‘Include Sales Deliveries’ and/or ‘Include Sales Orders (Counter Style)‘ and/or ‘Include
Recurring Invoices and/or ‘Include Job Orders‘ checkbox(s).  Enter a date range in the top of
the screen to include any Contract or Job Order Invoice Schedules.  Click the ‘Create’ button to
generate the Invoice.

The generated Invoice will create a ‘Source’ for each Order included in this Invoice.  If you click on
the ‘Lines’ tab you will see the content within each ‘Source’.  If you now print the Invoice you will
see the individual Source/Lines printed on the single Invoice

4.  Invoice Approvals

Option is provided - for Job Orders only - to force approvals against all lines scheduled for
Invoicing before they can be converted into a physical Invoice.  To do this, go into 
Jobs>Settings>Job Rules and ‘check’ the ‘Invoice Approvals’ checkbox.  Only those Users
given the authority to ‘approve’ can carry out the approvals activity.  Therefore go into
File>System Configuration>User Security and Options and click on the ‘User Options’ tab.  In
that screen ensure that the ‘Allow Approvals’ checkbox is ‘checked’.
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17 Item Variants

This tutorial describes the variants that can exist within an Item Code and how these are tracked
through Ostendo

1.2.  Item Creation

Go into Inventory>Items and click on the ‘Add’ button then enter details to create your Item.   The
mandatory fields are the Item Code, Unit of Measure, and Description.  Click the ‘Save’ button
when done.  Now let’s have a look at some of the options surrounding Items.

1.2.1.  Multiple Units of Measure

Ostendo allows you to define multiple Units of Measure against a single Item.  Stock of the Item is
segregated by UOM in addition to Sell Prices being associated with each UOM.  In this exercise
you will:

· Create an Item
· Link other Units of Measure (6-Pack, Dozen, Crate) to it
· Receive the Item in various Units of Measure
· View Stock that is segregated by Unit of Measure
· Split/Combine the current stock into other Units of Measure

Units of Measure are maintained via General>Settings>Standard Units.  Go into this screen and
add ‘Bottle’, ‘6-Pack’, ‘Dozen’, and ‘Crate’.  

Now let’s apply these to an Item.   Go to Inventory>Items and click on the ‘Add’ button.  Create a
new Item called (say) ‘Spring Water’.  Select UOM of ‘Bottle’ from the drop-down list against field
‘Unit’.  Enter a description (Example: ‘Simply Spring Water’).  Enter a ‘Std Sell Price’ of (say)
$1.50.   Click the ‘Save’ button to save the Item.

To add other Units of Measure to this Item you should click on the ‘Related’ Button found to the
right of the screen and select ‘Item Units’ from the displayed list.  You will see that the Base Unit (‘
Bottle’) is already in this screen with a conversion factor of 1 and a Price Discount of 0.  These
cannot be amended.

Add a Unit of ‘6-Pack’ with a Conversion Factor of 6 (I.e. there are 6 Bottles per 6-Pack) and a Sell
Price Discount of 10% (I.e. the Sell Price of a 6-Pack is the sell Price of an single Bottle multiplied
by the Conversion Factor multiplied by (100% - Discount %)).   Repeat this for the other Units (‘
Dozen’, and ‘Crate’).

To see the effect of these Units close the screen then go into Inventory>Inventory Adjustments.
Add a new Batch and ‘Save’.  Go into the ‘Lines’ tab and create a new line.  Go to the Item Code
field and select ‘Spring Water’ from the drop-down list (Hint: you can type ‘S’ and the cursor will
immediately go to Items beginning with S).  Enter an Adjustment Type of ‘Receipt’ and quantity of
20 and click the ‘Save’ button.  Add another line for ‘Spring Water’ but this time click on the ‘Unit’

field and select another Unit of Measure.  Repeat for the 3rd Unit of Measure.  Finally go into the ‘
Detail’ tab and click on the ‘Post all Adjustments’ button.

Go into Inventory>Inventory Availability screen, select ‘Spring Water’ and then go to the ‘Detail
’ tab.  You will now see the current stock of ‘Spring Water’ in each Unit of Measure.  While you are
in this screen click on the ‘Transaction History’ and ‘Projected Availability’ tabs.  Close the
Inventory Availability screen.

If you wish to split or combine Units then go into Inventory>Inventory Unit Change and locate ‘
Spring Water’ then click the ‘Details’ tab.  Highlight the record that you wish to split/combine then
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click on the ‘Change Unit of Measure for selected record’ Button.  On the displayed panel enter
the quantity being changed and the Unit Of Measure to which it is being changed then click the ‘
Update’ button.  If you now go into Inventory>Inventory Availability screen you will see that the
Unit Of Measure changes are recorded in the ‘Transaction History’.

1.2.2.  Status

Ostendo has 4 statuses used by Items

Active - Is currently used throughout Ostendo
Planned - Can be Purchased only
Runout - Cannot be ordered but can be used until stock is zero
Obsolete - Cannot be ordered, Issued, or received

Change the Status of ‘Spring Water’ to ‘Planned’ then go into Sales>Sales Orders.  Select Sales
Order SO300013 and click on the ‘Lines’ tab.   Add this Item to the Sales Order line and try to ‘
Save’ the line.  You should get a message preventing you from adding this Item due to its ‘
Planned’ status.  Cancel the line to exit the Sales Order.

As this Item will be used in later exercises reset its Status to ‘Active’

1.2.3.  Default Supply Method

This defines whether the Item is normally supplied from stock or you should raise a supply order
for each demand.  The selection options are:

Supply From Stock - This means that issue to Sales Orders, Assembly Issues, Job
Orders will come from stock.  Items with this Supply Method will normally be maintained
using an Inventory Replenishment routine.
Source On Demand - This means that whenever a demand (Sales Order, Assembly
Issue, Job Order) is made then Ostendo will immediately create a matching ‘Suggested’
Supply Order (Assembly Order or Purchase order). 

Use of these methods is covered in more detail under exercises covering ‘Inventory Control’
Training Exercises.

1.2.4.  Source By

In combination with the Default Supply Method this field defines from where the Item is procured: 
The displayed options are:

Purchasing - This means that the Item will automatically be available to Purchasing
whenever a requirement arises.
Assembling - This means that the Item will automatically be available to the ‘Assembly’
process whenever a requirement arises 
Custom - This means that the Item will automatically using one of two methods.  These
are:

Use a configuration ‘script’ defined in the Assembly module of Ostendo
Use a pre-defined Bill of Material and amend during Order creation

The use of the Purchasing and Assembling options will be explained in more detail in the ‘
Inventory Control’ Training Exercises.   The use of the Custom option will be explained in more
detail in the ‘Assembly Orders’ Training Exercises.    

For now leave the ‘Source By’ set to ‘Purchasing’

1.2.5.  Manufacturers Info
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Many stockists, especially in the electronics industry, hold Manufacturers information against
Items.  This provides facility to enquire on Inventory by Manufacturer, Brand, or Model.  In our
exercise we will link ‘Spring Water’ to a Manufacturer and Brand.

To prepare for this you should go into:

· Inventory>Settings>Manufacturers and create the Manufacturer’s Names.  Create an
entry (say) ‘Waterworld’

· Inventory>Settings>Brands and create the Brand Names.  Create an entry (say)  ‘
Pacific Blue’

Go into Inventory>Items and select ‘Spring Water’ then click on the ‘Manufacturer’s Info’ tab
and link the Manufacturer and Brand that you have just created to this item

Now let’s view the Manufacturer and Brand on the Item ‘List’ view.   Go to the Item ‘List’ tab ‘right
mouse’ in the main panel and select ‘Customize List Fields’.  (If this option is not displayed then
you don't have the rights to customise the screen as held against the User record - see 
File>System Configuration>User Security and Options).  

On the displayed panel you can:
· Locate field MANUFACTURER from the list
· Enter ‘Manufacturer’ in ‘Display Label’
· Click on the ‘Show field’ checkbox against this line
· Repeat for Field BRANDNAME 
· Click the ‘Save’ Button when done.

You will now see that the selected fields are visible in the ‘List’ view.  ‘Check’ the ‘Filtering and
Sorting’ checkbox at the bottom-left of the screen.   Place your cursor to the column heading of ‘
Manufacturer’ and click on the black triangle.  You can now restrict the display to a single
Manufacturer.  Click the cross at the bottom-left to restore the view

1.2.6.  Sales Warranty

You can attach a Warranty Identity to an Item.  The Warranty is carried through to Sales and Job
Orders and becomes effective when the Item is picked

Go into Service>Warranty Definitions and view the Warranty Codes that are currently on file.
Add your own as required.

Go back to Inventory>Items for Item ‘Spring Water’ and click on the ‘Sales Warranty Applies’
checkbox.  From the drop-down list select the applicable Warranty.  Note: you can also maintain
Warranty Codes by clicking on the icon to the right of the drop-down icon.

Go into Sales>Sales Orders and select Sales Order SO300015.  On the Sales Order Lines add
Item Code ‘Spring Water’ and ‘Save’ the entry.  If you now click on the ‘Warranty’ tab you will see
that the Warranty Code has been copied from the Item record to the Sales Order Line.  

Whilst in the Sales Order Line screen click on the ‘Picked Lines’ tab, click on the ‘Add’ button and
enter a quantity of (say) 1.    Click the ‘Save’ button

Close the Sales Order screen then go into Service>Warranty List where you will see the
generated Warranty record.  You can, of course, amend the details as required.
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1.2.7.  Customer Assets

A Customer Asset can be physical Item or a general description of  (for example) a building or
collection to be regularly serviced.  The Asset can be created as the result of a Sale of an Item or
can be created directly in the Service Module.  Each Asset can have a Service Schedule attached
to it and, when the service is due, reminders sent to the Customer.  This short exercise covers the
creation of a Customer Asset as a result of the Sale of a product.  The full Servicing and
Maintenance routine is explained in detail in the ‘Service Orders’ Training exercises.

Go to Inventory>Items and select Item ‘AC-8026’.  In the Detail screen you will see that the field ‘
Create Customer Asset’ checkbox is ‘checked’.   An adjacent button (Customer Asset Options)
will now become active.  Clicking on this button will bring up a panel where you can define the
Asset Type and (optionally) identify a Service Schedule (Asset Types and Service Schedules are
user-maintained in the ‘Service Orders’ Training Exercises and will not be covered here).

You should note that Items to be converted into Customer Assets must be ‘Serial Controlled’.

Go into Sales>Sales Orders and select Sales Order SO300013.  Go to the Lines screen and add
a new line to cover quantity 1 of AC-8026.  Click on the ‘Picked Lines’ tab and ‘Add’ a new pick
line.  Place the cursor in the ‘Qty’ field  and do NOT enter a quantity.  You should, however, click
on the ‘spyglass’ icon to bring up a panel that shows the individual serial numbers in stock.  Enter
a quantity of 1 against a single Serial Number and ‘Save’ the entry.  Click the ‘OK’ button to exit

If you now go to Service>Customer Asset you will see that the picked Item has now been created
into an Asset against the Customer.  (The Asset Identity will comprise of the Item Number followed
by the Serial Number).  Click on ‘Details’ to view the originating Sales Order.  Click on ‘Planning
and History’ to view the generated service schedule.

1.2.8.  Add-On Sales

‘Add-On’ Sales uses a list of Items that you may also wish to promote during the Sales process
when selling a specific Item.  For example, If the Item was a tin of Paint then you may wish to
suggest the purchase of Paint Brushes, Brush Cleaner, etc.  These ‘Add-On’ Sales Items can have
their own Sell Price specifically used when sold along with the originating Sales Line.

In this exercise we will try and promote ‘Water Cooler’ whenever the Customer orders ‘Spring
Water’.  

Go to Inventory>Items and create Item ‘WATER COOLER’ and enter a sell price of $150.  ‘Save’
the record

Go to the ‘List’ screen and select ‘SPRING WATER’ then go to the Item ‘Detail’ screen.  ‘Check’
the ‘Add-On Sales Apply’ checkbox.  The adjacent ‘Item Add-On Sales’ button will become
active.  Click on this button to bring up the ‘Add-On Sale’ maintenance screen.

Click on ‘Add’ to add a new ‘Add-On Sale’ Item and select ‘WATER COOLER’ and enter the
following:

Default Qty: Enter 1
Special Pricing checkbox: ‘check’ this box
Special Price: enter special price of $125
Sales Explanation: enter (say) “The Water Cooler is currently on Special”

‘Save’ the entry and exit the screen



63Item Variants

Go into Sales>Sales Orders and select Sales Order SO300013.  Go to the Lines screen and add
a new line for ‘SPRING WATER’.  You will see that - on the Info Line across the centre of the
screen - a button (Add-On Sale Items) will appear.  Click on this button.
If the Customer accepts the offer then simply click the ‘Create Order Lines’ button.  You will see
that the ‘WATER COOLER’ will be added to the Order at the special price.

Note: In the above example we used a stock ‘Item’ to offer as an Add-On Sale.  This could easily
be - for example - an extended Warranty, etc

1.2.9.  Serial Numbered Items

When an Item is defined as Serial Number controlled Ostendo will ensure that each individual item
has its own unique Serial Number.  This Serial Number follows the Item through the full Stock
Control and Sales Cycle process.

Go to Inventory>Items and click on the ‘Add’ button.  Create a new Item called (say) ‘Camera’.
On the Item Detail panel ‘check’ the ‘Serial No’ checkbox.  Having defined this then:

· All receipts into stock for this Item must be given a unique Serial Number (Note: The same
Serial Number can exist against a different Item Number)

· All Issues must be made from current stock.  I.e. You are not allowed to issue a Serial
Numbered Item that you don’t have in stock!!!

A Receipt Transaction: One method of receiving stock is to go to Inventory>Inventory
Adjustments and create a new Adjustment Batch.  Go into the Batch Line screen and add ‘
Camera’ with an ‘Adjustment Type’ of ‘Receipt’ and a quantity of 1.  If you try to ‘Save’ the
receipt then it will be rejected because a Serial Number is required.   Enter a Serial Number in the
line then click the ‘Post All Adjustments’ button in the ‘Detail’ tab.

If you now go into Inventory>Inventory Availability you will see that the individual Serial Number
is displayed.

An Issue Transaction: To issue an item go into Sales>Sales Orders and select Order
SO300013.  Select the ‘Lines’ tab and create a Sales Order Line for Item ‘Camera’.
Click on the ‘Picked Lines’ tab and then click the ‘Add’ button.  Place the cursor in the ‘Qty’ field
but do NOT enter a quantity.  You should, however, click on the ‘spyglass’ icon to bring up a panel
that shows the individual serial numbers in stock.   Select the Serial Number then ’Save’ the Issue
and ‘OK’ to exit the picking screen.

If you now go into Inventory>Inventory Availability you will see that the Serial Number does not
appear in Inventory.  If you go to the ‘Transaction History’ tab you will see that a Stock Movement
record has been created to cover the Issue

1.2.10.  Expiry Date

When an Item is received into Inventory it can be given an Expiration or Use-By Date.  Full visibility
of Quantity by Expiry date is available.  This Expiry Date follows the Item through the full Stock
Control and Sales Cycle.

Go to Inventory>Items and select Item 1500-2187 (Blue Paint) and go to the ‘Detail’ tab.  On that
screen ‘check’ the ‘Expiry Date’ checkbox.  Having defined this then:

· All receipts into stock for this Item must be given a Date
· All Issues from stock must contain an Expiry Date

A Receipt Transaction: One method of receiving stock is to go to Inventory>Inventory
Adjustments and create a new Adjustment Batch.  Go into the ‘Lines’ tab and add Item
1500-2187 with quantity of (say) 10.  If you try to ‘Save’ the record then it will be rejected because
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an Expiry Date has not been entered.  Enter an Expiry Date in the line.   Add another line for the
same Item with a different Expiry Date.   Finally, go to the ‘Detail’ tab and click on the ‘Post All
Adjustments’ button.

If you now go into Inventory>Inventory Availability and select Item 1500-2187 you will see the
received Stock segregated by Expiry Date.

An Issue Transaction: To issue an ‘Expiry Dated’ item go into Sales>Sales Orders and select
Order SO300013.  Select the ‘Lines’ tab and create a Sales Order Line for Item 1500-2187.
Click on the ‘Picked Lines’ tab and then click the ‘Add’ button.  In the created line select the
drop-down against the ‘Qty’ field to bring up a panel showing all stock for the Item.  Select the
specific Expiry Date and Quantity then ’Save’ the Issue and ‘OK’ to exit the picking screen.

If you now go into Inventory>Inventory Availability you will see that the Quantity against the
Expiry Date has been reduced by the issued quantity.  If you go to the ‘Transaction History’ tab
you will see that a Stock Movement record has been created to cover the Issue

1.2.11.  Revision Numbers

Revision control is the management of multiple revisions of the same unit.  It is most commonly
used in engineering to manage ongoing development versions of the same product.  Changes are
identified by incrementing an associated Revision Number (or Letter) code, termed the "revision
number". 

Go to Inventory>Items and select Item FC-7620 (Filing Cabinet - 3 Drawer) and go to the ‘Detail’
tab.  On that screen ‘check’ the ‘Revision No’ checkbox.  An adjacent (Current Revision) field
becomes active.  Click on the right-most icon in this field to bring up ‘Item Revisions’.  Add a
couple of Revisions in that screen then ‘Close’ it.  Click on the Left icon in the ‘Revision No’ field
and select a Revision Level to represent the current Revision Level then ‘Save’ the record

Having defined that this Item is subject to Revision Level Control then:
· All receipts into stock for this Item must be given a Revision Number
· All Issues from stock must contain a Revision

A Receipt Transaction: One method of receiving stock is to go to Inventory>Inventory
Adjustments and create a new Adjustment Batch.  Go into the ‘Lines’ tab and add Item FC-7620
with quantity of (say) 5.  If you try to ‘Save’ the record then it will be rejected because a Revision
Level has not been entered.  Go to the ‘Revision Level’ field and select a Revision Level from the
drop-down list.   Add another line for the same Item with a different Revision Level.   Finally, click
the ‘Post All Adjustments’ button in the Detail tab.

If you now go into Inventory>Inventory Availability and select Item FC-7620 you will see that the
received Stock is segregated by Revision Level.

An Issue Transaction: To issue an item go into Sales>Sales Orders and select Order
SO300013.  Select the ‘Lines’ tab and create a Sales Order Line for Item FC-7620.
Click on the ‘Picked Lines’ tab and then click the ‘Add’ button.  In the created line select the
drop-down against the ‘Qty’ field to bring up a panel showing all stock for the Item.  Select the
specific Revision Level and Quantity then ’Save’ the Issue and ‘OK’ to exit the picking screen.

If you now go into Inventory>Inventory Availability you will see that the Quantity against the
Revision Level has been reduced by the issued quantity.  If you go to the ‘Transaction History’
tab you will see that a Stock Movement record has been created to cover the Issue

1.2.12.  Batch Numbers
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Batch Numbers enable the user to segregate stock by their Batch (or Lot) Number.  The Food,
Beverage, Chemical, and Pharmaceutical industries require this mandatory feature to control
quality, quantity, and traceability.  Batch/Lot Numbers can be combined with ‘Expiry Dates’ where
required.

Go to Inventory>Items and select Item 1500-2186 (Red Paint) and go to the ‘Detail’ tab.  On that
screen ‘check’ the ‘Batch No’ checkbox.  At this point your should note that Batch Numbers can
be:

· Manually generated at time of receipt into Inventory, or
· Pre-keyed into a Batch List with option to also manually generate, or
· Pre-keyed into a Batch List from which the receipt Batch number MUST be selected

In the second two options you can click on the adjacent (Batches) button and pre-define the
batches.  You can restrict batch identities to those in this list by ‘checking’ the ‘Restrict Batch
Numbers to the List Below’ checkbox

Having defined that this Item is subject to Batch Control then:
· All receipts into stock for this Item must be given a Batch Number
· All Issues from stock must contain a Batch Number

A Receipt Transaction: One method of receiving stock is to go to Inventory>Inventory
Adjustments and create a new Adjustment Batch.  Go into the ‘Lines’ tab and add Item
1500-2186 with quantity of (say) 5.  If you try to ‘Save’ the record then it will be rejected because a
Batch Number has not been entered.  Go along to the Batch Number field and either key in the
Batch Number or select a Batch Number from the drop-down list.   Add another line for the same
Item with a different Batch Number.   Finally, click the ‘Post All Adjustments’ button in the ‘Detail’
tab.

If you now go into Inventory>Inventory Availability you will see that the Stock is segregated by
Batch Number.

An Issue Transaction: To issue an item go into Sales>Sales Orders and select Order
SO300013.  Select the ‘Lines’ tab and create a Sales Order Line for Item 1500-2186.
Click on the ‘Picked Lines’ tab and then click the ‘Add’ button.  In the created line select the
drop-down against the ‘Qty’ field to bring up a panel showing all stock for the Item.  Select the
specific Batch Number and Quantity then ’Save’ the Issue and ‘OK’ to exit the picking screen.

If you now go into Inventory>Inventory Availability you will see that the Quantity against the
Batch Number has been reduced by the issued quantity.  If you go to the ‘Transaction History’
tab you will see that a Stock Movement record has been created to cover the Issue

1.2.13.  Colour Segregation

The Colour option allows a user to have many different colours against the same Item Code and
be able to segregate stock by their Colour.  Within Ostendo this can be used independently or can
be combined with Size and/or Grade to accommodate the Apparel industry who need
Style/Colour/Size/Fit inventory segregation.

Go to Inventory>Items and select Item 485-2668 (Internal Spotlight 250 Watt) then go to the ‘
Detail’ tab.  On that screen ‘check’ the ‘Colour’ checkbox.  At this point your should note that
Colours can be:

· Manually generated at time of receipt into Inventory, or
· Pre-keyed into a Colour List with option to also manually generate, or
· Pre-keyed into a Colour List from which the receipt Colour number MUST be selected

In the second two options you can click on the adjacent (Colours) button and pre-define the
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available colours.  You can restrict colour selections to those in this list by ‘checking’ the ‘Restrict
Colours to the List Below’ checkbox

Having defined that this Item is subject to Colour Control then:
· All receipts into stock for this Item must be given a Colour
· All Issues from stock must contain a Colour

A Receipt Transaction: One method of receiving stock is to go to Inventory>Inventory
Adjustments and create a new Adjustment Batch.  Go into the ‘Lines’ tab and add Item 485-2668
with quantity of (say) 5.  If you try to ‘Save’ the record then it will be rejected because a Colour has
not been entered.  Go to the Colour field and either key in the Colour or select a Colour from the
drop-down list.   Add another line for the same Item with a different Colour.   Finally, click the ‘Post
All Adjustments’ button in the ‘Detail’ tab.

If you now go into Inventory>Inventory Availability you will see that the received Stock is
segregated by Colour.

An Issue Transaction: To issue an item go into Sales>Sales Orders and select Order
SO300013.  Select the ‘Lines’ tab and create a Sales Order Line for Item 485-2668.
Click on the ‘Picked Lines’ tab and then click the ‘Add’ button.  In the created line select the
drop-down against the ‘Qty’ field to bring up a panel showing all stock for the Item.  Select the
specific Colour and Quantity then ’Save’ the Issue and ‘OK’ to exit the picking screen.

If you now go into Inventory>Inventory Availability you will see that the Quantity against the
Colour has been reduced by the issued quantity.  If you go to the ‘Transaction History’ tab you
will see that a Stock Movement record has been created to cover the Issue

1.2.14.  Grade Segregation

The Grade option allows a user to have many different Grades against the same Item Code and
be able to segregate stock by their Grade (Example: Rough, Medium, Smooth)

Go to Inventory>Items and select Item 482-2218 (Standard 240 Volt Power Outlet - Single) then
go to the ‘Detail’ tab.  On that screen ‘check’ the ‘Grade’ checkbox.  At this point your should note
that Grades can be:

· Manually generated at time of receipt into Inventory, or
· Pre-keyed into a Grade List with option to also manually generate, or
· Pre-keyed into a Grade List from which the receipt Grade number MUST be selected

In the second two options you can click on the adjacent (Grades) button and pre-define the
available Grades.  You can restrict Grade selections to those in this list by ‘checking’ the ‘Restrict
Grades to the List Below’ checkbox

Having defined that this Item is subject to Grade Control then:
· All receipts into stock for this Item must be given a Grade
· All Issues from stock must contain a Grade

A Receipt Transaction: One method of receiving stock is to go to Inventory>Inventory
Adjustments and create a new Adjustment Batch.  Go into the ‘Lines’ tab and add Item 482-2218
with quantity of (say) 5.  If you try to ‘Save’ the record then it will be rejected because a Grade has
not been entered.  Go to the Grade field and either key in the Grade or select a Grade from the
drop-down list.   Add another line for the same Item with a different Grade.   Finally, click the ‘Post
All Adjustments’ button in the Detail tab.

If you now go into Inventory>Inventory Availability for Item 482-2218 you will see that the
received Stock is segregated by Grade.
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An Issue Transaction: To issue an item go into Sales>Sales Orders and select Order
SO300013.  Select the ‘Lines’ tab and create a Sales Order Line for Item 482-2218.
Click on the ‘Picked Lines’ tab and then click the ‘Add’ button.  In the created line select the
drop-down against the ‘Qty’ field to bring up a panel showing all stock for the Item.  Select the
specific Grade and Quantity then ’Save’ the Issue and ‘OK’ to exit the picking screen.

If you now go into Inventory>Inventory Availability you will see that the Quantity against the
Grade has been reduced by the issued quantity.  If you go to the ‘Transaction History’ tab you will
see that a Stock Movement record has been created to cover the Issue

1.2.15.  Size Segregation

The Size option allows a user to have many different Sizes against the same Item Code and be
able to segregate stock by their Size.  Within Ostendo this can be used independently or can be
combined with Colour and/or Grade to accommodate the Apparel industry that need
Style/Colour/Size/Fit inventory segregation.

Go to Inventory>Items and select Item 850-2192 (Clamp & Bearing) then go to the ‘detail’ screen.
On that screen ‘check’ the ‘Size’ checkbox.  At this point your should note that Sizes can be:

· Manually generated at time of receipt into Inventory, or
· Pre-keyed into a Size List with option to also manually generate, or
· Pre-keyed into a Size List from which the receipt Size number MUST be selected

In the second two options you can click on the adjacent (Sizes) button and pre-define the available
Sizes.  You can restrict Size selections to those in this list by ‘checking’ the ‘Restrict Sizes to the
List Below’ checkbox

Having defined that this Item is subject to Size Control then:
· All receipts into stock for this Item must be given a Size
· All Issues from stock must contain a Size

A Receipt Transaction: One method of receiving stock is to go to Inventory>Inventory
Adjustments and create a new Adjustment Batch.  Go into the ‘Lines’ Tab and add Item
850-2192 with quantity of (say) 5.  If you try to ‘Save’ the record then it will be rejected because a
Size has not been entered.  Go to the Size field and either key in the Size or select a Size from the
drop-down list.   Add another line for the same Item with a different Size.   Finally, click the ‘Post
All Adjustments’ button in the ‘Detail’ tab.

If you now go into Inventory>Inventory Availability you will see that the received Stock is
segregated by Size.

An Issue Transaction: To issue an item go into Sales>Sales Orders and select Order
SO300013.  Select the ‘Lines’ tab and create a Sales Order Line for Item 850-2192.
Click on the ‘Picked Lines’ tab and then click the ‘Add’ button.  In the created line select the
drop-down against the ‘Qty’ field to bring up a panel showing all stock for the Item.  Select the
specific Size and Quantity then ’Save’ the Issue and ‘OK’ to exit the picking screen.

If you now go into Inventory>Inventory Availability you will see that the Quantity against the Size
has been reduced by the issued quantity.  If you go to the ‘Transaction History’ tab you will see
that a Stock Movement record has been created to cover the Issue

1.2.16.  Combinations

You may wish to create your own Item code and give it a combination of the following
characteristics.
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· Serial Number
· Batch Number
· Colour
· Size
· Grade
· Expiry Date
· Revision Level

Carry out a Stock adjustment to receive some of the item into stock.  Now add the Item to an
existing Sales Order and issue the Item to the Order.
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18 Initialising Inventory Levels

It is suggested that to Initialise Inventory Levels in Ostendo you use the 'Inventory Adjustment'
option and go through the following process

Step 1.  Go into Inventory>Inventory Adjustments and create an Adjustment Batch header.  '
Save' the record and note the Batch Header Number

Step 2.  Create a Spreadsheet containing the following fields

· Adjustment Number
· Warehouse Code
· Location
· Item Code
· Item Description
· Item Unit
· Adjustment Type
· Adjustment Quantity
· Adjustment Cost
· Serial Number
· Expiry Date
· Batch Number
· Revision Number
· Item Grade
· Item Colour
· Item Size

Populate the above taking note of the following:

· Adjustment Number:  Use the Inventory Adjustment Batch Number that you noted in
Step 1

· Warehouse Code and Location:  The combination of Warehouse/Location must already
exist in Ostendo.   Enter these via Inventory>Warehouses and Inventory>Locations

· Item Code: This must already exist in Ostendo
· Adjustment Type:  Create an Adjustment Type of (say) 'Opening Stock' via

Inventory>Settings>Adjustment Types
· Adjustment Cost:  If your Inventory Costing Method is 'Standard' then this can be

ignored.  If it is 'Average' then a Unit Cost is required
· You must have a separate for each variation of Batch Number, Colour, Size, etc
· Serial Number: If the Item is serial numbered then the Adjustment Quantity can only be 1

Step 3.  Import the content of the Spreadsheet into Table INVENTORYADJUSTLINES using
either the Import routine (File>Data Importing) or use a Custom Script.  

Here is a Custom Script that uses the field layout defined above.  Note: amend line 
LoadSpreadSheet('c:\Inventory.xls') to point to your spreadsheet

Var
  RowCount : Integer;
  x : Integer;
begin
  LoadSpreadSheet('c:\Inventory.xls');
  RowCount := SSGetContentRowCount;
  for x := 0 to RowCount -1 do
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Begin
   InsertRecord('InventoryAdjustLines',
   'AdjustmentNo=' + SSGetCellText(0,x,0) + #13 +
   'WarehouseCode=' + SSGetCellText(1,x,0) + #13 +
   'Location=' + SSGetCellText(2,x,0) + #13 +
   'ItemCode=' + SSGetCellText(3,x,0) + #13 +
   'ItemDescription=' + SSGetCellText(4,x,0) + #13 +
   'Unit=' + SSGetCellText(5,x,0) + #13 +
   'AdjustmentType=' + SSGetCellText(6,x,0) + #13 +
   'AdjustmentQty=' + SSGetCellText(7,x,0) + #13 +
   'AdjustmentCost=' + SSGetCellText(8,x,0) + #13 +
   'SerialNo=' + SSGetCellText(9,x,0) + #13 +
   'ExpiryDate=' + SSGetCellText(10,x,0) + #13 +
   'BatchNo=' + SSGetCellText(11,x,0) + #13 +
   'RevisionNo=' + SSGetCellText(12,x,0) + #13 +
   'ItemGrade=' + SSGetCellText(13,x,0) + #13 +
   'ItemColour=' + SSGetCellText(14,x,0) + #13 +
   'ItemSize=' + SSGetCellText(15,x,0));
End;
   Showmessage('Opening Inventory Lines Added');
end.

To run the Script go into File>Custom Scripts and add a new script called (say) 'Opening Stock'.
Click on the 'Script' tab then copy and paste the above script.  Make sure that you have amended
the LoadSpreadSheet('c:\Inventory.xls'); to point to your spreadsheet..
Click on the 'Test Script' button to run the Script. 

Step 4.  Go into Inventory>Inventory Adjustments and check the imported record.  Amend as
required.

Step 5.  Click on the 'Detail' tab and click on the 'Post All Adjustments' button to update Ostendo
with the Opening Balances.



71Inventory Replenishment

19 Inventory Replenishment

Ostendo's Replenishment Routine provides the facility to recommend raising of Supply Orders
(Purchased and Assembly) to satisfy current and future demand requirements.   The options
available when running the Replenishment Routine are:

· Single or Multi-Level Replenishment
· Company or Site level execution
· Exclude selected Demand or Supply Orders
· Exclude Orders with 'Planned' or 'On-Hold' status
· Sales or Inventory Forecasting Basis 
· Three Forecasting Options within the Forecasting Basis
· Exclude Forecast from Replenishment
· Option to Expedite Purchase and/or Assembly Orders
· Included Item Selection Range options

Let's go through the above step-by-step to see them in action

1.  Single or Multi Level?

Two options are available to Replenish Inventory:

Single Level MRP: This focuses on the Item’s current actual and/or forecast future
demands to create Suggested Orders required to maintain stock.  This option is generally
used in the Wholesale/Retail/Stockists environment.

Multi-Level MRP:  In addition to looking at the current actual and/or forecast future
demands for each Item this option also looks to see if the Item has a Bill of Material and, if
so, will ‘explode’ any Suggested Orders to determine the components required to make it.
These are then used as ‘Suggested Demands’ when assessing component requirements.
This option is generally used in the Manufacturing environment.

1.  Single Level MRP

1.1.  Preparation

Go into Inventory>Items and select Item 100-2000 (Washer-Mild Steel-8mm).  In that record you
will see 4 fields that are used in the Replenishment function

Re-Order Level: If the projected stock falls below this level then a Suggested Order is
triggered using the Re-Order Quantity or the actual demand quantity (whichever is the
greater) to bring the stock up to the Re-Order level
Re-Order Qty: The minimum quantity that will be generated by a Suggested Order
Order Multiple: The Suggested Order quantity is rounded up to the nearest multiple of this
entry
Lead Time: The number of days between when the Item should be ordered and when it is
required 

1.2. Replenishment Process

Step 1.  To commence the Replenishment process go to Requirements>Inventory
Replenishment.  In the presented panel:

· Click on the ‘Create New Inventory Replenishment’ button if not already selected
· ‘Check’ the ‘Exclude any Forecasts for Items’ checkbox ***
· Select ‘From Item Code’ = 100-2000

· Select ‘To Item Code’ = 100-2000
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· Click the ‘OK’ button
· Leave all other fields 'as is'

*** To understand the basic Replenishment routine it would be better to ignore any Forecast at
present.  Having understood the process without a Forecast you may wish to repeat the Inventory
Replenishment including the Item’s Forecast which is described later in this Tutorial 

Step 2.  Determine Nett Demand

The Replenishment Routine extracts all ‘Actual Demands’ from the following sources
· Sales Orders
· Assembly Orders
· Jobs  

The Forecast demands and the Actual Demands are then compared such an ongoing demand is
generated from the greater of the Cumulative Forecast and the Cumulative Actual Demand.  For
Example:

Forecast    10    10     10    10    10    10
Actual      15     3     14     2
---------------------------------------------
Cumulative  15     5     12     8    10    10

The above analysis is carried out up to a Replenishment Horizon.   This was defined in the run
selection parameters in Step 1.  The parameter can be either:

· A fixed number of Days for all Items
· An Item’s Leadtime + A defined number of days

Step 3.  Determine Supply

The Replenishment Routine extracts all ‘Actual’ Supply quantities from the following sources
· Purchase Orders
· Assembly Orders

Step 4.  Creating Suggested Orders

Armed with the current stock level, Nett Demands, and Outstanding Supply orders then - starting
the system date - the Replenishment program will go through the following process:

1.  Add any overdue Supply Orders to the Current Stock Level and deduct any Nett Demands
equal or prior to the system day
2.  Is the ‘expected’ Stock Level below the Item’s Re-Order Level?

No - Go to question 4
Yes - Determine the greater of (a) the quantity required to bring it up to the Re-Order Level
and (b) the Re-Order Quantity.  Round this up in accordance with the Item’s Order Multiple
and create a Suggested Order

3.  Add the Suggested Order Quantity to the Current Stock Level
4.  Go to the next day
5.  Has the Replenishment Horizon been reached for this Item?

No - Go to question 6
Yes - End the Replenishment calculation for this Item

6.  Add any Supply Orders (Assembly Orders or Purchase orders) scheduled for this day
7.  Deduct any ‘Nett Demands’ scheduled for this day.
8.  Go back to the question 2

Step 5.  Replenishment Results
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The results of the Replenishment run are displayed showing all Items that have had Suggested
Orders created.  You can drill-down on each Item (clicking the ‘Detail’ tab) to see the detailed
results of the run.   This shows (by Day) all Demands, Supply Orders, and Suggested Orders with
a resulting stock balance at the end of the day.  On this ‘detail’ view the quantity displayed against
the Suggested Order can be amended.  The results of the change are immediately reflected on all
subsequent daily balances.

If you have made all the required changes then go back to the ‘List’ view, ‘check’ the lines that are
to be auctioned and click the ‘Accept Replenishment results for selected items’ button.  The
created ‘Suggested’ Order are converted into physical orders via Inventory>Create Required
Orders.  See below.

2.  Multi-Level MRP

Let us look at a simple example to demonstrate Multi-Level MRP.  Go into Inventory>Items and
create two Items with data shown below

Item Code         A
Unit                  Each
Description       Top Assembly
Supply Method  Supply from Stock
Sourced By      Assembly
Reorder Level    1
Reorder Qty      4
Order Multiple   1
Leadtime          7

Item Code         B
Unit                  Each
Description       Purchased Component
Supply Method  Supply from Stock
Sourced By      Purchasing
Reorder Level    1
Reorder Qty      10
Order Multiple   1
Leadtime          14

The next step is to create a Bill Of Material.  Go into Assembly>Bills Of Material and create a new
BOM for Item A.  On the presented BOM screen click on the ‘Lines’ tab and add a component B
with a usage quantity of 2

Now run multi-level MRP as follows.  Go into Requirements>Inventory Replenishment and, in the
parameters screen, ‘check’ the Multi-level explosion checkbox.

Click the ‘OK’ button to commence the Multi-Level Replenishment run

The program will go through the following steps;

Step 1.  Determine Nett Demand

The Replenishment Routine extracts all ‘Actual Demands’ from the following sources
· Sales Orders
· Assembly Orders
· Jobs
· Suggested Assembly Order Components ***  (See later)
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The Forecast demands and the Actual Demands are then compared such an ongoing demand is
generated from the greater of the Cumulative Forecast and the Cumulative Actual Demand.  For
Example:

Forecast    10    10     10    10    10    10
Actual      15     3     14     2
---------------------------------------------
Cumulative  15     5     12     8    10    10

The above analysis is carried out up to a Replenishment Horizon.   This was defined in the run
selection parameters in Step 1.  The parameter can be either:

· A fixed number of Days for all Items
· An Item’s Leadtime + A defined number of days

Step 2.  Determine Supply

The Multi-Level MRP Routine extracts all ‘Actual’ Supply quantities from the following sources
· Purchase Orders
· Assembly Orders

Step 3.  Creating Suggested Orders

Armed with the current stock level, Nett Demands, and Outstanding Supply orders then - starting
the system date - the program will go through the following process:

1.  Determine the Low-Level Code for each Item.  This Code represents the lowest level in the Bill
of Material structure that the Item appears and defines the priority sequence in which Items are
processed.        
2.  The next step is to delete all previous Suggested Orders and Suggested Demands
3.  Commencing with the first Item at Low Level Code 0 the Actual Demand is evaluated on a daily
basis.  
4.  The first day’s demand is assessed by adding any overdue Supply Orders to the Current Stock
Level.
5.  Is the ‘expected’ Stock Level below the Item’s Re-Order Level?

No - Go to activity 6
Yes - Determine the greater of (a) the quantity required to bring it up to the Re-Order Level
and (b) the Re-Order Quantity.     Round this up in accordance with the Item’s Order
Multiple and create a Suggested Supply Order.    
If this Item is ‘Assembled’ then get the component requirements from the Item’s BOM and
create ‘Suggested Demand Orders’ for each Component where the quantity is that
required to make the parent ‘Suggested Supply Order’ quantity (including component
scrap) and the required date is the Parent Item’s required date, less its Leadtime.

6.  Go to the next day.  
§ If the MRP Horizon has been reached then select the next Item and go back to Activity 4
§ If it is not beyond the MRP Horizon then, commencing with the current stock level, add any

Supply Orders (Assembly Orders or Purchase orders), and deduct any ‘Cumulative
Demand’ scheduled for this day then go back to the Activity 5

The results of the Replenishment run are displayed via the ‘Create Required Orders’ screen.
What you will find is that, for the above Items, the following calculations have been carried out.

Item A.  Current Stock is 0 therefore it needs to be brought up to its Re-Order Level using the
Reorder Qty.  Therefore a single Suggested Supply Order is created with the following information

Quantity = 4
Required Date = today’s date
Start Date = Today minus 7 days Leadtime
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Item B.  The Suggested Supply Order to make Item A would generate a Suggested Demand Order
for B to make A.   Therefore a single Suggested Demand Order is created with the following
information

Quantity = 8 (4 of Item A with a BOM requirement of 2 per A)

As the current Stock is 0 it needs to be brought up to its Re-Order Level of 1.  Therefore the total
demand is 9.  This is satisfied by creating a Suggested Order using the minimum Reorder quantity
held against B (10).  Therefore a single Suggested Supply Order is created with the following
information

Quantity = 10
Required Date = today’s date
Start Date = Today minus 14 days Leadtime

There are many variables within this simple scenario such as

§ The Sales, Job or Assembly Order demands come from the outstanding issue quantity
against these orders and not the original Order quantity

§ Similarly the Purchase or Assembly Order Supply comes from the outstanding receipt
quantity and not the Order quantity

3.  Other Replenishment options

Now that you have been through the basic concepts of Single and Multi-Level MRP let's have a
look at some variations.

3.1. Replenishment Horizon

The Replenishment Horizon restricts the processing to only look at Supply and Demand Orders
within a future time period.  This Time Period can be expressed as a definitive number of days or a
number of days over the Item's current Leadtime.   Try creating a Sales Order for A and schedule
it for 12 days time then re-run the MRP using an 8 day fixed Horizon.  You should find that
Ostendo will ignore this Order because it is beyond the Horizon.   Run Replenishment again but
this time 'check' the 'Leadtime Days + Additional Days' radio button.  The Sales Order will now be
included because the Horizon to be used for this Item will be the Item leadtime (7 Days) plus the
Additional Days (8 days).

3.2. Specific Site

You have the option to run the Replenishment globally across the Company Database or against
individual Sites within the Company.  To show you how Site Replenishment works we will go
through the process of

· Setting up Sites
· Defining User/Site relationship
· Defining Item Site Settings
· Looking at Sales, Assembly, Job, Purchase Orders by Site
· Running the Replenishment Process by Site

3.2.1. Site Parameters

3.2.1.1. Setting up Sites

To create a Site simply click on General>Site and add the Site.  In this exercise we will use the
current 'Company' Site and add a new 'Sales' Site.   Therefore, in addition to the current 'Company'
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Site create a second Site called (say) 'Spares'.   

3.2.1.2. User/Site Relationship

You can restrict a User to a Site within the User Security settings.  Therefore go into File>System
Configuration>User Security and Options and create a User called (say) 'Sales'.  In the 'User
Options' tab link this User to Site 'Spares'.   

3.2.1.3. Warehouses within a Site

Let us now create a Warehouse with a single location and link it to the 'Spares' Site. bGo into
Inventory>Warehouses and create a new Warehouse called (say) 'Retail' and link it to Site 'Spares
'.   Next go to Inventory>Locations and create a location called (say) 'Pickface' and link it to
Warehouse 'Retail'.

3.2.1.4. Item Site Settings

Having Identified the Site we will now use Items 100-2000, A and B and provide them with specific
Item/Site Parameters such as ROL, ROQ, Leadtime.  Therefore go into Inventory>Items and
highlight Item 100-2000.  Click on the 'Related' Button and you will see two sub screens:-

Item Site Settings: This allows you to set the Default Issue and receipt
Warehouse/Location for the Item.   Create a Site Settings for the above Items using the
Warehouse/Location you created above.
Item Site Master: This allows you to maintain Replenishment parameters for this Item at
the nominated Site.  Create a Site Master for the above Items and complete all fields

3.2.2. Site Specific Orders

We will look at how Orders are raised against a Site.  

This process already happens in that whenever you raise an order (Purchase, Sales, Job, or
Assembly) the Order Header record contains the originating Site.  The next question is where does
it get the Site information from?   This comes from the Site Name against the User who created
the Order (see 3.2.1.2. above).  

You may also wish to restrict the User to only looking at Orders for that Site.  To do this go into
File>System Configuration>System Screen Conditions and set up the following record covering
Sales Order

User Name: 'Sales' as set up in 3.2.1.2.
Screen: Sales Orders
Filter Condition: Enter the following SITENAME = 'Spares'

You will now find that User 'Sales' will only see Sales Orders that are related to Site 'Spares'

3.2.3. Site Replenishment Run

We will use the Single Level MRP option to show how the Replenishment Routine can be Site
specific.  Go to Requirements>Inventory Replenishment  and, in the presented panel, click on the ‘
Create New Inventory Replenishment’ button if not already selected.  

3.2.3.1. Site Selection

Click on the 'Specific Site' checkbox and then select the Site 'Spares' from the drop-down in the
adjacent field.  If you now run Replenishment without a 'From' and 'To' Item Number you will see
that all Items have been run.  You should note:

· All Items will be included in the Replenishment Run because we haven't stated otherwise
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in the Item Selection Options area.
· If the Item does not have Site-Specific parameters (EOL, EOQ, Leadtime, etc) then the

parameters held against the Item Master will be used.
· The Demand (Sales, Assembly, and Job Orders) and Supply (Assembly and Purchase

Orders) are those linked to the selected Site

3.3. Exclusions

3.3.1. Exclude Demands

You have the option to exclude one or more 'Demand' Order types from Jobs, Assembly and/or
Sales Orders.  This provides the following scenarios

· If you exclude all 3 Order Type Demands but include Forecasts (see 3.4.) you are
effectively running a Master Production Schedule (MPS)

· If you include all 3 Order Type Demands but exclude Forecasts you are running the
Replenishment process based purely on current actual demands.  This makes the
Replenishment routine more reactive to short-term requirements and should, therefore, be
run more frequently.

· If you exclude all 3 Order Type Demands and also exclude Item Forecasts you are
maintaining minimum Stock levels only.

· Where you are running an Assembly Line which has 'Line-Side' stock you could exclude
Assembly Order Demands but include the remainder.  The Line-side stock could have
their inventory maintained by ROL and ROP parameters (assuming regular stocktakes are
taken of the Line-Side Bin stock.

3.3.2. Exclude Supply Orders

You have the option to exclude either, or both, 'Supply' Order types from Purchasing and/or
Assembly Orders.  This means that if you exclude both Purchase and Assembly Supply Orders
then the Replenishment Demand will be the 'Gross' demand.  This can then be netted off against
the current Inventory levels only within the Replenishment run 

3.3.3. Exclude By Order Status

You also have the option to exclude Orders with the following status'

· 'Planned' Orders: If this is ‘checked’ selected then any Sales, Purchase, Job, or
Assembly Order whose status is 'Planned' will be ignored.  This useful, for example, if you
are building up a large Job Order and, during this development stage, you do not wish the
Job Lines to be included in the Replenishment process

· 'On-Hold' Orders: If this is selected then any Sales, Purchase, Job, or Assembly Order
whose status is 'On-Hold' will be ignored

3.4 Forecasting options

3.4.1. Forecast Type

During the Replenishment Process Ostendo will (optionally) compare Forecast demands and
Actual Demands for each Item to arrive at an ongoing demand based on the greater of the
Cumulative Forecast and the Cumulative Actual Demand.   (See Replenishment Process in 1.2.
above).  The Forecast is based on one of two types:

Inventory:  This type of forecast is based on future Inventory transactions and is primarily used
by the Warehousing/Distribution industry to replenish stock.  This Forecast generation is often
based on past Inventory transactions projected into the future
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Sales:  This type of forecast is based on future Sales and/or Job Orders (Independent
Demands) and is primarily used by the Manufacturing industry which uses multi-level Material
Requirements Planning (MRP) to create Replenishment Orders.  This forecast is driven by
Sales/Job Demands to determine an Ongoing 'Independent' Demand.  The Multi-level
Replenishment run then adds other - Dependent Demands - emanating from 'Suggested'
Assembly Orders created during the Replenishment run.  

Therefore if 'Inventory' Forecast is selected then the Replenishment Run will assume that it
includes both Independent and Dependent Demands.  On the other hand if 'Sales' is selected then
the Replenishment Run will assume that it is addressing Independent Demands only and any
Dependent Demands will be created during the Multi-Level MRP run.  

The style of Forecast is selected from the drop-down list under field 'Forecast Style' 

3.4.2. Forecast Source

The next question to ask is "Where does the Forecast come from?"  If you look at the drop-down
under field 'Forecast From' you will see two options

Entered Monthly:  This refers to the Monthly Forecast that you have manually entered into
screen Inventory>Item Forecast
History Generated:  This Forecast will be generated during the Replenishment Run.  The next
field (History Source) defines from where this information is obtained

Let's have a look at the various options these present us with

3.4.2.1. Entered Monthly.

Go into screen Inventory>Item Forecast and create a monthly Forecast for Item 100-2000 for (say)
1000 per month.  If you now run the Replenishment Routine (restrict the selection in the 'Item
Selection Options' at the bottom of the Replenishment Run screen to this Item Number) you will
see that the Forecast has been taken into account when creating Suggested orders

You may wish to try other variations using different Replenishment Horizons and Exclusions

3.4.2.2. History Generated

This feature enables Ostendo to auto-generate the Forecast during the Replenishment Run.  The
basis for the Forecast comes from the Forecast Type selected above.  I.e. 

Inventory:  All Inventory Transactions where the Item has been issued from Stock
Sales:  All Sales and Job Orders against which the Item has been issued

To support this selection and provide a basis for generating the Forecast you have the following
two options as defined by the selection under field History Source

Average Days:  If this is selected then the Ostendo calculates the sum of the history
(Inventory or Sales) over the number of days entered into field 'History Days' and
determines and average daily quantity.  This is used to calculate the Monthly quantity for
the current and subsequent months.  This calculated value is then uplifted by the 'History
Factor' (I.e 10% uplift = Monthly Quantity * 1.1) to arrive at a monthly Forecast to use.  
Same Month Last year:  If this is selected then the Ostendo calculates the usage over the
equivalent month in the past year and applies the 'History Factor' (I.e 10% uplift = Monthly
Quantity * 1.1) to arrive at a monthly Forecast to use in this Replenishment run.  

Try and re-run the Replenishment Routine using Item 100-2000 using Average Days and Same
Month Last Year with a History Factor and see the results
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3.5. Expedite

To 'Expedite' an Order infers that the Supply Order (Purchase or Assembly) can have its 'Required
Date' adjusted to satisfy Demand Requirements.  This doesn't physically adjust the Required Date
but assumes that it can be adjusted.  The Replenishment Routine generates a Report to show
where this assumed adjustment has been made.  This would then require the Buyer or Production
Controller to assess the adjustment and either manually change the Required Date in the Order or
obtain the item from elsewhere.

Note: Although you can specify that all Orders can be 'Expedited' there are instances where this is
not possible as some Orders cannot be Expedited.  In this situation you should go into the
Purchase Order or Assembly Order Header and 'check' the 'No Expediting of the Order' checkbox.
This will ensure that the order will not be expedited even though the 'Expedite' checkbox in the
Replenishment Routine has been selected.

Within the Replenishment Run parameter selection you can identify if you wish to expedite either
Purchase or Assembly Orders.   In each case if the checkbox is not 'checked' then these orders
will not be expedited:

An Expedite Report can be printed (via Replenishment>Reports) identifying what Supply Order(s)
have been expedited to satisfy the demand requirements.

Try raising a Purchase Order for Item 100-2000 with a Required Date of (say) 2 months into the
future.  If you now create a Replenishment Run for Item 100-2000 and 'check' the 'Expedite
Purchase Orders' checkbox you will see that your Purchase Order will have been expedited.  Run
the Expedite Report (Replenishment>Reports>Expedite Purchase Order) to see the expedited
Supply Order.

3.6. Item Selection Options

You can restrict the Replenishment Run to a selected range of Items or Item Categories.  You
should be aware, however, that if you are carrying out a 'Multi-Level Explosion' and the component
Item(s) are not included within this selection range then they will NOT be processed
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20 Item Dimensions in Order Entry

Item Dimensions allow you to create one or multiple entries where you specify specific Lengths,
Widths, Depths and/or Pack Sizes.  These are then converted into a single Order Line Quantity. 
You can return to the Dimensions entry screen at any time and re-calculate the Order Line quantity

The Item Dimensions facility covers four basic scenarios that can be used individually or combined
to provide an extensive array of options.  The basic Dimensions are 

· Length
· Width
· Depth
· Pack Size

To demonstrate how these can be used we will go through a few practical examples

· Calculate the total length of Wood from various cut lengths
· Calculate number of Steel bars required to do a Job
· Calculate the Litres of Paint required for multiple surface areas
· Calculate the number of whole Roof Tiles required to roof a house
· Calculate the volume of concrete required to cover a driveway
· Enter various required pack sizes of Meat (this example includes a delivery tolerance)
· Take orders for 'ad-hoc' Pack Sizes

Calculate the total length of Wood from various cut lengths

Go into Inventory>Items and create an Item called (say) 'Pine 25 x 100' and give it a Unit of
measure of M (I.e. Metres).   Click on the 'Order Dims' tab and enter the following

Use Length: 'Check' the checkbox
Fixed: Leave 'unchecked'
Fixed Length Value: Not applicable
Use Width: Leave 'unchecked'
Fixed: Leave 'unchecked'
Fixed Width Value: Not applicable
Use Depth: Leave 'unchecked'
Fixed: Leave 'unchecked'
Fixed Depth Value: Not applicable
Use Pack Size: Leave Blank
Enter Pack Size: Not applicable
Conversion Factor: Leave Blank

Now go to Sales>Sales Orders and create an Order.  Click on the 'Lines' tab then click the 'Add'
button to create a new line.
Select Code Type 'Item Code' and, in 'Code' field select 'Pine 25 x 100'.  You will see that the '
Qty' field contains an Icon.  Click on this (or key Ctrl-Q) and the 'Sales Line Qty Dimensions'
screen will be presented showing two entry fields. (Qty and Length).  Click the 'Add' button to add
each line and enter the following Quantities and Lengths

Qty 5 at 2 Mtrs
Qty 8 at 2.5 Mtrs
Qty 3 at 3 Mtrs

You will see that the total entered quantity (39) is displayed at the top of the screen
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If you now click on the 'Update Order Line Qty with Calculated Qty' button then you will be taken
back to the Sales Order Line where the quantity will contain 39

You should note the following:
· You can overtype this evaluated quantity if required.
· At any time you can recall the 'Sales Line Qty Dimensions' screen and re-calculate.
· The entered dimensions are available for printing on Sales documents, etc

One thing you may have noticed is that when entering the Length you are not told the Units of that
length.  We will show you how this is achieved in the next example

Calculate number of Steel bars required to do a Job

In this example we issue a number of Steel Bars with UOM of 'Each' where each bar is 2 mtrs in
length.  Therefore you will need to calculate the total Length in Mtrs and divide this by 2 to arrive at
the number of Bars required.

Go into Inventory>Items and create an Item called (say) 'Mild Steel Bar' and give it a Unit of
measure of Each (I.e. a 2 Mtr long Bar).   Click on the 'Order Dims' tab and enter the following

Use Length: 'Check' the checkbox
Fixed: Leave 'unchecked'
Fixed Length Value: Not applicable
Use Width: Leave 'unchecked'
Fixed: Leave 'unchecked'
Fixed Width Value: Not applicable
Use Depth: Leave 'unchecked'
Fixed: Leave 'unchecked'
Fixed Depth Value: Not applicable
Use Pack Size: Leave Blank
Enter Pack Size: Not applicable
Conversion Factor: Enter 0.5 ***

*** The Conversion Factor of 0.5 will convert the evaluated Length into the number of Bars
required

When entering the Lengths we wish to inform the person entering the data that it must be in
Metres.  Therefore 'check' the 'Use Pack Size' checkbox and click the 'Enter Pack Size' button.
A panel will appear in which you should enter the following

'Check' the 'Restrict Pack Sizes to List below' checkbox
Add a single entry of

Pack Size: Enter Length in Metres
Conversion Factor: 1

This whole area will be covered on more detail later but, for now, Ostendo recognises the single
entry and automatically prefills the  'Sales Line Qty Dimensions' screen with this description.

Now go to Sales>Sales Orders and create an Order.  Click on the 'Lines' tab then click the 'Add'
button to create a new line.
Select Code Type 'Item Code' and, in 'Code' field select 'Mild Steel Bar'.  Click on the Icon in the
Qty field to bring up the 'Sales Line Qty Dimensions' screen.   If you 'Add' a new Line then the
Pack Size field will be prefilled with the narration ' Enter Length in Metres'. 

Enter the following dimension
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Qty 2 at 1.25 Mtrs
Qty 4 at 0.25 Mtrs

You have entered a total line length of 3.5 Mtrs.    The Conversion Factor will be applied and the
Order Line Quantity will display as 1.75 with a Unit of Measure of Each

Calculate the Litres of Paint required for multiple surface areas

In this example we enter multiple Wall dimensions and convert this into Litres of Paint required. 

Go into Inventory>Items and create an Item called (say) 'Wall Paint' and give it a Unit of
measure of 5L (I.e. a 5 Ltr Can).   Click on the 'Order Dims' tab and enter the following

Use Length: 'Check' the checkbox
Fixed: Leave 'unchecked'
Fixed Length Value: Not applicable
Use Width: 'Check' the checkbox
Fixed: Leave 'unchecked'
Fixed Width Value: Not applicable
Use Depth: Leave 'unchecked'
Fixed: Leave 'unchecked'
Fixed Depth Value: Not applicable
Use Pack Size: 'Check' the checkbox
Enter Pack Size: See Previous example
Conversion Factor: Enter 0.05 ***

*** The Conversion Factor of 0.05 assumes that 1 Litre of Paint will cover 4 square Metres of wall. 
Therefore the conversion factor will take into account

4 Square Metres of wall = 1 Ltr of Paint
1 Can of Paint = 5 Ltrs 

Now go to Sales>Sales Orders and create an Order.  Click on the 'Lines' tab then click the 'Add'
button to create a new line.  Select Code Type 'Item Code' and, in 'Code' field select 'Wall Paint'.
 Click on the Icon in the Qty field to bring up the 'Sales Line Qty Dimensions' screen.   If you
'Add' a new Line then the Pack Size field will be prefilled with the narration ' Enter Dimensions in
Metres'. 

Enter the following dimensions

Qty 1 Length 4 Mtrs and Width 3.5 Mtrs
Qty 1 Length 3.5 Mtrs and Width 3.5 Mtrs

You have entered a total area of 26.25 Squ Mtrs.    The Conversion Factor will be applied and the
Order Line Quantity will display as 1.3125 with a Unit of Measure of 5L

Calculate the number of whole Roof Tiles required to roof a house

In this example we have Roof Tiles of a known size.  We need to calculate the number of whole
tiles required to tile the roof taking into account that some tiles may be cut to fit.

Go into Inventory>Items and create an Item called (say) 'Roof Tile' and give it a Unit of measure
of Each.   Click on the 'Order Dims' tab and enter the following

Use Length: 'Check' the checkbox
Fixed: 'Check' the checkbox
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Fixed Length Value: Enter a value of 0.5 Mtr
Use Width: 'Check' the checkbox
Fixed: 'Check' the checkbox
Fixed Width Value: Enter a value of 0.4 Mtr
Use Depth: Leave 'unchecked'
Fixed: Leave 'unchecked'
Fixed Depth Value: Not applicable
Use Pack Size: Leave 'unchecked'
Enter Pack Size: Not applicable
Conversion Factor: Enter 1.5 ***

*** The Conversion Factor of 1.5 assumes that there will be approximately a 33% overlap  of the
Tiles

Now go to Sales>Sales Orders and create an Order.  Click on the 'Lines' tab then click the 'Add'
button to create a new line.  Select Code Type 'Item Code' and, in 'Code' field select 'Roof Tile'. 
Click on the Icon in the Qty field to bring up the 'Sales Line Qty Dimensions' screen.   Enter the
following dimensions

Qty 1 Length 10.26 Mtrs and Width 4.23 Mtrs

The Length value will require 10.26 / 0.5 = 20.52 Tiles
This is rounded to the nearest whole number of tiles in the 'Length' direction = 21
The Width value will require 4.45 / 0.4 = 11.125 Tiles
This is rounded to the nearest whole number of tiles in the 'Width' direction = 12

The total number of tiles =  Length Tiles * Width Tiles * Overlap

I.e.  21 * 12 * 1.5 = 378

Calculate the volume of concrete required to cover a driveway

In this example we will use 3 dimensions to calculate the volume of concrete for a driveway.

Go into Inventory>Items and create an Item called (say) 'Concrete' and give it a Unit of measure
of CuMtrs.   Click on the 'Order Dims' tab and enter the following

Use Length: 'Check' the checkbox
Fixed: Leave 'unchecked'
Fixed Length Value: Not applicable
Use Width: 'Check' the checkbox
Fixed: Leave 'unchecked'
Fixed Width Value: Not applicable
Use Depth: 'Check' the checkbox
Fixed: Leave 'unchecked'
Fixed Depth Value: Not applicable
Use Pack Size: Leave 'unchecked'
Enter Pack Size: Not applicable
Conversion Factor: Leave Blank

Now go to Sales>Sales Orders and create an Order.  Click on the 'Lines' tab then click the 'Add'
button to create a new line.  Select Code Type 'Item Code' and, in 'Code' field select 'Concrete'. 
Click on the Icon in the Qty field to bring up the 'Sales Line Qty Dimensions' screen.   Enter the
following dimensions
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Qty 1 Length 5.2 Mtrs, Width 2.65 Mtrs, Depth 0.25 Mtrs

  Ostendo will simply multiply these together to give 3.445 CuMtrs

Enter various required pack sizes of Meat

In the meat industry it is normal to receive an order for various 'Pack Sizes'.  The basic Pack Size
contains a 'Nominal Weight' therefore the number of Packs ordered directly relates to a 'planned'
delivery weight of Meat.  However, the content of each Pack Size can vary.   This means that
although the actual quantity of delivered pack sizes are 'as ordered' the actual weight being
delivered is at variance to the planned weight.

To allow for this variance you should first go into the Customer record (Sales>Customers) and, in
the 'Detail' tab click on the 'Pricing and Invoicing' sub tab.  In the displayed panel enter a enter
a 'Delivery Tolerance%' of (say) 5%.  This means that if the delivery weight is within 5% of the
Planned weight then the Order will be deemed to be complete

No go into Inventory>Items and create an Item called (say) 'Beef' and give it a Unit of measure
of Kg.   Click on the 'Order Dims' tab and enter the following

Use Length: Leave 'unchecked'
Fixed: Not applicable
Fixed Length Value: Not applicable
Use Width: Leave 'unchecked'
Fixed: Not applicable
Fixed Width Value: Not applicable
Use Depth: Leave 'unchecked'
Fixed: Leave 'unchecked'
Fixed Depth Value: Not applicable
Use Pack Size: 'Check' the checkbox
Enter Pack Size: Click on this Button
Conversion Factor: Leave Blank

If you click on the 'Enter Pack Size' button a panel will appear into which you can enter the Pack
Sizes and their conversion to KG.  Therefore 'Check' the 'Restrict Pack Sizes to List below'
checkbox and enter the following Pack Sizes:

Pack Size Conversion
Home Pack 5.0
10Kg 10.0
25Kg 25.0

Now go to Sales>Sales Orders and create an Order.  Click on the 'Lines' tab then click the 'Add'
button to create a new line.  Select Code Type 'Item Code' and, in 'Code' field select 'Beef'.  Click
on the Icon in the Qty field to bring up the 'Sales Line Qty Dimensions' screen.   Enter the
quantity and Pack Sizes ordered.  For example

Qty Pack Size
10 Home Pack
14 10Kg
8 25Kg

You will find that the Sales order Line will contain a total of 390 Kgs coming from

Qty Ordered Pack Size Kg/Pack Total Kgs
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10 Home Pack   5.0   50
14 10Kg 10.0 140
8 25Kg 25.0 200
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21 Job Calendar functions

1. Introduction

The Job Calendar view allows you to see what resources (Employees and/or Company Assets)
are required to perform required tasks.  

The main screen is split into three sections

· The main panel shows Resources, plus when and on what Job they are required. 
· The upper-right panel shows a calendar for you to select the displayed time periods 
· The lower-right panel shows all Jobs yet to be scheduled 

You can resize these panels by clicking on the panel boundaries and dragging them to the
required position

2. Creating a simple Job

This simple exercise describes how you can create a Job from within the Calendar View.  In the
Main panel click on a time slot under employee ‘Bob Drum’ and drag the cursor down 4 timeslots.
If you right click within the created darkened area then a panel will appear from which you should
select ‘New Job from selected time’.  The standard Job Order creation panel will appear for you
to create a Job Order.  Having created the Order a rectangle appears in the Main view spanning
the selected time.  This will contain the Customer Name and the Job Number.  

Let’s look at a few more things that you can do in this area

Change the Timeline: Click on the upper or lower edge of the Activity and drag it upwards or
downwards.   This will increase or decrease the duration of the Activity.

Move the Activity: Click on the centre of the Activity and drag it upwards or downwards.   This will
move the whole Activity.  You can also drag it sideways and give it to another Resource. 

Lets look in more detail at the creation and maintenance of Jobs

Create a job using the duration held against each Task: - Under a ‘Resource’ column
click on the time where you wish to start the Job and ‘Right Mouse’.  Select ‘New Job from
Start Time’.  This will bring up a Job Creation panel for you to create a new Job.  The
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created Order will begin at the designated Start time and will auto-calculate the Job
duration based upon the included Tasks (default Task or Tasks in a Template)

Create a job using the specified Duration: - This is what you did above when you
'Created a Simple Job'.  Just to recap:- Under a ‘Resource’ column click on the time where
you wish to start and drag the cursor down to encompass a duration then ‘Right Mouse’.
Select ‘New Job from Selected Time’.  This will bring up a Job Creation panel for you to
create a new Job.  The created Order will begin at the designated Start time and have a
duration as defined by the darker coloured area created by the above cursor drag.

New Booking for an existing Job: - This feature allows you to allocate a Resource to an
existing Job/Task.  Under a ‘Resource’ column click on the time where you wish to start
the Allocation and ‘Right Mouse’.  Select ‘New Booking for an existing Job’.  In the
presented panel select a Job Order and click the ‘OK’ button.  (If the Job contains more
than one Task you will be required to select the Task)   The Allocation will be added to this
panel in addition to adding the Resource to the Job Task.

New Booking from Copy: - This feature allows you to allocate a Resource to an existing
Job/Task by copying an existing allocation.  You should first go to the Job Task that you
wish to copy and ‘Right Mouse’ then select ‘Copy Booking’.  You should then under the
under the ‘Resource’ column click on the time where you wish to start the copied
Allocation and ‘Right Mouse’.  Select ‘New Booking from Copy’.   The Resource will be
added to the Job Task in addition to the Allocation appearing in this calendar.

Display Today’s activities: - This feature shows the display commencing with the system
date.   Simply ‘Right Mouse’ and select ‘Today’.

Go to Date: - This feature shows the display commencing with your selected date.  You
also have the option to select a Day, Week, Month, or workday calendar display format. 
Simply ‘Right Mouse’ and select ‘Got To Date’.

Resource Layout Editor: - This feature allows you to restrict the display to selected
Resources.  Note: if you exit and return to the Job Calendar the selections are lost.. If you
wish to retain previous settings then add a Department Code to the Resource (Employee
or Asset) record.  In the Job Calendar you can filter by ‘Department’.  This filtering will be
retained (by User) when you exit the Calendar.

Resources per Page: - You can select the number of Resources that is to be displayed.
If the number is greater than the maximum allowed by Ostendo then you the display will
remain at that maximum.  However you will see a scroll-bar and other options appearing at
the bottom of the Calendar.

Having created the Allocation you can amend it as follows

Open Job Task: - Go to the Allocation and ‘Right Mouse’.  If you select ‘Open Task’ then
the Task screen for the selected Job will be displayed.  You can make changes to the
Task as required.

Open Job: - Go to the Allocation and ‘Right Mouse’.  If you select ‘Open Job’ then the
Detail screen for the selected Job will be displayed.  You can make changes to the Job as
required.

Open Resource Assignments: - Go to the Allocation and ‘Right Mouse’.  If you select ‘
Open Resource Assignments’ then a panel will be presented that shows all resources
assigned to this Job

Set Task Status: - Go to the Allocation and ‘Right Mouse’.  If you select ‘Set Task Status’
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you have the option to define the status of the Task (Open, Closed, In Progress, or On
Hold).  The line colour of the Allocation in the Calendar will change to reflect the status

Set Task Tracking Code: - Go to the Allocation and ‘Right Mouse’.  If you select ‘Set
Task Tracking Code’ you have the option to select the current Tracking Code.  (Tracking
Codes are maintained via Jobs>Settings>Job Tracking).  If the selected tracking has a
linked colour code then the Allocation in the Calendar will be filled with that colour.

Set Resource Status: - Go to an Allocation and ‘Right Mouse’.  If you select ‘Set
Resource Status’ you have the option to select a Status icon.  Having selected the Status
you will see that the associated Icon will appear in the Allocation.

Delete Booking: - Go to an Allocation and ‘Right Mouse’.  If you select ‘Delete Booking’
you will be asked to confirm the action.  Upon acceptance the Allocation will be deleted
from both the Calendar and the Job.

Copy Booking: - This allows you to copy an Allocation and associate the copy to another
Resource (or even duplicate against this Resource).  For more info see ‘New Booking
from Copy’ above.

The Allocation Hint

You can create a ‘Hint’ that is displayed whenever the cursor is positioned over the activity.  The
content of this can be plain text or can include fields from the Job’s Header record.  For example:
The text could be

Customer = [CUSTOMER]
Phone = [ORDERPHONE]
Contact = [ORDERCONTACT]

When the cursor is positioned over the activity the following would be displayed

Customer = Jim Gold & Co Ltd
Phone = 44 312 587 6544
Contact = Ken Jolly

The fields in the square brackets are those defined in the JobHeader table.  To see the available
fields go to General>Reports>Full Listing of Tables and select JobHeader

3. The Calendar Panel

To the right of the Calendar View are 3 Calendar Months.  This is the default display.

3.1. Number of Months

You can view more months by dragging the Calendar Panel boundary left/right/up/down to let you
view the desired months.  

3.2. Days to View Selection

Within the calendar month you will see the following:

Active Days: Any Days that contain a Job Task will be in Bold. Clicking on this day will bring up
that day in the Main Panel.  Note: If the View is restricted to specific Resources (see later in this
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tutorial) then this highlighting reflects that selection.

View Days: If you drag the cursor over a few days then release, the Main Panel will immediately
reflect the selected time-span.

4. Main Panel

 The Main Panel shows all scheduled Job Tasks for each day displayed.  The tasks on display can
be viewed:

· For single or multiple Employees and/or Assets 
· Grouped by Resource within Date, Date within Resource, or Jobs by Date 
· In Daily, Workday, Weekly, Monthly, or user-selected time periods 
· With a horizontal Timeline 
· Filtered by Customer, Project, Job Type, Job Order, or Department 

4.1. Create New Jobs

You can create new Job Orders from within the Calendar in one of two ways:

New Job From Selected Time: As described above

New Job From Start Time: Go into a timeslot under a Resource and right click then select ‘New
Job From Start Time’ from the list.  A panel will appear for generation of a new Job with a start
date prefilled with the Timeslot Start-date and assigned to this Resource.  Simply select the
Customer and (if necessary) amend the ‘Estimated Duration’ then click the ‘Create’ button to
generate the Job.  The generated Job/Task will immediately appear in the Calendar View.

4.2. Timescale

You can amend the timeslots of the visible panel by going to the scale down the left-hand side and
clicking the ‘right mouse’.  The scale options are:

5 Minutes
6 Minutes (0.1 Hour)
10 Minutes
15 Minutes
30 Minutes
60 Minutes

For the purpose of this tutorial leave this at 30 minutes

4.3. Tasks that span more than one day

If a Task spans more than one day the following will apply

Begins today - The panel will have a ‘clock’ icon on the left showing the start time of the
Task
Ends Today - The panel will have a ‘clock’ icon on the right showing the end time of the
Task
Begins Earlier and ends Later than today - The panel will appear above the timeslots
with no ‘clock’

Also, the Task Status (as described in 2 - above) is also displayed as a thin coloured ‘band’ to the
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left of the Timeline.  

 You may wish to try these by going into the Job you created above (Jobs>Job Orders) and click
on the ‘Jobs Tasks’ button and amend the Task duration in the presented panel to (say) 12 Hours
then return to the Job Orders screen.   Now click on the ‘Job Booking’ Button and then click on
the ‘Clear Booking’ button to remove the previous schedule.  Enter a start date/time in the upper
part on this screen and click the ‘Calculate End Date and Time’ button.  Finally click on the ‘Book
In’ button and return to the calendar

4.4. Task Details

To look at the Task Details either:

· Double click on the Task, or
· Right Click on the Task and select ‘Open Task’

The Job Tasks Details screen will be presented.  In this screen you can:

· Add new Tasks 
· Remove current Tasks 
· Amend the Start Time, End Time and/or Duration of the Task 
· Amend the Resource allocated to the Task 
· Add another Resource or delete the current assigned Resource 

 
Try making some changes.  

4.5. Other Task Activities

You may wish to try the following activities related to a Task

Drag and Drop:  You can drag a Task and drop:
· Against another Resource 
· In the same Resource but to another timeslot 

Amend Timeline: You can amend the timeline against a Task by dragging the Start or End
boundary and dragging it to the Required Time

Parallel Tasks: You can assign Parallel Tasks to a Resource and they will appear side-by-side in
the Main View

Multiple Resources per Task: If you double click on the Task to bring up the ‘Job Tasks’ screen
you can click on the ‘Task Resources’ tab in the lower part of the screen and add another
Resource.  If you then return to the Calendar then the Task will be displayed against both
Resources.   If you move one Resource’s Start and End time for a Task then all other Resources
involved with that task will also move.

5. Jobs Not Booked In Panel

In preparation for progressing through this panel you should carry out the following:

Go into Jobs>Settings>Job Rules and amend the values against fields:
‘Default Duration Scale’ to read Hours
‘Default Estimated Duration’ to read 1
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Go into Jobs>Settings>Task Names and add a Task Name of (say) JobTask.  Make this
Task Name the default Task by clicking on the ‘Set Default’ button.

Finally go into Jobs>Job Orders and create a Job Order.  Whenever a Job Order is created it
is given the above Default Task.  You will see this if you click on the ‘Job Tasks’ button in the
Job’s ‘Detail’ panel

Note the number of the Job that you have just created.

Go back to the Job Calendar (Jobs>Job Calendar) and look in the ‘Jobs Not Booked In’ panel.
This panel shows all the Jobs that have been generated in Ostendo but have not yet been ‘
Booked In’.  You should see the Job Number that you have just created.  

A Job must be ‘Booked In’ before it is scheduled and added to the Main Panel.

 Go to the Job you have just created and either:
· ‘Right Click’ and select ‘Book In’, or
· Double Click on the Job

This action will bring up a ‘Booking In’ panel.  This panel contains a display only area showing
details on the Job.

You will see a field called ‘Job Start’.  This is prefilled with the Jobs date and time.  You can
amend this if required.  

Initially the Task line across the centre of the screen will have no Start Date/Time and End
Date/Time information.  However, if you click on the ‘Calculate Job End Date and Time’ button
the program will apply the Job duration to the calendar (set up in General>Settings>Work Times)
to arrive at an end Date and Time.  

Click on the ‘Book In’ button and the Job will be added to the Calendar. You will see on the Job
Calendar that:

· The Job appears against ALL Resources and each contains an exclamation mark Icon.  The
reason for this is that we have not yet allocated a Resource to the Job, and this is what we
will do now.

· You may also find that the duration goes over 1 hour (the Task Default time).  The reason
for this is that the General>Settings>Work Times could encompass (say) a lunch break

To allocate the Job to a specific Resource ‘right click’ on the mouse and select the Resource from
the drop-down list under ‘Assign to Resource’

6. Toolbar and Other Options

All the Toolbar Buttons can be turned on or off by selecting the drop-down to the right of the
Toolbar and selecting ‘Add or Remove Buttons’.  Let’s have a look at each button in turn

6.1. Print

You can output the current view to your screen (Preview) prior to printing or print directly to a
selected printer.  Try printing it back to your screen

6.2. Email

The drop-down list provides the following options
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XLS - Generates an XLS (spreadsheet) from the displayed information and then opens up
the Emailing routine on your PC with this XLS document as an attachment
HTML - Generates an HTML format and displays this in the ‘body’ of the generated email
XML - Generates an XML document, which can be called and displayed as a standard
Web form.    It also creates an XSL document showing the source document from the
displayed information.  The program then opens up the Emailing routine on your PC with
the XML and XSL documents attached.
CSV - Generates an CSV (Comma Separated Value) document from the displayed
information and then opens up the Emailing routine on your PC with this CSV document as
an attachment

 6.3. Export

This function provides the following options

XLS -  If this is selected then a panel will appear for you to save the current displayed data
as an Excel Spreadsheet.  You may then call up Excel and manipulate the data as
required.
HTML - If this is selected then a panel will appear for you to save the current displayed
data as an HTML file.  This file can then be called and displayed as a standard Web form
using your Browser.
XML - If this is selected then a panel will appear for you to save the current displayed data
as an XML file.  Two files are created.    

· An XML document that can be called and displayed as a standard Web form using
your Browser. 

· An XSL document showing the source document  
This file can then be called and displayed as a standard Web form using your Browser.
CSV - If this is selected then a panel will appear for you to save the current displayed data
as a Comma Separated Value file.  This can be used as an import format to external
systems.   You may also call up the CSV file in Excel (File Type = .csv) and manipulate the
data as required.

6.4. New Job Order

This will bring up the standard Job Order creation panel.

6.5. Resources

This option allows you to configure how the Resources are displayed.  Try each one and see the
result

Group By: The Main Panel display will change to reflect the selection from

· None - All Jobs (not showing Resources) for above Calendar View
· Resource - Display will be Date within Resource for above Calendar View
· Date - Display will be Resource within Date for above Calendar View

Resource Layout Editor: ‘Check’ the Resources that you want to appear on the Main Panel and
use the ‘Up’ or ‘Down’ buttons to defined the order in which they are to be displayed.

Resources per page: Enter or select the number of Resources you wish to be visible on the Main
Panel.  Note: At the bottom left of the Main Panel are scroll arrows that lets you scroll left or right to
view all Resources.
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Employee and/or Asset: Check either (or both) Resources (Employee or Asset) to select if they
are to appear in the Main Panel

6.6. Views

This option enables you to select a view that changes the way you look at the current Jobs:

Display Period Options: Enables you view the Timeline in various formats such as
Days - Shows Resource requirements for current Day 
Workdays - Shows Resource requirements for the days identified as a workday in the
current week as set up in General>Settings>Work Times. 
Weeks - Shows Resource requirements for current week 
Months - Shows Resource requirements for current Month 
Timeline - Displays the daily Resource requirements in a horizontal format 

Go to Date - Brings up a panel for you to enter the date to display 

View Position - You can select whether to have the ‘Calendar’ and ‘Jobs Not Booked In’ Panels
appear on the left or right of the screen. 

6.7. Screen Calls

These options enable you to call related screen whilst still working with the Calendar View.  The
screens are:

· Job Orders
· Customers
· Employees
· Project
· Tracking Codes
· Call Centre

6.8. Filter By

Clicking on this button allows you to select the specific filter.  The Main Panel display will then
restrict the display to that selection.  The selection options are:

· Customer 
· Project 
· Job Type 
· Job Order 
· Department 



94 Ostendo Tutorials

22 Job Calendar Info panel

With this feature you can construct your own information about the Job Task in the Jab Calendar
screen.  This information is displayed whenever the cursor is passed over the Task.  You can
include open format text in addition to any field from the Job Header record

This is how it works

1. Available Fields

All fields in the Job Header record are available for inclusion in this Info panel.  To get a list of
available fields go to General>Reports>Full Listing of Tables and select JobHeader.  Print the
document.   Armed with this document you can now construct the Information Text

2. Job Types

The Information Text is specific to the Job Type.  This allows you to (for example) specify the
Customer Asset ID for a Service Style Job, etc.   If you go into Jobs>Settings>Job Types you will
see a field called ‘Calendar Info Hint’.  It is in this ‘Memo’ field where you set up the text.  In this
example we will set up an Info Text that will show the Customer, Phone Number and Primary
Contact.  Select a Job Type and key in the following text:

Customer = [CUSTOMER]
Phone = [ORDERPHONE]
Contact = [ORDERCONTACT]

The identities within the square brackets are the actual field names taken from the JobHeader
table.  The remaining text is open format.  Save the changes and then go into the Job Calendar (
Jobs>Job Calendar).  If you move the cursor over the Job Task the info panel will be displayed
and the Job-specific information will be presented.

3. Enlarge the display panel

The panel by default will fit the Text to be displayed.  You can make this larger by adding an extra
line to the text comprising of (say) the underscore.  In this instance the above Info text will be
entered as

Customer = [CUSTOMER]
Phone = [ORDERPHONE]
Contact = [ORDERCONTACT]

                ____________________________________________
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23 Mail Merge

You have the option to print a document from within Ostendo whereby ‘User-defined’ source data
can be merged with a Word document to produce printed forms with data from both sources

In this guide we will create a letter to be sent to certain Suppliers.  The Letter contains a
combination of data fields from Ostendo and user Text.  In our example we will produce the
following letter

To <Company Name>
<Address Line 1>
<Address Line 2>
<Address Line 3>

Dear <Primary Contact>

  This is my test document for merging.

Regards

Step 1.  Extract the Supplier Data

Go into File>Reporting Configuration>Report and View Developer.   Click the ‘Add’ button and,
in the creation screen, ‘check’ the ‘Analysis’ Radio Button and enter ‘Suppliers’ in the ‘Name’ field

On the presented ‘Master Settings’ tab:
· Select ‘Purchasing’ from the drop-down against Category

· Against ‘Merge Word Document’ enter a document name (Example: SuppLetter) that
will become the Merge Template Document.  Note: use the 3 dots to generate the full
path

· Against ‘Merge Data File’ enter a file name (Example: SuppSource) that will become the
Merge Source Data.  Note: use the 3 dots to generate the full path

Now enter a query in ‘Master Query’ that will extract the data you wish to use.  For example

Select SUPPLIER, SUPPLIERADDRESS1,  SUPPLIERADDRESS2,
SUPPLIERADDRESS3, PRIMARYCONTACT from SUPPLIERMASTER

Also enter a Supplier From and To parameter as follows

From Supplier;SUPPLIERMASTER.SUPPLIER >= :FSUPPLIER
From Supplier;SUPPLIERMASTER.SUPPLIER <= :TSUPPLIER
Both linked to Code Type 1001

‘Save’ the entries

Step 2.  Run the Analysis and create the Data Source

This step will create the extracted data format from which the Merge Template can be created. 

Click the ‘Preview’ button to produce an Analysis View of the extracted data. 
Click on ‘Export’ on the top toolbar and select ‘Mail Merge’

This routine will generate your SuppSource data file containing the data displayed in the Analysis
View.
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The first time through you will also get a message stating ‘File Not Found.  Make sure the file
path is correct’.  This is because the Word document to print the information has not been
created yet.  That is the next step. 

Step 3.  Create the Document and link to the Data Source

This step will create the Document using Microsoft Word and link to the generated fields in the
extracted SuppSource file. 

Go into Microsoft Word and create a new document and ‘Save’ it as SuppLetter in the path that
you identified above.

Click on ‘Tools’ on the top toolbar within Word and select ‘Mail Merge’.  A panel will appear into
which you should carry out the following steps.

Step 3.1.  Click the ‘Create’ button and select ‘Form Letters’
Step 3.2.  On the displayed panel select ‘Active Window’

Click on ‘Get Data’ button and then on the Open Data Source option and point it the
SuppSource document that you generated above.   A panel will appear asking you to
define what the Field and Record delimiters are.  Select the following

Field Delimiter - , (I.e. A comma)
Record Delimiter - (enter)
Click the ‘OK’ button

Step 3.3.  On the presented panel click the ‘Edit Main Document’ button.

You have now linked the document to the data source.  The next step is to select the data fields
and place them on the document.

Step 4.  Constructing the Merge Document

This step will create the Document using Microsoft Word and link to the generated fields in

In the new document that you have just generated you will notice that a new toolbar called ‘Mail
Merge’ appears at the top of the screen.  In that Toolbar click on the ‘Insert Merge Field’ and you
will see the field names in the SuppSource file.

Type in the word ‘To’ followed by a space on the first line.  The position of the cursor now defined
where the first ‘merged field will appear.  
From the ‘Insert Merge Field’ select field ‘SUPPLIER’.  Your document should now look like this

To << SUPPLIER>>

Complete the remainder of the document using a combination of typed words and linked Data
Fields to produce the following

To <<SUPPLIER>>
<<SUPPLIERADDRESS1>>
<<SUPPLIERADDRESS2>>
<<SUPPLIERADDRESS3>>

Dear <<PRIMARYCONTACT>>

  This is my test document for merging.

Regards

 then ‘Save’ the document
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Step 5.  Preview

You can preview the finished report by clicking on the ‘<<ABC>>’ button on the ‘Mail Merge‘
Toolbar and, using the right and left arrows on the same Toolbar, progress through all the
extracted records.  You have now created the SuppLetter document to use in conjunction with
the SuppSource file.  Close all documents and we will now see the full process flow 

Step 6.  Running the Merged document from within Ostendo

Go into Ostendo and select Purchasing>Views then select ‘Suppliers’.   

Click on ‘Export’ on the top toolbar and select ‘Mail Merge’ and you will be presented with the
Merge document as you created above.

If you click on the print icon you will print the design view that you currently see
If you click on File>Print you will print the merged details

You can also click on the ‘Merge’ button on the Merge Toolbar and print the merged details
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24 Multi-Site Inventory in Ostendo

Within Ostendo you can define multiple Sites.  You then have the option to
segregate Inventory by Site.  This segregation covers:

· Warehouses/Locations
· Replenishment Run
· Inventory Costs (Last, Average, Standard)
· Sales Orders
· Job Orders
· Assembly Orders
· Purchase Orders

This Tutorial will take you through the process of
· Setting up Sites
· Defining User/Site relationship
· Defining Item Site Settings
· Creating a Site-specific Stock Adjustment
· Looking at Sales, Assembly, Job, Purchase Orders by Site
· Running the Replenishment Process by Site
· Setting up Inventory Costing by Site
· Defining Account Mapping by Site

1. Setup
We will begin this Tutorial by setting up information so that multi-Site Inventory
can be carried out.  This covers:-

· Defining the Site(s)
· Link a User to a Site
· Associating Warehouses to Sites
· Defining Item Site details
· Setting up an Item Rule to Auto Create Item/Site Master Records

1.1. Defining the Sites

To create a Site click on General>Company Sites and add the Site(s) you will
use.  In this Tutorial we will have a Manufacturing Site (the normal 'Company' Site
in the DEMO Database) with a Spares-Sales Site.   Therefore, in addition to the
current 'Company' Site create a second Site called (say) 'Spares'.   

1.2. User/Site Relationship

You can default a User to a Site within the User Security settings.  Therefore go
into File>System Configuration>User Security and Options and create a User
called (say) 'Sales'.  In the 'User Options' tab link this User to Site 'Spares'. 
Note: If you do not wish the User to default to a single Site then this field should
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be left blank.

1.3. Warehouses within a Site

Let us now create a Warehouse containing a single location and link it to the '
Spares' Site.

Go into Inventory>Warehouses and create a new Warehouse called (say) '
Retail' and link it to Site 'Spares'.   Next go to Inventory>Locations and create a
location called (say) 'Pickface' and link it to Warehouse 'Retail'.

1.4. Item Site Settings

Having Identified the Site we will now create a couple of Items and their specific
Item/Site Parameters such as ROL, ROQ, Leadtime.  Therefore go into 
Inventory>Items and click on the ‘Add’ button then enter details to create a
couple of Items.
Against each Item click on the 'Related' Button and you will see two sub screens:-

· Item Site Settings: This allows you to set the Default Issue and receipt
Warehouse/Location for the Item.   Create Site Settings for the above
Items using the Warehouse/Location you created above.

· Item Site Master: This allows you to maintain Replenishment parameters
and Costs for this Item at the nominated Site.  Create a Site Master for
each the above Items and complete all fields

1.5. Auto Create Item/Site Master Records

Of course it would be a lot easier if you could get Ostendo to create the Item Site
Master records automatically.  This can be achieved by going in to 
Inventory>Settings>Item Rules and 'checking' the 'Auto Create Item/Site
Master Records' checkbox.

2.  Inventory Transactions

We will now look at the impact Site-specific Inventory has across Ostendo.  This
will cover:

· Inventory Adjustments
· Orders (Sales, Assembly, Job, Purchase)
· Site to Site Transfers

2.1. Inventory Adjustment

Let us begin by creating stock in the 'Company' Site.  Go to Inventory>Inventory
Adjustments and create a new Adjustment Batch.  Click on the 'Lines' tab and '
Add' a new line.  In the 'Item Code' field select the Item that you created above in
1.4.  You will note that as you have not created an Item/Site record for site '
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Company' it will default to the system-level Warehouse/Location as defined in the
Item Master record.   Enter a quantity of (say) 100 then go back to the 'Detail' tab
and 'post' the Adjustment

Now let's do the same at the 'Spares' Site level.  The first step is to sign in to the '
Spares' Site (Hint: This is held against the User Name record used to sign into
Ostendo.  I.e. Section 1.2. above).   As before, go into Inventory>Inventory
Adjustments and create a new Adjustment Batch then click on the 'Lines' tab
and 'Add' a new line.  In the 'Item Code' field select the Item that you created
above.  You will note that Site's Item/Warehouse/Location will automatically
populate the relevant fields. Enter a quantity of (say) 10 then go back to the '
Detail' tab and 'post' the Adjustment

2.2. Site Specific Orders

We will look at how Orders are raised against a Site.  

This process already happens in that whenever you raise an order (Purchase,
Sales, Job, or Assembly) the Order Header record contains the originating Site. 
The next question is where does it get the Site information from?   This comes
from the Site Name against the User who created the Order (see 1.2. above).  If
that User does not have a Site Name held against it then the Default Company
Site (as held in the System Settings) will be used.

In this example we will create a Sales Order although the process equally applies
to Job, Assembly and Purchase orders.

You may wish to restrict the User to only look at Orders for their Site.  To do this
go into File>System Configuration>System Screen Conditions and set up the
following record covering Sales Order

User Name: 'Sales' as set up in 1.2.
Screen: Sales Orders
Filter Condition: Enter the following SITENAME = 'Spares'

You will now find that User 'Sales' will only see Sales Orders that are related to
Site 'Spares'

Create the Sales Order in the usual manner and add Sales Lines using the Items
you created in 1.4.   You will now find that when issuing lines from stock the
Warehouse/Location is automatically pre-filled with the Item's Site Settings.  As
before, you can amend this if required.

2.3. Transfer Items from another Site

When transferring Inventory from one Site to another we need to also keep track
of what is in transit between the Sites.  In this exercise we will transfer stock from
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the 'Main' Warehouse at the 'Company' Site to the 'Retail' Warehouse at the '
Spares' Site.    The following steps will be carried out

· Setting up a Transfer 'In Transit' Warehouse/Location
· Transfer from Source Site
· Receipt into User's Site

2.3.1. Setting Up an 'In Transit' Warehouse

Create another Warehouse and Location as described in Section 1.3 and link this
to the 'Company' Site.  We now need to establish a relationship whereby when
we transfer Inventory from the 'Company' Site to the 'Spares' Site it resides in this
interim Transfer Warehouse.  Therefore go to Inventory>Settings>InTransit
Defaults.  Add a record with the following data:

From Site:- 'Company'
To Site:- 'Spares'
InTransit Warehouse:- The Warehouse you have just created
InTransit Location:- The Location that you have just created

2.3.2. Create a Transfer Batch and transfer from 'Company' Site

Go to File>Switch User and sign in as 'ADMIN' (I.e. related to 'Company' Site)

Go to Inventory>Inventory Transfer and create a new Transfer Batch.  In the '
Detail' screen select 'Site Transfer' under Transfer Style and also select 'From
Site' ('Company') and 'To Site' ('Spares').

In the 'Lines' tab add the Item(s) that you created in 1.4. with a quantity of 1

Go back to the 'Detail' tab and click the 'Transferred to InTransit' button.

If you now click on the 'Related' button and select 'Inventory Availability' you will
see, for the Item, that the quantity has been transferred to the 'In Transit'
Location.

2.3.3. Receive from 'In Transit'

Go to File>Switch User and sign in as 'Sales' (I.e. related to 'Spares' Site)

Go to Inventory>Inventory Transfer and locate the Transfer Batch.  In the '
Detail' tab and click the 'Transferred from InTransit' button.

If you now click on the 'Related' button and select 'Inventory Availability' you will
see, for the Item, that the quantity has been transferred from the 'In Transit'
Location to this site's location.

3.  Inventory Replenishment
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This Tutorial focuses on Inventory Replenishment at a Site where the Inventory is
replenished by inter-site transfer.  (For more detail on the whole subject of
Replenishment in Ostendo see Help>Training and go to 3. Inventory
Control>Inventory Replenishment.)  

For Site Inventory Replenishment we will cover the following:
· Identifying where Site is replenished from
· Identifying Items to be Replenished (Transferred) from another Site
· Running Inventory Replenishment by Site
· Creating the Transfer Batch against the Source Site
· Transferring from the Source Site
· Receipt into User's Site

 
3.1. Replenishment Site

We are going to run Inventory Replenishment for the 'Spares' Site and transfer
some of the Inventory from the main 'Company' Site.  This means that Site '
Company' will transfer stock into a Transit area and Site 'Spares' will receive that
stock from the same transit area.  You have already established this relationship
in exercise 2.3.1.

3.2. Amend Sourced-By to read 'Transfer'

We now need to tell Ostendo which Items at the 'Spares' Site are to be
transferred (rather than Purchased or Assembled).  Therefore go back into the
Item Site Master screen (refer back to 1.4.) for the above Item and amend the '
Sourced By' to read 'Transfer'.  Whilst you are in this record enter the following
information:

· ReOrder Level = 1000
· ReOrder Quantity = 2000

Save the record.  This will force the Replenishment Run to generate a Suggested
Transfer record for this Item when we run the Replenishment Routine in the next
step.

3.3. Replenishment Routine

To generate the Transfer requirement let's start by running the Replenishment
Routine for the 'Spares' Site.  Therefore go to Requirements>Inventory
Replenishment

Inventory Replenishment gives you two options:

Single Level MRP: This focuses on nominated Items and addresses the
Item’s current actual and/or forecast future demands to create Suggested
Orders required to maintain stock.  This option is generally used in the
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Wholesale/Retail/Stockists environment.

Multi-Level MRP:  In addition to looking at the current actual and/or
forecast future demands for each Item this option also looks to see if the
Item is a Parent in a Bill of Material and, if so, will ‘explode’ any Suggested
Orders to determine the components required to make it.  These are then
used as ‘Suggested Demands’ when assessing component requirements.
This option is generally used in the Manufacturing environment.

We will use the Single Level MRP option to show how the Replenishment
Routine can be Site specific

Click on the 'Specific Site' checkbox and then select the Site 'Spares' from the
drop-down in the adjacent field.  If you now run Replenishment you will see that 
all Items have been run.  You should note:

· All Items will be included in the Replenishment Run because we haven't
stated otherwise in the Item Selection Options area.

· If the Item does not have Site-Specific parameters (EOL, EOQ, Leadtime,
etc) then those held against the Item Master will be used.

· The Demand (Sales, Assembly, and Job Orders) and Supply (Assembly
and Purchase Orders) are those linked to the selected Site

Confirm and select the 'Suggested' quantities then click on the 'Accept
Replenishment Results for selected Items' button.  This will make these records
available in the next step

3.4. Create Required Orders

To create the Transfer Batches go to Requirements>Create Required Orders
and select 'Transfers' from the drop-down under field 'Display Requirements For'.
Upon clicking the 'OK' button you will see those Items which require to be
Transferred.  Select the lines and then click the 'Generate Orders for Selected
Requirements' button.
If you now go to Inventory>Inventory Transfer you will see that a transfer batch
has been generated by Ostendo.  This can now be processed as described
above

4.  Inventory Costs

You can maintain Inventory Costs at either Company or Site level.  If you are
going to maintain at Site Level then do the following

4.1. Defining Item Costs by Site

To set Inventory costing at Site level go to Inventory>Settings>Item Rules and
'check' the 'Cost By Site' checkbox.  By doing this you will find that Ostendo will
automatically generate Item/Site Cost records for all Items in all Sites within the
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current database.  

4.2. Manually Maintaining Costs

Now go to Inventory>Items and, for any Item click on the 'Related' Button and
select 'Item Site Master'.  You will see that an Item/Site record will have been
created for each Site.  In the first instance each Item Site Detail record is prefilled
with data from the Item Master record.   For Item/Site Cost maintenance you can
amend the Site-specific Cost here or you can let Ostendo do this for you as
described in the next paragraph.  Full Site Cost History is visible by clicking on
the 'Cost History' tab in this 'Item Site Master' screen.

4.3. Automatic Update of Item Site Costs

Let's look at what happens in Ostendo when receiving an Item at a Site level.
Ensure that you are currently signed on as User 'Sales' (I.e. Site 'Spares')

Go into Inventory>Inventory Adjustments and create a new Adjustment header
record.  In the 'Lines' tab add one of the Items you created above and select
Warehouse 'Retail' and Location 'Pickface'.  Enter a quantity of 1 and enter a
receipt Adjustment Cost.  If you now post the Inventory Adjustment Batch two
things will have happened.

Item/Site Cost:  Go into the Item Master record and then to the Item Site
Master record and select Site 'Spares'.  You will see that the Item's Cost
for this Site has been updated.  Click on the 'Cost History' tab to see each
history record.
Item Cost: Go into Pricing>Item Costing and select the Item.  You will
see that the Cost is also maintained at Company level

5. Account Mapping

Standard Mapping across the Company is defined in File>Financial
Configuration>Cost Centre Mapping.  This comes prefilled with existing Cost
Centres when you install Ostendo.  Of course you can amend these by clicking
on the drop-down against each entry.

If you wish to have specific Site Mapping then you should first create the relevant
Cost Centres by going into General>Cost Centres and create Cost Centre
Codes specific to Site (For example SPARES-STOCK).

Now go into File>Financial Configuration>Cost Centre Mapping By Site and
create the mapping for Site 'Spares' by linking the Transaction Type to the Cost
Centre Code you have just created.  Note: When processing in Ostendo if a
Site-specific Cost Centre Mapping does not exist then the Standard Company
Mapping relationship will be used.
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In Ostendo you have the option to further break down the Sales and Labour
Mapping by Site by going into File>Financial Configuration>Sales Mapping
Matrix and File>Financial Configuration>Labour Mapping Matrix respectively
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25 New Company field checks

This describes the mandatory and optional steps required immediately after installation and prior to
using each functional area

1.  Upon installation

1.1.  Mandatory

Sign On as ADMIN with password pass

File>System Configuration>System Settings - Set up:-
Company Information

· If you wish to amend default company site then first add it to General>Company
Sites

· If you wish to amend the Units of Weight, Length, and Volume then create them
first via General>Settings>Standard Units

Start Numbers for various Modules and Documents
On ‘Network’ tab check appropriate Radio Button

File>Financial Configuration>Tax Code - Enter your home Tax code and set as ‘Default’

File>Financial Configuration>Tax Groups - Ostendo has a default Tax Group that is
automatically copied to Items, Descriptors, Customers, and Suppliers when those records are
created.   Unless you are using multiple Tax Groups and Tax Matrices to derive variable Tax Rates
by Customer/Supplier -v- Items/Descriptors it is recommended that you do not adjust this single
entry.

File>Financial Configuration>Tax Matrix - A single Tax Matrix is already set up in Ostendo to
link the Default Tax Code to all Customer/Supplier -v- Items/Descriptors relationships.  You can
create your own specific relationships if a different Tax Code is used

File>Financial Configuration>Credit Terms - Define all the Credit Terms (Yours and your
Supplier’s) and set the system default

File>Financial Configuration>Cut-Off Days - Adjust the Cut-off days as required

1.2.  Optional

File>Financial Configuration>Cost Centre Mapping - If you wish to amend the base mapping
then you should first create the Cost Centres via General>Cost Centres

File>Financial Configuration>Aging Periods - Adjust the periods as required

File>Financial Configuration>Statement Periods - Adjust the periods as required

File>Reporting Configuration>Specific Email Text - If you are sending Forms / Quotes / Orders
/ Invoices / etc via email then you may wish to review the current email Text and adjust as required

File>System Configuration>User Security and Options - Although the default Admin / pass is
already set up you may wish to amend the password (File>Change Password) to make
Administration rights more secure.  Having done that you may wish to consider entering other
Users (either individuals or departments).

General>Settings>Standard Units - Units are used throughout Ostendo to define the Unit of
Measure of Items, Descriptors, and Labour.  You should assess which Units you require and add
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them here.

General>Company Sites - You have the option to locate Warehouses and Company Assets by ‘
Site’ within the current logged-on Company.  If you are going to use multiple sites then create them
now before going into the Company Assets or Warehouse screens

2.  Company Assets

If you are going to record and maintain Company Assets then the following should be set up 

2.1.  Mandatory

No Mandatory entries required

2.2.  Optional

General>Settings>Asset Types - Each Asset can be grouped by Type for reporting and analysis
purposes.  You should assess which Asset Types you require and add them here.

General>Settings>Departments - You can record the Department where the Asset is located.
This is used for reporting and analysis purposes.  

General>Company Sites - You can record the Company Site where the Asset is located.  This is
used for reporting and analysis purposes.  

3.  Knowledge Base

If you are going to use the Knowledge Base function then the following should be set up 

3.1.  Mandatory

General>Settings>Article Types - Each entry is categorised into Article Types (such as FAQ,
How To, etc).  You should assess which Article Types you require and add them here.

General>Settings>Article Categories - Each entry is categorised into Article Categories (such as
General, Product, Service, etc).  You should assess which Article Categories you require and add
them here.

4.  CRM

If you are going to use the Customer Relations Management function then the following should be
set up 

4.1.  Mandatory

Labour>Employees - To assign Calls and schedule Activities you need to establish ’Employees’.

4.2.  Optional

Labour>Contacts - If you wish to link calls to specific Customer and Supplier Contacts then these
need to be set up.  You should note that Customer and Supplier Contacts added here are also
visible against the respective Customer/Supplier records.
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CRM>Settings>Call Classification - If you are using the Call Centre then each Call can be
allocated a Call Classification.  Although this is not mandatory it is useful when analysing Calls. 

CRM>Settings>Call Sub Classification - If you are using the Call Centre then each Call can be
allocated a Call Sub-Classification within the above Classification.  Although this is not mandatory
it is useful when analysing Calls. 

CRM>Settings>Call Resolution Code - Once a Call is closed it can optionally be allocated a
Resolution Code for analysis purposes. 

5.  Labour

The Labour function allows you to maintain all aspects of Labour Charges and Costs in addition to
being a centralised area for recording Employee Timesheets for all Order Types

5.1.  Mandatory

Labour>Settings>Labour Rules - Set the Rules that apply to Labour Bookings

Labour>Labour Codes - If you plan to charge Labour and/or monitor Labour/Employee Costs
then this must be set up.  Labour Codes are used to plan Labour times, charges and costs against
an Assembly or Job Order whereas the actual times, charges, and costs are made by Employees. 
Create your Labour Codes representing the Standard Charge and Cost Rates for carrying out
work.   Whist in this screen the ‘Special Rate Details’ button allows you to have different Charge
Rates by Rate Level.  This Rate is used for all Customers that have this Rate level linked to them.

5.2.  Optional

Labour>Settings>Rate Levels - A Labour Code can contain a single - system-wide - Charge
Rate.  You can, however, identify a special charge rate specific to a group of Customers using a ‘
Rate Level.  If you will be using Rate levels then create them here.

Labour>Settings>Rate Scales - Whenever an Employee makes a Timesheet Booking a ‘Rate
Scale’ is also required to denote at what Rate Scale the Employee should be charged (single time,
double time, etc).  The system is supplied with a single Rate Scales record (single time) and this is
set as the default.  If you charge a employee out at other rates then these should be created here.

Labour>Employees - Before you can create Employees the following should have already been
created:

· General>Settings>Departments - Allows scheduling of Resources by Department
· Labour>Labour Code - Links a default charge rate against the Employee

In addition to simply creating an Employee you can (by selecting the ‘Labour Codes’ tab) identify
different Fixed and Variable Overhead charges whenever this Employee is booked against the
Labour Code line.

Inventory>Settings>Categories - This is not a mandatory entry (against Labour Codes) but
Categories allow you to segregate the included records for reporting and analysis purposes.

General>Analysis Groups - Analysis Groups are used across Ostendo to facilitate viewing and
reporting by Group.  The Labour Code record contains this field.  If you are going to use this
feature then you should first establish the Analysis Groups

General>Settings>Departments - You can record the Department to which a Labour Code is
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associated.  This is used for reporting and analysis purposes.  

File>Financial Configuration>Tax Groups - Ostendo has a single (default) Tax Group that is
automatically copied to Labour Code when these records are created.   Unless you are using
multiple Tax Groups and Tax Matrices to derive variable Tax Rates by Customer/Supplier -v-
Items/Descriptors/Labour Code it is recommended that you do not adjust this single entry.

Service>Warranty Definitions - If you are offering Warranty whenever a Labour Code is used on
a Job then this is stored against the Labour Code record.  Warranty records should first be defined
using this File>Financial Configuration>Tax Groups - Ostendo has a single (default) Tax Group
that is automatically copied to Labour Code when these records are created.   Unless you are
screen

6.  Inventory

All users will use the Inventory module to a greater or lesser degree.  This includes Inventory Stock
Control and Descriptor Maintenance.

6.1.  Mandatory

Inventory>Settings>Categories - Although this is not a mandatory entry (against Items or
Descriptors) it is highly recommended that - because of its extensive use in Analysis, reports,
Financial Mapping, etc - it is addressed here and made mandatory in Item and Descriptor records.
 

6.2.  Optional

Inventory>Settings>Sub-Categories - This is not a mandatory entry (against Items) but
Sub-Categories allow you to segregate the included records for reporting and analysis purposes. 

Inventory>Settings>Adjustment Types - Adjustment Types are used to identify the Type of
stock movement being carried out.  The base system already contains some Adjustment Types.  If
you don’t wish to use these defaults then it is preferable to amend these before any transaction are
carried out

Inventory>Settings>Item Rules - The base Ostendo contains a default Warehouse and Location
that is copied to all Item records when they are created.  Amend this to suit your preference if you
have created you own Warehouse/Location

Inventory>Warehouses - If you are using Warehouses (as ‘checked’ in File>System
Configuration>System Settings) then you should create the Warehouses here and denote which is
the default Warehouse.  In creating a Warehouse a ‘Site’ should be entered.  Sites are maintained
via General>Company Sites

Inventory>Settings>Location Groups - If you are using Locations then you can (optionally)
categorise then into groups (Example: Raw Materials, Oils, Hazardous Goods, etc).  This
facilitates reporting and analysis by these groups. 

Inventory>Locations - If you are using Locations (as ‘checked’ in File>System
Configuration>System Settings) then you should create each Location within each Warehouse and
denote which is the default Warehouse/Location. 

General>Cost Centres - A Descriptor is linked to a Cost Centre for accounting purposes.  If
nothing is entered against the Descriptor record then the default in the Cost Centre Mapping
screen will be used.  You should note that Descriptors are used for many purposes such as:
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· Kitset headers
· Task Bill Headers
· Purchase Order Freight
· Purchase Order ‘Other’ charges
· etc

You can override the default by creating a definitive Cost Centre and applying it as required to
Descriptors

Pricing>Settings>Pricing Groups - Pricing Groups are used to facilitate ‘Batch Update’ of Sell
prices using screen Pricing>Batch Price Update.  If you are going to use this feature then you
should establish the Pricing Groups and associate each Item and/or Descriptor to the Group

General>Analysis Groups - Analysis Groups are used across Ostendo to facilitate viewing and
reporting by Group.  Both the Item and descriptor records contain this field.  If you are going to use
this feature then you should first establish the Analysis Groups

7.  Pricing

A base Sell price is held against an Item or Descriptor and that price is used is no other price
exists.  The Pricing function allows you to define prices at a Pricing Level and then associating the
Pricing Level to Customers

7.1.  Mandatory

Pricing>Settings>Pricing Level - Within the Pricing function you establish Item and Descriptor
Sell Prices by Pricing Level.  These Pricing Levels are attached to Customer records. 

7.2.  Optional

Pricing>Settings>Pricing Groups  - A Pricing Group is associated with Items and Descriptors to
facilitate Batch Price updates by Pricing Group. 

8.  Requirements

The Replenishment function has a routine that gathers all demands for Items and suggests supply
orders to satisfy the demand.  

8.1.  Mandatory

Requirements>Settings>Replenishment Rules - The Replenishment process uses default
parameters each time it is run.  You can amend the default run parameters here if required.

8.2.  Optional

No Optional settings

9.  Purchasing

The Purchasing function includes setting up Suppliers and then processing Purchase Order
through receiving and Supplier Invoice validation  
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9.1.  Mandatory

Purchasing>Settings>Purchase Rules - Prefilled with base settings.  You should check these
and ensure that they apply to this installation

Purchasing>Settings>Purchase Types - Defines the Types of Purchase order that can be
raised.   This is prefilled with a base setting.  You should check this to ensure that it applies to this
installation

9.2.  Optional

Purchasing>Settings>Supplier Types - The Supplier Type is attached to a Supplier record when
creating the Supplier.   This table is prefilled with a single base setting that is identified as the
default Supplier Type.  You should ensure that it applies to this installation and adjust if necessary.

Purchasing>Settings>Supplier Region - The Supplier Region is used for reporting and analysis
purposes and can be attached to a Supplier record.   

Purchasing>Settings>Supplier Code - The Supplier Code is used for reporting and analysis
purposes and can be attached to a Supplier record.   

Purchasing>Settings>Supplier Shipping Method - The Shipping Method is for information
purposes only.   

Purchasing>Settings>Purchase Tracking Codes - These are user-defined and facilitate manual
tracking of Purchase Orders.

Labour>Employees - A Supplier and Purchase Order can (optionally) have an associated ‘Buyer’.
Buyers are created in Labour>Employees and flagged as ‘This Employee is a Buyer’

10.  Assembly

The Assembly function is focused on manufacturing products for stock.

10.1.  Mandatory

Assembly>Settings>Assembly Rules - Prefilled with base settings.  You should check these and
ensure that they apply to this installation

Assembly>Settings>Step Names - If ‘Steps’ are required as entered into the Assembly Rules
panel then create the steps that are normally used.  A default step is in the base Ostendo.  

10.2.  Optional

Assembly>Settings>Assembly Tracking Codes - These are user-defined codes and facilitate
manual tracking of Assembly Orders.

11.  Sales

The Sales function is focused on selling products from Stock.
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11.1.  Mandatory

Sales>Settings>Sales Rules - Prefilled with base settings.  You should check these and ensure
that they apply to this installation

Sales>Settings>Sales Types - Defines the Types of Sales orders that can be raised.   This is
prefilled with settings supplied with the base system.  You should check this to ensure that these
apply to this installation

General>Settings>Quote Lost Reasons - If you make quotations then - whenever a Quote is lost
- you are required to enter a Lost Reason Code.  Some codes are in the base system but you may
wish to add your own.

File>Financial Configuration>Payment Accounts - If you make Bank Deposits for a batch of
payments then you need to define the specific accounts here.  Individual payment receipts are
linked to this account and displayed for selection in the ‘Bank Deposits’ screen

11.2.  Optional

Sales>Settings>Customer Types - The Customer Type is attached to a Customer record when
creating the Customer.   This table is prefilled with a single base setting that is identified as the
default Customer Type.  You should ensure that it applies to this installation and adjust if
necessary.

File>Financial Configuration>Tax Groups - Ostendo has a single (default) Tax Group that is
automatically copied to Items, Descriptors, Customers, and Suppliers when those records are
created.   Unless you are using multiple Tax Groups and Tax Matrices to derive variable Tax Rates
by Customer/Supplier -v- Items/Descriptors it is recommended that you do not adjust this single
entry.

File>Financial Configuration>Credit Terms - Prefilled with the system default Terms.  If the
Credit Terms are not in the drop-down list then set it up via this screen 

Sales>Settings>Customer Shipping Method - If you are recording Shipping Methods plus
charging and/or monitoring Costs then these should be recorded here.

Sales>Settings>Customer Shipping Method - If you are recording Shipping Methods plus
charging and/or monitoring Costs then these should be recorded here.

Sales>Settings>Customer Region - The Customer Region is used for reporting and analysis
purposes and can be attached to a Customer record.   

Sales>Settings>Customer Code - The Customer Code is used for reporting and analysis
purposes and can be attached to a Customer record.   

Labour>Employees - A Customer and Sales Order can (optionally) have an associated ‘
Salesperson’.  These are created in Labour>Employees and flagged as ‘This Employee is a
Salesperson’.

Sales>Settings>Lead Source - The Lead Source is linked to a Customer record.  If you wish to
analyse Customers by lead Source then the source type can be maintained here.   

Pricing>Settings>Pricing Level - Within the Pricing function you can establish Item and
Descriptor Sell Prices by Pricing Level.  These Pricing Levels are attached to Customer records. 
Ensure that all pricing Levels have been established for your Customer base 
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Labour>Settings>Rate Levels - A Labour Code can contain a single - system-wide - Charge
Rate.  You can, however, identify a special charge rate specific to a group of Customers using a ‘
Rate Level’.  Ensure that all Rate Levels have been established for your Customer base

Sales>Settings>Invoicing Groups - You can selectively generate Invoices and/or Statements for
Customers belonging to an Invoicing Group.  If you are going to use this feature then these Groups
need to be defined here.

Sales>Settings>Statement Cycles - You can selectively generate Statements for Customers
belonging to a common ‘Statement Cycle’ code.  If you are going to use this feature then these
codes need to be defined here.

Sales>Settings>Sales Tracking Codes - These are user-defined codes and facilitate manual
tracking of Sales Orders.

Sales>Settings>Contract Categories - If you are generating recurring Invoices then you can
allocate the covering Contract into a Contract Category.  If you are analysing Contracts by
Category then create those Categories here.

File>Financial Configuration>Payment Methods - For receiving Customer Payments and
Deposits you can optionally identify the source method.  These methods are maintained via this
screen.

12.  POS

The POS function provides for quick order entry, picking and billing using standard Point of Sale
functionality such as barcode scanning Cash Register monitoring, and end of day functions

12.1.  Mandatory

File>Financial Configuration>Payment Methods.  You should define the different types of
payment methods that you are going to use in POS  (Example: Cash, Credit Card, Cheque, etc)
along with any rounding factors that may apply.

Sales>Customers: Create a Customer (Example: ‘Cash Sales Customer’) that will be used the
default Customer to be displayed in the POS screen

General>Company Sites: All POS Stations are linked to a Company Site.  Therefore create at
least one Company Site

POS>Settings>POS Stations.  All POS transactions are recorded to the POS Station where they
were transacted.  Create at least one POS Station

Labour>Employees:  You need to identify an Employee as a POS Operator and also define other
options relating to POS

POS>Settings>POS Rules.  Review the current settings and amend as required.  

12.2.  Optional

File>Financial Configuration>Payment Method Denominations   You would normally have a
Payment Method called ‘Cash’.  For end-of-day processing you can count the quantity of each
denomination and Ostendo will evaluate the total vale in this denomination. 
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Barcodes.  The Point of Sale function accepts Barcodes directly into the Order Line or any of the
Search functions.  

Descriptors  To enter Barcodes against Descriptors go into Inventory>Descriptors and enter
the barcode into the ‘Barcode’ field
Items:  This is used against Items that don’t have sub-level variations (Batch Number, Expiry
Date, etc) or you do not wish to differentiate down to that level.  To enter Barcodes against
these Items go into Inventory>Items and enter the barcode into the ‘Barcode’ field.  
Items with variations:  For Items that have variations such as Unit of Measure, Batch
Number, Colour, etc. you can enter a barcode specifically related to the combination.  To do
this go to Inventory then, in the drop-down list under Items select Item Barcodes.  Select the
Item(s) that have sub-level variants and go to the ‘Detail’ view.  You can now enter the specific
Barcode for the exact combination of variants.
Serial Numbers:  Note:  For Items that are Serial Number Controlled it is not necessary to
enter a bar code as described above.  The reason for this is that a Serial Number Barcode is
attached to a single Item/Serial Number when it is received into stock.  Ostendo therefore
knows the sub level variations (if any) that are attached to this specific receipt.  Simply
scanning the Serial Number will enable Ostendo to recognise the Item and its variants.

13.  Service

The Service function is focused on maintaining and servicing Customer Assets or equipment.

13.1.  Mandatory

No Mandatory settings

13.1.  Optional

Service>Settings>Customer Asset Types - Each Asset can be grouped by Type for reporting
and analysis purposes.  You should assess which Asset Types you require and add them here.

Service>Settings>Confirmation Text - If you are sending Service Reminders via email you
should consider setting up a common email Text message here.  

Service>Warranty References - If you offer Warranty against your Goods and Services then you
should create the Warranty records here.  

14.  Jobs

The Jobs function is focused creating Orders that address carrying out a Service or a series of
Tasks.  This style of Order is used for both Service and Maintenance activities and Construction
and Contracting

14.1.  Mandatory

Jobs>Settings>Job Rules - Prefilled with base settings.  You should check these and ensure that
they apply to this installation

Jobs>Settings>Job Types - Defines the Types of Job Orders that can be raised.   This is
prefilled with settings supplied with the base system.  You should check this to ensure that these
apply to this installation

Jobs>Settings>Task Names - Tasks are required against Jobs.  A default Task is already set up
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in the base Ostendo.  You should assess if you will be using more Tasks and enter them here.

Labour - Jobs uses all the functions under the ‘Labour’ heading (section 5) so that section should
also be addressed.

Company Assets - The Jobs area also uses Company Assets (section 2) in the Job allocations
and scheduling area so Company Assets should also be addressed.

General>Settings>Work Times - A standard working week should be defined here.  This forms
the basis upon which Resource Scheduling is carried out and also the display of the Shop
Calendar.

14.1.  Optional

Jobs>Settings>Project Types - If you are maintaining Project then you can (optionally) link the
Project to a Project Type.  This allows you to group Projects for reporting and analysis purposes. 
You should assess which Project Types you require and add them here.

Labour>Employees - When creating a Project you can nominate a Project leader.  This Leader
comes from the list of Employees created in this screen

Jobs>Settings>Job Tracking - These are user-defined codes and facilitate manual tracking of
Job Orders.

Jobs>Settings>Job Categories - This is not a mandatory entry (against Job Orders) but
Categories allow you to segregate the included records for reporting and analysis purposes.

15.  Others

File>System Configuration>System Alerts - Assess the pre-defined Alerts and ‘check’ the ones
that are applicable.  These should be allocated a Severity level and pointed to a User Signon Code
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26 Order Inventory Availability

The Order Availability function in Ostendo assesses current stock levels to see which orders can
be satisfied in part or in full.  Additional option is given when receiving Purchased goods to carry
out this assessment taking into account the current receipt.  To begin this short tutorial go into 
Requirements>Order Inventory Availability and enter the following parameters

1.  Run Parameter options

1.1.  Order Priorities

The first step is to define the priority sequence of Orders.  Allocations will be made in accordance
with this priority.  You can identify up to three priority levels.  The first priority Level is the main
priority sequence; the second is the priority within the first sequence, and so on.  The available
options against each Priority level are:

None - No priority sequence
Required Date - The Order Required Date
Order Date - The Date the Order was raised
Customer Priority - The Priority (1 to 9) defined against the Customer master
Order Priority - The Priority Number (1 to 9) defined against the Order
Order Started - Orders whose status is ‘In Progress’ come first

1.2.  Orders and Status Inclusions

In addition to defining the Priority you can also restrict/include Sales Orders, Job Orders, or
Assembly Orders.   By default all the Orders with status Open and In-Progress are included but
you can also include Planned, On Hold, or Quote

1.3.   How to fill Orders

The next step is to define how you want to process available stock against the above selected
orders.  Three options are available

Partial Fulfilments: For each stock Item progressively allocate where there is a demand
until all demands are satisfied or available stock has been consumed.
Full Order Fulfilment : All lines in the Order are checked to see if any line in the order
cannot be fully satisfied.  If so then no lines in the Order will be allocated stock
Order Full Delivery Flag - This is combination of the previous two in that if the Order is
flagged as ‘Full Delivery’ and any line cannot be fully satisfied then none of the lines in that
Order will be included.  Orders not flagged as ‘Full Delivery’ will be treated as ‘Partial
Fulfilments’

1.4.  Other Parameters

Demand Up To Required Date: This denotes that all selected orders whose Required Date is
equal to, or earlier than, this date will be included.  

Restrict to Site: You can restrict the Order Availability run to all stock at a given Site.  

Restrict to Purchase receipt: This option allows you to focus only on those Items in a specific
Purchase receipt (in addition to current stock levels for those Items).  

2.  The Process

Ostendo will generate a list of all included Orders up to the ‘Demand Up to Required Date’
parameter and sort them into the required priority sequence.
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The first Order in the prioritised list is addressed as follows.

If the Fulfilment style is ‘Partial Fulfilments’ then the first Item in the Order is matched against the
available stock and either the demand is satisfied or the available stock has been consumed.  The
available stock against the Item record is reduced by this amount in preparation for matching
against the next demand.  The allocations continue with the next Line in the Order until all lines
have been addressed.  

If the Fulfilment style is ‘Full Order Fulfilment’ then all Items in the Order are checked to see if
there is sufficient stock to fully satisfy all lines.  If:

· There is sufficient stock then the allocations are made.  The available stock against each
Item record is reduced by this amount in preparation for matching against the next
demand.  

· There is insufficient stock then no allocations are made against any line and the process
continues with the next Order in the priority list.

If the Fulfilment style is ‘Order Full Delivery Flag’ then the Order is checked to see if the ‘Full
Delivery’ flag is checked and:

· If it is ‘checked’ then the allocation conforms to the ‘Full Order Fulfilment’ process
· If it is not ‘checked’ then the allocation conforms to the ‘Partial Fulfilment’ process

The next Order in priority sequence is then addressed in the same way until all orders have been
processed.

3.  The Results

A results screen is presented which provides information about the Order Allocation run.  You
should note that these evaluations are recommendations only and no update of the database has
taken place.

3.1. Availability Results

The front screen displays the results of the Allocations in the same priority sequence that the
process was carried out.   Each line in this screen represents an individual Order.  Most of the
fields in each line are display only.  I.e.

Seq No: A sequence number generated by the Order Availability Generate run
Order Class: Displayed options are Sales Order, Job Order, or Assembly Order
Order Number:  The Order Number within the Order Class.
Available:  Denotes if Stock is available in relation to the Allocation Policy
Required Date:  Required Date of the Order.
Order Date:  Date the Order was raised.
Order Status:  Current status of the Order.
Line Count:  Number of Lines in this Order.
Shortages:  No of lines that could not be fulfilled by this Order Allocation run.
Customer Priority: The ‘Priority’ number taken from the Customer master record
Delivery No: Delivery No if this is a Sales Order with ‘Delivery’ Style.

The following two fields are prefilled with the results of the Order Allocation run.  You have the
option to make changes and re-run the Order Allocation process if required

Order Priority: This is the current Order Header priority.  You can change this against any
line and rerun the Order Allocation process.  Note: This change will also update the
current Priority against the Order Header.
No Shortages Allowed:  This checkbox shows whether the Order allows shortages or if it
must be ‘Full Delivery Only’.  You have the option to ‘check’ or ‘uncheck’ this box before
rerunning the Order Allocation routine
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3.2. Order Lines

You can select a line from the above ‘Availability List’ panel and drill down to look at the content of
the Order.  There two panels and all fields are display only

Upper panel

Line No: The Line Number within the Order.  If the Item is within a Kitset or Task Bill then
this is the Line Number of the Kitset or Task Bill shown in the lower panel.
Code: The Item Code applicable to this line. 
Description: Description of the Item Code
Unit: The base Unit of Measure applicable to this Item Code. 
Order Qty: The quantity - in the base unit of measure - ordered for this line. 
Remaining Qty: The quantity yet to be delivered from this order line
Total Allocated: The quantity allocated by the Sales Allocation run
Shortage Qty: The quantity short (Remaining Qty - Total Allocated) for this Line
Stock Availability: The calculated Free Stock after higher Priority allocations have been
taken into account
Receipt Availability: The calculated Free Stock after higher Priority allocations have been
taken into account from a specific Purchase Receipt reference
Stock Allocation: The quantity allocated to this line from Inventory stock
Receipt  Allocation: The quantity allocated to this line from a Purchase receipt reference
On-Hand Qty: The current total On-Hand quantity in stock

Receipt Qty: The total quantity in the Purchase receipt reference
Parent Code: If this Line is contained in a Task Bill Code or Kitset Code then Code
Identity will be displayed here.  Note: The Task Bill Code or the Kitset Code will be
displayed in the lower panel

Lower panel

This panel shows all the Descriptors, Labour Codes, Task Bill Codes, and Kitset Codes that are
also included in the Order

Line No: The Line Number within the Order.  
Code Type: The type of line.  The displayed options are Kitset Code, Task Bill Code,
Labour Code, or Descriptor Code
Code: The specific Code related to the Code Type
Description: Description of the Code
Unit: The Unit of Measure applicable to the Code. 
Order Qty: The quantity ordered for this line. 
Remaining Qty: The quantity yet to be issued to this order line

3.3.  Action the Results

Across the centre of the ‘Results’ screen you will see an action bar containing two buttons.  These
allow you to carry out the following actions;

‘Release Orders’ button: If you click on the drop-down list you can select the action that you wish
to be carried out.  You will be asked to confirm the action after which the selected 'Available' Order
will be adjusted accordingly.  The options available from the drop-down list are:

Jobs - Change 'Open' Order status to 'In Progress'
Assemblies - Change 'Open' Order status to 'In Progress'
Delivery Orders - Generate Delivery Batches
Counter Sale Orders - Change 'Open' Order status to 'In Progress'
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Print: If you click on the drop-down list you can select the documents that you want to be printed.
You will be asked to confirm your selection after which the documents for the selected 'Available'
Orders will be printed.  The options available from the drop-down list are:

Job Sheets - Not Printed - Print selected Job Sheets that have not yet been printed
Job Sheets - All - Print all selected Jobs Sheets
Assembly Sheet - Not Printed - Print selected Assembly Sheets that have not yet been
printed
Assembly Sheets - All - Print all selected Assembly Sheets
Delivery Picklists - Not Printed - Print selected Delivery Picklists that have not yet been
printed
Delivery Picklists - All - Print all selected Delivery Picklists
Counter Picklists - All - Print all selected 'Counter' Sales Order Picklists

3.4. Shortages

In addition to the ‘Results’ screen you can also view the ‘Shortages’ screen.  This screen shows
two panels.  The upper panel shows all Items where there is insufficient stock to satisfy the Order
Allocation demands.  

Upper Panel

Item Code: The Item Code that is shortaged. 
Description: Description of the Item Code
Unit: The base Unit of Measure applicable to this Item Code. 
First Shortage Date: The date against the Order where the cumulative allocated quantity
exceeded the current available quantity
Shortage Qty: The quantity - in the base unit of measure - short for this line. 
First Supply Date: The date of the first Supply Order - displayed in the lower panel - that
could satisfy this shortage
Supply Qty: The quantity scheduled to be received in the first Supply Order in the Lower
panel

Lower Panel

You can select any line in the upper panel and the data in this panel will change to show all current
Supply Orders with their quantities and due dates relating to the Item..

Order Class: The Order Class of the Supply Orders.  This can be Purchase Orders or
Assembly Orders
Order Number:  Display only field showing the Order Number within the Order Class.
Required Date: The Required Date of the line within the Supply Order
Supply Qty: The remaining quantity to be received from the Supply Order
Supplier: If the Order Class is ‘Purchase orders’ then the Purchase order number will be
displayed.
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27 Order Matrix Dimensions

A time-consuming activity in Order Entry occurs where Items with similar attributes are being
added when each Item - along with its attribute - must be added to the Order individually.  Anyone
who works with Clothing, Shoes, Sports Goods and similar products knows the inherent
complication of dealing with large numbers of products that are similar but need to be tracked
separately.  For example, a garment could have 8 colours in 7 sizes which results in 56 discrete
Items for inventory tracking purposes.  By managing this inventory effectively your organisation can
guarantee time savings, cut costs and increase opportunities to generate revenue.

A Matrix Order Entry function streamlines the management of Sales Orders and enables a user to
quickly enter order quantities for items with similar attributes.  Traditionally this has been used in
the Apparel Industry where the user simply calls up a Garment Style and enters Order Quantities
against each Colour and Size combination into an Order Matrix from which Sales Order lines are
immediately populated with individual Item Codes representing the Style/Colour/Size and Sell
Price.  However it can equally apply to any Product which has similar attributes such as 'Screws'
which have various lengths and diameters, or Wood Panels which have predefined Length and
Width

Ostendo takes this Matrix Order Entry function a step further in that:
· You can utilise the Matrix Order Entry against both Sales and Purchase orders
· It can be applied to 2 or 3 dimensional variants such as the Shoe having 'Fit' (Narrow,

Standard, Broad) in addition to Colour and Size, or the Screw having 'Condition'  (Bright Steel,
Galvanised Steel) in addition to Length and Diameter

· Ostendo does not restrict the Matrix to Item Codes only.  You can also create an Order Matrix
that equally applies to Descriptors.  For example you may have a 'Freight' Matrix which creates
Descriptor Lines based on Travel Zones and Freight method (Overnight, Airfreight, Seafreight,
etc).  

· In addition you always have the option of switching back and forth between the Matrix and
traditional order entry modes.

This Tutorial will show you how the Matrix Order Entry is set up and how it is used.  We will use the
current information set up in the DEMO Database.  Initially we will set up and use a Matrix of 'Bolts'
where we have a series of Bolts (Item Codes 200-2066 through to 200-2107) that have various
Diameters and Lengths.  We will then extend this matrix to include a 3rd variable (Bolt Type) to
include Item Codes 210-2132 through to 210-2149.

1.  Setting up the Matrix

Two steps are required (a) Define the Variables and (b) combine the Variables into a Matrix and
link each combination to a defined Item Code

1.1. Define the Variables

Go into Inventory>Settings>Matrix Dimensions and add a new record called (say) Diameter.

Click on the 'Values' tab.  For the purpose of this Tutorial we will restrict this to the following 3
values:

8mm
9mm
10mm
11mm

Add another record called (say) Length.  In the 'Values' tab add the following
50mm
75mm
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1.2. Define the Matrix

Go into Inventory>Matrices and add a new record containing the following

Matrix Style - Bolts
Matrix Style - select 'XY' from the dropdown list
Description - Add your own description
X Axis - Select Diameter from the dropdown list
Y Axis - Select Length from the dropdown list

In the 'Lines' tab add the following records

Code Type Line Code Unit Diameter Length
Item Code 200-2066 Each 8mm 50mm
Item Code 200-2067 Each 9mm 50mm
Item Code 200-2068 Each 10mm 50mm
Item Code 200-2069 Each 11mm 50mm
Item Code 200-2099 Each 8mm 75mm
Item Code 200-2100 Each 9mm 75mm
Item Code 200-2101 Each 10mm 75mm

Note: We have not added Item 200-2102 (Diameter 11mm and Length 75mm) to demonstrate
what happens within the Matrix during Order Entry if this combination has not been specified.

2.  Using the Matrix

We will now use the Matrix to create Sales order Lines.  Therefore go into Sales>Sales Orders
and create a new Order.  Click on the 'Lines' tab and then on the Matrices button in the Batch
Entry Bar

This will bring up a 'Batch Entry - Matrices' screen.  In that screen click the 'Add' button to create a
new Matrix line and add the following:

Matrix Style: From the drop-down list select Bolts
Required Date: The Order Lines created from this Matrix will use this date.  Amend as
required

You will see that the Diameters and Lengths specified for this Matrix Style will be displayed in the
lower part of the screen.  You should note that the Matrix Cell 11mm dia x 75mm Long has three
dashes in it to denote that this is not a valid combination

Go into the first cell (8mm x 50mm) and enter a quantity.  You will see that the column and row
count is maintained by the program in addition to the total Matrix Quantity in the upper part of the
screen.  Enter quantities in other cells as required.

If you now 'close' the 'Batch Entry - Matrices' screen you will see that the Sales Order is now
populated with the Item Codes and quantities 
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28 Order Progress - Inquiry View

This tutorial will take you through the process of setting up and maintaining an Inquiry View for
Assembly or Job Orders to display a status colour for the current Step or Stage.  Although these
Inquiry Views are already set up in Ostendo this tutorial shows you how they were created so that
you can amend them if required.

The process for Assembly Orders and Jobs are basically the same so in this tutorial we will go
through creating and maintaining an Assembly Progress Inquiry.

To see the Assembly Progress screen supplied with Ostendo go into 
Assembly>Inquiries>Assembly Order Progress.  This Inquiry screen shows Assembly Orders
along with their current status within the following rules:

· If the Order Status is ‘Planned’ then a description of the Order’s Status will be displayed
under a ‘Tracking Status’ column.

· If the Order Status is ‘Open’, ‘On-Hold’, or ‘Finished’ then a description of the Order’s Status
will be displayed under a ‘Tracking Status’ column along with a colour-code status shown
under the respective Order Status column. 

· If the Order Status is ‘In-Progress’ then a description of the Order’s Status will be displayed
under a ‘Tracking Status’ column.  In addition a colour-code status will be shown under a
column depending upon the following:

· If the Assembly Order has not been updated with the current Step then the status colour will
be displayed under the ‘In-Progress’ column.

· If the Assembly Order has been updated with the current Step then the status colour will be
displayed under the ‘Department’ column that is linked to the Step.

· If the Order Status is ‘Completed’ then the Assembly Order will not be displayed

Let us now go through the process of creating your own Assembly Progress Inquiry:

1.  The first setup step is to define Departments along with the sequence in which they will be
displayed in the Progress Inquiry.  Therefore, go into General>Settings>Departments and add a
couple of Departments.  For example:

Department ‘Machine’ Sequence 1
Department ‘Assembly’ Sequence 2

2.  The next setup step is to create the Step Names and link them to a Department.  Therefore go
into Assembly>Settings>Step Names and add two or three Steps.  For Example

Step ‘Lathe’ Department Machine
Step ‘Milling’ Department Machine
Step ‘Assemble’ Department Assembly
Step ‘Inspect’ Department Assembly

3.  The third setup step is to define the Tracking Codes along with their colours.  Go into 
Assembly>Settings>Assembly Tracking Codes and create (say) the following Tracking Codes.

Tracking Code ‘Queued’ Colour Coral
Tracking Code ‘Started’ Colour DarkCyan
Tracking Code ‘On-Hold’ Colour ForestGreen

4.  The next step is to create Assembly Order.  Therefore go into Assembly>Assembly Orders
and create an order for Item 1105-2184 (Handle Assembly).   In the created Order change the
status to ‘Open’ (if not already that status) then click on the ‘Routing’ tab and add Steps Lathe,
Milling, Assemble, and Inspect.  Save the 
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5.  Go into File>Reporting Configuration>Report and View Developer and click the ‘Add’
button.  Select the ‘Inquiry’ Radio Button and give it name of (say) ‘MyTutorial’ then click the ‘
Create’ button.  In the ‘Master Settings’ screen select ‘Category’ ‘Assembly’ and give it a title of ‘
My Tutorial’.

Copy and paste the following query to the MasterQuery#1 area

Select ordernumber as "Order_Number", itemcode as "Item Code", requireddate as
"Req_Date", WORKFLOWSTATUS as "Tracking_Status", 

case when (orderstatus = 'Open') then (case when (trackingcolour is null) then 16436871 else
trackingcolour end) else null end as "DISPLAYCOLOR_Open", 

case when (orderstatus = 'OnHold') then (case when (trackingcolour is null) then 16436871
else trackingcolour end) else null end  as "DISPLAYCOLOR_OnHold",

case when (((currentstepname is null)) and orderstatus = 'InProgress') then (case when
(trackingcolour is null) then 16436871 else trackingcolour end) else null end  as
"DISPLAYCOLOR_InProgress", 

case when (((currentstepname = 'Lathe') or (currentstepname = 'Milling')) and orderstatus =
'InProgress') then (case when (trackingcolour is null) then 16436871 else trackingcolour end)
else null end  as "DISPLAYCOLOR_Machine", 

case when (((currentstepname = 'Assemble') or (currentstepname = 'Inspect')) and orderstatus
= 'InProgress') then (case when (trackingcolour is null) then 16436871 else trackingcolour end)
else null end  as "DISPLAYCOLOR_Assembly", 

case when (orderstatus = 'Finished') then (case when (trackingcolour is null) then 16436871
else trackingcolour end) else null end as "DISPLAYCOLOR_Finished",

ITEMDESCRIPTION as "Item_Description",OrderQty as "Order_Qty", CompleteQty as
"Completed_Qty",sysuniqueid from AssemblyHeader order by 3,1

 
Note:

· The main thing to note is the statement "DISPLAYCOLOR_(ColumnName)". The
command ‘DISPLAYCOLOR’ tells Ostendo to show the colour of the Tracking Code rather
than the Tracking Code Name

· The first Case statement determines the tracking colour when the Order status is ‘Open’ 
· The second Case statement determines the tracking colour when the Order status is ‘On

Hold’ 
· The third Case statement determines the tracking colour when the Order status is ‘

InProgress’ and no Step Name has been entered against the Assembly Order
· The fourth Case statement determines the tracking colour when the Order status is ‘

InProgress’ and the StepNames linked to Department ‘Machine’ have been entered
against the Assembly Order

· The fifth Case statement determines the tracking colour when the Order status is ‘
InProgress’ and the StepNames linked to Department ‘Assembly’ have been entered
against the Assembly Order

· The sixth Case statement determines the tracking colour when the Order status is ‘
Finished’ 

Having copied the Query to the MasterQuery#1 area click the ‘Save’ button.  Now click the ‘
Preview’ Button to view the results.  You will see that the Assembly Order you created above will
have the default colour under column ‘Open’
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6. To see the process flow go back to the above Assembly Order and change the Tracking Code
to ‘Queued’.  If you re-run the Inquiry View then you will see the current Tracking Status under
column ‘Tracking Status’ and its colour under column ‘Open’

See what happens when you change the Assembly Order Status to ‘In Progress’ and have a
Tracking Code of ‘Started’
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29 Payments and Deposits

1. Introduction

This tutorial describes the Payment receipts process and covers:
· Recording Deposits
· Matching Deposits to Invoices
· Recording Payment Receipts
· Matching Payments to Invoices
· Reversing ‘matched’ Payments and Deposits
· Refunding a Payment

2. Recording a Deposit

A Deposit covers a payment against a Sales or Job Order and is usually an initial ‘Pre-Payment’ at
the time the Order is placed.   This will subsequently be matched against an Invoice once the
Invoice has been created

It is not necessary to have a Sales Order before taking the Deposit.  However in this example we
will create a Sales Order and then create a Deposit taken from that order   

Go into Sales>Sales Orders and click the ‘Add’ button.  In the presented panel select Sales Type
‘Counter Sales’.  From the drop-down list under ‘Customer’ select Customer ‘Azure Products
Ltd’ then click the ‘Create Order’ button.  

In the generated order click on the ‘Lines’ tab and add Item ‘5000-5002’ (LCD 19 inch Monitor). 
Take a note of the Sales Order Number then save and exit the Order.

Go into Sales>Customer Deposits and click the ‘Add’ button to create a new Customer Deposit
record.   select Customer ‘Azure Products Ltd’ then click on the drop-down under ‘Deposit for’
and select ‘Specific Sales Order’.   A field (Order No) will appear from which you can select the
Order Number you created above.  Enter a Deposit Amount and complete the remainder of the
screen then ‘Save’ the record.

We will come back to this Deposit later in this exercise.

3. Recording a Payment

A Payment covers the receipt of funds from a Customer in response to an Invoice.  The Payment
is recorded and then matched against the Invoice.

Go into Sales>Customer Payments and click the ‘Add’ button to create a new Customer
Payment record by selecting Customer ‘Azure Products Ltd’ and completing a Payment for an
amount of (say) $100 then ‘Save’ the record but stay in the Customer Payments screen.

We will now match the payment against Invoice(s)

4. Matching a Payment  to an Invoice

Let us begin by creating an Invoice.   Go into Sales>Sales Orders and select the Order that you
created above.  Go into the ‘Lines’ tab and select your Item ‘5000-5002’ (LCD 19 inch Monitor). 
In the lower part of the screen click on the ‘Picked Lines’ tab and then click the ‘Add’ button to
add a new line in this lower panel.  Single click in the Qty field and click on the ‘spyglass’ icon.  On
the presented screen enter a quantity of 1 against any Serial Numbered Line then click the ‘Save’
button.  Click the OK button to issue the Item and close the screen.  Whilst still in the Sales Order
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screen click on the ‘Invoice’ button then generate and print the Invoice.

Go back to Sales>Customer Payments and select the payment you received above then click
the ‘Apply to Invoices’ tab.  Click the ‘Auto Apply’ button to apply the payment to the first Invoice.
Click the ‘Update Selected Invoices’ to post the applied amount

5. Matching a Deposit to an Invoice

While still in Sales>Customer Payments click on the ‘Add’ button and create a new record.  From
the drop-down under field ‘Payment Style’ select ‘Use Customer Deposit’ then select the deposit
reference from the drop-down field that has just appeared to the right 
Now click on the ‘Apply to Invoices’ tab.  Click the ‘Auto Apply’ button to apply the deposit to the
first Invoice.  Click the ‘Update Selected Invoices’ to post the applied amount.

6. Reversing an applied Deposit or Payment

You may have applied the Deposit or Payment to the wrong Invoice(s).  In this instance simply go
into Sales>Customer Payments and select the Deposit or Payment containing the error.  If it is
not visible in the ‘List’ View then ‘check’ the ‘Include Fully Applied Status’ checkbox at the
bottom of the screen

Go to the ‘Detail’ tab in the selected record and click on the ‘History’ tab (half-way down the
screen).  Highlight the record in error and click the ‘Delete’ button.  This will create a reversed
journal in addition to amending the status of the Payment/Deposit to either ‘Received’ or ‘Partially
Applied’

7. Refunding a Payment

You can refund a payment that has been ‘posted’ using the following process.

The first step is to create a Credit Note for the refunded amount.    Therefore go into Sales>Direct
Invoicing and clicking on the ‘Add’ button.  On the displayed panel ‘check’ the ‘Create an Invoice
or Credit without an Order’ radio button and select a Customer from the drop-down against field ‘
Billing Customer’ then click the ‘Create’ button.  Enter the Header information then click on the ‘
Lines’ tab to enter a Descriptor line with a negative quantity.  Finally, click the print ‘Print’ button to
print the Credit.  

The next step is to create the Refund record.  Therefore go into Sales>Customer Payments and
create a Payment (Refund) record.  Enter the value of the Payment as a negative amount

The final step is to apply this Refund to the Credit (Note: NOT an Invoice)  Therefore click on the ‘‘
Apply to Invoices’ tab and apply this refund to the Credit Note you have just created by ‘checking’
the ‘Select’ checkbox against the Credit and keying in the Refund amount (as a negative value)
into ‘Applied Amount’ field

Finally, click the ‘Update Selected Invoices’ button.
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30 POS Workstations and Operators

Before you can begin with POS you are required to set up at least one POS workstation and one
POS Operator.

1.  Setting up a POS Workstation

To set up a Workstation in POS you first need to identify the name of your PC.  The easiest way to
do this is to click on POS>Point of Sale.  A panel will be presented that identifies your computer's
name.  Note it down.

The next step is to go to POS>Settings>POS Stations and click on the 'Add' button.  In the
generated line enter the following:

Computer Name: Enter the name you noted above.  Optionally you can click on the
drop-down list and find your computer through 'My Network
Places'

Station ID: Enter any Number (Example 1)
Description: Enter a brief Description of the station
Site Name: Select the Company Site from the drop-down list
Printer: From the drop-down list elect the printer where Receipts and

Invoices will be printed
Print To: From the drop-down list select the default output media
Receipt Form Name: From the drop-down list select the POS Receipt .fr3 file
Invoice Form Name: From the drop-down list select the POS Invoice .fr3 file
Default Sales Mode: For the purpose of this setup tutorial select 'Retail'
Default Float Value: Enter (say) 100
For now leave the remaining fields blank

You should now 'Save' the record

2.  Setting up a POS Operator

To identify a POS Operator in Ostendo you should go into Labour>Employees and add an
Employee record.  In the 'Detail' tab you should address the following fields:

Employee is a POS Operator:  'Check' this checkbox
Set Password:  Click on this to define the POS password for this Employee
Default POS Salesperson: select the Salesperson who will be linked to any sale made by
this Employee.  (Maybe used for Sales Commissions)
Can change POS Prices: 'Check' this checkbox if the POS Operator is allowed to amend
the Sell Price
Can change Sale Date: 'Check' this checkbox if the POS Operator is allowed to amend
the date the Sale was made.
Show the following related buttons: from the drop-down list 'Check' the functions that
this Operator can see in the POS Screen

You should now 'Save' the record

Having set up at least one POS Station and POS Operator you can now go into the Point Of Sale
routine by clicking on POS>Point of Sale and entering as the POS Operator with password.
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31 POS LayBy Cancellation

This short Tutorial describes the actions that should be carried out when a Customer Cancels a
Layby Order.  This includes

· Returning the Layby Item to Inventory
· Charging a Re-stocking fee
· Refunding payments made to date (with or without restock Fee)

A pre-requisite of carrying out this Tutorial is that you should already have knowledge of setting up
and creating POS Orders in Ostendo.

1.  Preparation

Go into Inventory>Descriptors and create a new Descriptor called (say) ‘Restock Charge’ with
the following information

Unit of Measure: Each
Description: Restocking Charge
Sell Price: $5

2.  Creating the Layby Order

Go into POS>Point of Sale and:
· Create a Layby Order
· Add a Line using (say) 1off Item 5000-1010 (Standard 101 Keyboard)
· Click on the ‘Pay’ button (or press F12)
· Make a partial payment of (say) $20

3.  Returning the Layby Item to Inventory

Recall the Layby POS order by clicking on the ‘Hold’ button (or pressing the F10 key) and
selecting the ‘Layby’ button.    Select the Layby Order and click the ‘OK’ button.  This will restore
the Layby Order back to the main POS screen.
Highlight the Line Item and click on the ‘Delete’ (F8) button.  This will return the Item back into
stock

4.  Applying a ‘Restock’ charge

Click on the ‘Add’ (F5) button and add the ‘Restocking Charge’ Descriptor you created above
with a quantity of 1.   Click on the ‘Pay’ button (or press F12).  There are two ways you can present
this next step:

4.1. Invoice to cover Restock Charge only

Upon entry to the payment screen you will see two payment lines.  
· The original Layby Payment
· The amount to be refunded

You can return the amount to be refunded then click on the F12 (Print) button and print an invoice
to cover the Restock Charge

4.2. Layby Receipt that includes the Restock Charge 
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Upon entry to the payment screen you will see two payment lines.  
· The original Layby Payment
· The amount to be refunded

If you highlight the refund line and then click the Delete (F8) button the line will be deleted but you
find that the fields at the bottom of the panel will reflect the change that is due.  If you now click on
the F12 (Print) button then you will see that a Layby Receipt will be printed which includes the
Restock Charge.
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32 Printing a linked image in a Report

This exercise will take you through creating a Report that will use the Item Master File and will
show you how to print linked Images from the Image Master File.  

1.  Preparation

You should go into Inventory>Items and select the Item Number that is to have the linked Image.
Click on the ‘Related’ Button and select ‘Item Images’ to add an image to the Item.   Note: You can
alternatively go to General>Image Management and create the link.

2.  Creating the Report

Go into File>Reporting Configuration>Report and View Developer

2.1.  Creating the Selection Criteria

Click the ‘Add’ button and create a new report (say) ‘Item Image Test’

Complete the fields in the upper part of the screen as follows

Include in Main Menu: ‘Checked’
Name: Prefilled with ‘Item Image Test’
Manu Order: Enter where you want it to appear under Ostendo Inventory ‘Reports’
Category: Select ‘Inventory’ from the drop-down list
Type: Prefilled with ‘Report’
Specific Screen: Leave Blank
Report File Name: Prefilled with ‘Item Image Test’

In the ‘Master Query’ area enter the following

select * from ITEMMASTER order by ITEMCODE

In the ‘Condition’ area enter the parameter

Item Code;ITEMCODE=:SCREENPARAM
Type = 1004

Click on the ‘Detail Queries’ tab and enter the following in Query#1

select * from IMAGEMASTER where IMAGETYPE = 
'Item' and LINKEDTO = :ITEMCODE
order by IMAGENAME

The above now provides a Parent (Item Number) to Child (Image) link with a selection parameter
that will allow you to select a specific Item Number.

2.2.  Creating the Report

Go into the ‘Master Settings’ tab click on the ‘Edit’ button (to the right of the screen).  A panel will
appear for you to select the Item Number.  Select the above Item and click the OK button.

On the presented panel select ‘Standard Report Wizard’ and click OK



131Printing a linked image in a Report

Go to the ‘Fields’ tab and move ItemCode and ItemDescription to the right panel.  Click the ‘Finish’
button

On the presented layout click on Report>Data on the top toolbar and ‘check’ the DD_1 checkbox.
 

Click on the ‘Insert Band’ icon   and select ‘Detail Data’.  A ‘Detail Data’ Band will be inserted
into the Report.  In the presented panel select DD_1.  Expand the band in preparation for inserting
the picture.

Click on the ‘Picture Object’ button    (down the left of the screen) and position it in the ‘Detail
Band then click the Green ‘tick’ symbol.  Resize the Picture and/or Band as required.

2.3.  Linking the Picture object to the Item

For the next step you need to have the ‘Object Inspector’ on your screen.  To display this go to
Views on the top toolbar then select ‘Toolbars’ and then ‘Object Inspector’

-  With the above ‘Picture Object’ selected you will see (on the left) that the field name is Picture1:
TfrxPictureView.   Under that are two tabs.  Select the ‘Properties’ tab and ‘check’ the ‘Stretched’
checkbox and uncheck the ‘Autosize’ checkbox

-  Now select the DetailData1 Band and you will see (on the left) that the field name is 
DetailData1: TfrxDetailData.   Under that are two tabs.  Select the ‘Events’ tab and in the field ‘
OnBeforePrint’ enter DetailData1OnBeforePrint

Finally, above the DetailData1: TfrxDetailData you will see a tab called ‘Code’.    In right hand
panel enter the following

Click on the ‘Code’ tab (To the left of the screen) and enter the following code.

procedure DetailData1OnBeforePrint(Sender: TfrxComponent);
begin
   if (<DD_1."IMAGEFILE"> <> null) and (trim(<DD_1."IMAGEFILE">) <> '') then
    begin
     DetailData1.visible := True;
     Picture1.loadfromfile(<DD_1."IMAGEFILE">);
    end 
   else
    begin
      DetailData1.visible := False;
    end;
end;

begin
  
end.

If you now click on the ‘Preview’ Icon on the top Icon Bar you should see the finished report.

2.4.  Items without an Image

The Report as it stands will only print those Items that contain an Image.  It is most probable that
you will also want to print those Items that don’t have an Image attached to then.  To achieve this
go into the Report Layout Edit screen and click on the 'MasterData1' Band.  Now refer to the
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Object Inspector (Properties) panel.  You will see a field called 'PrintIfDetailEmpty'.  'Check' that
field.
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33 Printing an Item with it's Properties

This exercise will take you through creating a Report that will use the Item Master File and will
show you how to print linked Properties from the Properties Master File.  

1.  Preparation

You should go into Inventory>Items and select the Item Number that is to have the Properties.
Click on the ‘Related’ Button and select ‘Item Properties’ to add Properties to the Item. 

2.  Creating the Report

Go into File>Reporting Configuration>Report and View Developer

2.1.  Creating the Selection Criteria

Click the ‘Add’ button and create a new report (say) ‘Item Properties Test’

Complete the fields in the upper part of the screen as follows

Include in Main Menu: ‘Checked’
Name: Prefilled with ‘Item Properties Test’
Manu Order: Enter where you want it to appear under Ostendo Inventory ‘Reports’
Category: Select ‘Inventory’ from the drop-down list
Type: Prefilled with ‘Report’
Specific Screen: Leave Blank
Report File Name: Prefilled with ‘Item Properties Test’

In the ‘Master Query’ area enter the following

select * from ITEMMASTER order by ITEMCODE

In the ‘Condition’ area enter the parameter

Item Code;ITEMCODE=:SCREENPARAM
Type = 1004

Click on the ‘Detail Queries’ tab and enter the following in Query#1

select * from ITEMPROPERTIES where ITEMCODE = :ITEMCODE
order by PROPERTYNAME

The above now provides a Parent (Item Number) to Child (Properties) link with a selection
parameter that will allow you to select a specific Item Number.

2.2.  Creating the Report

Go into the ‘Master Settings’ tab click on the ‘Edit’ button (to the right of the screen).  A panel will
appear for you to select the Item Number.  Select the above Item and click the OK button.

On the presented panel select ‘Standard Report Wizard’ and click OK

Go to the ‘Fields’ tab and move ItemCode and ItemDescription to the right panel.  Click the ‘Finish’
button
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On the presented layout click on Report>Data on the top toolbar and ‘check’ the DD_1 checkbox.
 

Click on the ‘Insert Band’ icon   and select ‘Detail Data’.  A ‘Detail Data’ Band will be inserted
into the Report.  In the presented panel select DD_1.  

For the next step you need to have the ‘Data Tree’ on your screen.  To display this go to Views on
the top toolbar then select ‘Toolbars’ and then ‘Data Tree’.  The fields should now display on the
right of your screen.  If the field List locate DD_1 and the Properties fileds will be displayed.   Drag
and drop the required fields into the Detail Data Band.

If you now click on the ‘Preview’ Icon on the top Icon Bar you should see the finished report.

2.3.  Items without an Image

The Report as it stands will only print those Items that contain Properties.  It is most probable that
you will also want to print those Items that don’t have Properties attached to then.  To achieve this
go into the Report Layout Edit screen and click on the 'MasterData1' Band.  Now refer to the
Object Inspector (Properties) panel.  You will see a field called 'PrintIfDetailEmpty'.  'Check' that
field.
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34 Quote, Order and Invoice Styles

Ostendo provides facilities for you to configure the Quote, Order and Invoice Styles.  These can
range from

· Using the standard forms provided
· Using modified forms
· Using modified forms specific to Customer/Suppliers
· Importing/Exporting Reports and Views

1.  Using Standard Forms

1.1.  Sales Quotations

Ostendo has 3 pre-defined Quote Styles using the Standard Forms.  The preferred style is defined
for Sales Quotes in Sales>Settings>Sales Rules

Formal: This shows all Line information along with each line’s Unit Price, quantity and extended
Price.  All this is summated into a single Quote Price.  No action is required to produce this Invoice
Style as it is the ‘base’ style provided with the system.  If you create a Sales Order and print the
Quote then it will be in the ‘Formal’ Style
 
Letter Style: This is in the form of a Letter that contains an introductory text (such as “Thank you
for giving us the opportunity….etc) followed by a single line showing the Quoted Price and ending
in a ‘footer’ Text (such as “This Quote is valid for a period of 30 days…..etc).  If you wish to use
this Style then you should carry out the following preparation steps.

Step 1.   Go into General>Frequently Used Text and make two entries to represent the
main letter content plus the summary content.  For example:

Name: Quote Header
Text/Phrase: Thank you for giving us the opportunity to make a Quotation. 
I’m sure that you will find our quoted price very competitive.

Name: Quote Footer
Text/Phrase:  This Quotation is valid for a period of 30 days from the above
date.  If you have any questions please feel free to contact us at any time.

Step 2.  Go into Sales>Settings>Sales Rules for Sales Quotes and address the following
fields

Default Quote Header Notes: Select the Quote Header you created above
Default Quote Footer Notes: Select the Quote Footer you created above
Default Quote Style: Select ‘Letter’
Default Quote Print Lines: Select ‘Print Single Line’
Default Quote Line Description: Enter (say) ‘Our Quoted Price is:’

If you now create a Sales Quote and print the Quote then it will be in the ‘Letter’ Style

Letter Style with Line Details: This is combination of both the Formal and Letter Styles.   Go into
Sales>Settings>Sales Rules and address the following fields

Default Quote Header Notes: Select the Quote Header you created above
Default Quote Footer Notes: Select the Quote Footer you created above
Default Quote Style: Select ‘Letter’
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Default Quote Print Lines: Select ‘Print Detail Lines’

If you now create a Sales Quote and print the Quote then it will be in the ‘Letter with Line Details’
Style

Note: At any time when printing the Quote from within the Sales Quote screen you can click on
the ‘Quote Opt’ button and select any of the above Style options and make it specific to that Quote

1.1.1.  Line Detail Print Options

If you are printing Line Details on the quote then you have the additional option to group selected
lines and print them in one of three ways.

· Print each Line within the Group
· Print Group Header and Footer in addition to lines within the Group
· Print Group Footer summary record with no Line Details

To see this in action you should first go to General>Settings>Analysis Groups and create (say)
the following Groups with the associated settings in the ‘Quote Form Grouping’ field.

Labour Group Totals Only
Material Header and Footer
Miscellaneous No Grouping

Create a Sales Quotation and add (say) 2 Labour Code Lines, 2 Item Code Lines, and 2 Descriptor
Lines.  In the Lines screen you will see a field called ‘Analysis Group’.  For each of the records
just created link them to the appropriate Analysis Group Code

If you now print the Quotation you can see the effect created by each option.

Note: The main Item, Descriptor, and Labour Code records contain field ‘Analysis Group’.  This
allows you to pre-allocate the Analysis Group, which is automatically copied to the Sales or Job
Quote.

1.2.  Job Quotations

As with Sales Quotes (above) Job Quotations use the same three options:
· Formal
· Letter Style
· Letter Style with Line Details

And the preferred option is defined in the Job Rules (Jobs>Settings>Job Rules).

The difference between Job Quotes and Sales Quotes is what is displayed in the Line Details and
this explained in the following two sections.

1.2.1.  Job Quotation - ‘From Schedule’ Style Job

A ‘From Schedule’ style Job Order uses an agreed quoted amount that is broken down into one
or more scheduled Invoices.  In this instance the Quotation will print the Invoicing Schedule rather
than the individual Lines that make up the Job.  To see this in action create a Job Quotation using
a Job Type whose Invoice Style is ‘From Schedule’

You can enter multiple lines to build up the Job Value or simply click on the ‘This is a Fixed Price
Job’ in the Job’s Detail screen and entering the Fixed Price.
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To create the Invoicing Schedule click on the ‘Invoices’ button on the Job Orders screen (or go to
Jobs>Job Invoices).  In that screen you can generate the planned Invoices to be raised against
the total Job Value.  Each Planned Invoice can be configured to show one of the following options

· Print the linked Descriptor and notes only
· Print the Linked Descriptor and notes with additional descriptive lines 
· Don’t print the Linked Descriptor but print additional priced descriptive lines 

Print the Quotation using each of the above options to see how the Quotation is presented when
using the ‘Formal’ and ‘Letter Style with Line Details’ Quote formats

One problem that could arise under this scenario is that you may wish to print the Job Order Lines
in a Quote prior to agreeing an Invoicing Schedule.  If you wish to create a Quote you should
(temporarily) amend the ‘Invoice Style’ to ‘From Actual Entries’.  Once the Quote has been
printed and you have NOT created an Invoice, you can revert the ‘Invoicing Style’ back to ‘From
Schedule’.  You can alternate between these two options until the first Invoice has been created.

1.2.2.  Job Quotation - ‘From Actual Entries’ Style Job

A ‘From Actual Entries’ style Job Order uses the Job’s planned Lines to evaluate an estimated
price.  Therefore the format is similar to that described against Sales Quotes.

One problem could arise under this scenario is that you may not have any ‘planned’ activities but
simply record ‘Actuals’ for billing purposes.  If you wish to create a Quote you should (temporarily)
amend the ‘Invoice Style’ to ‘From Schedule’ then create the details against a ‘Planned’ Invoice.
Once the Quote has been printed and you have NOT created an Invoice, you can revert the ‘
Invoicing Style’ back to ‘From Actual Entries’.  You can alternate between these two options
until the first Invoice has been created.

1.3.  Sales Order Acknowledgment

When printing the Order Acknowledgement you have the additional option to group selected lines
and print them in one of three ways.

· Print each Line within the Group
· Print Group Header and Footer in addition to lines within the Group
· Print Group Footer summary record with no Line Details

To see this in action you should first go to General>Settings>Analysis Groups and create (say)
the following Groups with the associated settings in the ‘Order Form Grouping’ field.

Labour Group Totals Only
Material Header and Footer
Miscellaneous No Grouping

Create a Sales Order and add (say) 2 Labour Code Lines, 2 Item Code Lines, and 2 Descriptor
Lines.  In the Lines screen you will see a field called ‘Analysis Group’.  For each of the records
just created link them to the appropriate Analysis Group Code

If you click on the ‘Print’ button to the right of the Order screen you now can print the Order
Acknowledgment and see the effect created by each option.

Note: The main Item, Descriptor, and Labour Code records contain field ‘Analysis Group’.  This
allows you to pre-allocate the Analysis Group, which is automatically copied to the Sales Order
Acknowledgement.
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1.4.  Sales Invoice

The Line printing options described in 1.1.1. for printing Sales Quotes also apply to Sales Invoice
Lines.    I.e. You have the additional option to group selected lines and print them in one of three
ways.

· Print each Line within the Group
· Print Group Header and Footer in addition to lines within the Group
· Print Group Footer summary record with no Line Details

To see this in action you should first go to General>Settings>Analysis Groups and create (say)
the following Groups with the associated settings in the ‘Invoice Form Grouping’ field.

Labour Group Totals Only
Material Header and Footer
Miscellaneous No Grouping

Create a Sales Order and add (say) 2 Labour Code Lines, 2 Item Code Lines, and 2 Descriptor
Lines.  In the Lines screen you will see a field called ‘Analysis Group’.  For each of the records
just created link them to the appropriate Analysis Group Code

If you now issue the Lines and print the Invoice you can see the effect created by each option.

Note: The main Item, Descriptor, and Labour Code records contain field ‘Analysis Group’.  This
allows you to pre-allocate the Analysis Group, which is automatically copied to the Sales Order

1.4.  Job Order Invoice

1.4.1.  Job Order Invoice - ‘From Schedule’ Style Job

As a ‘From Schedule’ style Job Order uses an agreed Invoicing schedule the Invoice print will
contain the details as defined against each Planned Invoice.    To create the Invoicing Schedule
click on the ‘Invoices’ button on the Job Orders screen (or go to Jobs>Job Invoices).  In that
screen you can generate the planned Invoices to be raised against the total Job Value.  Each
Planned Invoice can be configured to show one of the following options

· Print the linked Descriptor and notes only
· Print the Linked Descriptor and notes with additional descriptive lines 
· Don’t print the Linked Descriptor but print additional priced descriptive line

1.4.2.  Job Order Invoice - ‘From Actual Entries’ Style Job

A ‘From Actual Entries’ style Job Order uses only those ‘Actual’ bookings made against the Job.
The lines to be Invoiced can be grouped in a similar manner to that defined for Sales Invoices.  
I.e. You have the additional option to group selected lines and print them in one of three ways.

· Print each Line within the Group
· Print Group Header and Footer in addition to lines within the Group
· Print Group Footer summary record with no Line Details

To see this in action you should first go to General>Settings>Analysis Groups and create (say)
the following Groups with the associated settings in the ‘Invoice Form Grouping’ field.

Labour Group Totals Only
Material Header and Footer
Miscellaneous No Grouping
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Create a Job Order and add (say) 2 Labour Code Lines, 2 Item Code Lines, and 2 Descriptor
Lines.  In the Lines screen you will see a field called ‘Analysis Group’.  For each of the records
just created link them to the appropriate Analysis Group Code

If you now issue the Lines and print the Invoice you can see the effect created by each option.

2.  Using Modified Forms

The scenarios outlined in the previous section describe what can be achieved using the standard
forms in Ostendo.  Of course you may wish to modify the standard layout to include (say) your
company logo.  To do this you need to understand the basic process by which Ostendo gets the
modified forms

If you go into File>Reporting Configuration>Report and View Developer you will see that all the
reports are linked to ‘Level’ ‘System’.  These reports are provided by Development-X and you
cannot amend them.   If you wish to modify a Report or View then you must first copy the standard
report to your company folder (I.e. The Ostendo Company that you currently signed into).  You can
then modify the copied Report.  When Ostendo runs the Report it will first check if it exists in your
Company Folder and, if found, will use it.  If it is not in your Company Folder it will use the ‘System’
level report.  Let’s see this in action by copying (say) the Sales Invoice and then modifying that
copy.

Go into File>Reporting Configuration>Report and View Developer and click on the ‘Add’
button.  Click on the ‘Copy from Another’ Radio Button and select ‘Invoice’ from the drop-down
list under ‘Output to be copied’ then click the ‘Create’ button to copy it to your company folder.
(You may wish to go into Windows Explorer and go to where you have installed Ostendo.  Under
that folder you will see a ‘Reports’ sub-folder and under that another sub-folder for the Company.
You will see your copied report in that folder.)

If you now click on the ‘Edit’ button you can amend the copied report to your requirements

3.  Using Modified Forms specific to Customers/Suppliers

You may wish (for example) to have a specific Invoice layout whenever you send an Invoice to a
defined Customer or Customer Group.  To take advantage of this facility you can copy the existing
Report as defined in the previous section, amend as required, then save the Invoice as (say) ‘
InvoiceTrade’ somewhere on you PC

Go into File>Reporting Configuration>Specific Form Layout and create a new record with the
following fields completed.

Print Form Name: Invoice
Condition: Customer or Customer Group as required
Value: Specific Customer or Customer Group
Filename: Locate the full location of your Report ‘InvoiceTrade’

If you now create Sales Order for a Customer or a Customer in the Customer Group and go
through to creating an Invoice the ‘InvoiceTrade’ Form will be used 

4.  Importing/Exporting Forms

You have the option to develop a report and then ‘Export’ it and send to another Ostendo User. 
The recipient can then ‘Import’ the Report into their copy of Ostendo.  Within the Report and View
Developer you will see two Buttons.  These are:

Export: If you click on this button then the current Report, View, Pivot, or Chart’s details will be
exported and generated as a .dat file.   You should note that, in the case of a Report, this does
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NOT export the .fr3 file.  This must be copied separately (from your Ostendo ‘Reports’ folder) if
you are transferring the Report to another Ostendo.

Import: If you click on this button then you will be asked to point to the .dat file generated using the
above ‘Export’ process.  Upon selecting the .dat file the Report, View, Pivot, or Chart’s details will
immediately be imported into the current (sign-on) Company.   You should note that, in the case of
a Report, you should also copy the specific .fr3 file into the ‘Ostendo>Reports>Company’ folder
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35 Receiving and Applying Payments

1. Introduction

This tutorial describes the Payment receipts process and covers:
· Recording Deposits
· Matching Deposits to Invoices
· Recording Payment Receipts
· Matching Payments to Invoices
· Reversing ‘matched’ Payments and Deposits

2. Recording a Deposit

A Deposit covers a payment against a Sales or Job Order and is usually an initial ‘Pre-Payment’ at
the time the Order is placed.   This will subsequently be matched against an Invoice once the
Invoice has been created

It is not necessary to have a Sales Order before taking the Deposit.  However in this example we
will create a Sales Order and then create a Deposit taken from that order   

Go into Sales>Sales Orders and click the ‘Add’ button.  In the presented panel select Sales Type
‘Counter Sales’.  From the drop-down list under ‘Customer’ select Customer ‘Azure Products
Ltd’ then click the ‘Create Order’ button.  

In the generated order click on the ‘Lines’ tab and add Item ‘5000-5002’ (LCD 19 inch Monitor). 
Take a note of the Sales Order Number then save and exit the Order.

Go into Sales>Customer Deposits and click the ‘Add’ button to create a new Customer Deposit
record.   select Customer ‘Azure Products Ltd’ then click on the drop-down under ‘Deposit for’
and select ‘Specific Sales Order’.   A field (Order No) will appear from which you can select the
Order Number you created above.  Enter a Deposit Amount and complete the remainder of the
screen then ‘Save’ the record.

We will come back to this Deposit later in this exercise.

3. Recording a Payment

A Payment covers the receipt of funds from a Customer in response to an Invoice.  The Payment
is recorded and then matched against the Invoice.

Go into Sales>Customer Payments and click the ‘Add’ button to create a new Customer
Payment record by selecting Customer ‘Azure Products Ltd’ and completing a Payment for an
amount of (say) $100 then ‘Save’ the record but stay in the Customer Payments screen.

We will now match the payment against Invoice(s)

4. Matching a Payment  to an Invoice

Let us begin by creating an Invoice.   Go into Sales>Sales Orders and select the Order that you
created above.  Go into the ‘Lines’ tab and select your Item ‘5000-5002’ (LCD 19 inch Monitor). 
In the lower part of the screen click on the ‘Picked Lines’ tab and then click the ‘Add’ button to
add a new line in this lower panel.  Single click in the Qty field and click on the ‘spyglass’ icon.  On
the presented screen enter a quantity of 1 against any Serial Numbered Line then click the ‘Save’
button.  Click the OK button to issue the Item and close the screen.  Whilst still in the Sales Order
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screen click on the ‘Invoice’ button then generate and print the Invoice.

Go back to Sales>Customer Payments and select the payment you received above then click
the ‘Apply to Invoices’ tab.  Click the ‘Auto Apply’ button to apply the payment to the first Invoice.
Click the ‘Update Selected Invoices’ to post the applied amount

5. Matching a Deposit to an Invoice

While still in Sales>Customer Payments click on the ‘Add’ button and create a new record.  From
the drop-down under field ‘Payment Style’ select ‘Use Customer Deposit’ then select the deposit
reference from the drop-down field that has just appeared to the right 
Now click on the ‘Apply to Invoices’ tab.  Click the ‘Auto Apply’ button to apply the deposit to the
first Invoice.  Click the ‘Update Selected Invoices’ to post the applied amount.

6. Reversing an applied Deposit or Payment

You may have applied the Deposit or Payment to the wrong Invoice(s).  In this instance simply go
into Sales>Customer Payments and select the Deposit or Payment containing the error.  If it is
not visible in the ‘List’ View then ‘check’ the ‘Include Fully Applied Status’ checkbox at the
bottom of the screen

Go to the ‘Detail’ tab in the selected record and click on the ‘History’ tab (half-way down the
screen).  Highlight the record in error and click the ‘Delete’ button.  This will create a reversed
journal in addition to amending the status of the Payment/Deposit to either ‘Received’ or ‘Partially
Applied’

7. Refunding a Payment

If you have received and banked a payment that has been partially applied to an Invoice, and the
Customer requires this as a refund then you can achieve this through the following process

1.  Create a Direct Invoice for the amount to be refunded by going into Sales>Direct Invoicing
and clicking on the ‘Add’ button.  On the displayed panel ‘check’ the ‘Create an Invoice or Credit
without an Order’ radio button and select the Customer from the drop-down against field ‘Billing
Customer’ then click the ‘Create’ button.  Enter the Header information then click on the ‘Lines’
tab to enter a Descriptor line to cover the Invoice amount then click the print ‘Print’ button to print
the Invoice.  

Go into Sales>Customer Payments and apply the balance of the payment to this Invoice

2.  The next step is to Credit the Invoice that you have just created and apply the amount to be
refunded. 

Go into Sales>Direct Invoicing and click on the ‘Add’ button.  On the displayed panel ‘Select the
Customer and then check’ the ‘Create Credit by reversing an Invoice’ radio button.  Select the
above Invoice from the drop-down in field 'Existing Invoice Number' and click the ‘Create’ button.
Finally, click the print ‘Print’ button to print the Credit.  

The next step is to create the Refund record.  Therefore go into Sales>Customer Payments and
create a Payment (Refund) record.  Enter the value of the Payment as a negative amount

The final step is to apply this Refund to the Credit (Note: NOT an Invoice)  Therefore click on the ‘‘
Apply to Invoices’ tab and apply this refund to the Credit Note you have just created by ‘checking’
the ‘Select’ checkbox against the Credit and keying in the Refund amount (as a negative value)
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into ‘Applied Amount’ field

Finally, click the ‘Update Selected Invoices’ button.
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36 Rentals

This Tutoriail describes the setup and processes necessary to carry out Rental activity within
Ostendo.  Rentals have two basic areas

· The Sales Order and Billing function
· The Equipment Availability and Tracking function 

In Ostendo the Billing function is covered using Descriptors.  This Descriptor is linked to an Item
(Equipment).  When generating a Rental Order (which contains both a Start and anticipated Return
Date) the Descriptor is added to the Order Line.  This then allows Ostendo to display the linked
Item’s planned or actual availability.   Billing will be carried out using Ostendo’s current pricing
structure held against the Descriptor 

1.  Setup

1.1.  Rental Items

You should first identify the Rental Item by going into Inventory>Items and creating a standard
Item Code (For example: Wheelbarrow)

1.2.  Descriptors

The next step is to identify the Descriptors and their Charge Rate.  For example:

Descriptor Code Unit Unit Price
Wheelbarrow – Hour Hour $12.00
Wheelbarrow – Day Day $30.00
Wheelbarrow – Week Week $70.00

In creating each Descriptor you will see an extra ‘tab’ on the Descriptor’s Main screen called ‘
Rental Settings’.  This has three fields

Rental Descriptor: checkbox which should be ‘checked’ if the Descriptor is being used for Rental
purposes. 
Rental Item Code: From the dropdown list select the Item Code that is to be linked to this
Descriptor.  In our example the same Item Code (Wheelbarrow) will be used against each
Descriptor 
Default Rental Quantity: enter the quantity of the Item that is normally rented when the Descriptor
is used.  This defaults to 1 but you can amend it

1.3.  Sales Types

The last setup step is to define a Sales Type.  Go into Sales>Settings>Sales Types.  Identify a
Sales Type as being a Rental Order by ‘checking’ the ‘Rental Order’ checkbox.

2.  Creating and Monitoring a Rental Order

2.1.  Order Creation

Go into Sales>Sales Orders.  If you click the ‘Add’ button to create a new order (use the above ‘
Rental’ Sales) you will see on the Order creation panel a ‘Rental Start’ and ‘Rental End’ date
(prefilled with system date).  Amend these dates as required to conform to the Rental period then
create the order

Add the above Descriptor to the Sales Order Line.  You should note that you have the option to
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amend the Rental Descriptor’s  linked Item Code

In the order line you will see two additional features specifically for Rental Lines

2.1.1.  An additional ‘Tab’ is available in the lower part of the screen called ‘Rental Code’.  This
contains the linked Item Code and its Description.  It also contains a quantity field that can be
amended to adjust the default quantity entered in 1.2. (above) and make it specific to this order.

2.1.2.  The ‘Info Bar’ across the centre of the screen shows the current and available stock
against the linked Item.  If you click on this button the Item’s availability screen will appear.  If you
click on the ‘Projected Availability’ tab you will see Item’s availability taking into account current
stock, Rental Issues, and Rental returns. 
Note 1:  The current order line will not be included (yet) until the Item has been issued to the
Customer (see 2.2. below)
Note 2:  The Issue and Return dates are those entered and maintained against the Sales Order
and the quantity is taken from that held in the screen described in 2.1.1. (above)

2.2.  Order Maintenance

In the Sales Order ‘Detail’ screen you will see a ‘Retail Info’ tab.  In that panel the following fields
are present:

Rental Start Date: You can amend this as required.  This will be reflected in the availability status
of Rental Line Items 
Rental End Date: You can amend this as required.  Again, this will be reflected in the availability
status of Rental Line Items 
Rental Items Issued: ‘Check’ this checkbox if you have issued the Item to the Customer.  This
updates this Order header and provides a status relating to the whereabouts of the rented Items
Rental Items Returned: ‘Check’ this checkbox if the Item(s) have been returned from the
Customer.  This will then remove this line from the Rental lines in the Inventory Availability screens
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37 Serial Kits

Serial Kits are individual – unique - Serial Numbers within an Item.  Each Kit can comprise of one
or more component Items that may vary in their individual attributes (Colour, Size, Batch, Serial
Number, Expiry Date, etc).   Ostendo will allow you to view each Serial Kit to determine what
specific Items are included; plus the attributes those Items contain.  This facilitates variable Kit
contents within the same Serial Kit Code in addition to providing traceability of the individual Kit
contents.  

An example of where this can be used is (say) a laptop computer.  The computer itself is Serial
Numbered and it contains a Hard -Disk Drive, DVD Burner, etc that have their own Serial Number
in addition to a Warranty.  Full visibility of the Serial Kit contents is visible at all times

This is how it works

1. Kit Lists

Kit Lists are base ‘Kit Content’ templates that can optionally be used in association with Serial Kits.
Whenever a Serial Kit Item is received into stock the Kit Content List is automatically attached to
the Serial Kit Item record.  These Lists are maintained via Inventory>Lists.  The specific
conditions that apply to the Serial Kit can be entered and maintained

2. Serial Kits.

Go into Inventory>Items and create an Item.   While in that screen ‘check’ the ‘Serial No’
checkbox.  You should also ‘check’ the ‘Serial Kit’ checkbox which identifies it as a Serial Kit Item.
 A field to the right of ‘Serial Kit’ will now become active from which you can optionally nominate
the ‘Kit List’ created above.  This kit forms the base template that is attached to any receipt record.

3.  Creating the Serial Kit

Whenever a specific Serial Number for the Item is received for the first time Ostendo will check to
see if the Item is also flagged as a Serial Kit Item and, if so, a separate ‘Serial Kit’ record will be
generated for the received Serial Number.  To do this go into Inventory>Inventory Adjustments
and create a new Adjustment Batch.  In the ‘Lines’ tab add the Serial Numbered Item with quantity
of 1 and enter its actual Serial Number.  Go back to the ‘Detail’ tab and ‘post’ the adjustment.

4.  Amending the Serial Kit content  

If you now go into Inventory>Serial Kits you will see the generated Kit.  You now have the option
to amend the Kit Contents as required to:

· Identify specific variants such as Serial Number, Batch Number, etc
· Identify any specific additional user-defined information (E.g. Length)
· Add or delete Lines

5.  Serial Kit status

The individual Serial Numbered Item(s) themselves will be visible when in stock and moved to
Sales History when sold.  The associated linked Serial Kit record, however, will have its status
automatically changed from ‘In Stock’ to ‘Issued’.  Full visibility of all the Serial Kits and their
contents will be available at all times.

6.  Points to Note

6.1. Serial Numbered Item receipts can originate from Purchase Order Receipts, Assembly Order
receipts, Stock Adjustment receipts.  Ostendo will check if a Serial Kit for the received Serial
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Number exists with status ‘Issued’ and, if so, will change the status to ‘In Stock’.  If the received
Serial Number is a new Number then a Serial Kit will be generated using the linked Kit List.

6.2. Identifying variables in Serial Kit content

The Serial Kit Line’s variants can be entered/maintained at any time.  There is no validation of the
variant values.

6.3. If a Kit Component is Warranty Controlled then, upon issue of the parent Serial Kit to an

Order, a Warranty record will be generated to cover it.
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38 Specific Email Text

Whenever you email a Customer/Supplier a document as an attachment to an email you may wish
to format the email itself such that it reflects the content of the document being sent.  The process
flow is the same for the following documents.

· Invoice
· Pro-Forma Invoice
· Statement
· Sales Order
· Job Order
· Delivery Document
· Purchase Order
· Job Quote
· Sales Quote
· Call Centre

In this tutorial we will format an email for sending an Invoice.   

1.  Preparation

In preparation for emailing the Invoice go into Sales>Customers and select a Customer record. 
On the ‘Detail’ tab enter the Customer’s email address into field ‘Email’.  You should also click on
the drop-down against ‘Primary Contact’ and select a Contact.  Note: If the Customer does not
have any linked contact records then click on the rightmost icon in the ‘Primary Contact’ field and
create one.

2.  Available Fields

You should first determine the available fields - from the Invoice document - that we can include in
the Email.

Go to File>Reporting Configuration>Report and View Developer and locate the Sales Invoice.
Click on the ‘Master Settings’ tab and look in the ‘Master Query #0’ area.  This will tell you the
tables that are being used.  In our example there are two tables (SALESINVOICEHEADER,
CUSTOMERMASTER). 
Go to General>Reports>Full Listing of Tables and choose these two tables then print the report.
All the fields in this report are available for placing in the email. 

3.  Creating the Email Text

Go to File>Reporting Configuration>Specific Email Text and ‘Add’ a new record.   Under ‘
Name’ select ‘Invoice’.  Go to field ‘Email Subject’ and enter a short text such as Our Invoice.  A
field defined in the above tables should follow this text.   The format should be [MD_.”xxxxxx”]
where xxxxxx is the field name.  Therefore in our example the full text will be 

Our Invoice [MD_."INVOICENUMBER"]

You can also go to field ‘Email Body’ and create an extended Text such as: 

To [MD_."PRIMARYCONTACT"]
     [MD_."CUSTOMERINVOICENAME"]

Please find attached our Invoice [MD_."INVOICENUMBER"] dated [MD_."INVOICEDATE"]
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for your attention

4.  Emailing the Invoice.  

Go into Sales>Direct Invoicing and click on the ‘Add’ button.  On the displayed panel ‘check’ the ‘
Create an Invoice or Credit without an Order’ radio button and select a Customer from the
drop-down against field ‘Billing Customer’ then click the ‘Create’ button.  Enter the Invoice
Header and Line details as required and then click the ‘Print’ button to output the Invoice.  On the
output media panel select the Email icon.  

The constructed email with the Invoice attached will be returned to your screen for final approval
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39 Using the Reporting Periods Feature

These exercises will show how you can reference records created in the ‘Reporting Periods’
screen to aid in the creation of Reports and Views.  We will create the following Reports and
Views.  You should note that although these exercises are focused in the Sales area the Reporting
Periods screen can be used anywhere across Ostendo.

· Select Month-to-Date records for (say) Sales Commissions
· Select MTD compared to previous Year’s MTD
· Select MTD in addition to YTD figures
· Select MTD and YTD figures and compare to previous Year’s MTD/YTD

Firstly let’s have a quick look at the Reporting Periods screen itself to view the available options

You will notice that you create a record along with a brief description followed by up to 4 Period
Definitions.  Each Period Definition has 8 fields (4 fields to define the Start Date and 4 to define the
End Date).    You should complete the first Period Definition as follows (The remaining Period
Definitions are optional)

Start Date Type:  You can select one of the following to define the Type from which the entries in
the next three fields will determine the exact date:

· None: No Type selected (not applicable to Period Definition 1
· Fixed Date: This uses the date defined in field ‘Fixed Date’
· BOM: This uses the first day of the current month offset by the value entered into ‘Start

Offset Type’ and ‘Start Offset’ fields
· BOY: This uses the first day of the current year offset by the value entered into ‘Start

Offset Type’ and ‘Start Offset’ fields
· EOM: This uses the last day of the current month offset by the value entered into ‘Start

Offset Type’ and ‘Start Offset’ fields
· EOY: This uses the last day of the current year offset by the value entered into ‘Start

Offset Type’ and ‘Start Offset’ fields
· Current Date: Uses the current System Date
· Financial BOY: Using the Fiscal Month entered into System Settings this will determine

the Beginning of the Financial Year derived from the date evaluated by the ‘Start Offset
Type’ and ‘Start Offset’ fields

· Financial EOY: Using the Fiscal Month entered into System Settings this will determine
the End of the Financial Year derived from the date evaluated by the ‘Start Offset Type’
and ‘Start Offset’ fields.

Start Offset Type: You can specify the Offset to be in Days or Months
Start Offset: This can be the number of days or months (positive or negative) around the base
date from the Start Date Type
Fixed Date: This is used specifically against the ‘Fixed Date’ Start Date Type to denote the actual
Date.

2.  Select Month-to-Date records

Go into File>Report and View Developer>Reporting Periods and add a record as follows:

Reporting Period: MTD-Extract
Description: Month to Date Records
Period 1 Start Definition

Start Date Type: BOM
Start Offset Type:
Start Offset:
Start Fixed Date:
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Period 1 End Definition
End Date Type: Current Date
End Offset Type:
End Offset:
End Fixed Date:

Period 2 to Period 4 Definitions – leave blank

‘Save’ the Reporting Period record

2.1.  Create the Report

We will start off by creating a simple Report that will, using the above Reporting Period Record,
show Sales Orders raised in the current month.

Go into File>Reporting Configuration>Report and View Developer  and create a new Report called
(say) ‘Orders This Month’.  Complete the rest as follows:

Include in Main Menu: ‘Check’ this checkbox. 
Name: Prefilled with ‘Orders This Month’
Menu Order: Leave this blank.
Category:  Select ‘Sales’ from the drop-down list.
Type:  Leave as ‘Report’
Specific Screen: Leave Blank
Report File Name:  Leave as ‘Orders This Month’
Archive:  Leave this area blank
Master Query:  In the Master Query area type in the following query 

select * from SalesInvoiceheader, get_reportingperiods
where periodcode = 'MTD-Extract' and invoicedate >= period1start and
invoicedate <= period1end

In this query you will see a ‘Standard Procedure’ (get_reportingperiods) which
automatically converts the entries in the Reporting Periods record ‘MTD-Extract’ into
actual dates to compare against the data being extracted. 

Click on the ‘Edit’ button then select the Report Wizard and add Invoice Number, Invoice Status,
Invoice Date, and Customer to the report then click the ‘Finish’ button to generate the Report.

If you now click on the ‘Preview’ Icon (4th from left on the top toolbar) you will see that the finished
printed report only extracts those records you defined in the Reporting Period.  Exit out of Report
and View Developer (saving where required) and then go to Sales>Reports you will see that your ‘
Orders This Month’ report is listed.

3.  Compare current MTD with Last Year’s MTD by Customer

In this instance we will create an Analysis View to output – by Customer – the MTD Sales Figures
compared to last year’s MTD

Go into File>Report and View Developer>Reporting Periods and add a record as follows:

Reporting Period: MTD-Compare
Description: Compare MTD to last years MTD
Period 1 Start Definition

Start Date Type: BOM
Start Offset Type:
Start Offset:
Start Fixed Date:
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Period 1 End Definition
End Date Type: Current Date
End Offset Type:
End Offset:
End Fixed Date:

Period 2 Start Definition
Start Date Type: BOM
Start Offset Type: Month
Start Offset: -12
Start Fixed Date:

Period 2 End Definition
End Date Type: Current Date
End Offset Type: Month
End Offset: -12
End Fixed Date:

Period 3 to Period 4 Definitions – leave blank

‘Save’ the Reporting Period record

3.1. Create the Analysis View

Go into File>Reporting Configuration>Report and View Developer  and create a new Analysis View
called (say) ‘Customers MTD Compare’.  Complete the rest as follows:

Include in Main Menu: ‘Check’ this checkbox. 
Name: Prefilled with ‘Customers MTD Compare’
Menu Order: Leave this blank.
Category:  Select ‘Sales’ from the drop-down list.
Master Key Field:  Leave Blank
Detail Key Field: Leave Blank
Title:  Enter ‘Customer MTD’
Merge Word Document:  Leave Blank
Merge Data File:  Leave Blank
Master Query:  In the Master Query area type in the following query 

select customermaster.customer as "Customer",
cast(sum(case when (invoicedate >= period1start and invoicedate <= period1end)
then invoicenettamount else 0 end) as decimal(13,2)) as "MTD_Value" ,
cast(sum(case when (invoicedate >= period2start and invoicedate <= period2end)
then invoicenettamount else 0 end) as decimal(13,2)) as "LYMTD_Value" ,
max(salesinvoiceheader.sysuniqueid) as griduniqueindex
from SalesInvoiceheader, get_reportingperiods, customermaster 
where periodcode = 'MTD Compare' and
customermaster.customer = salesinvoiceheader.customer
group by 1

If you now run the Analysis it will show the MTD compared to last year’s MTD figures

4.  Analyse this Year’s Sales compared to last year

In this instance we will create an Analysis View in which we can filter and sort by Customer,
Customer Type or Salesperson.

Go into File>Report and View Developer>Reporting Periods and add a record as follows:

Reporting Period: SalesYTD
Description: Sales YTD to last years YTD
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Period 1 Start Definition
Start Date Type: BOM
Start Offset Type:
Start Offset:
Start Fixed Date:

Period 1 End Definition
End Date Type: Current Date
End Offset Type:
End Offset:
End Fixed Date:

Period 2 Start Definition
Start Date Type: BOM
Start Offset Type: Month
Start Offset: -12
Start Fixed Date:

Period 2 End Definition
End Date Type: Current Date
End Offset Type: Month
End Offset: -12
End Fixed Date:

Period 3 Start Definition
Start Date Type: BOY
Start Offset Type: 
Start Offset: 
Start Fixed Date:

Period 3 End Definition
End Date Type: Current Date
End Offset Type:
End Offset:
End Fixed Date:

Period 4 Start Definition
Start Date Type: BOY
Start Offset Type: Month
Start Offset: -12
Start Fixed Date:

Period 4 End Definition
End Date Type: Current Date
End Offset Type: Month
End Offset: -12
End Fixed Date:

‘Save’ the Reporting Period record

4.1. Create the Analysis View

Go into File>Reporting Configuration>Report and View Developer  and create a new Analysis View
called (say) ‘YTD Analysis’.  Complete the rest as follows:

Include in Main Menu: ‘Check’ this checkbox. 
Name: Prefilled with ‘YTD Analysis’
Menu Order: Leave this blank.
Category:  Select ‘Sales’ from the drop-down list.
Master Key Field:  Leave Blank
Detail Key Field: Leave Blank
Title:  Enter ‘YTD Analysis’
Merge Word Document:  Leave Blank
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Merge Data File:  Leave Blank
Master Query:  In the Master Query area type in the following query 

select customermaster.customer as "Customer", customermaster.customertype
as "Type", customermaster.customerregioncode as "Region",
customermaster.salesperson as "Salesperson", cast(sum(case when (invoicedate
>= period1start and invoicedate <= period1end) then invoicenettamount else 0
end) as decimal(13,2)) as "MTD_Value" ,
cast(sum(case when (invoicedate >= period2start and invoicedate <= period2end)
then invoicenettamount else 0 end) as decimal(13,2)) as "LYMTD_Value" ,
cast(sum(case when (invoicedate >= period3start and invoicedate <= period3end)
then invoicenettamount else 0 end) as decimal(13,2)) as "YTD_Value" ,
cast(sum(case when (invoicedate >= period4start and invoicedate <= period4end)
then invoicenettamount else 0 end) as decimal(13,2)) as "LYTD_Value" ,
max(salesinvoiceheader.sysuniqueid) as griduniqueindex
from SalesInvoiceheader, get_reportingperiods, customermaster 
where periodcode = 'SalesYTD' and
customermaster.customer = salesinvoiceheader.customer
group by 1,2,3,4

If you now run the Analysis it will show the MTD and YTD figures compared to last year’s MTD and
YTD figures.  As this is in an Analysis View you can drag and drop the Type, Region and
Salesperson columns into the top ‘Group By Box’ to show Sales for that Group.
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40 Variable Units of Measure

This tutorial will take you through the process of Selling, Purchasing and Stocking a Product in a
base Unit of Measure but Invoicing in another Unit where the conversion from one unit to the other
is variable.  This scenario is used extensively in the Meat Industry where the Stock is held as (say) 
‘carcass’ but the billing is in Kilograms.

In this Tutorial we will:

· Create a ‘Xmas Ham’ with a base Unit of Measure of ‘Each’.  
· Identify the Ham as being Invoiced in another Unit
· Purchase and receive the ‘Ham’.
· Have a Look and the Inventory records for Hams
· Raise a Sales Order for the Hams
· Pick the Hams
· Raise an Invoice for the picked Hams

1.  Create the product ‘Ham’

The first step is to create the Ham.  Therefore go into Inventory>Items and add product ‘HAM’
with the following fields completed.

Unit ‘Each’
Description ‘Xmas Ham’
Default Supply Method ‘Supply from Stock’
Sourced By ‘Purchasing’
Primary Supplier Select a Supplier from the drop-down list
Sell Price ‘30’
Buy Price ‘18’
Size ‘Check’ the ‘Size’ checkbox**

** We are going to segregate Hams by their Size (I.e. their actual weight in Kgs).  This means that
all Inventory receipts must have their weight recorded.  This enables you to view the available
Hams along with their weights.

Before you save the record continue with the next step.

2.  Identify the Ham as being Invoiced in another Unit

To continue with creating the ‘Ham’ we now need to identify that the product is to be Invoiced in a
different Unit of Measure.  Therefore, by clicking on the ‘Sizes’ button adjacent to the Size
checkbox, you should enter the following information

Is Conversion Factored ‘Check’ this checkbox
Planned Conversion Factor Enter (say) 20
Unit Of Measure Select ‘Kg’ from the drop-down list of Standard
Units

The Planned Conversion Factor and Unit of Measure in this example denotes that this Ham is
nominally 20Kgs per Ham.  This provides an indicative weight of the hams in a Sales Order.

3. Raise a Purchase Order and receive the ‘Ham’ into stock

Go into Purchasing>Purchase Orders and raise a Purchase Order for (say) 20 Hams.  Now go
to Purchasing>Purchase Receipts and receive these into stock.  If you attempt to receive the full
quantity you will get a message stating that the ‘Size’ is a required field.   Therefore – in the ‘Lines’
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screen – click on the ‘Allocations’ tab in the lower part of the screen.  We will now receive the
following

7 Hams at 19.5 Kg
7 Hams at 20.0 Kg
6 Hams at 20.5 Kg

Click the ‘Add’ Button twice to create three records.  Go to the ‘Size’ field and enter 19.5, 20.0,
and 20.5 respectively.

Click on the ‘Edit Allocation Quantities’ button and allocate the above quantities to their
respective sizes

Finally, click on the ‘Detail’ tab at the top of the screen and click the ‘Post all Purchase Receipt
Entries’ button.

4. Have a Look and the Inventory record from Hams

If you go to Inventory>Inventory Availability and select ‘Ham’ you will see the stocked quantities
of Hams along with their sizes.

5. Raise a Sales Order for the Hams

Go into Sales>Sales Orders and raise a ‘Counter Sale’ style order.  Go into the ‘Lines’ screen
and add a Sales Line for Hams with a quantity of (say) 5.  You will see that it has brought in the
nominal sell price currently held against the ‘Ham’ record.  Now let us pick the Hams

6. Pick the Hams

In the ‘Line’ screen click on the ‘Picked Lines’ tab in the lower part of the screen and then click
the ‘Add’ button.  In the generated line in the lower part of the screen click on the icon shown
within the ‘Qty’ field…this will bring up the current stock for the Hams.  Enter the picked quantity
against each line so that they total to the Order Line quantity.

For your own information add up the total Kilograms of the Hams that you have just picked and
note this down.  This is the ‘Actual’ picked weight and it is this value that is used to determine the
Invoice Price. 

7. Raise an Invoice for the picked Hams

In the Sales order screen click on the ‘Invoices’ button down the right of the screen and bring the
Invoice back to your screen.  You will see that the Unit of Measure created in step 2 above is the
UOM in the Invoice and the weight is that which you calculated in the previous step.

The Sell Price per Kg is calculated from the Sell Price for the Ham divided by the Planned
Conversion factor you entered in Step 2.  I.e. Ostendo will calculate the Sales Order Sell Price per
Kg by dividing the Price Level Price by the nominal weight in Kgs.  If there is no Price Level Price
then the Base Price will be used.  In our example we will use the Base Price of the Ham.  This
would give us a Price per Kg of $30/20Kg = $1.50 per Kg.  

The Invoice Price is evaluated when the Hams are picked.  Ostendo will determine the sum of the
actual weights picked and multiply this by the above Price/Kg to give you the Invoice Line extended
Price.
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41 Warranty Control

The Warranty Control function enables you to define Warranty Definitions that include the
Warranty Terms, Inclusions, Exclusions, and any additional relevant notes.   This can be attached
to an Item, Descriptor or Labour Code which, when sold, generates a specific Warranty record
covering the Sales.

1.  Warranty Definition

The first step is to define the Warranty you are offering.  Go into Service>Warranty Definition
and click the ‘Add’ button to create a new definition to cover (say) ‘Labour and Parts’ 

2.  Linking Warranty to Item/Descriptor/Labour Code

You can now define which Items, Descriptor Codes, or Labour Codes that this Warranty Definition
covers.   To do this, go into the following screens and select an entry against which you are going
to offer Warranty:
 

Items: Inventory>Items
Descriptors: Inventory>Descriptors
Labour Codes: Labour>Labour Codes

In each of these screens you will see two fields:

Sales Warranty Applies: ‘Check’ the checkbox
(Warranty Definition):     Select the Warranty Definition from the drop-down list

3.  Auto Creating a Warranty

Go into Sales>Sale Orders and click the ‘Add’ button.  Select Customer ‘Jim Gold & Co Ltd’ and
Sales Type ‘CounterSales’ then click the ‘Create Order’ button.  Go into the ‘Lines’ tab and add a
line for the Item, Descriptor, or Labour Code, which have a linked Warranty Code.

While you are in the Sales Order Lines screen click on the ‘Picked’ tab and enter the quantity and
date of the pick.  The action of ‘Picking’ the line will automatically generate the warranty record.  To
view this go into Service>Warranty List and you will see the Warranty record.  Select it and go
into the Detail tab.  Points to note are:

§ The Order and Invoice Information is held against the Warranty
§ The Customer Code is held here but can be amended if the Warranty is transferable 
§ The Item/Descriptor/Labour Code covered is identified
§ The effective start date and end date is taken from the pick date
§ All relevant information is copied from the Warranty Template

4.  Manually Creating a Warranty

While you are still in the Warranty List screen you can also click on the ‘Add’ button and create
your own Warranty record.  The fields covering ‘Associated Sales Information’ section are all
optional.  Therefore you can create a Warranty record linked to anything and then monitor against
it whenever a Warranty Claim is made.

5.  Warranty Reports and Views

Go to Service>Reports and Service >Views where you will find various outputs for Warranties
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